End User License Agreement

CAREFULLY READ THE FOLLOWING LICENSE AGREEMENT. THIS DOCUMENT IS A LEGAL AGREEMENT BETWEEN YOU, AND DIAGNOSTIC INSTRUMENTS, CONCERNING THE USE OF THE ENCLOSED SOFTWARE. THIS AGREEMENT CONSTITUTES THE COMPLETE AGREEMENT BETWEEN YOU AND DIAGNOSTIC INSTRUMENTS.

BY OPENING THE SOFTWARE PACKAGE OR USING THE CD, YOU ARE CONSENTING TO BE BOUND BY AND ARE BECOMING A PARTY TO THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS AGREEMENT, DO NOT OPEN THE PACKAGE OR USE THE CD. PROMPTLY RETURN THE CD, INCLUDING THE WRITTEN MATERIALS, THE BINDER, AND ALL OTHER EQUIPMENT/CONTAINERS TO THE DEALER FROM WHOM YOU PURCHASED THEM. YOU WILL RECEIVE A FULL REFUND.

License Grant
The package contains software ("Software") and related explanatory written materials ("Documentation"). "Software" includes any upgrades, modified versions, updates, additions and copies of the Software. "You" means the person or company who is being licensed to use the Software or Documentation. "We" and "us" means Diagnostic Instruments, Inc.

We hereby grant you a nonexclusive, limited license to use one copy of the Software on any single computer, provided the Software is in use on only one computer at any time. The Software is "in use" on a computer when it is loaded into temporary memory (RAM) or installed into the permanent memory of a computer—for example, a hard disk, CD-ROM or other storage device.

Title
We remain the owner of all right, title and interest in the Software and Documentation. You will agree to use your best efforts to protect the software from unauthorized use, illegal reproduction, or illicit distribution.

Copyrights and Trade Secrets
Diagnostic Instruments owns all rights to the Software. This agreement does not convey ownership of the software to you, but only the right to use a copy of the software strictly in accordance with this agreement. The unauthorized duplication or distribution of the software or the documentation is an infringement of Diagnostic Instruments' rights to the software and may be subject to criminal and/or civil penalties.

Archival or Backup Copies
You may either:

- Make one copy of the Software solely for backup or archival purposes, provided that the original copyright notice and/or other legend is reproduced on each copy, or

- Transfer the Software to a single hard disk, provided you keep the original solely for backup or archival purposes, and provided that the original copyright notice and/or other legend is reproduced on each copy.
Things You May Not Do
United States copyright laws and international treaties protect the software and documentation. You must treat the software and documentation like any other copyrighted material—for example a book. You may not:

- Copy the Documentation (although you may print one working copy from a downloaded version from our website),
- Copy the Software except to make archival or backup copies as provided above,
- Modify, translate, or adapt the Software or merge it into another program,
- Make any attempt to discover the source code of the Software through reverse engineering,
- Place the Software onto a server so that it is accessible via a public network such as the Internet,
- Sublicense, rent, lease or lend any portion of the Software or Documentation.

Transfers
You may transfer all your rights to use the Software and Documentation to another person or legal entity provided you transfer this Agreement, the Software and Documentation, including all copies, updates and prior versions to such person or entity and that you retain no copies, including copies stored on computer.

Software Limited Warranty
We warrant that for a period of 30 days after delivery of this copy of the Software to you:

- The physical media (if any) on which this copy of the Software is distributed will be free from defects in materials and workmanship under normal use, and
- The Software will perform in substantial accordance with the Documentation.

To the extent permitted by applicable law, THE FOREGOING LIMITED WARRANTY IS IN LIEU OF ALL OTHER WARRANTIES OR CONDITIONS, EXPRESS OR IMPLIED, AND WE DISCLAIM ANY AND ALL IMPLIED WARRANTIES OR CONDITIONS, INCLUDING ANY IMPLIED WARRANTY OF TITLE, NONINFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE, regardless of whether we know or had reason to know of your particular needs. No employee, agent, dealer or distributor of ours is authorized to modify this limited warranty, or to make any additional warranties.

Limited Remedy
Our entire liability and your exclusive remedy shall be:

- The replacement of any CD(s) or other media not meeting our Limited Warranty which is returned to us or to an authorized Dealer or Distributor with a copy of your receipt, or
- If we or an authorized Dealer or Distributor are unable to deliver a replacement CD(s) or other media that is free of defects in materials or workmanship, you may terminate this Agreement by returning the Software and Documentation and your money will be refunded.

IN NO EVENT WILL WE BE LIABLE TO YOU FOR ANY DAMAGES, INCLUDING ANY LOST PROFITS, LOST SAVINGS, OR OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING FROM THE USE OF OR THE INABILITY TO USE THE SOFTWARE (EVEN IF WE OR AN AUTHORIZED DEALER OR DISTRIBUTOR HAS BEEN ADVISED OF THE POSSIBILITY OF THESE DAMAGES), OR FOR ANY CLAIM BY ANY OTHER PARTY.
Term and Termination
This license agreement takes effect upon your use of the software and remains effective until terminated. You may terminate it at any time by destroying all copies of the Software and Documentation in your possession. It will also automatically terminate if you fail to comply with any term or condition of this license agreement. You agree on termination of this license to either return to us or destroy all copies of the Software and Documentation in your possession.

Confidentiality
The Software contains trade secrets and proprietary know-how that belong to us and it is being made available to you in strict confidence. ANY USE OR DISCLOSURE OF THE SOFTWARE, OR OF ITS ALGORITHMS, PROTOCOLS OR INTERFACES, OTHER THAN IN STRICT ACCORDANCE WITH THIS LICENSE AGREEMENT, MAY BE ACTIONABLE AS A VIOLATION OF OUR TRADE SECRET RIGHTS.

General Provisions
- This written license agreement is the exclusive agreement between you and us concerning the Software and Documentation and supersedes any and all prior oral or written agreements, negotiations or other dealings between us concerning the Software.
- This license agreement may be modified only by a written agreement signed by you and us that specifically supersedes this agreement.
- The laws of the State of Michigan govern this license agreement.
- You agree that the Software will not be shipped, transferred or exported into any country or used in any manner prohibited by the United States Export Administration Act or any other export laws, restrictions or regulations.

Trademarks
Adobe Photoshop is a registered trademark of Adobe Systems Incorporated. Image Pro and Image Pro Plus are registered trademarks of Media Cybernetics. MetaMorph is a registered trademark of MDS Analytical Technologies. SPOT, Idea, Insight, RT, RT-KE, RT-SE, Flex, Xplorer, Xplorer XS, Pursuit, Pursuit XS, Correct Color Technology, Enhanced, and Boost are trademarks of Diagnostic Instruments, Inc. Windows 95, Windows 98, Windows 98SE, Windows NT, Windows 2000, Windows ME, and Windows XP, Windows Vista, Windows 7, and Windows Office are registered trademarks of Microsoft, Inc. Mac OS is a registered trademark of Apple Computer, Inc. FireWire is a registered trademark of Apple Computer, Inc. and a licensed trademark of the 1394 Trade Association. All other product names mentioned in this document are the property of their respective trademark holders.

Warranty Information
In no event shall Diagnostic be liable for any consequential, indirect, incidental, or special damages of any nature arising from the sale or use of this product.

In no event, and under no circumstance shall Diagnostic be liable to the Dealer or to any other individual or entity for any indirect, special, consequential, or incidental losses or damages, including without limitation, lost profits.
EXCEPT, AS EXPRESSLY SET FORTH IN THIS AGREEMENT, DIAGNOSTIC INSTRUMENTS, INC., MAKES NO WARRANTIES OR REPRESENTATIONS TO THE DEALER OR USER, EITHER EXPRESS OR IMPLIED. THIS INCLUDES, WITHOUT LIMITATION, WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR THE VALIDITY, NON-INFRINGEMENT, OR OWNERSHIP OF ANY PATENTS OR TECHNOLOGY IN OR CONCERNING THE CAMERA. DIAGNOSTIC INSTRUMENTS INC., HEREBY EXPRESSLY DISCLAIMS ALL SUCH WARRANTIES, GUARANTIES, REPRESENTATIONS, OR CONDITIONS.

Diagnostic Instruments reserves the right to change any or all of this policy at any time.

Copyright 2011, Diagnostic Instruments, Inc. All rights reserved.

V5.0.1
# Table of Contents

End User License Agreement.................................................................................................................................1
Table of Contents ..........................................................................................................................................................5

SECTION I – INTRODUCTION & QUICK START......................................................................................................14
Chapter 1 - About This Manual......................................................................................................................................14
  Introduction ..................................................................................................................................................................14
  Document Conventions ...............................................................................................................................................14
  Organization of the Manual .......................................................................................................................................15
Chapter 2 – Basic vs. Advanced Applications............................................................................................................17
  Introduction ..............................................................................................................................................................17
  Basic vs. Advanced Features .....................................................................................................................................17
Chapter 3 - Quick Start..................................................................................................................................................18
  SPOT Basic Application – Taking Your First Picture .................................................................................................18
  Preparing the Microscope and Camera .....................................................................................................................18
  Capturing the Image..................................................................................................................................................18
  SPOT Advanced Application – Taking Your First Picture ..........................................................................................22
  Preparing the Microscope and Camera .....................................................................................................................22
  Capturing the Image..................................................................................................................................................22

Chapter 4 - Custom Configuration.............................................................................................................................25
  Configuring the SPOT Application for your camera, coupler and microscope.......................................................25
  Importing Calibrations ..............................................................................................................................................25
  Importing Palettes (Advanced application only).......................................................................................................27
  Importing Easy Essentials Taskbar (Advanced Application Only) .......................................................................28
  Importing Image Sets (Advanced Application Only) .................................................................................................29

SECTION II – THE SPOT BASIC APPLICATION ......................................................................................................31
Chapter 1 – Introduction................................................................................................................................................31
  Introduction: Using the SPOT Basic Application .....................................................................................................31
  Opening SPOT Basic................................................................................................................................................31
  The SPOT Basic Application Overview ..................................................................................................................32
  The Viewing and Editing Window ...........................................................................................................................33
  Typical Image Acquisition Process ..........................................................................................................................34
Chapter 2 – Image Settings and Preferences.............................................................................................................36
  Image Settings - Preparing to Take a Picture ...............................................................................................................36
  Image Settings Window – Common Functions .........................................................................................................36
  Image Settings Window – Tabs ..................................................................................................................................37
  Features Specific to Auto Exposures ..........................................................................................................................45
  Features Specific to Manual Exposures ......................................................................................................................48
  Preferences ................................................................................................................................................................53
  Application Selection (only available if SPOT Advanced is installed) .....................................................................54
  Image Display ..........................................................................................................................................................54
  Window Arrangement ...............................................................................................................................................55
  Magnifier .................................................................................................................................................................55
  Toolbar .....................................................................................................................................................................56
  Image Sequences ......................................................................................................................................................56
  Thumbnails ...............................................................................................................................................................56
  Spell-Checking ...........................................................................................................................................................57
  Shorthand ..................................................................................................................................................................57
  Profile Saving ...........................................................................................................................................................57
  Image Acquisition ....................................................................................................................................................57
  Bus (Firewire cameras only) ......................................................................................................................................58
  Temperature Readout (Xplorer and Pursuit only) ......................................................................................................58
  Image Print Resolution ...............................................................................................................................................59
  Add Extensions to File Names on Save (Mac) ...........................................................................................................59
  File Paths .................................................................................................................................................................59
  Messages ................................................................................................................................................................59
Chapter 5 - SPOT Basic Reporting

Creating a Calculated Calibration ................................................................. 60
Creating a User-Defined Calibration ......................................................... 60
Importing and Exporting Calibrations ....................................................... 62

Chapter 4 – SPOT Basic Viewing and Editing Image Documents .................... 78

Creating a New Report .................................................................................. 119

Chapter 3 – Image Captures and the Camera Menu ....................................... 70

Taking a Picture ............................................................................................ 70

Chapter 2 – SPOT Basic Image Acquisition.................................................. 66

Acquire Flatfield .......................................................................................... 77
Acquire Time Lapse Images .......................................................................... 75
Camera Communication ................................................................................ 76

Correction Frames ....................................................................................... 77

Chapter 1 – SPOT Basic Camera Settings....................................................... 60

Display Live Images .................................................................................... 70
 Compute White Balance Values (Color cameras only) ................................ 72
 Capturing the Final Image .......................................................................... 94
 Acquire Time Lapse Images ...................................................................... 75
 Camera Communication .............................................................................. 76

Reticle Set Up ............................................................................................... 62
Creating a Reticle ......................................................................................... 63

Chapter 3 – Image Captures and the Camera Menu ....................................... 70

Image Auto-Save .......................................................................................... 66
Single Image Acquisition ............................................................................ 66
Time Lapse Acquisition .............................................................................. 66

Chapter 2 – SPOT Basic Image Acquisition .................................................. 66

Common Auto-Save Features ..................................................................... 67
Auto-Save to Individual Files Specific Features ....................................... 68
Auto-Save to Image Sequence Files Specific Features .............................. 68

Chapter 4 – SPOT Basic Viewing and Editing Image Documents .................... 78

Creating a User-Defined Calibration ......................................................... 60

Chapter 2 – SPOT Basic Image Acquisition .................................................. 60

Acquire Flatfield .......................................................................................... 77
Acquire Time Lapse Images .......................................................................... 75
Camera Communication ................................................................................ 76

Correction Frames ....................................................................................... 77

Chapter 1 – SPOT Basic Camera Settings....................................................... 60

Display Live Images .................................................................................... 70
 Compute White Balance Values (Color cameras only) ................................ 72
 Capturing the Final Image .......................................................................... 94
 Acquire Time Lapse Images ...................................................................... 75
 Camera Communication .............................................................................. 76

Reticle Set Up ............................................................................................... 62
Creating a Reticle ......................................................................................... 63

Chapter 3 – Image Captures and the Camera Menu ....................................... 70

Image Auto-Save .......................................................................................... 66
Single Image Acquisition ............................................................................ 66
Time Lapse Acquisition .............................................................................. 66

Chapter 2 – SPOT Basic Image Acquisition .................................................. 66

Common Auto-Save Features ..................................................................... 67
Auto-Save to Individual Files Specific Features ....................................... 68
Auto-Save to Image Sequence Files Specific Features .............................. 68

Chapter 4 – SPOT Basic Viewing and Editing Image Documents .................... 78

Creating a New Report .................................................................................. 119

Chapter 5 - SPOT Basic Reporting.................................................................. 119

Creating a New Report .................................................................................. 119

Working in Report Mode ............................................................................... 119
### Chapter 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu

- Image Setups .................................................................................................................. 143
  - Image Setups .................................................................................................................. 144
  - Live Image Window and Live Image Controls ............................................................... 172
- Calibrations ......................................................................................................................... 184
  - Creating a Calculated Calibration .................................................................................. 184
  - Creating a User-Defined Calibration ............................................................................. 185
  - Importing and Exporting Calibrations ............................................................................ 186
- Reticles ................................................................................................................................ 186
  - Creating a reticle ............................................................................................................ 187

### SECTION III – THE SPOT ADVANCED APPLICATION

#### Chapter 6 - SPOT Basic Image Printing

- Example Printing Workflow: ............................................................................................ 131
- Print Layout Editor – Printing Single or Multiple Image Files ........................................... 132
  - Layout ............................................................................................................................... 132
  - Top Image ......................................................................................................................... 133
- Print Layout Editor – Printing Sequential Image Files ...................................................... 135
  - Print Controls ................................................................................................................... 135

---

**Table of Contents**

- Cursor Functionality ........................................................................................................... 119
- Sizing and Positioning Report Objects ................................................................................ 120
- Using Right/Ctrl-click and Double-click Functionality ...................................................... 120

- Defining View Options ...................................................................................................... 120
  - Zoom ................................................................................................................................. 121
  - First Page ......................................................................................................................... 121
  - Previous Page ................................................................................................................ 121
  - Next Page ....................................................................................................................... 121
  - Last Page ......................................................................................................................... 121
  - Set Display Grid Size ..................................................................................................... 121
  - Set Object Grid Size ....................................................................................................... 121
  - Show Tools .................................................................................................................... 122
  - Full Screen .................................................................................................................... 122

- Defining Report Attributes ............................................................................................... 122
  - Colors ................................................................................................................................ 122
  - Line Thickness ................................................................................................................ 123
  - Image Border and Justification ....................................................................................... 123
  - Arrow Size and Direction ............................................................................................... 123
  - Box/Ellipse Fill ................................................................................................................ 123
  - Text Font ........................................................................................................................ 124
  - Text Border, Justification, and Background .................................................................. 124
  - Title .................................................................................................................................. 124
  - Time .................................................................................................................................. 124

- Defining Report Objects .................................................................................................... 125
  - None .................................................................................................................................. 125
  - Lines .................................................................................................................................. 125
  - Connected Lines .............................................................................................................. 126
  - Shapes .............................................................................................................................. 126
  - Image ................................................................................................................................ 126
  - Text .................................................................................................................................. 127

- Editing Report Objects ..................................................................................................... 127
  - The Edit Menu ................................................................................................................. 127

- Saving Reports ................................................................................................................... 129

- Printing and Distributing Reports ..................................................................................... 130

---

**Spot Software User Guide**
<table>
<thead>
<tr>
<th>Chapter 9 – SPOT Advanced Reporting</th>
<th>347</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction .................................................</td>
<td>347</td>
</tr>
<tr>
<td>Overview: The SPOT Sample Report ..........</td>
<td>347</td>
</tr>
<tr>
<td>Open the SPOT Sample Report .................</td>
<td>347</td>
</tr>
<tr>
<td>View the SPOT Sample Report Objects ........</td>
<td>348</td>
</tr>
<tr>
<td>Run the SPOT Sample Report..................</td>
<td>348</td>
</tr>
<tr>
<td>Creating a Report...........................................</td>
<td>349</td>
</tr>
<tr>
<td>Working in Report Mode............................</td>
<td>350</td>
</tr>
<tr>
<td>Defining Report Attributes ......................</td>
<td>353</td>
</tr>
<tr>
<td>Colors..........................................................</td>
<td>353</td>
</tr>
<tr>
<td>Line Thickness..............................................</td>
<td>353</td>
</tr>
<tr>
<td>Image Border and Justification................</td>
<td>354</td>
</tr>
<tr>
<td>Arrow Size and Direction .......................</td>
<td>354</td>
</tr>
<tr>
<td>Box/Ellipse Fill............................................</td>
<td>354</td>
</tr>
<tr>
<td>Text Font ....................................................</td>
<td>355</td>
</tr>
<tr>
<td>Text Border, Justification, and Background....</td>
<td>355</td>
</tr>
<tr>
<td>Title ..........................................................</td>
<td>355</td>
</tr>
<tr>
<td>Time ............................................................</td>
<td>355</td>
</tr>
<tr>
<td>Defining Report Objects .........................</td>
<td>356</td>
</tr>
<tr>
<td>None..........................................................</td>
<td>356</td>
</tr>
<tr>
<td>Lines..........................................................</td>
<td>356</td>
</tr>
<tr>
<td>Connected Lines............................................</td>
<td>357</td>
</tr>
<tr>
<td>Shapes.........................................................</td>
<td>357</td>
</tr>
<tr>
<td>Editing Report Objects .........................</td>
<td>364</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 7 – SPOT Advanced Custom Dialogs</th>
<th>323</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction ........................................</td>
<td>323</td>
</tr>
<tr>
<td>Macro-specific Commands .......................</td>
<td>329</td>
</tr>
<tr>
<td>Defining Database Fields .......................</td>
<td>332</td>
</tr>
<tr>
<td>Saving Images ...........................................</td>
<td>335</td>
</tr>
<tr>
<td>Editing Database Image Records................</td>
<td>336</td>
</tr>
<tr>
<td>Moving Database Images .........................</td>
<td>337</td>
</tr>
<tr>
<td>Searching Databases ....................................</td>
<td>340</td>
</tr>
<tr>
<td>Defining Search Conditions .....................</td>
<td>340</td>
</tr>
<tr>
<td>Ordering Search Results .........................</td>
<td>342</td>
</tr>
<tr>
<td>Displaying Search Results ........................</td>
<td>342</td>
</tr>
<tr>
<td>Saving and Reusing Search Criteria .............</td>
<td>344</td>
</tr>
<tr>
<td>Editing Database Image Records (from a search)</td>
<td>344</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Ch. 8 – SPOT Advanced Databases</th>
<th>325</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction ..................................</td>
<td>325</td>
</tr>
<tr>
<td>The Database Menu .........................</td>
<td>325</td>
</tr>
<tr>
<td>The SPOT Sample Database ..................</td>
<td>326</td>
</tr>
<tr>
<td>Open the SPOT Sample Database ..........</td>
<td>326</td>
</tr>
<tr>
<td>View the Database Structure ..............</td>
<td>326</td>
</tr>
<tr>
<td>View Database Preferences ................</td>
<td>327</td>
</tr>
<tr>
<td>Search the Database ........................</td>
<td>328</td>
</tr>
<tr>
<td>Save an Image to the Database ............</td>
<td>328</td>
</tr>
<tr>
<td>Creating and Modifying Databases ........</td>
<td>329</td>
</tr>
<tr>
<td>Setting Up a New Database ..................</td>
<td>329</td>
</tr>
<tr>
<td>Defining File and Save Preferences .......</td>
<td>330</td>
</tr>
<tr>
<td>Defining Database Fields ...................</td>
<td>332</td>
</tr>
<tr>
<td>Saving Images ......................................</td>
<td>335</td>
</tr>
<tr>
<td>Editing Database Image Records ............</td>
<td>336</td>
</tr>
<tr>
<td>Moving Database Images .....................</td>
<td>337</td>
</tr>
</tbody>
</table>

| Intrduction ............................................... | 279 |
| Benefits ................................................... | 279 |
| Creating a Macro ........................................... | 279 |
| Accessing and Navigating the Macro Window | 280 |
| New ......................................................... | 280 |
| Record ...................................................... | 291 |
| Edit .......................................................... | 291 |
| Play .......................................................... | 292 |
| Protect ...................................................... | 293 |
| Macro-specific Commands ....................... | 293 |
| Conditional Commands ............................. | 294 |
| Variable Commands ..................................... | 303 |
| Timing Commands ........................................ | 310 |
| Communication Commands ....................... | 314 |

<table>
<thead>
<tr>
<th>Ch. 7 – SPOT Advanced Custom Dialogs</th>
<th>323</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction ........................................</td>
<td>323</td>
</tr>
<tr>
<td>Macro-specific Commands ...................</td>
<td>329</td>
</tr>
<tr>
<td>Defining Database Fields ..................</td>
<td>332</td>
</tr>
<tr>
<td>Saving Images .......................................</td>
<td>335</td>
</tr>
<tr>
<td>Editing Database Image Records ..........</td>
<td>336</td>
</tr>
<tr>
<td>Moving Database Images ....................</td>
<td>337</td>
</tr>
<tr>
<td>Searching Databases ............................</td>
<td>340</td>
</tr>
<tr>
<td>Defining Search Conditions .................</td>
<td>340</td>
</tr>
<tr>
<td>Ordering Search Results .....................</td>
<td>342</td>
</tr>
<tr>
<td>Displaying Search Results ..................</td>
<td>342</td>
</tr>
<tr>
<td>Saving and Reusing Search Criteria ........</td>
<td>344</td>
</tr>
<tr>
<td>Editing Database Image Records (from a search)</td>
<td>344</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Ch. 8 – SPOT Advanced Databases</th>
<th>325</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction ..................................</td>
<td>325</td>
</tr>
<tr>
<td>The Database Menu .........................</td>
<td>325</td>
</tr>
<tr>
<td>The SPOT Sample Database ..................</td>
<td>326</td>
</tr>
<tr>
<td>Open the SPOT Sample Database ..........</td>
<td>326</td>
</tr>
<tr>
<td>View the Database Structure ..............</td>
<td>326</td>
</tr>
<tr>
<td>View Database Preferences ................</td>
<td>327</td>
</tr>
<tr>
<td>Search the Database ........................</td>
<td>328</td>
</tr>
<tr>
<td>Save an Image to the Database ............</td>
<td>328</td>
</tr>
<tr>
<td>Creating and Modifying Databases ........</td>
<td>329</td>
</tr>
<tr>
<td>Setting Up a New Database ..................</td>
<td>329</td>
</tr>
<tr>
<td>Defining File and Save Preferences .......</td>
<td>330</td>
</tr>
<tr>
<td>Defining Database Fields ...................</td>
<td>332</td>
</tr>
<tr>
<td>Saving Images ......................................</td>
<td>335</td>
</tr>
<tr>
<td>Editing Database Image Records ............</td>
<td>336</td>
</tr>
<tr>
<td>Moving Database Images .....................</td>
<td>337</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Ch. 9 – SPOT Advanced Reporting</th>
<th>347</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction ..................................</td>
<td>347</td>
</tr>
<tr>
<td>Overview: The SPOT Sample Report ..........</td>
<td>347</td>
</tr>
<tr>
<td>Open the SPOT Sample Report ..........</td>
<td>347</td>
</tr>
<tr>
<td>View the SPOT Sample Report Objects ........</td>
<td>348</td>
</tr>
<tr>
<td>Run the SPOT Sample Report ............</td>
<td>348</td>
</tr>
<tr>
<td>Creating a Report .........................</td>
<td>349</td>
</tr>
<tr>
<td>Working in Report Mode ....................</td>
<td>350</td>
</tr>
<tr>
<td>Defining Report Attributes ...............</td>
<td>353</td>
</tr>
<tr>
<td>Colors ..................................................</td>
<td>353</td>
</tr>
<tr>
<td>Line Thickness ......................................</td>
<td>353</td>
</tr>
<tr>
<td>Image Border and Justification .............</td>
<td>354</td>
</tr>
<tr>
<td>Arrow Size and Direction ....................</td>
<td>354</td>
</tr>
<tr>
<td>Box/Ellipse Fill .....................................</td>
<td>354</td>
</tr>
<tr>
<td>Text Font ..............................................</td>
<td>355</td>
</tr>
<tr>
<td>Text Border, Justification, and Background</td>
<td>355</td>
</tr>
<tr>
<td>Title ....................................................</td>
<td>355</td>
</tr>
<tr>
<td>Time ......................................................</td>
<td>355</td>
</tr>
<tr>
<td>Defining Report Objects .....................</td>
<td>356</td>
</tr>
<tr>
<td>None ....................................................</td>
<td>356</td>
</tr>
<tr>
<td>Lines .....................................................</td>
<td>356</td>
</tr>
<tr>
<td>Connected Lines ....................................</td>
<td>357</td>
</tr>
<tr>
<td>Shapes ...................................................</td>
<td>357</td>
</tr>
<tr>
<td>Editing Report Objects ......................</td>
<td>364</td>
</tr>
</tbody>
</table>
Introduction .................................................................................................................................................. 411
Quantitative Imaging Features under the Edit Menu .................................................................................. 411
  Preserve Pixel Intensity Data ................................................................. 411
  Set Intensity Display Scaling ............................................................... 411
Quantitative Imaging Features under the View Menu ............................................................................... 412
  Show Image Display Settings Panel .................................................. 412
  Show Image Display Histogram Area .............................................. 413
Quantitative Imaging Features under the Camera Menu ........................................................................... 413
  Save Image Display Values .............................................................. 413
Quantitative Imaging Features under the File Menu ............................................................................... 414
  Duplicate Image .................................................................................. 414
  Export Pixel Values ............................................................................ 414
Ch. 4 – Peripheral Device Control ........................................................................................................... 415
  Introduction .......................................................................................... 415
  What is the Peripheral Device Controller? ............................................................................................ 415
  Why and when would I use this feature? ............................................................................................... 415
  Developing Peripheral Device Commands ............................................................................................ 415
    Naming the External Device ........................................................... 416
    Specifying the Device’s Communication Settings .................. 416
    Naming the External Device Command ................................. 417
    Entering the Desired Command ................................................ 417
    Setting a Response Command ..................................................... 419
    Using Variables .................................................................................. 419
    Using Timeouts ................................................................................... 419
    Testing the Peripheral Device Command .............................. 419
    Modifying and Deleting the Peripheral Device Command ... 420
    Using the Peripheral Devices Commands ........................................ 420
      From the Dropdown menu .......................................................... 420
      In a Taskbar .................................................................................... 420
      In a Macro ...................................................................................... 421
  Moving Peripheral Device Commands ............................................................................................... 421
    To import peripheral device commands .............................. 421
    To export peripheral device commands .................................. 421
Ch. 5 – Extended Third Party Interface Module ....................................................................................... 422
  Introduction .......................................................................................... 422
  Using SPOT Extended Third Party Interface Module ........................................................................... 422
    Connecting to the SPOT Camera .................................................. 422
    New Toolbar in SPOT Extended Third Party Interface ...... 422
Appendix A: Electronic Imaging Theory and SPOT Cameras ...................................................................... 423
  Introduction .......................................................................................... 423
  Digital Photography .............................................................................. 423
  Dark Current, System Offset, and Scientific Imaging ......................................................................... 423
  Color Images .......................................................................................... 424
  SPOT Digital Cameras ............................................................................ 425
    Pixel Digitization ................................................................................ 425
    Gain ........................................................................................................ 426
    An Automated Exposure Process ................................................. 426
Appendix B: Keyboard and Toolbar Button Commands .............................................................................. 429
Appendix C: Correct Color Technology ..................................................................................................... 433
  Introduction .......................................................................................... 433
  Microscope Setup .................................................................................. 433
  Camera Setup .......................................................................................... 433
  Display Monitor Setup .......................................................................... 433
    Simple Method .................................................................................... 433
    Enhanced Method ................................................................................ 434
Index .......................................................................................................................................................... 435
SECTION I – INTRODUCTION & QUICK START

Chapter 1 - About This Manual

Introduction

This software user guide contains instructions for using the 5.0 version of the SPOT Software with the following camera lines: Idea, Insight, RT, Pursuit, Flex, and Xplorer. Some features described in this manual apply only to specific camera lines, or to specific types of cameras within those lines. In these cases, the camera line or type of camera is listed in parentheses after the feature name.

A PDF (portable document format) version of this document has been included on the CD that contains the SPOT Software. Refer to your hardware guide for installation procedures and technical specifications specific to your particular camera line.

Document Conventions

The following is a list of the textual conventions used in this manual:

<table>
<thead>
<tr>
<th>Notes</th>
<th>Note: This is an example of a note. Notes appear within the text to indicate information for further consideration or reference.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cautions</td>
<td>CAUTION! This is an example of a cautionary note. Cautionary notes appear to indicate that you should carefully consider the implications of an action.</td>
</tr>
<tr>
<td>Warnings</td>
<td>WARNING THIS IS AN EXAMPLE OF A WARNING. WARNINGS INDICATE THAT THE ACTION YOU ARE TAKING COULD EITHER CAUSE INJURY TO YOURSELF OR COULD HARM YOUR SYSTEM</td>
</tr>
</tbody>
</table>
Organization of the Manual

The SPOT Software User Guide is structured as shown in the table below. The manual is split into 6 main Sections with each SPOT Interface in its own Section, so if you own SPOT Basic, all of the information you need pertaining to SPOT Basic specific features will be in Section II.

<table>
<thead>
<tr>
<th>Section</th>
<th>Chapter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>SECTION I</strong></td>
<td>Ch. 1 – About This Manual</td>
<td>Describes document conventions and the manual structure.</td>
</tr>
<tr>
<td><strong>INTRODUCTION and QUICK START</strong></td>
<td>Ch. 2 – SPOT Basic vs. Advanced Applications</td>
<td>Compares the features of the Basic and Advanced Applications.</td>
</tr>
<tr>
<td></td>
<td>Ch. 3 – Quick Start</td>
<td>Steps for immediately capturing your first image in either the Basic or Advanced Application.</td>
</tr>
<tr>
<td></td>
<td>Ch. 4 – Custom Configuration</td>
<td>Steps for importing pre-configured Calibrations, Palettes, Easy Essentials™ Taskbar, and Image Setups</td>
</tr>
<tr>
<td><strong>SECTION II</strong></td>
<td>Ch. 1 - Introduction</td>
<td>Outlines the steps to getting started in SPOT Basic</td>
</tr>
<tr>
<td><strong>THE SPOT BASIC APPLICATION</strong></td>
<td>Ch. 2 – Image Settings, Live Imaging, and Interface Preferences</td>
<td>Details the SPOT Basic Application’s image setting options, how to use the Live Imaging feature, and the Preferences available for customizing your own SPOT Basic environment.</td>
</tr>
<tr>
<td></td>
<td>Ch. 3 – Image Captures and Camera Menu</td>
<td>Discusses the different types of image captures and the Camera Menu options.</td>
</tr>
<tr>
<td></td>
<td>Ch. 4 – Viewing, Editing, and Annotating Images</td>
<td>Describes the rich set of image editing and customization features in the SPOT software including calibration and measuring tools.</td>
</tr>
<tr>
<td></td>
<td>Ch. 5 – Reporting</td>
<td>Describes the Basic application’s reporting functionality.</td>
</tr>
<tr>
<td></td>
<td>Ch. 6 – Image Printing</td>
<td>Describes the procedures for printing images from the SPOT application.</td>
</tr>
<tr>
<td><strong>SECTION III</strong></td>
<td>Ch. 1 – Introduction</td>
<td>Outlines the steps to getting started in SPOT Advanced</td>
</tr>
<tr>
<td><strong>THE SPOT ADVANCED APPLICATION</strong></td>
<td>Ch. 2 – Image Setups, Live Image Controls and the Setup Menu</td>
<td>Details the SPOT Advanced Application’s image setting options, how to use the Live Imaging feature, and the Preferences available for customizing your own SPOT Advanced environment.</td>
</tr>
<tr>
<td></td>
<td>Ch. 3 – Image Captures and the Camera Menu</td>
<td>Discusses the different types of image captures and the Camera Menu options.</td>
</tr>
<tr>
<td></td>
<td>Ch. 4 – Viewing and Editing Image Documents</td>
<td>Describes the rich set of image editing and customization features in the SPOT software including calibration and measuring tools.</td>
</tr>
<tr>
<td></td>
<td>Ch. 5 – Taskbars</td>
<td>Describes how to develop and utilize the floating taskbar feature</td>
</tr>
<tr>
<td>Section IV</td>
<td>Section IV</td>
<td></td>
</tr>
<tr>
<td>------------</td>
<td>------------</td>
<td></td>
</tr>
<tr>
<td>INTEGRATING A SPOT CAMERA INTO ANOTHER APPLICATION</td>
<td>THE SPOT ADVANCED MODULES (Optional)</td>
<td></td>
</tr>
<tr>
<td>Ch. 1 – Introduction</td>
<td>Ch. 1 – Introduction</td>
<td></td>
</tr>
<tr>
<td>Outlines the ways a SPOT Camera can be used in different software applications</td>
<td>Introduction to the Optional Advanced Modules</td>
<td></td>
</tr>
<tr>
<td>Ch. 2 – The SPOT Standard TWAIN Interface – PC</td>
<td>Ch. 2 – Peripheral Device Control</td>
<td></td>
</tr>
<tr>
<td>Describes the features and functionality of the included Standard TWAIN interface for use on a PC.</td>
<td>Outlines the steps necessary to setting up a peripheral device library and how to use a peripheral device.</td>
<td></td>
</tr>
<tr>
<td>Ch. 3 – The SPOT 3rd Party Interface – Mac</td>
<td>Ch. 3 – Extended Depth of Focus</td>
<td></td>
</tr>
<tr>
<td>Describes the features and functionality of the included Standard TWAIN interface for use on a Mac.</td>
<td>Describes the optional extended depth of focus features in the module.</td>
<td></td>
</tr>
<tr>
<td>Ch. 4 – Quantitative Imaging</td>
<td>Ch. 4 – Quantitative Imaging</td>
<td></td>
</tr>
<tr>
<td>Outlines the features unique to the Quantitative Imaging module and how they can assist you with your imaging.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ch. 5 – Extended TWAIN</td>
<td>Ch. 5 – Extended TWAIN</td>
<td></td>
</tr>
<tr>
<td>Explains how the entire SPOT Application is accessible from a 3rd Party host application and how to transfer images.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SECTION VI</th>
<th>AN APPENDICES</th>
</tr>
</thead>
<tbody>
<tr>
<td>Appendix A – Electronic Theory and SPOT Cameras</td>
<td>An introduction to the theory behind SPOT cameras.</td>
</tr>
<tr>
<td>Appendix B – Keyboard and Toolbar Button Commands</td>
<td>A table of menu commands and their keystroke and button equivalents.</td>
</tr>
<tr>
<td>Appendix C – Correct Color Technology™</td>
<td>Instructions for setting up the computer and microscope for Correct Color Technology™.</td>
</tr>
</tbody>
</table>
Chapter 2 – Basic vs. Advanced Applications

Introduction

The SPOT Software is available in either the Basic or Advanced applications.

- The Basic application is a simplified, stand alone version of the SPOT program which offers users a streamlined interface for capturing images without some of the decisions available in the Advanced application. The Basic application is ideal for users who simply need ‘snapshots’ of their specimens and do not plan on doing quantitative fluorescence work. Refer to Section II – The SPOT Basic Application for more details.

- The Advanced application is an easy to use, powerful and expandable version of the SPOT program which allows user greater control over the way images are captured and edited. The Advanced application supports additional features like database image archiving, extra report features and has the ability to be expanded with additional modules such as Extended Depth of Focus, Peripheral Device Control, and others. See Section III for details about the Advanced application and Section V for information on the available modules.

When you install the software, a SPOT icon will be placed on your desktop. If you have installed the Basic application, the SPOT icon on your desktop will automatically launch the SPOT application. If you have installed the Advanced application, you will be offered a choice between launching either the SPOT Basic or the SPOT Advanced application. The following paragraphs briefly compare the two applications.

Basic vs. Advanced Features

The SPOT Basic application includes simple image capture and editing functionality while the SPOT Advanced application has more extensive image capture and editing features as well as additional software tools. The following table compares the general features of the SPOT Basic and Advanced applications.

<table>
<thead>
<tr>
<th>Features</th>
<th>Advanced</th>
<th>Basic</th>
</tr>
</thead>
<tbody>
<tr>
<td>automated post-processing adjustments</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>calibration and measurement functions</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>customizable (user-defined) image setups</td>
<td>Extensive</td>
<td>Simple</td>
</tr>
<tr>
<td>customizable printing</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>database (Windows only)</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>exposure adjustment</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>image annotation</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>image editing</td>
<td>Extensive</td>
<td>Simple</td>
</tr>
<tr>
<td>live image preview</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>image editing in multiple color spaces</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>macro scripting</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>pre-defined image setups</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>recall of exposure values used in previous images</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>reporting</td>
<td>Extensive</td>
<td>Simple</td>
</tr>
<tr>
<td>sequential imaging</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>taskbars</td>
<td>X</td>
<td></td>
</tr>
</tbody>
</table>
Chapter 3 - Quick Start

SPOT Basic Application – Taking Your First Picture

The following sections list the basic steps for setting up your microscope and camera to immediately begin capturing images in the Basic application. The picture taking process consists of two multi-part steps:

- Preparing the microscope, specimen, and camera.
- Capturing the image.

These steps assume that you have already installed the SPOT software and connected the camera to your computer. If you have not done so, please refer to the installation guidelines provided with your SPOT Software CD.

Preparing the Microscope and Camera

1. Select the specimen that you want to photograph, and set up the microscope for Koehler illumination, if available on your microscope.
2. Ensure that the specimen is in focus.
3. Using a daylight filter, set the lamp voltage to the photo setting (or the rated lamp voltage). Keep an assortment of ND (neutral density) filters on hand to use for images that are too bright (i.e., you receive the Exposure time too short for Camera error message).
4. Open the SPOT Basic application by clicking on the SPOT icon on your desktop and selecting SPOT Basic if prompted.
5. Click on the White Balance toolbar button and follow the prompts to white balance your camera's exposure.

Capturing the Image

To capture an image, follow these steps:

1. View a real-time preview of your image capture by clicking on the Live toolbar button. The Live Image window appears. As the camera computes the optimal auto-exposure time, the title bar displays Computing Exposure. When the program finishes the exposure computation, the title bar displays Live Image - Running, as shown here.
2. Click on the Image Settings toolbar button to open the Image Settings dialog box. Check to ensure you are using the Profile named ‘Default’ and that the settings are as listed below. You can change between sections of the Image Settings dialog by selecting the appropriate tab.

**Appearance Tab**
- **Correct Colors** – Selected
- **Gamma** – 1
- **Contrast** – 0
- **Saturation** – 1
- **Color Temperature** - 5000
- **Noise Filter** – Selected
- **Flatfield** – None selected

**Exposure Tab**
- **Exposure Type** – Auto
- **Image Type** – brightfield-transmitted light
- **Brightness** – 1.00
- **Gain Limit** – 1 (all the way left towards ‘quality’)
- **Live Image Auto-Brightness** – Selected
- **Binning** – none
- **Spot Metering Area** – Same as Imaging Area
- **Live Image Maximum Exposure** – 10 seconds
Area Tab

- **Chip Imaging Area** – Full Chip
- **Display Full Chip Area in Live Mode** – Unselected
- **Resolution: Live and Captured** – Normal (if available)
- **Rotate** – As needed
- **Flip** – As needed
- **Live Mode Acceleration** – All the way to the left, 0 (if available)

Focus Tab

- **Show Focus Gauge** – Selected
- **Focusing Area** – Same as Imaging Area
3. Click on the Acquire Single Image toolbar button. The Acquire Single Image Dialog box displays the status of the capture as it is downloaded to your screen. Close the Live Image and Image Settings to see your captured image.
SPOT Advanced Application – Taking Your First Picture

The following sections list the basic steps for setting up your microscope and camera to immediately begin capturing images in the Advanced application. The picture taking process consists of two multi-part steps:

- Preparing the microscope, specimen, and camera.
- Capturing the image.

These steps assume that you have already installed the SPOT software and connected the camera to your computer. If you have not done so, please refer to the installation guidelines provided with your SPOT Software CD.

Preparing the Microscope and Camera

1. Select the specimen that you want to photograph, and set up the microscope for Koehler illumination, if available on your microscope.
2. Ensure that the specimen is in focus.
3. Using a daylight filter, set the lamp voltage to the photo setting (or the rated lamp voltage). Keep an assortment of ND (neutral density) filters on hand to use for images that are too bright (i.e., you receive the Exposure time too short for Camera error message).
4. Open the SPOT Advanced application by clicking on the SPOT icon on your desktop and selecting SPOT Advanced if prompted.
5. Click on the White Balance toolbar button and follow the prompts to white balance your camera’s exposure.

Capturing the Image

To capture an image, follow these steps:

1. View a real-time preview of your image capture by clicking on the Live toolbar button. The Live Image window appears. As the camera computes the optimal auto-exposure time, the title bar displays Computing Exposure. When the program finishes the exposure computation, the title bar displays Running, as shown here.
2. Click on the Live Image Controls button to open the Live Image Controls dialog box. Check to ensure that the settings are as listed below. You can change between sections of the Live Image Controls by expanding and collapsing the +/- next to each subdivision heading.

![Live Image Controls dialog box]

**Note:** In order to have your captured image look like your Live Image, be sure each section’s Link option is linked, without the red circle and line through it. Click on the Link icon to toggle the Links on and off.

### The Exposure Section
- **Type** – Auto
- **Binning** – none
- **Image Type** – brightfield-transmitted light
- **Brightness** – 1.00
- **Gain Limit** – 1
- **Auto-Brightness** – Selected
- **Maximum Exposure** – 10000 milliseconds

![Exposure section settings]

### The Imaging Area Section
- **Area** – Full Chip
- **Always Display Full Chip Area** – Unchecked

![Imaging Area section settings]
The Enhancements Section

Correct Colors – Checked
Gamma – 1.0
Contrast – 0
Saturation – 1
Color Temperature – 5000

4. Click on the Acquire Single Image toolbar button. The Acquire Single Image Dialog box displays the status of the capture as it is downloaded to your screen.
Chapter 4 - Custom Configuration

Configuring the SPOT Application for your camera, coupler and microscope.

The following sections outline the steps to customize your SPOT imaging setup. Depending on the level of SPOT software being used, the following options will be available for you to Import and use in your SPOT application: Calibrations, Palettes, Easy Essentials™ taskbar, and/or Image Setups.

Note: Have your SPOT camera installed, turned on, and the SPOT application running and please read through each section before beginning an Import session.

Importing Calibrations

1. Identify the magnification of the coupler that is attaching your SPOT camera to your microscope. If the coupler is made by Diagnostic Instruments, the magnification should be engraved near the camera end of the coupler.

2. In the SPOT software, select the Setup menu and choose Calibrations.

3. The Calibration Setup dialog window will appear and offer the option to Import. Click the Import button and browse to C:\Program Files\Common Files\SPOT Imaging Solutions\SPOT\Templates\Calibrations.
4. Select the file name (i.e. ‘1.0X Coupler Calibrations.spk’) which corresponds to your coupler magnification and click on the Import button.

5. The Import dialog window will appear with a listing of calibrations. Select the appropriate calibrations that match the objective magnifications on your microscope. To select multiple calibrations, use the Ctrl (PC), or Apple (Mac), button on your keyboard while clicking with your mouse.

6. Once you have selected all relevant calibrations, click on the Import button. The selected calibrations will then appear as a listing in the Calibration Setup window pane. The pre-configured, calculated calibrations are ready for use.

If you would like to save this subset of Calibrations, you can Export these settings. See Section III - Ch. 2 – SPOT Advanced Image Setups, Live Image Controls and the Setup Menu for more information on Importing and Exporting.

**Note:** Please review and consider the following information before importing the provided calibrations.

The image scaling used by the camera depends on the camera’s pixel size and the magnification of the lens system in the light path leading to the camera. The calculated calibrations included in the software account for two major lens systems on most microscopes:

1. The microscope objective setting
2. The camera/microscope coupler

**CAUTION!**

The calibrations that are provided as part of the SPOT application only account for the above two variables. These calibrations will not be valid if your microscope system has any other lens system with magnifications other than 1.0X.

The accuracy of the calculated calibrations is only as accurate as the lens systems. If precise measurements are necessary, we recommend using a User Defined Calibration with either a Traceable or Non-Traceable stage micrometer. We offer two versions of each, one for transmitted light and another set for reflected light.
<table>
<thead>
<tr>
<th>Cat. No.</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SM-775</td>
<td>Transmitted Light Stage Micrometer</td>
</tr>
<tr>
<td>SM-776</td>
<td>Reflected Light Stage Micrometer</td>
</tr>
<tr>
<td>SM-777</td>
<td>Transmitted Light Stage Micrometer, Traceable</td>
</tr>
<tr>
<td>SM-778</td>
<td>Reflected Light Stage Micrometer, Traceable</td>
</tr>
</tbody>
</table>

Contact our office for ordering or technical information at (586) 731-6000.

For more information on User Defined and Calculated Calibrations, please see Chapter 2 of either Section II for SPOT Basic or Section III for SPOT Advanced.

### Importing Palettes (Advanced application only)

Three pre-configured palettes are available for colorizing monochrome images. The Palettes which are available for importing are for DAPI (461 nm), GFP (509 nm) and Texas Red (605 nm). To import these palettes follow these steps:

1. In the SPOT software, select Setup from the main menu and choose Palettes.
2. The Palette Setup dialog will appear, click on the Import button.
3. Browse to C:\Program Files\Common Files\SPOT Imaging Solutions\SPOT\Templates\Palettes and select 'DAPI GFP TxRed Palettes.spx' and click on 'Import'.
4. In the Import dialog box, select the name of the Palette(s) that are appropriate and click on the Import button. Use the Ctrl button (PC), or Apple (Mac), and left-mouse click to select multiple Palettes and click on the Import button.

For more information on Palettes, please see Section III - Ch. 2 – SPOT Advanced Image Setups, Live Image Controls and the Setup Menu.
Importing Easy Essentials™ Taskbar (Advanced Application Only)

We have created a simple to use taskbar that offers one-button clicking for many of your day to day tasks. To import and view the Easy Essentials taskbar, follow these steps:

1. In the SPOT software, select Setup from the main menu listing and choose Taskbars.

2. The Taskbar Setup dialog will appear; click on the Import button.

3. Browse to C:\Program Files\Common Files\SPOT Imaging Solutions\SPOT\Templates\Taskbars and select 'Easy Essentials.spx' and click on 'Import'.

4. In the Import dialog box, select the name of the taskbar and click on the Import button.

5. Now that the taskbar has been imported, to view the taskbar, go to the View menu in SPOT and choose Taskbars.

6. A drop down list will appear with all available taskbars. Select the Taskbar, 'Easy Essentials'.

For more on setting up and customizing Taskbars, please see Section III – Ch. 5 – SPOT Advanced Taskbars.
Importing Image Setups (Advanced Application Only)

To make capturing images even easier, we have included basic Image Setups that can be imported based on your type of camera. These Image Setups will provide a good starting point for capturing basic brightfield and fluorescent images.

To import the Image Setups which are relevant to your type of camera, be sure to have your camera plugged in, turned on and the SPOT application open.

1. With the SPOT applications open select Help\About Spot from the main menu.
2. A splash screen will appear with information regarding your camera and software. Take note of the Model number of your camera and click Close at the bottom of the splash screen to close the window.
3. Select Setup from the main menu and choose Image Setups.
4. The Image Setups dialog will appear; click on the Import button.
5. Browse to C:\Program Files\Common Files\SPOT Imaging Solutions\SPOT\Templates\Image Setups and select the file name which corresponds to your camera’s model number. For example, if your camera model is 25.4, select the file named ‘25.4.x.spx’ and click on the Import button.
6. The Import dialog will open with a listing of pre-configured Image Setups for your camera based on the main types of imaging you may be doing with your SPOT Camera. Use the Ctrl button (PC), or Apple (Mac), and left-mouse click to select multiple Image Setups and click on the Import button.

For more on creating, importing and exporting Image Setups, please see Section III – Ch. 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu.
SECTION II –
THE SPOT BASIC APPLICATION

Chapter 1 – Introduction

Introduction: Using the SPOT Basic Application

The SPOT Basic application allows you to quickly and conveniently capture and edit images, without having to make decisions related to the numerous processing and editing options available in the Advanced program.

This chapter is divided into the following sections:

• Opening the SPOT Basic Interface
• The SPOT Basic Interface Overview
• Typical Imaging Process

Opening SPOT Basic

1. Double-click on the SPOT icon on your desktop.
2. Depending on your installation of the SPOT application, you may be presented with an interface selection dialog. Select the icon for SPOT Basic.
3. The SPOT Basic application will open and be ready for imaging needs.
The SPOT Basic Application Overview

Once the connection has been established with the SPOT Camera, click on the Live Image and Image Settings buttons on the toolbar. The interface can be arranged to look similar to that below. Each of the areas of the interface will be described in further detail in the subsequent chapters.
The Viewing and Editing Window

When you open or capture an image, it appears in the main viewing and editing window. All of the image save, view, edit, and annotation functions are accessed from this window, which consists of three areas:

- The Menu Bar
- The Toolbar
- The Status Bar

The Menu Bar

The Menu Bar in the Basic application varies according to whether an image is open.

If you have not yet either captured a new image or opened an existing image, the following menus are available: File, View, Camera, Setup, and Help.

If you have either captured a new image or opened an existing image, the following menus are available: File, Edit, View, Camera, Setup, Window, and Help.

- The **File** menu contains file open and save options, which for the most part, are identical to the standard file open and save options. Refer to Opening and Saving Files (below) for details. In addition, the File menu contains the report creation and viewing options. Refer to Chapter 5 – SPOT Basic Reporting for more details.
- The **Camera** menu contains initialization, image capture, white balance, flatfield correction, and live imaging options. Refer to Chapter 3 – Image captures and the Camera Menu for additional details.
- The **View** menu contains different options for viewing captured images. Refer to Chapter 4 – Viewing and Editing Image Documents for details. View selections are limited to “Full Screen” when an image has not yet been captured.
- The **Setup** menu contains options used to define operating preferences. Refer to Chapter 2 – SPOT Basic Image Settings and Preferences for details.
- The **Edit** menu contains image-editing options. Additional details can be found in Chapter 4 – Viewing and Editing Images Documents.
- The **Window** menu contains standard Windows display options. Refer to Chapter 4 – Viewing and Editing Images Documents for details.
- The **Help** menu contains information about the SPOT software and enables you to access the on-line help system.

The Toolbar

The Toolbar appears underneath the Menu Bar and contains all of the image capture, editing, and annotation functions in the Basic application. The following diagram illustrates the Basic program Toolbar, as it appears for an open image:
The Status Bar

The status bar at the bottom of your screen displays information about the on-screen image. The following is an illustration of the status bar, as it appears for an open image.

| Auto-Save ON | -21.7°C | 2048x2048 24bpp | [865,545] 162,95,73 | Fit to Win | Modified |

Each of the above section is described in the following list:

- **Auto-Save ON** – If Auto-Save is enabled in the Image Setup, Auto-Save ON will be displayed. If Auto-Save is not enabled the first section of the status bar will be empty.
- **Temperature** – The current temperature of the CCD. This value will only be displayed when using an Xplorer or Pursuit camera.
- **Image size** – (Columns, rows) in pixels [e.g., (1600, 1200)].
- **Pixel bit depth** (bits per pixel) - The pixel bit depth at which the image was captured. This value reflects the pixel bit depth for the image setup that was used to capture the image.
- **X Y pixel coordinates** - As you move your cursor over an image, the status bar displays the x y coordinates of the cursor in pixels.
- **Brightness values** - As you move your cursor over an image, the view status bar indicates the brightness values of the pixel coordinates. The status bar displays separate red, green, and blue brightness values for each part of the image.
- **Size Settings** - In the illustration above, the view status bar displays **Fit to Win** (Fit to Window), the default image capture setting. The size status will update to the setting selected, either Fill Window, Fit Height, or Fit Width. If you are in one of the zoom modes, this area displays the magnification level (e.g., 100%, 200%, etc…).
- **Modified Status** - The section to the right of the size settings states **New** until you modify an image. Once an image has been modified from the original status, the word **Modified** appears here.

Note: When the camera is on, but no image has been captured or loaded from an image file, only a limited number of toolbar icons will be functional.

When the camera is off or not connected, only a limited number of toolbar icons will be available and functional.

Typical Image Acquisition Process

1. Open SPOT Basic either from the desktop icon, or the application selection dialog.
2. Open the Live Image and Image Settings.
3. Select or create an Image Profile.
4. Adjust the focus and frame the specimen.
5. Adjust the image appearance using the Image Settings’ tabbed controls.
6. Acquire image.
7. View, Edit and Annotate your image.

8. Save your image.

The following chapters will explain in detail the functionality of each of the controls and displays encountered in the SPOT Basic application.
Chapter 2 – Image Settings and Preferences

The SPOT Basic application provides many useful features for scripting your images and customizing the interface to suit your needs. There are Image Settings, Calibrations, Reticles, Auto-Save features and Preferences available for you to make SPOT your very own. All of these features are available from the Setup Menu and are discussed in further detail below.

Image Settings - Preparing to Take a Picture

The Image Settings dialog is the central point for defining both live image and image capture settings. The Image Settings window enables you to optimize the live image view, and then capture an image using these settings. To open the Image Settings dialog, either click on the Image Settings toolbar button, or select Show Image Settings from the Setup menu. Each image capture/live image view option is discussed in the sections below. For additional information on the Live Image window, please refer to Chapter 3 – Image Captures and the Camera Menu.

Image Settings Window – Common Functions

Profile

The Profile feature allows you to name a particular configuration of image settings and recall it when you encounter that imaging situation again. When you open the Basic application the Default Profile is selected. When you make changes to any of the image settings, these changes can be saved to a Profile – either the Default or one that you create and name.

To add, edit, or delete Profiles, select the appropriate button or right-click on the Profile box. Either affords you the following options:

- **Add** – Add a new Profile. When you add a new Profile, the program prompts you to name it.
- **Save** – Save a Profile that you have modified.
- **Rename** – Rename an existing Profile.
- **Delete** – Delete a Profile. This option appears only if there is more than one Profile.

The Image Settings dialog box is divided into 5 tabs:

- **Appearance** – Adjustments for gamma, colors, and some post-processing features
- **Exposure** – Settings for image brightness
- **Area** – Options to set an imaging region of interest and image rotation
- **Focus** – Settings for the focus gauge
- **Measure** – Selections for how to apply calibrations, measurements, and reticles to images
Image Settings Window – Tabs

Appearance Tab

Use Defaults

The Use Defaults button will reset the values for Gamma, Contrast, Saturation and Color Temperature to their original default positions of 1 for Gamma, 0 for Contrast and Saturation and 5000K for the Color Temperature. This button may be useful if multiple adjustments have been made to these settings and you would like to start over with a fresh, un-adjusted image. Each of the features is discussed in further detail below.

Correct Color Technology™ (Color Cameras Only)

The Correct Color Technology option utilizes camera dependent color correction profiles that optimize the matching of colors between your microscope specimen, the live image you view on the screen of your monitor, and the image you capture with your SPOT camera. This is done by transforming the raw camera color data allowing it to be adjusted to display the closest approximation of the same color on your monitor.

In order to get the best results using this feature, you should make sure you set up your imaging system including your computer monitor appropriately. See Appendix C: Correct Color Technology for more information on system set-up.

Note: Color correction transformations that occur when you use Correct Color Technology will be applied to the raw image data, leaving a modified image file. If you will require the raw data for further analysis of your image, you should uncheck the Correct Color Technology checkbox.

Turning on Correct Colors enables the following additional color space manipulations: Contrast, Saturation, and Color Temperature.

Note: If your camera is a three-shot or slider version, Correct Color Technology will only be available in the Image Settings window if RGB is set as the filter color.

Gamma

Gamma adjustments are nonlinear operations which smoothly lighten darker areas of an image without burning out bright areas or lightening black areas. This is especially useful for capturing/editing images with a wide range of brightness values (dynamic range) such as fluorescence specimens or macroscopic objects with glints, (e.g., printed circuitry).
When the bright areas of these types of images are correctly exposed, the darker areas can be so dark that they are in effect invisible. Gamma Adjust can remedy this problem. The figures below illustrate the effect of a gamma adjust on a fluorescent image. The image on the left is the original image prior to the gamma adjustment. The image on the right has been gamma adjusted to a value of 1.75. In this instance, the gamma adjustment results in a better display of detail by lightening the darker areas without burning out bright areas or lightening black areas:

Fluorescence image, no gamma adjustment

Fluorescence image, gamma adjusted to 1.75

In the SPOT Software:

- Values between 1 and 4 lighten the darker areas of the image.
- Values between .1 and 1 darken the brighter areas of the image.

Refer to Ch. 4– SPOT Basic Viewing and Editing Image Documents for more details on gamma adjustment and color spaces.

**Contrast (only available when Correct Colors is enabled)**

Contrast is the degree of difference between the brightest and darkest parts of an image. If you would like to exaggerate the differences between bright and dark areas in an image, adjust the Contrast slider to the right to a level which looks suitable to you.

**Saturation (only available when Correct Colors is enabled)**

Saturation refers to the dominance of hue in a color. Colors which are not fully saturated will be more grey, or pastel, and colors which are fully saturated will be richer in color (hue). Move the Saturation slider to the right if you want to increase the richness, or to the left to decrease the richness of the colors in the image.

**Color Temperature (only available when Correct Colors is enabled)**

The Color Temperature slider (in Kelvin) is available for users to match the display of their images with their source illumination’s color temperature. Below is a list of some general color temperatures for typical light sources. Keep in mind these are averages or ranges and your individual bulb may differ. For the best accuracy, check the specification on your light bulb for the color temperature in degrees Kelvin.
For example, if you are using a Halogen bulb without a daylight blue filter in the light path, adjust the slider for **Color Temperature** to 3200K to best match how the software will display your image with what you see at the eyepieces. See the table below for a list of commonly available light sources and their range of typical color temperatures.

<table>
<thead>
<tr>
<th>Type of Bulb</th>
<th>Typical Color Temperature (K)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Incandescent</td>
<td>2800 – 3400, varies with voltage setting on microscope</td>
</tr>
<tr>
<td>Halogen</td>
<td>3200</td>
</tr>
<tr>
<td>Direct Sunlight</td>
<td>5000</td>
</tr>
<tr>
<td>Mercury</td>
<td>5000 - 6000</td>
</tr>
<tr>
<td>Xenon</td>
<td>6000 - 6200</td>
</tr>
</tbody>
</table>

**White Balance (Color cameras only)**

White balance is the ratio of red, green, and blue exposure times (3-shot cameras) or gains (color mosaic cameras) necessary to achieve the proper color rendition for an image. Many factors impact the coloration of an image capture, including lamp voltage, the coloration of the glass used in the slide, and the coloration of the glass used in the lenses of the microscope’s objectives. To minimize the impact of these factors, use the White Balance feature. When you perform a white balance calculation, SPOT samples the color of the white light provided by your light source after it has passed through the slide and the objective, and then calculates the red, green, and blue exposure times (3-shot cameras) or gains (color mosaic cameras) needed to produce images where the white areas are white and the color areas are true.

You should perform a new white balance calculation when:

- Starting a new image capture session.
- Changing the lamp voltage.

To perform a white balance, follow these steps:

1. Set the illumination and the objective that you will use for the image capture.
2. Select the appropriate **Image Profile**. Each Image Profile has its own set of white balance values. Any white balance values that you compute for an image type remain linked to that image type until you compute new values. When selecting a new image profile, remember that you will be using the white balance values linked to that image profile.
3. Show the camera a sample of white light. This step varies according to microscopy technique and Image Type (sample), as shown in the table below.

4. Click on the **White Balance** button. By default, a **Compute White Balance** dialog will appear with instructions on how to properly perform a white balance. If the preference to show helpful Messages has been turned off, this step will be skipped.

   ![Note: If you are comfortable with performing White Balances, you can check the box for Do not show this message again. If you desire, you can always turn this message back on in the Preferences (see below).]

<table>
<thead>
<tr>
<th>Image Type</th>
<th>White Balance Technique</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brightfield-transmitted light</td>
<td>Position the slide so that the specimen is not in the field of view, but light is going through the slide near the specimen.</td>
</tr>
<tr>
<td>Darkfield-transmitted light</td>
<td>Perform the white balance using the brightfield mode on your microscope. See Brightfield – transmitted light above.</td>
</tr>
<tr>
<td>Fluorescence</td>
<td>Use the Match Color feature (see below)</td>
</tr>
<tr>
<td>Nomarski DIC/Hoffman</td>
<td><strong>For Nomarski DIC:</strong> Adjust the Nomarski prism until the image is in either the “brightfield” or the “gray scale” view. <strong>For Hoffman:</strong> Perform the white balance directly on the Hoffman image.</td>
</tr>
<tr>
<td>Phase contrast</td>
<td>Position the slide so that the specimen is not in the field of view, but light is going through the slide near the specimen.</td>
</tr>
<tr>
<td>Polarized light</td>
<td>Place all polarizers and compensators into the light path and then position the slide so that the specimen is not in the field of view, but light is going through the slide near the specimen.</td>
</tr>
<tr>
<td>Brightfield-reflected light</td>
<td>Replace your sample with a mirror.</td>
</tr>
<tr>
<td>Darkfield-reflected light</td>
<td>Perform the white balance using the brightfield mode on your microscope. See Brightfield – reflected light above.</td>
</tr>
<tr>
<td>Stereo/Macro (all three options)</td>
<td>Using an EPI-illuminator (shining a light on the top of your specimen from off to one side), replace your sample with a white sheet of paper.</td>
</tr>
</tbody>
</table>

5. Click on **Begin** to start the calculation. The camera computes the white balance values, and they are automatically saved to the image settings for the image profile that you selected.

**Match Color**

The Match Color feature is typically used in two situations:

- You want to set the white balance for pictures taken with a microscopic technique that never has white in its images. A prime example of this situation is fluorescence microscopy. (To White Balance an Image)

- You want to change the colors of an image on the screen to match the way that you think the specimen looks. (To Match a Color)

If you use the Match Color option on a captured, previewed, or Live image, you can follow these steps to adjust the white balance.

1. Click on the Match Color button.
2. The mouse cursor will change to an eye dropper. Use the cursor to select (click) the color which needs to be adjusted to white.

Note: The R, G, and B values of the pixel that you select must all be less than full scale, i.e. 255 for 8 bit images, 1023 for 10 bit images, 4095 for 12 bit images and 16383 for 14 bit images.

3. The Match Color dialog appears with information about the pixel that you selected:

- **Hue** – The actual color, as distinguished from others in the color spectrum. Hue is derived from a color wheel and is expressed in the color’s angular location (i.e., 0 to 360 degrees).

- **Saturation** – The richness of perceived pure hue in the color. Saturation (in the SPOT Software) is measured on a numerical scale of 0 to 100, where zero equals pure grey and 100 equals pure hue (i.e. ‘day glow’).

4. Click the Make White/Grey button to rebalance the red, green, and blue ratio to make the selected pixel ‘white’.

5. To use these new values for the white balance values, click the Set White Balance button and click OK.

If you use Match Color on a captured or previewed image, you can also adjust a color which is not being displayed as you see it with your eyes.

Note: If you use the following options on a Live Image, the change you make will only be reflected in the current image frame. While you use the Match Color feature, the Live image is paused and the below changes will only be reflected in the displayed paused image frame. As soon as you click the OK button on the Match Color dialog box, the Live Image will resume and any modifications you made will revert back to the original colors. To retain the settings, click the **Set White Balance** button.

To use the Match Color feature for this purpose, follow these steps:

1. Click on the Match Color button.

2. The mouse cursor will change to an eye dropper. Use the cursor to select (click) the color which needs to be adjusted to a different color.

Note: The R, G, and B values of the pixel that you select must all be less than full scale, i.e. 255 for 8 bit images, 1023 for 10 bit images, 4095 for 12 bit images and 16383 for 14 bit images.

3. The Match Color dialog box appears with information about the color you selected as outlined above (Hue and Saturation).
Section II – Chapter 2 – SPOT Basic Image Settings and Preferences

4. The color you selected can be adjusted by a few different methods, aside from the Set White Balance option described above:

   • The Hue and Saturation inputs which are best used for minor adjustments or to set fluorescent colors to saturation.

   • The Select Color option is available for assigning a color correction to the image. This is accomplished by moving the crosshairs on the color wheel to the desired location by clicking on the new location or clicking and dragging.

For any of these adjustments, you can click the “Modify Main Image” check box to see your changes on the source image as you make them.

5. Click on OK to accept the adjusted image.

Noise Filter

The Noise Filter corrects for the effects of electrical or thermal noise. When capturing dim images with lengthy exposure times, the noise filter acts as a “virtual cooler” for non-cooled camera models, eliminating “hot pixels.”

The Noise Filter checks each pixel on the CCD chip as described below:

1. The program compares the value of each pixel with the values of eight neighboring pixels of the same color.

2. If none of the eight neighboring pixels has a value within the threshold value set (±15 %) for the pixel being checked, the value for the pixel being checked is replaced with the average of the eight neighboring pixels

   Note: On color mosaic cameras, this procedure is performed on each, the red, green and blue sets of pixels.

To activate the Noise Filter, check the Noise Filter box. The program runs the noise filter each time an image is captured.

Flatfield

The Flatfield option is used to correct for display problems associated with uneven intensity or coloration in illumination, or to correct for artifacts (e.g., dust) in the optical system.

   Note: Flatfield correction with the SPOT camera refers only to the correction of uneven lighting. It should not be confused with the correction of optical field flatness.

To use Flatfield Correct, follow these steps:

1. Ensure that the specimen is under the desired objective and in focus.

2. From the Image Settings menu, select Add under the Flatfield dropdown menu. The Get Flatfield dialog box appears.
3. Choose a number of frames to average. Larger numbers of frames will increase the accuracy of the flatfield correction, but will also increase the length of time it takes to create the flatfield image. The default number of frames to average is 3.

4. Select a name for the flatfield image file. Because flatfield image files are different for each objective, you might want to name the file according to the objective’s magnification (e.g., 10x).

5. Remove the slide from the field of view.

6. Click on Begin. The program will acquire the number of frames that you specified.

7. When the program finishes acquiring the frames, it will prompt you to block all of the light to the camera. This can be accomplished by installing the dust cap that was supplied with the camera or by adjusting the microscope’s optical path. After the light is blocked, click on OK. The program computes another frame.

8. The name of the flatfield file that you defined in step four should appear in the drop-down list of flatfield files.

9. Additional flatfield files can be created and used in different Image Profiles. This may be useful when using different objectives where different flatfield files would be necessary. Each Image Profile could be for a different objective with a different flatfield file. Use the pull down list to select from your list of Image Profiles and then make the appropriate flatfield file selection and save it to an Image Profile.

Perform the image capture. SPOT automatically uses the flatfield image to correct the capture.

**Exposure Tab**

*Exposure Type: Auto or Manual*

The Exposure option gives you the choice of having the camera calculate exposure time (Auto), or setting the exposure on your own (Manual). When you enter one of the above exposure settings, note that it applies both to the live image that you are viewing and the captured image. The exposure options will vary according to whether you select Auto or Manual, as illustrated later in this section. First the common features will be described.
Features Common to Auto and Manual Exposures

Binning

Binning combines adjacent pixels on the CCD chip, thereby reducing the number of pixels used in the image capture. Binning is useful when you have dim images and want to increase sensitivity and reduce download time. This gives you higher frame rates and less noisy images. But, as binning level increases, image resolution decreases. All of these factors should be considered when you select a binning option.

There are different binning options, depending on the camera model. Here are some of the possible choices:

- None 1 pixel = 1 pixel
- 2 x 2 4 pixels = 1 pixel
- 3 x 3 9 pixels = 1 pixel
- 4 x 4 16 pixels = 1 pixel
- 8 x 8 64 pixels = 1 pixel

Note: If your camera is a color mosaic version, binning will collapse the color data, resulting in a monochrome image.

Filter Color (3-Shot Color and Slider models only)

The Filter Color option specifies the color or colors that will be exposed in the live image preview/image capture.

- **RGB** – Preview/capture a full color version of your specimen using each state (red, green and blue) of the LCD filter.
- **Red** – Preview/capture a monochrome version of your specimen using the red state of the LCD filter.
- **Green** – Preview/capture a monochrome version of your specimen using the green state of the LCD filter.
- **Blue** – Preview/capture a monochrome version of your specimen using the blue state of the LCD filter.
- **Clear (not available on all LCD Filters)** – Preview/capture a monochrome version of your specimen using the clear state of the LCD filter.
- **None (Slider models only)** – Preview capture a completely unfiltered image. When using the Live Image window to focus or position dim images, users can slide the filter out to provide higher frame rates and less noisy images.

Display Images in Grayscale (3-Shot Color and Slider models only)

Grayscale imaging provides a “Black and White” version of your colored monochrome image. This feature provides a higher contrast, more easily visualized version of colored fluorescence images. The reason the human eye can visualize grayscale images better than monochrome color images is related to the fact that white light stimulates all three color receptors in the eye, providing higher perceived brightness and resolution. Use the Display Images in Grayscale to use this feature.
Features Specific to Auto Exposures

Image Type

An Image Type tells the SPOT program how to expose image captures. Each of the 11 available Image Types corresponds to a microscopy technique: select the Image Type that matches the technique you are using. The camera will compute exposures and capture the image accordingly. The table below describes typical situations for each image type.

<table>
<thead>
<tr>
<th>Image Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brightfield-reflected light</td>
<td>Polished metallurgical specimens and semi-conductors using a microscope with a vertical illuminator.</td>
</tr>
<tr>
<td>Brightfield-transmitted light</td>
<td>Stained specimens on glass slides using transmitted light microscopes.</td>
</tr>
<tr>
<td>Darkfield-reflected light</td>
<td>Bright areas of specimens being viewed with darkfield, reflected light techniques.</td>
</tr>
<tr>
<td>Darkfield-transmitted light</td>
<td>Bright specimens on dark backgrounds using transmitted light darkfield technique.</td>
</tr>
<tr>
<td>Fluorescence</td>
<td>Fluorescence specimens fluorescing in a single red, green, or blue primary color</td>
</tr>
<tr>
<td>Nomarski DIC/Hoffman</td>
<td>Specimens being viewed with either Nomarski DIC or Hoffman techniques.</td>
</tr>
<tr>
<td>Phase contrast</td>
<td>Specimens being viewed using the phase contrast technique.</td>
</tr>
<tr>
<td>Polarized light</td>
<td>Specimens being viewed with polarized light techniques.</td>
</tr>
<tr>
<td>Stereo/macro-metallic glints</td>
<td>Metallic specimens with intense glints.</td>
</tr>
<tr>
<td>Stereo/macro–no glints</td>
<td>Matte specimens without bright glints.</td>
</tr>
<tr>
<td>Stereo/macro–shiny glints</td>
<td>Shiny or wet specimens with bright glints.</td>
</tr>
</tbody>
</table>

Brightness

The Brightness control allows you to overexpose or underexpose (darken or lighten) the image area. A brightness value of 1, the default value, gives you the correct image brightness for most images. In many cases, an image has varying levels of brightness; to see a specific area better you might want to lighten or darken the image. When using the Brightness control, the SPOT camera uses an algorithm that combines gain and exposure time to provide the fastest possible frame rate in live mode:

- When overexposing images to make them brighter (i.e., entering values between 1.01 and 34), the camera first selects the highest possible gain before lengthening the exposure time. Because gain also brightens an image, less exposure time is needed.
- When underexposing images to make them darker (i.e., entering values between 0.24 and 0.99) the camera uses the lowest possible exposure time before lowering the gain.

Gain Limit

Normally an auto exposure routine in a digital camera sets the exposure time so that the brightest pixel on the CCD chip is completely “filled” with electrons, or is “full well”. This simple technique works well for bright images, but as an image gets dimmer, exposure times can get uncomfortably long. With the SPOT camera, you can shorten exposure times by filling the brightest pixel on the CCD to less than full well, and then using this lower level as full scale. The inverse fraction of full well that the brightest pixel on the CCD is filled to is known as the gain. For example, filling a pixel to half of full well cuts the exposure time in half. Since the exposure time is cut in half, we call this a gain of 2.

The Gain Limit feature allows you to set an upper limit on the gain options that will be available during the Auto-Exposure process.
For example, with a Gain Limit of 32 the camera can “choose” from a range of gain options. However, if you find that gains of 16 or 32 are too noisy for your images, you can prevent the camera from selecting these options by setting the Gain Limit to 8. When the Gain Limit option is set to 8, the camera is limited to the lower four gain options: 1, 2, 4, or 8. The following table illustrates levels of gain, the fraction of full well that the brightest pixel is filled to for each level, and a sample exposure time for each level:

<table>
<thead>
<tr>
<th>Gain</th>
<th>Fraction of Full Well</th>
<th>Exposure Time (sample)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>80 seconds</td>
</tr>
<tr>
<td>2</td>
<td>1/2</td>
<td>40 seconds</td>
</tr>
<tr>
<td>4</td>
<td>1/4</td>
<td>20 seconds</td>
</tr>
<tr>
<td>8</td>
<td>1/8</td>
<td>10 seconds</td>
</tr>
<tr>
<td>16</td>
<td>1/16</td>
<td>5 seconds</td>
</tr>
<tr>
<td>32</td>
<td>1/32</td>
<td>3 seconds</td>
</tr>
<tr>
<td>64</td>
<td>1/64</td>
<td>1 second</td>
</tr>
</tbody>
</table>

The table below summarizes the relationship between exposure time, background noise, and gain.

<table>
<thead>
<tr>
<th>Gain Limit</th>
<th>Possible Auto – Gain Settings</th>
<th>Exposure Time (dim images)</th>
<th>Background Noise (dim images)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>Longest</td>
<td>Lowest</td>
</tr>
<tr>
<td>2</td>
<td>1, 2</td>
<td>↑</td>
<td>↓</td>
</tr>
<tr>
<td>4</td>
<td>1, 2, 4</td>
<td>↑</td>
<td>↓</td>
</tr>
<tr>
<td>8</td>
<td>1, 2, 4, 8</td>
<td>↑</td>
<td>↓</td>
</tr>
<tr>
<td>16</td>
<td>1, 2, 4, 8, 16</td>
<td>↑</td>
<td>↓</td>
</tr>
<tr>
<td>32</td>
<td>1,2,4,8,16,32</td>
<td>↑</td>
<td>↓</td>
</tr>
<tr>
<td>64</td>
<td>1,2,4,8,16,32,64</td>
<td>Shortest</td>
<td>Highest</td>
</tr>
</tbody>
</table>

To set the Gain Limit, follow these steps:

1. Ensure that the camera is set to use the Auto-Exposure option.
2. Click on the Gain Limit select list, and select the number that you want to limit the gain to.

For more information on the concept of gain, refer to Appendix A: Electronic Imaging Theory and the SPOT Camera.

**Live Image Auto-Brightness**

Live Image Auto-Brightness is a feature that will recalculate brightness levels automatically. This feature is useful when you are changing objectives or changing between brighter and darker samples because the software will automatically recalculate the proper exposure based upon the brightness level as opposed to you clicking on the Live or Recompute Exposure (see below) buttons. Live Image Auto-Brightness is only available when you are using Auto exposure and viewing a live image.
**Spot Metering Area**

Similar to the way photographers spot meter their cameras on a particular location within their subject image plane, the SPOT user can do the same within the microscope’s imaging plane. The spot metering feature allows the user to best select an area of the image to be used as the region of interest for the automatic exposure level determined by the software.

This can be useful when the default auto-exposure settings (full image sampling) do not provide a captured image that provides the detail you need for a particular region of your subject being viewed.

On the Exposure Tab, there are two options:

- **Same as Imaging Area**
  This selection will meter the exposure based on the entire imaging area.

  OR

- **Set Area**
  This selection will meter the exposure off of the area in the selected subregion

  To set the Spot Metering Area:

  - Click on the **Set Area** button under Spot Metering Area.
  - Select the area of the Live, Paused, or Preview image by clicking and dragging the mouse across the desired area on the image.

**Exposure Limits – Live Image Maximum**

The Maximum Exposure setting allows you to set the maximum exposure time that is allowed while using the Auto Exposure feature. Computed auto exposures that would require an exposure time that exceeds this limit will result in an **Image Too Dim** error message. This allows you to configure what exposure time is considered out of range for the type of imaging you are performing.

Without this setting the software could try to calculate a multi-hour exposure due to the common user error of not having the microscopes light path selector set to send light to the camera. Typically the value is set to between 1-2 seconds for brightfield and bright fluorescence images. Longer exposures may benefit from manual exposure setting or test bracketing of sample specimens.

The range of valid values is dependent upon the type of camera you are using.

**Recompute Exposure**

**Recompute Exposure** is a way of forcing the camera and software to recalculate the appropriate exposure time. This feature is useful when not using the Live Image Auto-Brightness feature and you would prefer to control when the camera recalculates its exposure. If you would like the software to automatically adjust the exposure, you can use the Live Image Auto-Brightness feature, see above for details.
Features Specific to Manual Exposures

Exposure Time(s)
Photographically speaking, an exposure is the total amount of time that light is allowed to hit the imaging sensor before it is read out by the camera. The exposure of the image can be manipulated by adjusting the Exposure Time to suit your needs. Use the slider-bar or type in a value to specify an exposure time and adjust as needed.

Gain
When you define your own Exposure, you can enter the precise gain that the camera will use for an image capture. You can manually enter the gain value by using the slider bar to make your selection. The gain value displays to the right of the slider-bar.

To read more about Gain and what it is used for, please refer to the previous section about Gain Limit.

Auto-Adjust Exposure
This feature is designed to auto-adjust the exposure with changes to the binning level.
Select this checkbox and the SPOT program will adjust the exposure each time the binning level is changed in order to match the original brightness level of the displayed image.

The Exposure Time will decrease with greater binning levels and increase with lower binning levels.

Area Tab

Chip Imaging Area
SPOT allows you to use any rectangular portion of the CCD chip for image capture.

Using a portion of the chip is helpful in cases where you want to:
- Increase the live preview or captured frame rates
- Keep file sizes small.
- Shorten download times.
- Avoid areas of the image with optical problems (e.g., vignette areas).

There are three image area options:
- Full Chip – Capture the entire area of the CCD chip.
- **Center** – Capture a rectangular part of the CCD chip’s area that has the same height - to-width ratio as the full chip, and is centered on the center of the full chip. The percentage that you enter is the percentage of full chip width that the new area’s width will be.

- **Selection** – Capture a specific part of the CCD chip. To set, click on the **Set Area** button. Click and drag a rectangular region on the Live, Paused, or Preview Image.

**Display Full Chip Area in Live Image** - Ensures that you will always see the Full Chip view when viewing a live image. Keep in mind that the selection that you make here determines how the live image displays when viewing a region of the chip. Refer to the Chip Imaging Area section for details.

**Rotate 90°**

To match what you see through the eyepieces to what you see on your computer monitor, rotating the displayed image may be necessary. This may be required in situations where the optics provide a mirrored image or the camera is required to be rotated relative to the eyepiece image. Specify whether images will be rotated during the image capture/live image viewing process.

- Select **None** if you do not want the image to be rotated.
- Select **Left 90°** to rotate the image counterclockwise 90 degrees
- Select **Right 90°** to rotate the image clockwise 90 degrees.

**Flip**

To match what you see through the eyepieces to what you see on your computer monitor, flipping the displayed image may be necessary. This may be required in situations where the optics provide a mirrored image or the camera is required to be rotated relative to the eyepiece image. Specify whether images will be flipped during the image capture/live image viewing process.

- Select **Horizontal** to flip the image from left to right.
- Select **Vertical** to flip the image from top to bottom.
- Select both options to flip the image from left to right and from top to bottom.

**Resolution**

The Resolution option specifies various resolution mode settings for the SPOT cameras. These settings increase or decrease the resolution for any region of interest. The trade off in each instance is between frame rate download time and resolution.

**Flex**

The Flex camera has the ability to shift its CCD sensor and increase the captured image resolution. Moving the CCD sensor provides the user with several different resolution options.

<table>
<thead>
<tr>
<th>Resolution</th>
<th>Application</th>
</tr>
</thead>
<tbody>
<tr>
<td>FX15201/52 4MP Interpolated Color</td>
<td>The Normal setting takes a picture without shifting the CCD sensor. Each pixel on the CCD measures one color; red, green or blue, and the other two colors are interpolated based on neighboring pixels. The Normal setting is suggested for situations where a fast image capture is needed, such as when the specimen is moving or when a fluorescent dye is quenching rapidly. This mode of image capture provides images of a quality similar to other color mosaic SPOT cameras and a large area of image capture.</td>
</tr>
</tbody>
</table>
### 4-Shot 4Mp Co-Site Sampled Color

The 4-shot setting takes four consecutive images as the piezoelectric carriage moves the whole sensor in one-pixel increments in a 2x2 matrix so that each pixel location in the image will have each of the sensor’s colors shifted through it. This mode provides full color sampling similar to that achieved with SPOT 3-shot cameras. Shifting the CCD increases the time needed to capture the image. The 4-shot setting is suggested for non-moving, non-quenching specimens and when very accurate color and full sensor resolution is to be maintained.

<table>
<thead>
<tr>
<th>16-Shot 16Mp Co-Site Sampled Color</th>
</tr>
</thead>
</table>
| The 16-shot setting moves the sensor 16 half pixel moves in a 4x4 matrix providing full color sampling at twice the CCD resolution. This increases the time needed to capture the image. The 16-shot setting is suggested for non-moving, non-quenching specimens and when very accurate color and high resolution is required. This mode of image capture extends the sensor resolution via subpixel sampling and provides images of unparalleled quality (resolution and color) compared to other color cameras available.

### Normal 4Mp Monochrome

The Normal setting takes a picture without shifting the CCD sensor. The Normal setting is suggested for situations where a fast image capture is needed, such as when the specimen is moving or when a fluorescent dye is quenching rapidly. This mode of image capture provides images of a quality similar to other 4Mp monochrome SPOT cameras and a large area of image capture.

### 4-Shot 16Mp Monochrome

The 4-shot setting for the Flex Monochrome cameras takes four consecutive images as the piezoelectric carriage moves the whole sensor in half pixel increments in a 2x2 matrix. Shifting the CCD increases the time needed to capture the image. The 4-shot setting is suggested for non-moving, non-quenching specimens and when high resolutions images are desired.

### 9-Shot 36Mp Monochrome

The 9-shot setting for the Flex Monochrome cameras takes four consecutive images as the piezoelectric carriage moves the whole sensor in one-third pixel increments in a 3x3 matrix. Shifting the CCD increases the time needed to capture the image. The 9-shot setting is suggested for non-moving, non-quenching specimens and when very high resolutions images are desired.

### 16-Shot 64Mp Monochrome

The 16-shot setting for the Flex Monochrome cameras takes four consecutive images as the piezoelectric carriage moves the whole sensor in one-quarter pixel increments in a 4x4 matrix. Shifting the CCD increases the time needed to capture the image. The 16-shot setting is suggested for non-moving, non-quenching specimens and when very high resolutions images are desired. This mode of image capture extends the sensor resolution via subpixel sampling and provides images of unparalleled quality.

---

**Note:** Sub-pixel shifting will increase the image file size.
Idea

The SPOT Idea camera allows the selection of lower resolution settings to provide faster frame rates and smaller file sizes. Using the camera in these modes can improve imaging of moving specimens or enhance sequential image captures. The Resolution of the Live Image and Captured Images can be set independently using the respective pull down menus.

<table>
<thead>
<tr>
<th>Resolution</th>
<th>Application</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal Full Sensor Resolution</td>
<td>The Normal setting takes a picture without reducing the resolution of the sensor. The Normal setting is suggested for situations where a full resolution image capture is needed.</td>
</tr>
<tr>
<td>0.5 One-Half Resolution</td>
<td>The Half Resolution setting takes a picture with one half of the pixels in the width, and one half the pixels in the length dimensions. This setting allows for a faster live image display and may be of benefit when you may want to capture a better image of a moving specimen.</td>
</tr>
<tr>
<td>0.33 One-Third Resolution</td>
<td>The One-Third Resolution setting takes a picture with one half of the pixels in the width, and one half the pixels in the length dimensions. This setting allows for a faster live image display and may be of benefit when you may want to capture a better image of a moving specimen.</td>
</tr>
<tr>
<td>0.25 One-Quarter Resolution</td>
<td>The One-Quarter Resolution setting takes a picture with one half of the pixels in the width, and one half the pixels in the length dimensions. This setting allows for a faster live image display and may be of benefit when you may want to capture a better image of a moving specimen.</td>
</tr>
</tbody>
</table>

**Live Mode Acceleration**

Live Mode Acceleration enables you to “speed up” the live image display (higher frame rates) in cases where you are willing to sacrifice some live preview resolution for a higher frame rate. Depending on the model of your SPOT camera, this option may appear as a slider with multiple positions or a simple check box to toggle the feature on or off. If you have a slider available, moving the slider towards the right increases the acceleration. This setting does not decrease the resolution of the captured image.

**Focus Tab**

**Show Focus Gauge**

The Focus Gauge feature is designed to be an aid in focusing the selected region of the Live Image window. As the focus is adjusted at the microscope the blue bar lengthens and shortens showing the current focus level. The red line acts as a high water mark showing the highest level of focus over the last few seconds. Check the box for **Show Focus Gauge** to activate this feature.

**Focusing Area**

The Focus gauge can be set to provide focus feedback from all or only a specific area of the image. The two options are:
Section II – Chapter 2 – SPOT Basic Image Settings and Preferences

- **Same as Imaging Area**: This selection will set the focus gauge based on the entire area currently being viewed.

- **Set Area**: This selection will set the focus gauge based on a sub-region you draw. The sub-region is created by clicking the Set Area button and then clicking and dragging the desired area on your image. Once the selection has been made it will be highlighted in pink.

---

**Note**: The Focus Area must be within the Imaging Area. If you are using the option to “Display Full Chip Area in Live Mode” and you draw a region outside of the yellow box, no selection will be made and the ‘Set Area’ button will remain depressed, waiting for a valid input. If the region is drawn overlapping the imaging area, the software will use the portion of the drawn focus region which is within the imaging area.

**Measure Tab**

The Measurement Tab provides the user access to image dimensioning tools including Image Calibration selection, Reticle overlays, and Measurement tools.

**Save Calibration with Image**

If one or more calibrations have been set up, a list will be available in the pull-down menu. Select the appropriate calibration to save to the Profile and be applied to each image captured using the Profile. See Chapter 4 for additional details on setting up Calibrations.

**Apply Reticle to Live Images**

If one or more reticles have been set up, a list will be available in the pull-down menu. Select the appropriate reticle to apply to Live Images and save to the Profile. See later in this Chapter for additional details on setting up Reticles.

**Apply Reticle to Captured Images**

If one or more reticles have been set up, a list will be available in the pull-down menu. Select the appropriate reticle to apply to Captured Images and save to the Profile. See later in this Chapter for additional details on setting up Reticles.

**Measure**

This button opens the Measure dialog for Live Image measurements. The Measurement Dialog freezes the Live Image to facilitate the accurate drawing of the measurement tool options on the paused image.

The intent of the Live Image Measurement tool is to provide you with an easy way to make a measurement while ‘on-the-go’ and viewing the Live Image as a rough estimate of the measurement. The easiest measurements are applied to captured images (See Ch. 4 – SPOT Basic Viewing and Editing Image Documents for more about measurement tools and how to apply them to captured images).

While the Measurement dialog is open and after a measurement is applied to the image, you can choose to Export the Measurement. Please see Ch. 4 – SPOT Advanced Viewing and Editing Image Documents for details.
There are two methods for applying Live Image Measurements to a captured image, the option you choose will mostly depend on whether your sample is moving or not.

For moving specimens, capturing the specimen before it moves out of the field of view and freezing its motion during the measurement process is of primary importance. To achieve this, the user should select the Pause button at the bottom of the Live Image window when the specimen is in an acceptable position. This will freeze the Live Window Image then the Measurement button should be selected, measurements made, and the dialog closed. The final step is to select the Transfer button at the bottom of the Live Image Window. This will Transfer the Paused Live Image to a Captured Image Window allowing for its further editing, annotation and saving.

Note: If the user transfers the image prior to the closing the measurement dialog the measurements will not be displayed on the transferred image. To display the measurement on the transferred image, first close the Measurement dialog and then click the Transfer button on the Live Image window. Alternatively, the measurements can re-applied to the Captured Image Window using the Add/Edit Measurements feature in the Edit Menu.

For non-moving specimens, Go to the Preferences dialog found in the Setup Menu (below), Select the Image Acquisition pane and check the box for Apply Live Image Measurements to Captured Images.

Note: If no calibration has been saved with the Profile, the default calibration will be ‘Uncalibrated’ and the measurements will be expressed in pixels. Once a Calibration Setup is added to the Image the Measurements will be displayed in the measurement units of the calibration.

Preferences

The SPOT applications’ Preferences can be accessed from the Setup Menu and selecting Preferences. Use the Preferences option to specify:

- How new image windows are displayed
- Image window arrangement
- Magnifier settings
- Size of the onscreen toolbar
- Sequential imaging memory settings
- Thumbnail appearance
- Spell checking options
- Shorthand settings
- Image profile save selections
- Image capture settings
- The relative bus width used during image capture (Firewire cameras only)
- Temperature readout interval (Xplorer and Pursuit cameras only)
- Image print resolution choices
• Image Cache file path settings
• Helpful messages selection

Each preference is discussed in further detail below.

**Application Selection** (only available if SPOT Advanced is installed)

The Application Selection pane will only be available to users who have installed the SPOT Advanced Application in addition to the Basic application. There are three options for how to launch the SPOT program if both applications have been installed.

**Always run SPOT Basic**

If **Always run SPOT Basic** is selected in the Preferences, every time you click on the SPOT icon on your desktop, the SPOT Basic application will always open without asking for your selection.

**Always run SPOT Advanced**

If **Always run SPOT Advanced** is selected in the Preferences, every time you click on the SPOT icon on your desktop, the SPOT Advanced application will always open without asking for your selection.

**Ask which application to use**

If **Ask which application to use** is selected, clicking on the SPOT icon on your desktop will launch the application selector dialog for you to make your selection every time you start the SPOT Software.

**Image Display**

**View Mode**

The View Mode defines how images will be displayed when they are captured based on source image size, display canvas size or zoom level. (Note: Live Image View Modes are controlled in the Live Image Window Controls)

**Normal** – When selected, captured images will be displayed at the Zoom Level specified with the Cursor Zoom tool turned OFF. (Use Zoom selection if you would like Zoom tool turned ON)

- **Zoom Level** – this setting defines the percentage zoom your image will be displayed if Normal or Zoom (below) are selected.

**Zoom** – When selected, captured images will be displayed at the Zoom Level specified with the Cursor Zoom tool turned ON. Right-click to zoom in, left-click to zoom out.

- **Zoom Level** – this defines the amount of zoom your image will display if you select the Zoom option or Normal (above).

**Fit to Window** – When selected, the captured image is sized to fit into the Display Window. Choose this setting to provide a full field of view at the maximum size that will still fit into the Display Window. In most cases, this will result in the displayed image appearing at lower resolution that what is available in the image. The magnifier can be used to look at image details in this case.

**Fit Height** – When selected, the display zoom level of the captured image will automatically adjust to the maximum setting which allows the entire image height to be viewable within the
Display Window. This may result in areas of the image not being displayed or portions of the display window not being used while in Full Screen mode.

**Fit Width** – When selected, the display zoom level of the captured image will automatically adjust to the maximum setting which allows the entire image width to be viewable within the Display Window. This may result in areas of the image not being displayed or portions of the display window not being used while in Full Screen mode.

**Fill Window** – This feature will resize the image to entirely fill the Display Window or full screen. Note this will result in horizontal or vertical areas of the image not being displayed since they will be out of the image window field of view.

**Show**

**Annotations** - When selected, any annotations previously added to the image will be displayed upon opening it.

**Calibration Marks** - When selected, any calibration marks previously added to the image will be displayed upon opening it.

**Measurements** - When selected, any measurements previously added to the image will be displayed upon opening it.

**Reticles** – When selected, any reticles previously applied to the image will be displayed upon opening it.

**Enable Pan Window**

When selected, a pan window will open on the captured image any time any of the image is outside the Display Window’s Field of View. This is useful in all of the view modes and when the Zoom Mode Cursor tool is to be used after the image is captured.

**Auto Arrange Windows**

When selected, each successive image taken will be placed next to the preceding image in a horizontal, vertical or tiled matrix orientation.

The Horizontal setting will place new images to the right of the previously captured images until the Column Limit entry in the Window Arrangement settings is met (next section). The images will be resized as they are captured to maximize their viewable area. Once the Column Limit is reached, additional images will form a new Row under the previously captured images. The Vertical setting will place new images under the previously captured images until the Row Limit entry in the Window Arrangement settings is met (next section). The images will be resized as they are captured to maximize their viewable area. Once the Row Limit is reached, additional images will form a new Column to the right of the previously captured images.

The Tiled setting will place new images into a matrix of rows and columns that will maximize their viewable area.

**Window Arrangement**

Set the number of columns or rows to be allowed when Auto-Arrange Vertically or Horizontally has been selected above.

**Magnifier**

Set the dimension and magnification factor of the magnifier window. Define the magnifier window size in pixels and the magnification with a numerical value.
Toolbar
This selection allows the user to specify whether the onscreen toolbar icons in the SPOT program should be shown at all, as well as if they should be displayed in small or large format.

Image Sequences

Memory Usage Limit
Specify how much memory is allocated for image acquisition. Note that the entry parameters are system dependent.

Cache Images During Play
When ‘playing’ an image sequence (see Ch. 8), the SPOT program allows you to select how it loads the displayed images.

If Cache Images During Play is selected…The program pre-loads as many images from the sequence as your computer’s RAM allows. This enables a faster display of the image sequence. But, if you have a sequence with many images, the size of the combined images could exceed the RAM, and in this case, the SPOT program will load as much of the sequence as possible, play that part of the sequence, and then pause to load the remaining images.

If Cache Images During Play is not selected…The program loads each image in the sequence individually. In cases where you have a large sequence with many files, this allows you to work without being restricted by RAM limitations. The display of images will be somewhat slower than a display where images are cached.

Thumbnails
Select a thumbnail size to be used for the Show Image File Thumbnails option. There are four options available from which to choose:

- Small (60 x 60 pixels)
- Medium (90 x 90 pixels)
- Large (120 x 120 pixels)
- User Defined
  Minimum width and height = 20 pixels
  Maximum width and height = 200 pixels

Secondly, you can specify the resolution of image thumbnails (Show Image File Thumbnails option). Select from one of the following 4 options:

- Small (54 pixels)
- Medium (84 pixels)
- Large (114 pixels)
- User Defined
  Minimum resolution = 16 pixels
  Maximum resolution = 200 pixels
Spell-Checking

- Select whether or not to use the spell checking offered by the SPOT program. You can also select to Add a Dictionary if you have one loaded on your local machine. Additional .dic & .dict format dictionaries can be acquired for free from the internet.

Shorthand

If you are typing the same text repeatedly, you may want to use the Shorthand feature. Use the Add button to create a new Shorthand entry. In the Shorthand Item entry dialog, enter the shorthand keystrokes into the Key entry field and the autofill text into the Text entry field. To modify or delete an existing entry click on the entry in the list and then select Modify or Delete.

After entry your Shorthand entries will be recognized in any text entry dialog and will automatically be replaced with the autofill text.

Profile Saving

There are three options for saving your changes to your Image Profiles:

Automatically Save Changes- With this option selected, the SPOT Software will automatically save any changes you make to an Image Profile upon closing the SPOT application or changing profiles.

Prompt Before Saving Changes - With this option selected, you will be asked if you would like to save changes to your Image Profile upon closing the SPOT Application or changing profiles.

Do Not Save Changes - With this option selected, changes to your Image Profile will not be saved nor will you be prompted and informed of the changes upon closing the SPOT Application or changing profiles.

Image Acquisition

Specify the pixel bit depth for captured images. The Captured Image Bit Depth option enables you to specify a different image bit depth when saving an image captured in the SPOT program. The options vary depending on the camera used:

8 Bits per Channel –

With monochrome cameras, captured images are 8 bits per pixel monochrome providing 256 levels of grayscale. With color cameras, captured images are 24 bits per pixel RGB color providing 16.58 million color representations. This option results in smaller, more manageable image sizes, and is best for images that do not require extensive modification.

10 Bits per Channel –

With monochrome cameras, captured images are 10 bits per pixel monochrome providing 1024 levels of grayscale. With color cameras, captured images are 30 bits per pixel RGB color providing 10.7 billion color representations. This option results in smaller, more manageable image sizes, and is best for images that do not require extensive modification.

12 Bits per Channel –

With monochrome cameras, captured images are 12 bits per pixel monochrome providing 4096 levels of grayscale. With color cameras, captured images are 36 bits per pixel RGB color providing 68.6 billion color representations. This option reduces banding problems that can result with modified images, but also results in larger file sizes. When saving 12 bit per channel images, SPOT prompts you to select either 12 bits per channel or 16 bits per channel. If you use Adobe’s Photoshop for image editing, you should select the 16 bit per channel option because Photoshop cannot read 12 bit per channel images.
14 Bits per Channel –

With monochrome cameras, captured images are 14 bits per pixel monochrome providing 16,384 levels of grayscale. With color cameras, captured images are 42 bits per pixel RGB color providing 4.4 trillion color representations. This option further reduces banding problems that can result with modified images, but also results in even larger file sizes.

Specify whether you would like to utilize a shutter sound on image capture.
The Make Shutter Sound option, when checked, will provide a “click” sound during the camera exposure sequence, confirming that the image capture is complete. If the image capture is relatively quick, you will hear a single click. If the exposure is longer (i.e. greater than one second) you may hear a “beginning exposure” click and an “ending exposure” click.

Apply Live Image Measurements to Captured Images
Select this box if you would like your Live Image Measurements to appear on your captured images. Read more about the options available for Live Image Measurements in Chapter 3.

Monitor Color Filter Position for Image Capture (Slider cameras only)
If this option is selected the SPOT software will produce an error message if the color filter isn’t in the proper position while capturing an image. The Monitor Camera Color Filter Position box is checked by default.

Monitor Color Filter Position for Live Images (Slider cameras only)
If this option is selected the SPOT software will produce an error message if the color filter isn’t in the proper position while viewing the Live image. The Monitor Camera Color Filter Position box is checked by default.

Use Single Channel Readout for Live Images (Insight, Flex, RT, Pursuit, Xplorer cameras)
Many SPOT cameras normally use two channels to read out their Live Image in order to provide faster focusing. However, with two channels reading out the image, there is a chance for a slight mismatch in the shading between the two sides of the live image display.

To avoid this mismatch, you can choose to readout live images using a single channel, thus eliminating any shading mismatch, but this selection will result in slower effective focusing of the camera.

Note: All SPOT cameras, except for the Insight Gigabit, always capture images in single channel mode, thereby eliminating any chance of shading mismatch in the acquired images.

Bus (Firewire cameras only)
This setting allows the user to specify the relative bandwidth to be utilized when the camera is capturing and transferring data to the computer. The three choices are High, Medium, and Low.

Temperature Readout (Xplorer and Pursuit only)
This option enables the user to specify the time interval between sensor temperature readings in seconds.
Image Print Resolution
This option is available for users who wish to set the print resolution of images in pixels per unit area. For example, a full size image from a SPOT 4Mp camera such as the IN1420 would be 2048 pixels wide by 2048 pixels tall. If you wanted to set the printing size to be 2.048 inches by 2.048 inches, you would set the image print resolution to 1000 pixels per inch. In this way, the larger the number of pixels per inch you select, the smaller the image will print and vice versa.

The Image Print Resolution set here will affect all images acquired. The Image Print Resolution is used within the SPOT Software’s Print Dialog Editor and is passed with the image information to other image applications such as Photoshop. See Ch. 6 – SPOT Basic Image Printing for more on the Print Dialog Editor.

Add Extensions to File Names on Save (Mac)
When selected, the Add Extensions to File Names on Save option automatically appends the file type extension (e.g., JPG, tiff, bmp, etc…) to your image file. This enables cross platform file sharing, because Windows based programs require a file type extension, while Mac based programs do not. Once the file type extension is added, Windows based programs can recognize the Mac file.

File Paths
Image Cache File Path
Use this setting to set the path for caching images to a hard disk instead of RAM.

Base Object Image File Path
Use this feature to set the root file path where Images which will be used as Objects are stored on your local computer. In the SPOT Basic application this would include Annotation Stamp Image Files. See more about Annotation Stamp Images in Chapter 4.

Messages
Select Show All Informational Messages to display helpful prompts from the SPOT program to walk you through such features as Compute White Balance, etc. It is only recommended to turn this feature off for expert users of the SPOT program.

Calibration Set Up
The SPOT program allows you to create calibrated images. Calibrations facilitate the SPOT Measure, Reticle and Calibration Mark Features. Multiple calibrations can be made to accommodate the multiple magnifications available on your imaging system.

There are two types of calibrations available, Calculated and User-Defined.

The Calculated Calibration type is generally used when only an approximate order of magnitude reference mark or measurements are needed. They are the easiest to make and will be sufficient for many applications.

The User-Defined Calibration type is generally used when quantitative data is required. They are derived from an empirical measurement of a known reference standard and therefore compensate for production variations that are a source of error in the Calculated calibrations.
Creating a Calculated Calibration

To setup a Calculated calibration, follow the steps below.

1. From the Setup Menu, select Calibrations. The Calibration Setup Dialog will be displayed.

2. For a new calibration, choose Add, or for an existing calibration you can select Modify.

3. The Calibration Editor dialog appears (see right).

4. Enter a name for the calibration if the calibration is New. Typically either the objective magnification or zoom level magnification is used, in this example, 10X.

5. Select the Calculated setting.

6. Enter the objective, adapter, and auxiliary/body magnifications in to the Objective, Relay and Other fields, respectively. Note that missing or no lens elements should be set to 1.

7. Select the standard units you require from the drop down and the SPOT program will calculate the appropriate calibration in the units you specify for the camera you have connected. If the units you desire to use are not available, you can type it into the entry field too.

Creating a User-Defined Calibration

To set up a User-Defined calibration, you will need a base image to use for the calibration. You can either use a captured image or the Live Image as the base image. If you have a captured image and the Live Image open, both options will be available to you (below), otherwise only the option available will be listed in the Calibration Editor dialog (below). Note, before you begin these steps you must have either the Live Image open or a captured image displayed.
To begin:
1. Place a stage micrometer under the objective.

2. Use the Live Image preview to adjust the microscope to display as much of the stage micrometer as possible and align the stage micrometer square to the field of view. Refer to Chapter 3 – SPOT Basic Image Captures and the Camera Menu for details on using the live image display.

3. You can either work off of the Live Image or you can capture an image of the stage micrometer. Refer to Ch. 3 – SPOT Basic Image Captures and the Camera Menu for details on capturing images.

4. From the Setup menu, select Calibrations. The Calibration Setup dialog appears (see right).

Note: Set the zoom level to an appropriate level on either the Live Image or the Captured Image prior to proceeding to the next step. Once the Calibration Editor dialog opens, the zoom level of the image will be locked. If the Live or Captured image is open with the pan window enabled and the zoom is on, the image will scroll as you draw your line (step 8) thus making for more accurate placement of the cursor on the image pixels. (See Ch. 3 and 4 of this section for more information about using the Zoom options in the Live and Captured images, respectively.

5. Click on Add. The Calibration Editor dialog appears.

6. Enter the name of the calibration setup. Typically this corresponds to the magnification of the objective (e.g., 10x).

7. Select the User-Defined setting.

8. Using the mouse, draw the calibration line along the length of the stage micrometer image. When you draw the line, keep these guidelines in mind:
   - Keep the line as straight as possible.
   - Make the line as long as possible.
   - Use the largest unit of measurement that the micrometer allows for.

To draw the line, follow these steps:
  - Position the crosshair cursor over the stage micrometer mark that represents the start point of your calibration line
  - Left click on the mouse.
  - Drag the cursor to the stage micrometer end mark
  - Left click on the mouse again.
  - The length of the line in pixels appears on the Calibration Setup window.
  - To adjust the start or finish points of the calibration setting line, click and drag the edit handles at either end of the line.
To redraw the calibration setting line, click on the line to select it and press the delete key. You can then redraw the line.

9. Enter the length and units of the line that you drew.
10. Click on OK.

This magnification setup is now calibrated and you are ready to perform measurements. Repeat steps one through ten for each optical magnification.

**Importing and Exporting Calibrations**

You can move your calibration setups to and from another computer.

To export calibration setups, follow these steps:

1. Choose Calibrations from the Setup menu.
2. Highlight the calibration setups that you would like to export. To select multiple calibration setups, hold down the Control button while selecting them.
3. Click on Export.
4. Select a File name and location and choose Save.

To import calibration setups, follow these steps:

1. Choose Calibrations from the Setup menu.
2. Click on Import.
3. Select the calibration file that you would like to import. This will be a file of type SPOT Export (spx).
4. Choose Open. The calibration setups will appear in the Import menu.
5. Select the calibration setups that you require and choose Import.

The calibration setups will now be available for you to use.

**Reticle Set Up**

Reticles are calibrated geometric image overlays that are used as a comparison reference for sizing, qualifying (Go/No-Go) or counting objects in the underlying image.

Reticles are available for use on both Live and Captured Images. They are easily generated and customizable. Reticles provide objects such as cross-hairs, rulers, grids, concentric circles or rectangles, and allow for the combination of several different reticle objects into one reticle setup.

There are two steps to implementing reticles:

1) Creation of the Reticle Setup

2) Linking a Reticle Setup to an Image Profile.

The following section will cover the creation of Reticle Setups. For details on Linking a Reticle Setup to an Image Profile, see Chapters 2 and 4 of this section.
Creating a reticle

To create a new reticle or to Modify an existing reticle, follow these steps:

1. From the Setup menu, select Reticles.

2. The Reticles dialog box will appear. Click the Add button to create a new reticle. If you would like to modify an existing reticle, click on the name of the reticle and click the Modify button to modify it.

3. The Add/Modify Reticle dialog box will appear which will ask if you want to create your reticle based upon a Currently Open Image (only available if an image is open) or if you want to use a Blank Image.

   Select Currently Open Image to use an actual image on which to base your reticle. Select the appropriate image title from the pull down list and click Ok.

   Select Blank Image if you would like to create reticles on an empty, grey image document. Set the blank image’s dimensions in pixels and then provide it with an appropriate calibration if available. The check box to Display in Fit to Window Mode is checked by default, which allows you to see the entire image within the image document window. Click on Ok.

4. The Reticle dialog box will appear which has all the tools for specifying which objects you would like in each reticle file you create. One reticle file may contain as many objects as you would like. Select the type of reticle object you want by clicking on the appropriate object button.

Reticle Objects

Select Tool

The Select Tool enables cursor based manipulation of reticle objects using their edit handles. When this tool is active, use your mouse to click on and select an object. Once active, edit handles appear as small white and yellow features attached to reticle objects. Edit handles will typically allow you to free hand resize, rotate or reposition an object. More precise object manipulation can be achieved selecting an object and then typing in desired dimensions to the control fields for that object. (See the following sections)

To select multiple objects, hold the Control button while you click or, if you click and drag the cursor across reticle objects, all objects which fall in the highlighted region will be selected. When multiple objects are selected, changes made to available settings will affect all objects.
Line

Use the Line Tool to create a horizontal, vertical, and diagonal lines on your image.

Set the **Line Thickness** and **Color** to be applied to the lines of the reticle. Type in the thickness value or use the up and down arrows to set the thickness. Click on the **Color** button to open the Select Color dialog.

Check the box to **Show Text** if you would like to display the numerical units for the ruler marks. Use the Font button to pick the font characteristics you would like to use. Use the pull down list to select the number of **Decimal** places you would like displayed.

Choose whether you want **Horizontal** and/or **Vertical** Lines by selecting the appropriate check boxes. Each line's individual characteristics can be set. Choose a **Length of Image Width/Image Height** to fill the entire width/height of an image with the horizontal or vertical line. Alternatively, set the length of the line by typing in the number of units you wish to display.

Select whether or not you want to display **Major** or **Minor Ruler Marks** and set the spacing for the major ruler marks.

You can also choose to start the numbering from **Left** or **Center** for **Horizontal** lines and the **Top** or **Center** for **Vertical** lines.

Adjust the placement of the reticle object by typing in X,Y coordinates, or use the **Center on Image** button to have the reticle centered.

The angle of the line can be set by providing a value in the Rotation input box. Either type in a value, or use the up and down arrows. Values from -180 to +180 degrees are valid.

Rectangle

Use the Rectangle Tool to place one or multiple concentric rectangles on your image.

Set the **Line Thickness** and **Color** to be applied to the lines of the reticle. Type in the thickness value or use the up and down arrows to set the thickness. Click on the **Color** button to open the Select Color dialog.

Check the box to **Show Text** if you would like to display the numerical units for the rectangle. Use the Font button to pick the font characteristics you would like to use. Use the pull down list to select the number of **Decimal** places you would like displayed.

Set the **Initial Size of the Rectangle** to be displayed. Units will be displayed according to the base image’s specified calibration units.
Specify a set number of rectangles to be displayed on the image, or check the box to Fill the Entire Image with rectangles and set the Height/Width increment to be used. The units displayed will be based on the calibration of the base image.

The angle of the rectangle(s) can be set by providing a value in the Rotation input box. Either type in a value, or use the up and down arrows. Values from -180 to +180 degrees are valid.

**Circle**

Use the Circle Tool to place one or multiple concentric circles on your image.

Set the *Line Thickness* and *Color* to be applied to the lines of the reticle. Type in the thickness value or use the up and down arrows to set the thickness. Click on the *Color* button to open the *Select Color* dialog.

Check the box to *Show Text* if you would like to display the numerical units for the diameter of the circle. Use the *Font* button to pick the font characteristics you would like to use. Use the pull down list to select the number of *Decimal* places you would like displayed.

Set the *Initial Size* of the Circle to be displayed. Units will be displayed according to the base image’s specified calibration units.

Specify a set number of circles to be displayed on the image, or check the box to Fill the Entire Image with circles and set the Diameter increment to be used. The units displayed will be based on the calibration of the base image.

**Grid**

Use the Grid Tool to place a defined grid pattern over an image.

Set the *Line Thickness* and *Color* to be applied to the lines of the reticle. Type in the thickness value or use the up and down arrows to set the thickness. Click on the *Color* button to open the *Select Color* dialog.

Define the Grid dimensions by selecting the number of Rows and Columns for the reticle. The number can be an exact value or you can select to Fill Image Height or Fill Image Width. The Row Height and Column Width can also be set. Units displayed will be according the base image’s specified calibration.

Choose between Row and Column Labels of None, Numeric, Alpha, or Roman. The direction of the label can be set to start from Top or Bottom for the Rows and from the Left or Right for the Columns. If preferred, you can turn off the Row and Column size labels by un-selecting the box for Show Grid Size.
5. Once you have selected the first Reticle object, click on the base image to place the reticle object.

6. The placement of the reticle object can be manipulated by moving the cursor over a line of the reticle, and clicking and dragging when the mouse cursor changes to a crosshair. Alternatively, once a reticle object has been added to the base image, the placement can be adjusted by using the discrete, type in values for the x, y coordinates of the center of each reticle object or by simply clicking the Center on Image button to center the reticle object.

7. If you need to start over, you can use the Delete button to erase the highlighted and active reticle object or the Delete All button to delete all reticle objects on the base image.

8. Provide a Name for the Reticle and click on Ok.

9. The reticle will now be available for adding to images. See Chapter 4 for more information on how to add a reticle to an existing image or above in this Chapter's Image Settings section for how to apply reticles to Live and Captured images.

Note: When manually entering X, Y coordinates, be advised that (0, 0) is the top left corner.

Image Auto-Save

The Image Auto-Save feature is available to assist you with your work flow to automatically save images as part of the capture process. To enable SPOT’s auto-save feature select Setup Image Auto-Save.

Auto-save functionality can be set individually for Single Image Acquisitions and Time Lapse Image Acquisitions. Both have the ability to either be saved to individual files or image sequence files and the settings for these options are slightly different.

Single Image Acquisition

Use the Single Image Acquisition’s setting to automatically Save to Individual Files, or to save each image to an Image Sequence File. If Auto-Save is not desired, select Off.

Time Lapse Acquisition

For Time Lapse Image Acquisition, select to automatically save each image individually by selecting Save to Individual Files or select to add each image to an Image Sequence File. If Auto-Save is not desired, select Off.

Whether Save to Individual Files or Save to Image Sequence Files is selected, an additional tab is available for more settings pertaining to the selected option.
Common Auto-Save Features

File Name Prefix
This prefix appears before the number of each captured image. To enter the File Name Prefix, you can:

- Type only the name (e.g., Cell) in the box. The program automatically saves the image to the last used directory. If you specify the prefix only, you cannot see exactly where the files are being saved. Thus, to avoid having to search for your files, you should verify the location of the last save.
- Type the full path and file name (e.g., C:\Spotcam\T-cells) in the box to specify the location of the image. When entering the file path and name, you can also specify a new directory simply by entering it in the path (e.g., C:\Spotcam\Cells\T-Cells).
- Click on the browse button to select a new file location and file name prefix. All of the image files are saved with the prefix that you enter. Thus, if your Append Number (see below) is 1, the file name for the image would be ‘T-Cells0001’.

You can also click on the browse button to select an existing image sequence or an existing individual TIFF image to which you would like to add images subsequently.

Format
Select the file format for your saved images. For more details about image saving options, please refer to Chapter 4.

- For individual 8 bit/channel files, there are six options: Windows Bitmap, JPEG, Mac PICT, TIFF Uncompressed, TIFF JPEG, or JPEG2000. For individual 12 bit/channel files, there are three options: JPEG 2000, TIFF Uncompressed (12-bit/chan), TIFF Uncompressed (16-bit/chan). For individual 16 bit/channel files there are two options: JPEG 2000 and TIFF Uncompressed (16-bit/chan).
- For image sequences of 8 bit/channel files, there are two options: TIFF Uncompressed or TIFF JPEG. For image sequences of 12 bit/channel files, you can save the sequence only as TIFF Uncompressed. For image sequences of 16 bit/channel files, you can save the sequence only as TIFF Uncompressed.
- The BigTIFF file format has been added to support larger file sizes. This is especially useful with image sequence files. This format should be available for all bit/channel settings.

Note: Images saved as BigTIFFs may not be viewable in other applications, as this file format is not widely supported.

Append Number
When Append Number is selected, the individual images will be numbered, beginning with the append number chosen. The append number will be automatically incremented by one for each subsequent image. See Digits (below) for information on how to add more digits to the append number.

Digits
The entry for the Digits field works with the Append Number above. Choose the number of zeroes you want to appear before the append number and place it in the Digits field.
JPEG Quality

JPEG quality is the level of compression for JPEG images: this option is available only when JPEG or TIFF JPEG is selected as the image file format. Enter an integer between 1 and 100 to set the JPEG quality for images. A value of one is the most compressed (and lowest image quality), while a value of 100 is the least compressed (and highest image quality).

Compression

When the JPEG2000 file format is selected, the Image Auto-Save Setup dialog displays compression options:

Lossless – Information is not lost when the image is compressed.

Lossy – Information is lost according to the ratio that you enter: the higher the ratio that you enter, the smaller the file size and the lower the quality of the image.

Save Thumbnails

The option to Save Thumbnails is available when either the TIFF or TIFF JPEG file format is selected. Check this box to have a thumbnail preview of your image available.

Auto-Save to Individual Files Specific Features

Below are the options on the Auto-Save to Individual Files tab which are active when Save to Individual Files is selected.

File Name Conflict Action

This section determines how the program will respond if it finds an image file with the same name as an image from the current session. Select one of the following options:

Overwrite Existing File – The program overwrites the existing file with the new image capture.

Display Warning – The program displays a warning message indicating that a file of the same name already exists, and stops the image capture.

Image Display

Make a selection from the options below in order to determine how image captures will be displayed.

Display Each Image in a New Window – The program opens a window for each new image capture. This option works well if you plan to capture a limited number of images in the session. If you plan to capture many images, however, displaying numerous windows uses up memory and could interfere with use of other programs.

Display Only Current Image – The program sequentially displays each image in the same window. Each image displays only until the next image is captured. This is useful when you have numerous captures where you do not want to be concerned with running out of memory.

Don’t Display Images – The program automatically saves all of the image files to the specified location without displaying them.

Auto-Save to Image Sequence Files Specific Features

When the option to Save to Image Sequence is selected, the following features are active.
Display Images
Select this box to open an image sequence immediately after the capture. To save the image sequence to file without opening it, deselect the box.

For Multiple Acquisitions
The For Multiple Acquisitions section is intended to help you decide how the software should behave if a second file with the same name occurs. The following options are available:

Overwrite Existing File – The program overwrites the existing file with the new image capture.

Display Warning – The program displays a warning message indicating that a file of the same name already exists, and stops the image capture.

Append Existing Files – The program will add new image captures to the existing image sequence file.
Chapter 3 – Image Captures and the Camera Menu

Now that the features of the SPOT Basic application which affect the way your images and interface look have been discussed (see Chapter 2 – Image Settings and Preferences), this chapter will discuss various image capture options and other features available under the Camera Menu.

Taking a Picture

The actual capture of a digital image (taking the picture) is similar to traditional photographic techniques. In digital photography, however, it is possible to continually capture, refine, and recapture images until you have an optimal representation: the first image that you capture might be only one of several that you use to produce a publishable product. A sample image capture process, from start to finish might proceed as follows:

- Adjust the Preferences as needed (see previous chapter).
- Open the Live Image window.
- Frame and focus the image as needed.
- Click on the Image Settings toolbar button to access the Image Settings window and adjust the live image view settings (see previous chapter).
- Click on the Acquire Single Image toolbar button to capture the final image.

In the Basic application, image capture settings and live image view settings are defined from the same source - the Image Settings window. This gives you the convenience of being able to view a live image, adjust the settings in real-time, and then capture the image with the live image view settings.

Note: Except for the Captured Image Bit Depth, which is defined on the Preferences window, all image capture/live image settings are defined from the Image Settings window.

Initialize Camera

If you turned on the SPOT power supply after you opened the program, you need to initialize the camera in order to activate all of the capture and editing options. To do so, select the Initialize option from the Camera menu.

Display Live Images

The Live Image option enables you to see a real time preview of your specimen/image capture. For instance, you can use the Live Image window to:

- Scan the image for an area of interest.
- Zoom in on an area of interest.
- Focus on an area of interest.
- Frame an area of interest.
- Define image capture settings – See Chapter 2 for more details.
To open the Live Image window, either click on the Live Image toolbar button, or select the **Display Live Images** option from the **Camera menu**.

---

*Note: Occasionally, when viewing a dim live image, you might notice that the right half of the image is brighter or dimmer than the left half. To display images in real time, the camera uses two separate amplifiers to simultaneously read the right and left halves of the CCD chip. With some images, particularly dimmer samples, the brightness of the two halves may not match. This results in a “split” appearance. To avoid this problem with captured images, all cameras, except for the Insight Gigabit, read the whole CCD through a single amplifier. A “split” Live Image view is **not** indicative of what your image capture will look like. Refer to Appendix A: Electronic Imaging Theory and SPOT Cameras for more details.*

---

- The title bar at the top of the Live Image window displays the status of the live image view - **Running**, **Computing Exposure**, or **Paused**. Double-click on the title bar to "roll up" the live image display. This pauses the live image display. Double-click again to display the whole window and resume the live image display.

- The **Full Screen** option (accessed via the View menu or [F 7]) can be used with live images. To access live image viewing options while in the full screen view, right click on the live image. To exit the full screen view, either press [F 7], move the cursor to the edges of the screen and click on the Exit Full Screen Mode button that appears, or move to the top of the screen and select the View\Full Screen from the menu bar that appears.

The following options are available on the Live Image window:

**Pan Window**

When this box is checked, if the Live Image is zoomed in beyond the ‘Fit to Window’ mode, the pan window will automatically appear for easy navigation.

**Display Zoom Level Indicator and Slider Bar**

This button will change its label depending on how the Live Image is displayed; Actual Size, Fit to Window, Fit Width, Fit Height, Fill Window, or a percent Zoom. The slider to the right of this button also allows for easy changes to the zoom level. See more on these options in the Preferences section of Chapter 2.
Magnifier
This button toggles the magnifier on and off and turns your mouse cursor into a magnifier tool when placed over the image while toggled on. See additional details in Chapter 2’s Preference section.

Restart
Resample the brightness of the image, compute new exposure times, and restart the live image display. This is useful for updating exposure times when specimen brightness has changed.

Pause/Resume
Pressing the Pause button freezes the live image display. This is useful when you are changing a specimen and want to preserve the last view. In addition, to use the Transfer option (see below), you must first Pause the live image view. Click on Resume to restart the live image view using the same exposure computations as when the Pause button was pressed.

Close
Click the Close button to close the Live Image Display window.

Compute White Balance Values (Color cameras only)
White balance is the ratio of red, green, and blue exposure times (3-shot cameras) or gains (color mosaic cameras) necessary to achieve the proper color rendition for an image. Many factors impact the coloration of an image capture, including lamp voltage, the coloration of the glass used in the slide, and the coloration of the glass used in the lenses of the microscope’s objectives. To minimize the impact of these factors, use the White Balance feature. When you perform a white balance calculation, SPOT samples the color of the light from your light source after it has passed through the slide and the objective, and then calculates the red, green, and blue exposure times (3-shot cameras) or gains (color mosaic cameras) needed to produce images where the white areas are white and the color areas are true.

You should perform a new white balance calculation when:

- Starting a new image capture session.
- Changing the lamp voltage.
- Switching to a different objective on the microscope.

To compute new white balance values, follow these steps:
1. Set the illumination and the objective that you will use for the image capture.
2. Select the appropriate Image Profile. Each Image Profile has its own set of white balance values. Any white balance values that you compute for an image type remain linked to that image type until you compute new values. When selecting a new image profile, remember that you will be using the white balance values linked to that image profile.
3. Show the camera a sample of white light. This step varies according to microscopy technique and Image Type (sample), as shown in the table below.
Section II – Chapter 3 – SPOT Basic Image Captures and the Camera Menu

4. Click on the **White Balance** button. By default, a **Compute White Balance** dialog will appear with instructions on how to properly perform a white balance. If the preference to show helpful Messages has been turned off, this step will be skipped.

![Compute White Balance dialog](image)

---

**Note:** If you are comfortable with performing White Balances, you can check the box for **Do not show this message again**. If you desire, you can always turn this message back on in the Preferences (see Chapter 2 for more information).

---

5. Click on Begin to start the calculation. The camera computes the white balance values and they are automatically saved to the image settings for the image type that you selected.

<table>
<thead>
<tr>
<th>Image Type</th>
<th>White Balance Technique</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brightfield-transmitted light</td>
<td>Position the slide so that the specimen is not in the field of view, but light is going through the slide near the specimen.</td>
</tr>
<tr>
<td>Darkfield-transmitted light</td>
<td>Perform the white balance using the brightfield mode on your microscope. See Brightfield – transmitted light above.</td>
</tr>
<tr>
<td>Fluorescence</td>
<td>Use the Match Color feature</td>
</tr>
</tbody>
</table>
| Nomarski DIC/Hoffman           | **For Nomarski DIC:** Adjust the Nomarski prism until the image is in either the "brightfield" or the "gray scale" view.  
**For Hoffman:** Perform the white balance directly on the Hoffman image. |
| Phase contrast                 | Position the slide so that the specimen is not in the field of view, but light is going through the slide near the specimen. |
| Polarized light                | Place all polarizers and compensators into the light path and then position the slide so that the specimen is not in the field of view, but light is going through the slide near the specimen. |
| Brightfield-reflected light    | Replace your sample with a mirror.                                                     |
| Darkfield-reflected light      | Perform the white balance using the brightfield mode on your microscope. See Brightfield – reflected light above. |
| Stereo/Macro (all three options) | Using an EPI-illuminator (shining a light on the top of your specimen from off to one side), replace your sample with a white sheet of paper. |
Capturing the Final Image

There are two ways to capture a single image in the SPOT Basic software: Acquire Single Image and Pause/Transfer on the Live Image window. Both options are discussed in further detail below.

**Acquire Single Image**

The Acquire Single Image option should be your primary means of capturing images. Using this feature ensures the image will be at full resolution and the set bit depth you have indicated. There are three different ways to access the Acquire Single Image option:

- From the Camera menu, select Acquire Single Image
- Press the Acquire Single Image button on the toolbar
- Press [F9] on your keyboard

Either option above captures an image according to the Image Settings that you defined (see previous sections).

The Acquire Single Image status dialog box appears. Status messages display as the camera computes the gain and exposure times. If the live image window is open, the image capture uses the gain and exposure times calculated for the live image and skips the exposure computation (step 1 below). The status messages are as follows:

1. **Computing Exposure** – The camera is sampling brightness levels in the image in order to determine proper gain and exposure time.
2. **Exposing** – A countdown clock displays when the exposure will last longer than 2 seconds. This informs the user that the electronic shutter is open and counts down the minutes: seconds remaining until it closes.
3. **Reading Image Data** – The camera is downloading the image to the computer.

   Note: For 3-Shot Color and Slider cameras, steps #2 and #3 will occur from 1 to 3 times, depending upon which color filters have been selected.

4. **Processing** – The camera is preparing to display the image.

The newly captured image appears on screen. If the live image screen is open, the captured image will appear behind the live image screen. To view it, simply close the Live Image window or roll it up by double clicking on the Live Image window’s title bar.

**Pause/Transfer**

The Acquire Single Image function should be your first choice for capturing a single image. However, a second option is available, the Pause/Transfer button.

This option is helpful in situations with rapidly changing or moving samples. If you see something that you like, you can Pause the live image before it changes. Then, you can Transfer the paused image to a SPOT editing window and save it to file. The Transfer option is not active until the Pause button is pressed.

If you do not want to Transfer the paused image, you can resume the Live Image display by either pressing Resume or Restart (see above for more details).
Acquire Time Lapse Images

The Acquire Multiple Images option allows you to capture a sequence of images. SPOT’s multiple image capture process enables you to save an image sequence in two different ways:

- You can save a sequence as a group of individual image files.
- You can save a sequence as a single (TIF or BigTIFF format), “sequence image file” that is composed of multiple images. Refer to the Viewing, Editing, and Annotating Images section for details on viewing and modifying image sequence files.

The Get Sequential Images option allows you to capture a sequence of images over time. The images can be saved into a sequence or as individual files. If saved into a sequence, the sequence can then be exported for use in other applications. The number of images that can be acquired is limited to 100,000.

To use the Get Sequential Images option, follow these steps:

1. Select the image setup that you want to use for the sequential image captures. Either define a new image setup, or select an existing setup from the drop down list on the status bar (bottom right corner).
2. From the Camera menu, select the Get Sequential Images option. The Get Sequential Images window appears. The following section describes each option available.
3. After you have entered all of the options, click on Begin to start the image capture sequence. Refer to Ch. 4 – SPOT Basic Viewing and Editing Image Documents for details on viewing and modifying image sequence files.

**Number of Images**

Enter the number of images (values from 1 to 100,000 are allowed by the software) you would like to capture as part of the time lapse acquisition.

**Compute Each Exposure before Each Image**

Select this option if you would like the SPOT software to recalculate the exposure before each image capture. Using this feature would be beneficial when the brightness level of the specimen may change over the span of the time lapse acquisition. If the brightness level is expected to remain constant and timing is an issue, you may want to consider leaving this box unchecked so as to minimize computation time between image captures. Please note that this option is only available if your current image setup is set to use an Auto Exposure.
**Time Interval**

*As Short as Possible*

If you select as short as possible, the camera will begin exposing the next image as soon as the previous image data has been downloaded.

With Xplorer and Pursuit cameras only, selecting as short as possible will enable the camera to begin exposing the next image while downloading image data from the first image. This enables these cameras to capture sequential images very quickly. However, if your computer doesn’t have enough memory to support this, your images may be overexposed. If this occurs, unselect the as short as possible checkbox and type in 0 as the time interval. This will prevent the camera from beginning the next exposure until the image data download has finished.

**Discrete Time Interval**

If the parameters of your time lapse acquisition dictate discrete timing where perhaps certain events are occurring at a certain time, or if you merely need to capture images every set period of time, you can use the option to enter a discrete time interval instead of using the above option As Short as Possible. Enter the time interval between the start of one image capture to the start of the next image capture in hours, minutes, and seconds.

**Place Images into an Image Sequence**

There are two options for file output when acquiring time lapse images. You can choose to have each image be its own image document and available for saving as its own image file. Alternatively, if this box is selected, the SPOT software will automatically add the captured images into an image sequence document as they are being captured. If the current Image Profile has Auto-Save activated for Time Lapse Images being saved to Image Sequence Files, this option will be inactive. See Ch. 2 – SPOT Basic Image Settings and Preferences for more on Image Auto-Save options.

**Defer Image Processing/Display until Done**

The process of capturing and displaying an image requires some processing time by the computer. This processing takes a small amount of time and can delay sensitive and short time interval time lapse acquisitions. In order to minimize any delays by the computer’s processing time, use the option to Defer Image Processing/Display until Done. When this feature is selected the entire sequence is completed before displaying or saving the images.

**Camera Communication**

In the SPOT software there are a few options available under the Camera Menu for communications with SPOT cameras. These features include the ability to select a device, initialize a camera, or disconnect a camera. Each of these features will be discussed in further detail below.

**Select Device**

Selecting this option from the dropdown menu will allow the user to switch between SPOT cameras running on the same computer. When an alternate device is selected, for example from an Insight camera to an RT camera, the menu and toolbars will adjust to acknowledge the appropriate options and settings for the new device. The SPOT program, however, will not shut down. This on the fly device switching capability can be very convenient for the user with the need for multiple cameras during the day.
Initialize

If you turned on the SPOT power supply after you opened the program, you need to initialize the camera in order to activate all of the capture and editing options. To do so, select the Initialize option from the Camera menu.

Disconnect

This feature allows the user to disconnect their SPOT camera from the SPOT software so as to make it available for other software applications to access it. Enable this feature by selecting Disconnect from the Camera Menu.

Correction Frames

The SPOT Software allows for a limited amount of correction frames in the SPOT Basic application. Additional correction frames are available in the SPOT Advanced application. Please refer to the appropriate chapter in Section III of this manual for more information about these options. In SPOT Basic, the only available correction frame is the Flatfield correction, which will be discussed here.

Acquire Flatfield

The Flatfield correction is available here, under the Camera menu as well as from the Appearance tab of the Image Settings. Ideally, a Flatfield correction file will be associated with a certain type of Image Profile. Please see additional details on how to set up Flatfield corrections within Image Profiles in Chapter 2 of this Section.
Chapter 4 – SPOT Basic Viewing and Editing Image Documents

Introduction
This chapter will cover details about the software features available for working with image files. Topics will include:

- The File Menu options
- Viewing Images
- Editing Images
- Saving Images
- Working with Image Sequence Files

The File Menu
All of the file open and save options in the Basic SPOT program are accessed from the File menu. These options are described below.

Open Image File
Open image files of a specified format (i.e., JPEG, TIFF, BMP, etc.). In addition to using this menu option, you can open images by dragging an image file from the Desktop or Explorer onto the SPOT program window.

Show Image File Thumbnails
Display thumbnail previews of specified files and open images from the preview screen. To show file thumbnails, follow these steps:

1. From the File menu, select the Show Image File Thumbnails option. The Thumbnail File Spec window displays all of the image files in the directory.
2. Navigate to the directory for the image files that you want to display.
3. Use the Files of type drop down box, to specify the file type.
4. Select the file or files for which you want to display thumbnails. If you do not select a file or files, the program displays thumbnails for all files of the specified type in the directory.
5. Click on Open. The Thumbnails preview window appears. For each thumbnail, you can:
   - Double-click (Mac and Windows) on a thumbnail to open an image for viewing or modification.
   - Right-click (Windows) [Ctrl] Click (Mac) on a thumbnail to display a list of options. The right-click menu enables you to perform a variety of actions directly from the thumbnail window:
     - Select Image
     - Open Image
     - Delete Image
     - Print Image
• Move/Rename Image File
• Copy Image
• Add Image to Image Sequence (see below)
• Add Image to Report (see below)
• Select All Images in the thumbnail view. When you use this option, the right-click menu expands to include the above options for multiple images
• Click and drag with the mouse to select two or more images.

Open Image Sequence File
An image sequence file is a single TIFF format file that contains multiple images. Select this open to open a saved image sequence file. Refer to the Taking a Picture section of Chapter 3 for more information on capturing time lapse/image sequence files.

Create New Image Sequence
This option allows you to create a new image sequence file from single images. The images can come from an open image or an image on disk (from file). The two options are:

From Files
Select this option to browse through your computer for image files to add to the image sequence. Multiple images can be selected by holding the Control button while you click to select images in the browser window.

From Open Images
If all of the images that you would like to add to an image sequence are open, select the option to create the sequence From Open Images. A dialog box will appear asking if you Additional images can be added to the image sequence file in one of two ways:
The File menu’s Add Image to Image Sequence option allows you either to add an open, non-sequence (individual) image to a sequence or to create a new image sequence from the image. See below for more information.
When an image sequence is open, the Sequence menu has additional options for adding images. Refer to Working with Image Sequence Files later in this chapter for more details.

New Report
Create a new Basic Mode report. Refer to Chapter 5 – SPOT Basic Reporting for more details.

Open Report
Open a Basic Mode report. Refer to Chapter 5 – SPOT Basic Reporting for more details.

Reload
Reload the image from the hard drive (or other media). All changes made since opening the image file are lost. This option appears only when a saved image is open.
Save

Save a previously unsaved image to new file, or update the changes to an existing file. This option appears only when an image is open. When you save a new image, you will also have the ability to select from the following file formats. The format options which are available are dependent on the bit depth of the image. This setting is made in the Preferences. Please refer to Chapter 2 for more information on bit depth.

**Individual Files:**
- For individual 8 bit/channel files, there are six options: Windows Bitmap, JPEG, Mac PICT, TIFF Uncompressed, TIFF JPEG, or JPEG2000.
- For individual 12 bit/channel files, there are three options: JPEG 2000, TIFF Uncompressed (12-bit/chan), TIFF Uncompressed (16-bit/chan).
- For individual 16 bit/channel files there are two options: JPEG 2000 and TIFF Uncompressed (16-bit/chan).

*Note: Images with higher than 8 bit/channel may not open correctly in other applications.*

**Image Sequence Files:**
- For image sequences of 8 bit/channel files, there are two options: TIFF Uncompressed or TIFF JPEG.
- For image sequences of 12 bit/channel files, you can save the sequence only as TIFF Uncompressed.
- For image sequences of 16 bit/channel files, you can save the sequence only as TIFF Uncompressed.
- The BigTIFF file format is available to support larger file sizes, beyond the standard limit of 4GB in a TIF file. This is especially useful with image sequence files. This format should be available for all bit/channel settings.

*Note: Images saved as BigTIFFs may not be viewable in other applications, as this file format is not widely supported.*

*Note: When saving images with a bit per channel setting above 10 bits per channel, you may have the option to Promote Data to 16-bits per channel.*

Save As

This option appears only when an image is open. Use the Save As option to save an image to a new file name and/or file location.
Save All

If you have a large number of images to save, you may want to use the Save All feature to save all open image files. The program prompts you for the name and file location of each image.

Close

This option appears only when an image is open. Use this option to Close an image document. If the image has not been saved or if changes have been made to the image document, the program will ask you if you would like to save the changes made to the image or not. Select Yes to re-write the original file or save a new image to file. Select No to throw away your changes and close the image document. If you select Cancel, the image document will remain open.

Move/Rename

This option differs from the Save As option in that it does not retain a copy of the original file in the original location. Using Move/Rename is comparable to cutting and pasting a file. When you select this option, a browser window will open asking you to set the new destination and name of the image file.

Delete

When you select Delete from the File menu, you will be asked to verify that you really do want to delete the file. Select Yes to delete the file and select No to cancel the deletion and keep the image. This option is only available when an image document is open.

Export Movie File (available only when image sequence is open)

Image sequence files are only viewable within the SPOT application. If you want to view your image sequence outside of SPOT, you will need to export it to a suitable file format. Use the Export Movie File feature to export a SPOT image sequence file to either *.AVI (PC) or *.MOV (Mac). To export the image sequence, follow these steps:

1. Open a SPOT image sequence. Refer to Chapter 3 for details on capturing image sequences/time lapse images.
3. Enter the File Name for the avi file.
4. Specify the location where you want to save the avi file.
5. Specify which images in the sequence that you want to Export. Select either:
   a) All Images – the avi file will contain all of the images in the sequence.
   b) Specified Images - the avi file will contain only the images that you specify (i.e., below the radio button).
6. Specify the Frame Rate in frames per second.
7. Specify the Compression Settings. When you click on the Compression Settings button, the Video Compression dialog displays the compression application(s) available on your computer. Because each computer will have different installed applications, the Video Compression options will vary.

After you have entered all of the desired settings, click on Save. The program displays a status message as it exports the file.
Add Image to Image Sequence

Add an open, non-sequence image to an open image sequence, or create a new image sequence from an open image. To use this option, the non-sequence image must be the active window and the image sequence must be open in the background.

When you click on Add Image to Image Sequence, SPOT prompts you to specify either the Image Sequence or a new image sequence. If more than one image sequence is open, select the sequence from the drop-down list.

Add Image to Report

Add a selected open image to an open SPOT report. When you select this option, SPOT prompts you to select from a list of reports. If you have not defined a report, SPOT automatically creates a new report for you and inserts the image as a Static Image object. Refer to the Creating Reports section of this chapter for more details.

Duplicate Image

The Duplicate Image option allows you to easily create copies of your images, with or without layers (annotations, calibration marks, measurements, and reticles) being merged into the pixel data. Additionally, the bit depth of the copied image can be altered at this point. When you select this option from the File menu, the Duplicate Image dialog box will appear.

The following options are available to you under the Duplicate heading:

Actual Data

If the original image has been modified or annotations, calibration marks, measurements, or reticles have been added to the image and you do not want to have these edits be permanently merged into the pixel data, select the Actual Data option. When you make this selection, the option to Merge Object in Layers is automatically deactivated so as to keep the layers separate from the pixel data.

As Displayed

For a quick and easy way to make a copy of an image with the layers merged into it, use the As Displayed option with the Merge Objects in Layers option checked (below). Merging the layers into the image can be useful for sharing your edited images with non-SPOT users. See more about Merging layers under the Editing Images section of this chapter.

New Image Bit Depth

When duplicating images, the New Image Bit Depth setting allows you easy access to changing the bit depth of the image. For more information on selecting an appropriate bit depth, please refer to the Change Bit Depth feature in the Editing section of this chapter.

Merge Objects in Layers

This feature works hand in hand with the As Displayed option above. Check this box if you would like to merge your layers into the pixel data of your copied image. For more information about merging layers, please see the Editing Images section of this chapter.
Print
Use the Print option to print images from the SPOT application. Refer to Chapter 6 – SPOT Basic Image Printing for more information on the Printing options available in SPOT.

Exit
Select Exit from the File menu when you are ready to close and Exit the SPOT program.

Shortcuts
Directly underneath the Exit menu item, there will be a divider and below it is a list of the most recently viewed images. This list is intended to allow for quick access to these documents without having to browse to them with the Open Image menu item.

Viewing Images
After opening or capturing an image, you can adjust the way you view images in the SPOT application.

All of the image viewing options are accessible from two menus:
- **View** – Contains options for how images should be displayed within their individual window
- **Window** – Contains options for how multiple image windows should be displayed within the SPOT application window.

The View Menu
To help you view and analyze your image captures, the View menu contains the following options:

- Actual Size
- Fit to Window
- Fill Window
- Fit Width
- Fit Height
- Set Zoom Mode
- Show Magnifier
- Zoom Level
- Show Grid Lines
- Link Image Window Zoom Level
- Enable Pan Window
- Link Image Window Scrolling
- Show Image Information
- Show Annotations
- Show Calibration Marks

<table>
<thead>
<tr>
<th>View</th>
<th>Camera</th>
<th>Setup</th>
<th>Window</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actual Size</td>
<td>Fill Window</td>
<td>Fit Height</td>
<td>Fit Width</td>
<td>Ctrl+F</td>
</tr>
<tr>
<td>✓ Fit to Window</td>
<td>Show Magnifier</td>
<td>Zoom Level</td>
<td>Show Grid Lines</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Fill Window</td>
<td>Set Zoom Mode</td>
<td></td>
<td></td>
<td>Ctrl+G</td>
</tr>
<tr>
<td>Fit Height</td>
<td>Show Image Information</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Set Zoom Mode</td>
<td>Enable Pan Window</td>
<td></td>
<td></td>
<td>Ctrl+W</td>
</tr>
<tr>
<td>Show Magnifier</td>
<td>Link Image Window Scrolling</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Zoom Level</td>
<td>Link Image Window Zoom Level</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show Grid Lines</td>
<td>Show Image Information</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Link Image Window Zoom Level</td>
<td>Show Annotations</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Enable Pan Window</td>
<td>Show Calibration Marks</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Link Image Window Scrolling</td>
<td>Show Measurements</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show Image Information</td>
<td>Show Raster</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show Annotations</td>
<td>Full Screen</td>
<td></td>
<td></td>
<td>F7</td>
</tr>
</tbody>
</table>
- Show Measurements
- Show Reticles
- Full Screen

**Actual Size**

When selected, each pixel from the camera image is represented by a single pixel in the display image. In many cases, this will result in the displayed image appearing with scroll bars since the camera resolution is usually greater than the screen resolution.

**Fit to Window**

When selected, the image is sized to fit into the Live Image Window. Choose this setting to provide a full field of view at the maximum size that will still fit into the Live Image Window. In most cases, this will result in the displayed image appearing at lower resolution that what is available in the image. The magnifier can be used to look at image details in this case.

**Fill Window**

This feature will resize the image to entirely fill the preview window or full screen. Note that horizontal or vertical areas of the image will not be seen since they will be out of the image window field of view.

**Fit Width**

When selected, the display zoom level of the image will automatically adjust to the maximum setting which allows the entire image width to be viewable within the display canvas. This may result in unused areas of the Live Image Window or portions of the display screen while in Full Screen mode.

**Fit Height**

When selected, the display zoom level of the image will automatically adjust to the maximum setting which allows the entire image height to be viewable within the display canvas. This may result in unused areas of the Live Image Window or portions of the display screen while in Full Screen mode.

**Set Zoom Mode**

1. Either select **Zoom Mode** from the View menu, or click on the Zoom toolbar button:

2. The cursor changes to a magnifying glass, and the Zoom toolbar button becomes active. The precise reference point for the zoom location is indicated by the white dot in the center of the magnifying glass. The row and column numbers at the bottom of the screen indicate the exact position of the white dot as you move the magnifying glass over the image.

3. Use the mouse to zoom in or zoom out:
   a) Position the mouse over the center of the area that you want to zoom in on.
   b) Either left click to zoom in 2x, or right click to zoom out 2x.
   c) To return to the normal view mode, de-select the Zoom option.
The Zoom feature works in conjunction with the pan window (see Show Pan Window below), which allows you to see where you are in relation to the larger image while zoomed in.

Note: While in Zoom Mode, all of the standard save, view, and edit options are available, however, if you select one of the following options – Add Calibration Mark, Add Measurement, or Annotate – the Zoom Mode function will be turned off. To re-enter Zoom Mode, follow Step 1 above.

Show Magnifier

The Show Magnifier option enables you to use your mouse cursor as a magnifier. This option can also be selected by toggling the toolbar icon on and off.

When this option is turned on and you move your mouse over an image, the image area will be displayed in a user-definable arrangement of pixels (i.e. 200x200 pixels) and a user-defined magnification (i.e. 10x). See Preferences for more on customizing the magnifier option.

Zoom Level

The Zoom Level option, like the Zoom Mode option enables you to view zoomed images. However, unlike the Zoom Mode option, the Zoom Level feature gives you the option to add annotations, including text, calibration marks, and measurements, to the zoomed image without being forced back out of the Zoom Level. To use the Zoom Level option, select Zoom Level from the View menu and select a percentage option from the list.

Like the Zoom Mode option, the Zoom Level option can be used in conjunction with the pan window (see Enable Pan Window below), which allows you to see where you are in relation to the larger image while zoomed in.

Show Grid Lines

Show Grid Lines clearly defines pixel borders, which are often invisible in low contrast areas of an image. Clearly defined borders help in positioning the cursor at an exact row and column location (i.e., using the readouts at the bottom of the screen), which then allows you to view the brightness value for the individual pixel.

To show the grid lines on an image, follow these steps:
1. Position the magnifying glass in the center of the area that you want to zoom in on.
2. Zoom to either 8x or 16x. If you are using the Zoom Level option, select a percentage of 800 or greater.
3. From the View menu, select the Show Grid Lines option. Grid lines appear around each pixel.

Note: The Show Grid Lines option is available only when you zoom in on an image.
Link Image Window Zoom Level

Link Image Window Zoom Level allows the user to have multiple images open at once and zoom all of them to the same level with one click of the mouse. Once this feature is activated for an image, it will automatically be applied to all subsequent opened or captured images.

The user has two options for zooming in and out once the Link Image Window Zoom Level is activated.

1. Go to the View Menu, select Zoom Level and choose a pre-set value for all of the images to which be zoomed.

2. Use the Set Zoom Mode feature (either from the View Menu or the magnifying glass icon on the toolbar) and use your mouse’s left- and right-click options to zoom in or out, respectively.

This feature can be quite useful when used in conjunction when the Link Image Window Scrolling and Enable Pan Window features.

Enable Pan Window

Enable Pan Window allows you to navigate around an image while zoomed in at high magnifications. When you select the Enable Pan Window option, the program highlights your location in relation to the whole image, and, by dragging the highlighted area around the pan window; you can explore the image, piece by piece. Without the Enable Pan Window option, the process of moving to a new point while in high magnification would involve several steps:

1. Zooming in to the first area of interest.
2. Zooming out to determine where you are.
3. Determining a new area of interest.
4. Re-zooming in to the new area of interest.

The pan window replaces this tedious process. When you select Enable Pan Window, a smaller version of the image appears with a grey and highlighted box over the zoomed area of the image.

To use the pan window, follow these steps:

1. Either select Enable Pan Window from the View menu, or click on the Enable Pan Window toolbar button.

Note: The pan window can be enabled at any level of magnification, but the pan window will only appear when the level of magnification exceeds the “fit to window” size for the captured image.

2. Position the cursor on the image in the pan window: it changes from a magnifying glass to hand with a pointing finger.
3. To move to a different area of the image, either left click on the rectangle and drag it to the new location, or left click on the new location. The cursor will change to a grabbing hand while left clicking within the pan window.
Link Image Window Scrolling

When you have multiple captured images open at one time, and they are not set to “Fit to Window” mode, you may choose to link the scrolling action of one image to the other(s). This feature allows you to more easily review different images of the same specimen in order to compare and contrast their condition over time.

Enable the Link Image Window Scrolling in the dropdown menu. You will notice that the scroll bars will “synchronize” with each other, regardless where they were positioned prior to enabling this feature.

When you begin to scroll one window, the other(s) will also scroll in sync, whether you use the scroll bars (vertical or horizontal) or the mouse wheel (vertical).

Show Sequence Controls

The Show Sequence Controls option displays the play controls for image sequences. This option appears only when an image sequence is open. Using the Image Sequence dialog you can:

- Play all or part of an image sequence in forward or reverse order.
- Set the display interval between images.
- Set the action that takes when the image sequence finishes playing – i.e., stop, restart, or reverse.

Refer to the Working with Image Sequences section for details.
Show Image Information

General
When you select General, File information related to the image is presented. This will include “general” information including the filename, its path location, its size, the format it has been stored in, the captured image size in pixels, and the bit depth of the captured image.

Image Date/Time
The Image Date/Time feature pulls up the date and time associated with the capture of an image. When you capture an image, the SPOT software remembers the date and time of the image capture. When you save the image, even if this is many hours later, the program sets the created date and time of the image file to the date and time of the original image capture.

When image files are transferred over networks, the created date and time is sometimes reset to the date and time of the transfer, making it an unreliable indicator of the image capture time. Because TIFF and JPEG format images have tags both for the created date and the original capture date and time, they are not affected by network transfers. If reliable image capture date and time information is important to your work, you should save images in either TIFF or JPEG format.

When you select the Image Date/Time option from the View menu, a dialog box displays the date and time associated with the capture.
- For non-TIFF, non-JPEG format image files, this is the Created date/time, as explained above.
- For TIFF and JPEG format image files, this is the TIFF/JPEG tag date and time.
- For SPOT Database images this is the original date and time that was stored in the database file.

Acquisition Information
When selected from the dropdown menu, Acquisition Information will display the image capture settings that were associated with the open image file. The information displayed will include such settings as user name, camera type used to capture the image, image setup used, exposure type, gain setting, read speed of the camera, filter color (color cameras), binning setting, chip area, gamma setting, etc.
Annotations

The Annotations window indicates any annotations that have been associated with this saved image. Once you have highlighted one of the listed annotations, you may use the find button to locate it on the open image. When you select Find, the annotation will flash one time.

Measurements

The Measurements window indicates any measurements that have been associated with this saved image. Click the + on a listed measurement, and the actual value of the measurement will be shown.

Once you have highlighted one of the listed measurements, you may use the find button to locate it on the open image. When you select Find, the measurement will flash one time.

You may also use this window to export the measurement as a database value to an existing or a new file. Highlight all desired measurements in the image information box by holding the Control key while you select the measurements with your mouse.

Memo

The Memo Window, when selected from the dropdown menu, will display the memo that is associated with the open image file. To Edit the text, click the Edit button.

The Image Memos stored with an image in SPOT can be read by other programs which properly handle TIFF images. If you desire other programs to be able to read the information stored in the Image Memo, select the TIFF file format upon saving. Other file formats (such as JPEG, JPEG2000, etc.) will not likely be able to have their SPOT Image Memo read by another program. See earlier in this Chapter’s Save section for more on file formats.

Show Annotations

When Show Annotations is selected, any annotations that have been added to the image will be shown. The Show Annotations option is inactive if no annotations have been added to the image.
Show Calibration Marks
When Show Calibration Marks is selected, any calibration marks that have been added to the image will be shown. The Show Calibration Marks option is inactive if no calibration marks have been added to the image.

Show Measurements
When Show Measurements is selected, any measurements that have been added to the image will be shown. The Show Measurements option is inactive if no measurements have been added to the image.

Show Reticles
When Show Reticles is selected, any reticles applied to an image will be displayed. The Show Reticles option is inactive if no reticle has been applied to the image.

Full Screen
View a full screen version of an image – i.e., without the SPOT menus or toolbars or the Windows navigation bar. This option allows you to utilize the entire window for previewing images. Press [F 7] to view a full screen image or click on the Full Screen toolbar button. Press [F 7] again to exit the full screen view. Alternatively, Windows users can exit the full screen view by moving the cursor to the top of the window and clicking on the Exit Full Screen Mode button that appears.

While working in Full Screen mode, Windows users can access SPOT menu options using standard keystroke combinations, as illustrated in the table below:

<table>
<thead>
<tr>
<th>Keys</th>
<th>Menu Option</th>
</tr>
</thead>
<tbody>
<tr>
<td>[Alt] + A</td>
<td>Attributes (Report mode)</td>
</tr>
<tr>
<td>[Alt] + C</td>
<td>Camera</td>
</tr>
<tr>
<td>[Alt] + D</td>
<td>Database (Advanced mode)</td>
</tr>
<tr>
<td>[Alt] + E</td>
<td>Edit</td>
</tr>
<tr>
<td>[Alt] + F</td>
<td>File</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>[Alt] + H</td>
<td>Help</td>
</tr>
<tr>
<td>[Alt] + O</td>
<td>Object (Report mode)</td>
</tr>
<tr>
<td>[Alt] + Q</td>
<td>Sequence</td>
</tr>
<tr>
<td>[Alt] + S</td>
<td>Setup</td>
</tr>
<tr>
<td>[Alt] + V</td>
<td>View</td>
</tr>
<tr>
<td>[Alt] + W</td>
<td>Window</td>
</tr>
</tbody>
</table>

The Window Menu
The Window menu options include Cascade, Tile, Arrange Horizontally, Arrange Vertically, Close All, and a list of currently open image documents. For descriptions of these features, refer to your operating system’s help.

Note: The Window menu options include Cascade, Arrange Horizontally, Arrange Vertically, Arrange Icons, and Close All. For descriptions of these features, refer to the standard Windows help.
Editing Images

All of the editing options in the Basic program mode are accessed via the Edit menu. There are six editing categories in the Basic program mode which offer you ways to modify your images. Each of these categories will be explored in detail.

- Basic Editing
- Image Position
- Image Quality
- Annotation
- Calibration Marks, Measurements, and Reticles
- Memos

Basic Editing

The Edit menu contains several functions that are common to most operating systems.

Undo

Undo the last edit that you made. The Undo option only allows for one level of edits: in other words, you can only undo the immediately preceding edit. To Undo an action, select Undo from the Edit menu or click the Undo toolbar icon.

Redo

Redo the last edit to the image to which you just applied the ‘Undo’. The Redo option only allows for one level of edits: in other words, you can only redo the immediately preceding undone edit. To Redo an action, Select Redo from the Edit menu or click the Redo toolbar icon.

Cut (Mac)

Cut text fields within the SPOT program.

Copy to Clipboard (PC)/Copy (Mac)

Copy all or part of an image onto the clipboard for insertion into another program. These options are identical to the Windows [Ctrl C] command and the Mac [⌘ C] command.

1. Press and hold the left mouse button (PC)/mouse button (Mac).
2. Drag the cursor over the image until the dotted rectangle covers the area of the image that you want to copy. If you copy without "cutting out" a specific portion of the image, SPOT selects the entire image.
3. Either select the Copy to Clipboard/Copy option from the Edit menu, or press [Ctrl C] (PC)/[⌘ C] (Mac). The image is now ready to be pasted into another application.
4. Open the application that you want to paste the image into, and select from the available pasting options.

Paste (Mac)

Paste text fields in the SPOT program. The Paste field is grayed when editing images.

Clear (Mac)

Clear a text field in the SPOT program. The Clear field is grayed when editing images.
Select All (Mac)
Select an image for copying into another application.

Image Position
From the Edit menu, you can:
- Reposition images
- Match the on-screen orientation of a specimen to the microscopic view
- Crop an image to better reflect the area of interest
- The following options are available for adjusting the position of your image.

Rotate Right
- Rotate an image clockwise in 90-degree increments.

Rotate Left
- Rotate an image counter-clockwise in 90-degree increments.

Flip Horizontal
- Flip an image from right to left.

Flip Vertical
- Flip an image from top to bottom.

Crop
Cut out a portion of an image. To crop an image, follow these steps:
1. Press and hold the left mouse button.
2. Drag the cursor over the image until the dotted rectangle covers the area of the image that you want to crop.
3. From the Edit menu, select Crop. The Crop Area window displays the pixel coordinates of the rectangle that you selected. From this window you can fine-tune the crop area by modifying the pixel coordinates. If you select the Crop option directly from the menu (i.e., without specifying a crop area), the Crop Area window displays the values for the entire image.
4. Click on OK to crop the image. The cropped image appears on-screen.

Note: When you crop an unsaved image, the program automatically discards the area of the image outside the crop. To give yourself the opportunity to change the crop area, you should save the image before you crop it.

Image Quality
The image quality editing options provide you with a wide array of powerful and easy to use tools for changing the appearance of an image after it has been captured. These tools enable you to enhance the appearance of an image in ways that are not possible with conventional photography. All of these tools are available under the Edit menu.
With the exception of Make Negative, Convert to Monochrome and Change Pixel Bit Depth, all of the image quality editing options utilize **thumbnail** images to preview the edits being made to the main image. As illustrated at right, a thumbnail of the image capture appears in the adjustment window, and the **Modify Main Image** box is checked as the default.

- **If you leave the box selected…** As you make editing adjustments, the changes appear in both the main image and the thumbnail.

- **If you deselect the box…** As you make editing adjustments, the changes appear only in the thumbnail image. After you click on OK, the changes appear in the main image.

Properly utilized, thumbnail images can be very helpful as part of the image editing process. Consider the following:

- **You can use thumbnails to speed the editing process.** The SPOT software often cannot update all the pixels in the main image as quickly as you can adjust the edit controls. In cases where the thumbnail image is sufficient to judge the effect of the edits, you can save time by deselecting **Modify Main Image**, so that the main image is updated only after you close the editing window. Deselecting **Modify Main Image** also makes the editing feel more “real time.”

- **The thumbnail can be used to display a smaller, magnified section of an image.** When you select a specific image area (i.e., by dragging the cursor) before selecting an edit function, only the selected area appears in the thumbnail. This is useful for Sharpen, an edit function that affects only the fine structure of an image. This is also useful when you are analyzing histograms, and want the histogram to represent only the section of the image that interests you.

**Filter**

The Filter menu option contains five options for modifying images:

- Smooth
- Sharpen
- Unsharp Mask
- Filter Noise
- Median Filter

**Smooth**

Use Smooth to smooth out grainy images. The smooth option works by lightening the darker side of contrast boundaries and darkening the lighter side. Because the Smooth option removes the high frequency details from an image, some fine image detail is also lost.

To smooth the appearance of an image, follow these steps:

1. From the Edit menu, select Filter > Smooth.
To preview images on the thumbnail image only; deselect the Modify Main Image box.

2. Either use the slider bar to select a Strength value between one and 100, or enter the value in the box.

3. When you have determined a suitable value, click on OK. The smoothed image appears.

**Sharpen**

Use Sharpen to improve the appearance of soft or blurry looking pictures. The Sharpen option works by darkening the darker side of a contrast boundary and brightening the brighter side of a contrast boundary.

To sharpen the appearance of an image, follow these steps:

1. From the Edit menu, select **Filter > Sharpen**.
   - To preview changes on the thumbnail image only, deselect the Modify Main Image box.

2. Either use the slider bar to select a Strength value between one and 100, or enter the value in the box.

3. When you have determined a suitable value, click on OK. The sharpened image appears.

**Unsharp Mask**

Use the Unsharp Mask filter to improve the appearance of an image’s high frequency details. The Unsharp Mask option sharpens an image by subtracting a brightness-scaled, low-pass-filtered image from the original image.

To apply the Unsharp Mask filter, follow these steps:

1. From the Edit menu, select **Filter > Unsharp Mask**.
   - To preview changes on the thumbnail image only, deselect the Modify Main Image box.

2. Either use the slider bar to select a Strength value between one and 100, or enter the value in the box.

3. When you have determined a suitable value, click on OK. The sharpened image appears.

**Filter Noise**

The Filter Noise corrects for the effects of electrical or thermal noise. When capturing dim images with lengthy exposure times, the noise filter acts as a “virtual cooler” for non-cooled camera models, eliminating “hot pixels.”

The Noise Filter checks each pixel on the CCD chip as described below:

1. The program compares the value of each pixel with the values of eight neighboring pixels of the same color.

2. If none of the eight neighboring pixels has a value within the threshold value set (±15 %) for the pixel being checked, the value for the pixel being checked is replaced with the average of the eight neighboring pixels.
To filter noise, follow these steps:

1. From the Edit menu, select Filter > Filter Noise.
2. Enter a value between 10% and 100%. The Threshold value is set to a default of 15%, but will default to the last used setting thereafter. Refer to the procedure described at the start of the Filter Noise section for an explanation of the Threshold value.
3. Click on OK. The filtered image appears on-screen.

Note: Image Profiles can be defined to automatically use the noise filter when capturing an image. Refer to Ch. 2 for details.

**Median Filter**

The Median Filter corrects for the effects of shot noise. This filter functions by considering a sample pixel and its surrounding 8 pixels. The values of all nine pixels are compared and the median value of the group is substituted for the sample pixel. In this process, all pixels are always being modified, unless, of course, the sample pixel is the median value of the group.

Unlike the Filter Noise function, there is no need for any user inputs regarding the median filter process.

This approach negates any impact that a hot pixel might have on the filtered value of another neighboring (sample) hot pixel.

Note: Filtering algorithms always utilize original data for each sample pixel being considered. In other words, filtered (substituted) pixel data is not used in the filtering process.

**Make Negative**

Make Negative creates a color negative (with complimentary colors) of an image. From the Edit menu, select Make Negative. The Program automatically converts the image to a negative.

**Adjust Image**

The Adjust Image options allow you to correct images that are overly bright or dark, or to modify areas of interest that are too light or too dark to see important details. To access these editing options, select Adjust Image from the Edit menu. The Adjust Image window appears, as shown at right. Adjust images either by entering a value in the box or by moving the slider bar.

The Adjust Image window provides three adjustment parameters:

- **Color Space** – This option enables you to select the color space that is best suited to the type of image that you are editing:
  - RGB (Red Green Blue) – Use for monochrome images
Section II – Chapter 4 – SPOT Basic Viewing and Editing Image Documents

- **HSL** (Hue Saturation Luminance) – Use for all color images except fluorescence
- **HSV** (Hue Saturation Value) – Use for fluorescence images

Refer to the Image Editing and the Concept of Color Space section below for more detailed descriptions of the three color spaces.

- **Modify Main Image** - When this box is checked (the default), both the thumbnail image and the main image change as you are adjusting the image. If you want the main image to change after you have made the adjustments – and thereby speed the editing process - deselect the Modify Main Image box.

- **Reset** – Click on the Reset button to return the image to its pre-adjustment appearance.

**Dark Level**
The Dark Level adjustment lightens or darkens an entire image by adding the value that you specify to all of the pixels in the image.

To adjust Dark Level, enter a number between -100 and 100.3
- Numbers between zero and –100 darken the image.
- Numbers between zero and 100 lighten the image.

**Brightness**
The Brightness adjustment lightens or darkens the bright areas in an image. For example, if you used the Dark Level adjustment to modify an image, but the new bright areas are either too dark or too light to see the details, you can use the Brightness feature to correct this. Because the Brightness adjustment is *multiplicative* (as opposed to the Dark Level adjustment which is *additive*), it multiplies the pixel values in the image by the value that you specify. A multiplicative process affects bright areas more than dark areas. Before adjustment an image’s Brightness value is always one.

- To adjust Brightness, enter a number between 0 and 5.
- Numbers between zero and one darken the image.
- Numbers between one and five lighten the image.

**Gamma**
The Gamma adjustment lightens the darker (mid-tone) areas of an image without burning out bright areas or lightening black areas. This is useful when modifying images with a wide *dynamic range*, (i.e., the range of brightness values recorded by the CCD chip. Before adjustment, the Gamma value is always one.

- To adjust Gamma, enter a number between .1 and 4.
- Numbers above one lighten the mid-tone areas in the image.
- Numbers below one darken the mid-tone areas in the image.

**Contrast**
The Contrast adjustment exaggerates or subdues the difference between the bright and dark areas in an image. Before adjustment, the Contrast value is always one.

- To adjust Contrast, enter a number between 0.10 and 5.
- Numbers above one exaggerate the contrast between bright and dark areas.
- Numbers below one subdue the contrast between bright and dark areas.
**Image Editing and the Concept of Color Space**

A color space is a coordinate system that is used to mathematically represent color. In order to satisfy the imaging requirements of different microscopy techniques, the SPOT program allows you to adjust brightness, color, and contrast in three color spaces: RGB, HSL, and HSV.

The color space options and their suggested uses are as follows:

- **Adjust RGB** (Red Green Blue) – Use for monochrome images
- **Adjust HSL** (Hue Saturation Luminance) – Use for all color images except fluorescence
- **Adjust HSV** (Hue Saturation Value) – Use for fluorescence images

Each color space is described below.

**RGB**

The RGB color space operates by assigning a red, green, and blue value to each pixel in an image. Because red, green and blue are the primary colors for emissive light, this is the method that color computer monitors use to display images. However, the RGB color space is not intuitive to users.

**HSL**

The HSL color space is a more intuitive model based on the three attributes that are common to all colors: hue, saturation, and luminance. Instead of assigning a red, blue, and green value to each pixel, the HSL color space assigns a value for each color attribute (e.g., hue, saturation, and luminance). These attributes are defined as follows:

- **Hue** – Hue is the designation for the actual color, as distinguished from others in the color spectrum. Hue is derived from a color wheel and is expressed in the color's angular location (in degrees) on the wheel. (e.g., +180° to –180° for the SPOT software).
- **Saturation** – Saturation is the proportion of perceived pure hue in the color. Saturation (in the SPOT software) is measured on a numerical scale of 0 to 100, where zero is pure gray and 100 is pure hue (e.g., day glow).
- **Luminance** – Luminance is the relative brightness or darkness of a hue. Luminance (in the SPOT software) is measured on a numerical scale of 0 to 100. A saturated color starts out as black at a luminance of 0, reaches full brightness as a saturated color at a luminance of 50, and then transitions through lighter pastel shades to white at a luminance of 100. This mimics the human perception of increasing brightness for images that are illuminated with light that contains a broad spectrum of wavelengths.

**HSV**

The HSV color space was added to the SPOT software to optimize fluorescence image editing. Both the RGB and the HSL color spaces are problematic when used to edit color fluorescence images. Increasing gamma in RGB can cause dimmer sections of the image to lose saturation (look “washed out”) and change hue. Increasing gamma or brightness in HSL causes the brighter areas of an image to look unnaturally pastel or even white. The HSV color space avoids both problems.

The HSV color space is similar to the HSL color space in that it also uses the intuitive concepts of hue and saturation. However, instead of luminance for brightness, it uses Value. Value is like Luminance in that a value of 0 is black. Value differs from Luminance in that a Value of 100 (in the HSV color space) is the brightest version of the original hue whereas a Luminance of 100 (in the HSL color space) is always white.
For example, a dim cherry red changes to a bright cherry red when its Value is increased from 30 to 100. When its Luminance is increased from 30 to 100, a dim cherry red turns white. HSV works well for fluorescence images because the dyes in fluorescence images emit single wavelength light. This light is, by definition, highly saturated. Editing in the HSV color space ensures that all areas of the image retain their saturated colors. Thus, using the HSV color space, images can be modified without causing the bright areas to look unnaturally pastel or white.

**Match Color**

The Match Color feature is typically used in two situations:

- You want to change the colors of an image on the screen to match the way that you think the specimen looks.
- You want to set the white balance for pictures taken with a microscopic technique that never has white in its images. A prime example of this situation is fluorescence microscopy.

If you use the Match Color option on a captured, previewed, or Live image, you can follow these steps to adjust the white balance.

1. Click on the Match Color button.
2. The mouse cursor will change to an eye dropper. Use the cursor to select (click) the color which needs to be adjusted to white.

   **Note:** The Set White Balance button appears only for a newly captured, unsaved, and unedited image.

3. The Match Color dialog appears with information about the pixel that you selected:

   - **Hue** – The actual color, as distinguished from others in the color spectrum. Hue is derived from a color wheel and is expressed in the color’s angular location (i.e., 0 to 360 degrees).
   - **Saturation** – The richness of perceived pure hue in the color. Saturation (in the SPOT Software) is measured...
on a numerical scale of 0 to 100, where zero equals pure grey and 100 equals pure hue (i.e. ‘day glow’).

4. Click the Make White/Grey button to rebalance the red, green, and blue ratio to make the selected pixel ‘white’.

5. To use these new values for the white balance values, click the Set White Balance button and click OK.

Note: If you use the following options on a Live Image, the change you make will only be reflected in the current image frame. While you use the Match Color feature, the Live image is paused and the below changes will only be reflected in the displayed paused image frame. As soon as you click the OK button on the Match Color dialog box, the Live Image will resume and any modifications you made will revert back to the original colors. To retain the settings, click the Set White Balance button.

If you use Match Color on a captured or previewed image, you can also adjust a color which is not being displayed as you see it with your eyes.

To use the Match Color feature for this purpose, follow these steps:

1. Click on the Match Color button.

2. The mouse cursor will change to an eye dropper. Use the cursor to select (click) the color which needs to be adjusted to a different color.

3. The Match Color dialog box appears with information about the color you selected as outlined above (Hue and Saturation).

4. The color you selected can be adjusted by a few different methods, aside from the Set White Balance option described above:

- The Hue and Saturation inputs which are best used for minor adjustments or to set fluorescent colors to saturation.

- The Select Color option is available for assigning a color correction to the image. This is accomplished by moving the crosshairs on the color wheel to the desired location by clicking on the new location or clicking and dragging.

For any of these adjustments, you can click the “Modify Main Image” check box to see your changes on the source image as you make them.

5. Click on OK to accept the adjusted image.
Convert to Monochrome

Use this feature to quickly change a color image to its corresponding monochrome image. For instance, this feature will take a 24 bit RGB image and convert it to an 8 bit monochrome image with one simple click. Choose the Convert to Monochrome feature from the Edit menu. This feature is not available for monochrome images.

For maximum flexibility with your bit depth setting, you can use the Change Pixel Bit Depth option instead.

Note: When Convert to Monochrome is applied, all color data is removed from the image and is not retrievable.

Change Bit Depth

Use Change Bit Depth to change the bit depth of the currently open image. To change the pixel bit depth for an image, follow these steps:

1. From the Edit menu, select the Change Bit Depth option. The Change Bit Depth window displays the current Bit Depth for image.

2. Select the pixel bit depth that you want to change the image to.

Changing from one monochrome bit depth to another monochrome bit depth or from one RGB bit depth to another RGB bit depth does not require the addition of any color channeling information. In this case, select the new pixel bit depth and click on OK.

Changing from an RGB color image to a monochrome image requires the entry of color channeling information. When you select the new pixel bit depth, the color channeling information appears.

Select the color channel(s) that you want to use. Select either a single color or the All Channels option, which is the default.

- If you select a single color channel, the program uses only the values for that color (in the original image) when it creates the monochrome image.

- If you select All Channels, the program uses a mathematical algorithm to combine the red, green, and blue values from the original image when it creates the monochrome image.

In order to have the image retain its new bit depth setting, you will have to save the image to file. For more on image saving options, please refer to the Save section in this chapter, above.
Annotate

Image annotation is useful when you want to prepare captures for formal presentation, or inclusion in an article or reference work. Using SPOT’s image annotation features, you can:

- Add text to an image.
- Use an arrow, line, rectangle, or ellipse to emphasize a particular area in an image.
- Add a graphic stamp such as a company logo to an image.
- Add freehand lines to an image.
- Number objects in an image.
- Add the current user name to an image.

Other annotations are also available. To annotate an image, select Annotation from the Edit menu. Several changes take place in the SPOT image-editing environment:

- The Edit menu options change to reflect annotation editing.
- The Object menu appears with options for inserting drawing objects, text, images, and image related information onto an image.
- If None is selected, the cursor is an editing tool for selecting, sizing, and positioning objects. When creating new reports, None is the default option.
- If an annotation object is selected, the cursor changes to a cross-hair icon for placing new objects on the image. Refer to Adding Annotation Objects to SPOT Images (below) for descriptions of each object.

- The View menu changes to reflect annotation mode:
  - The two zoom options and the Show Grid Lines options are no longer displayed.
  - The Show Tools option is present – this option displays the Tools dialog box, which contains shortcuts for inserting annotation-drawing objects.

The Attributes menu appears with options for specifying annotation qualities. See below, Defining Annotation Attributes for descriptions of each option.

The Done! Menu allows you to switch back to the image capture/edit mode. The Done! Menu has only one option, End Annotation Mode. When you select this option the SPOT program reverts back to the standard SPOT image-editing environment. If the Tools are in view, you can also click on the Done button.

Adding Annotation Objects to SPOT Images

Once in Annotation mode, Annotation objects can be added to images in one of two ways:

- Through the Object menu.
- Through the Tools dialog box. To access the Tools dialog box, select the Show Tools option on the View menu. The Tools dialog box, as illustrated above, displays shortcut buttons to the eleven drawing objects on the Object menu:

Before discussing the individual objects, review the following general procedure for inserting an annotation object into an image:
Section II – Chapter 4 – SPOT Basic Viewing and Editing Image Documents

Note: In some cases, the procedure varies to fit the object’s characteristics. The specifics are noted in the descriptions of the individual objects.

1. From the Object menu, select the type of item (i.e., Lines, Connected Lines, etc…) that you want to add to the image. The cursor’s functionality varies according to whether an object type (i.e., line, text) is selected. If an object type is selected, the cursor changes to a cross-hair icon that is used to add new report objects to the grid. If None is selected, the cursor is an editing tool that is used to select and position objects.

2. Use the mouse to move the cross hair to the location where you want to insert the object.

3. Left-click at the insertion point.
   - If you selected a line, box, or other shape, hold down the mouse button and drag the object to the desired size.
   - If you selected one of the other objects, the object will either appear (e.g., Image Time) or the program will prompt you to enter the associated information (e.g., Text, Image Memo, etc…).

4. After you have added the object, there are three options:
   - Add another object of the same type, as described in step 3.
   - Add a different type of object - select from the Object menu options, the toolbox.
   - Resize, reposition, or edit an object. To do so, select None from the Object menu.
     - To resize an object, select (left-click) the object and drag the handles to make the object larger or smaller.
     - To reposition an object, left-click and drag the object to the desired area of the image document.
     - After the object has been added, it can be edited. To edit an annotation object select the object and choose an option from either the Edit menu or the Attributes menu. You can also edit an object by right clicking on it.

5. When finished, choose End Annotation Mode from the Done! Menu, or click the Done button on the Tool box.

6. To merge the annotation into the image so that they can be displayed when the image is opened in other applications, access the Edit menu, choose Merge, and then Merge Annotations. The annotations will then be merged into the pixel data. Please see the Merge feature, later in this chapter, for more information on Merging layers into your image.

The following section describes each Annotation object in detail.

None

Select None when you want to use the cursor to edit and position the objects. For a shortcut, use the Escape key on your keyboard to change the functionality of your cursor to a select tool, None.

Lines

Unconstrained Line - Add a straight line annotation to the image
Horizontal Line - Add a horizontal line annotation to the image.
Vertical Line - Add a vertical line annotation to the image.
Arrow – Add an arrow to the image. Either select Lines>Arrow from the Object menu, or click on the Tools box button. Left click on the image and drag toward the area that the arrowhead will point to.
**Connected Lines**

*Polygon* – Add a closed polygon to an image. Either select Polygon from the Object menu, or click on the Tools box button. Left click and release, and then drag the mouse to create a side. Left click again to start a new side. Double click to finish the polygon. The program automatically adds any additional lines needed to close the figure.

*Polyline* – Add an open polygon to an image. Either select Polyline from the Object menu, or click on the Tools box button. Left click and release, and then drag the mouse to create a side. Left click again to start a new side. Double click to finish the polyline.

*Freehand* - Add a freehand line to the image.

**Shapes**

*Rectangular Box* – Add a square cornered box to the image.

*Rounded Box* - Add a round cornered box to the image.

*Ellipse* – Add an elliptical object to the image. Ellipses are drawn inside of the rectangular area that you define. Ellipses touch the top, bottom, right and left sides of this rectangle.

Either select Ellipse from the Object menu, or click on the Tools box button. To draw an ellipse, left click at the point where you want to position one vertex of the rectangle and drag the cursor to the point of the opposite vertex.

*Circle* – Add a circle to the image.

**Images**

*Image* – Add an image to the image.

1. From the Object menu, select Image.
2. Left click at the point on the display grid where you want to insert the Image box, and holding down the mouse button, drag the cursor to create the desired shape and size for the image (it can also be resized/re-positioned at a later point). When you release the mouse button, the Select Image dialog box appears.
3. Specify the file source for the image:

   *Currently Open Image* – Add a currently open image. If you have one or more open images, SPOT lists the file name(s) and path(s) in the drop-down box. Select from the list.

   *Image File* – Add an image from disk. Specify the file name and location either by entering the path in the Name box, or clicking on the selection box to the right.

   *Database (Windows only)* – Add an image from a SPOT database. In order to insert a database image, the database must be open. Enter the Image ID for the file. If you do not know the database image ID, search the database – the display table indicates the Image ID for each file.

4. Click on OK. The image appears on your report grid.

*Stamp* – Insert a selected image onto the image capture. From the Object menu, select Stamp. The last selected image appears on your image. To select a new image to insert, choose the Stamp option from the Attributes menu.

**Note:** Because the Mac edition does not have database functionality, Mac users will not be able to use the Database option.
Text
Add text to the image.

1. Either select Text>Text from the Object menu, or click on the Tools box button.
2. Left click at the point where you want to insert the text. The Text window appears.
3. Enter the text.
4. Click on OK. The text box appears.
5. Resize the box as needed to display the text.

Current Date - Add the current date to the image. This date defaults to the date set on the computer you are using.

Current Time - Add the current time to the image. This time defaults to the time set on the computer you are using.

Current User Name – Add the current user’s name to the image. This defaults to the user who is logged on the computer.

Image User Name – Add the name of the person who captured the image to the image. This will be blank when added to the image if the image user name was not recorded with the image when it was taken.

Image Date - Add a date to the image. This date defaults to the date that the image was captured. To change the date, double click on the box, and enter the desired date.

Image Time - Add the image capture time to the image. This time defaults to the time that the image was captured. To change the time, double click on the box, and enter a new time. The time that appears here varies according to whether the file was transferred across a network, and whether the file is a SPOT database image. Refer to the Image Date/Time section of this chapter for more details.

Image Title - Add a title to the image. The title automatically defaults to the file name and location of the open image, e.g., C:\images\cells\fluor1. To change the title, double click on the box and enter a new title.

Image Memo – Add a previously defined TIFF image memo. Click at the point where you want to insert the text box. To change the memo, double click on the box and modify the text as needed. Changing the text in the memo annotation does not affect a memo that is attached to the image file.

Image Sequence Index (sequence images) - Add the Sequence Index (number) to the image. This is the number of the image within the sequence – i.e., the Sequence Index for the first image in the sequence is “1,” the second image “2,” etc…

Image Sequence Size (sequence images) – Add the total number of images in the sequence to the image.

Image Sequence Elapsed Time (sequence images) – Add the elapsed time between the image being annotated and an image that you specify. After selecting Object>Text>Image Sequence Elapsed Time, the program prompts you to enter the Reference Image Index Number. If you specify a number that comes after the image being annotated, the elapsed time will be negative. For instance, if you are annotating image number five in a sequence of 10, and you specify a Reference Image… of eight, the elapsed time will be a negative value.

AutoNumber – Adds numbering to the image starting at 1 and incrementing by 1 for each click of the mouse. Good for counting and tracking objects in an image. You may elect to change the starting number to a value greater than one by defining Autonumber’s attributes (see section below).
Defining Annotation Attributes

All of the general style and appearance options can be accessed from the Attributes menu. Annotation attributes can be defined for an entire report or on an object-by-object basis (see the Adding Annotation Objects to SPOT Images section above).

- When an annotation object is selected, the attribute is defined for the selected object(s) only. In addition, when you right click on an object, the menu displays the attribute options for that object.
- When nothing is selected, the attribute is defined for all future, relevant objects.

The following section details each of the annotation attributes and the report objects that they affect.

Colors

Define the foreground and background colors for all objects. Follow these steps:

1. From the Attributes menu, select Colors.
2. Define the Text/Lines color. This is the color of the text, the line, or the border around a text/image box. The default foreground color is black. To select a color click on Color.
3. The next window varies, depending on whether you are using a Windows or a Mac system.
   - Windows allows you to select from a palette of colors or enter specific HSL or RGB color values.
   - Mac OS allows you to select from a palette of colors, enter specific RGB, CMYK, HLS, or HSV values, and enter Internet specific colors.
4. Define the Background/Fill color. This is the color that appears behind text and in boxes. Lines and images do not display a background color.

You may set your selections as the default by selecting the Save as Defaults checkbox.

Line Thickness

Determine line thickness for the following objects: Line, Horizontal Line, Vertical Line, Arrow, Box, Rounded Box, Ellipse, Freehand, Polygon, and Polyline.

1. From the Attributes menu, select Line Thickness.
2. Enter a Thickness value between 1 and 5 pixels.
3. Click on OK.

You may set your selections as the default by selecting the Save as Defaults checkbox.

Box/Ellipse Options

Define the appearance of the Box and Ellipse objects. Specify whether you want a fill for the object.

1. If you do not want the box to be filled (i.e., you want a transparent box), click on OK.
2. If you want to specify a fill for the box, check the Fill Box/Ellipse.
4. Click on OK. The background will fill with the color selected in the Attributes/Colors/Background/Fill selection.

You may set your selections as the default by selecting the Save as Defaults checkbox.

---

**Note:** In order to define a background/fill color for a Box or a Rounded Box, a fill must be selected. Similarly, in order to define a background/fill color for a text box, the background (see Text Border, Justification, and Background below) must be set to Opaque.

---

**Image Options**

The Image Options dialog allows you to set how images used as annotation objects will appear on the base image.

**Border**

Images used as annotation objects can have a border around them. To have a borderless image, uncheck the Border box. To set the thickness (in pixels) of a border line, check the Border box and enter a value between 1 and 15.

**Retain Original Resolution**

Check this box if you would like to have the annotation image object retain its original resolution. Otherwise if left unchecked, the annotation image object will take on the base image’s resolution.

**Show Annotations, Show Calibration Marks, Show Measurements, Show Reticles**

Each layered object in a SPOT saved image can be independently turned on or off on the annotation object (as long as these layers have not already been merged to the image data). Check or uncheck each box to indicate which layers you would like to have shown on the annotation object.

**Arrow Size and Direction**

Specify the size of the arrowhead and define the direction that the arrow points.

1. To specify the size of the arrowhead, enter a value between 1 and 10.

2. Specify the direction of the arrow:
   - To draw an arrow starting tail first and finishing with the point (head), select **Tail to Head**.
   - To draw an arrow starting point (head) first and finishing with the tail, select **Head to Tail**.

3. Click on OK.

The Arrow Size and Direction attribute is not available for Mac users. For Mac users, arrows are always drawn **Tail to Head**.
Text Font

Define the appearance of the text for the Text, Image Date, Image Time, Image Title, Image Memo objects.

1. Select a Font, a Font Style, and a point Size. The Sample box displays a preview of the font.
2. Define any Underline effects.
3. Click on OK.

Text Options

Define the appearance of the text boxes for the Text, Image Date, Image Time, Image Title, Image Memo objects.

1. Specify whether the text box should have a border. To add a border, click on the Border box, and enter a Thickness value between .05 and 10.
2. Define the Justification of the text. This justification applies to the position of the text in the box, not the position of the text on the page.
3. Define the Background. Select either Transparent or Opaque.
4. Define the orientation at which the text should be displayed relative to the text box. Select 0, 90, -90 or 180 degrees.
5. Click on OK.

Title Options

Define the appearance of the title associated with the captured image(s).

1. Specify whether the title should include the computer file storage path as part of the image title.
2. Specify whether the title should include the computer file name extension as part of the image title.
3. Click on OK.

Time Options

1. Specify whether the time stamp should include seconds.
2. Specify whether the time stamp should include milliseconds.
3. Click on OK.
**Stamp Image**

Use the Stamp Image option to select the image that you want to use for the Stamp option. To select the image, choose Stamp Image. The Stamp Image dialog box prompts you to enter a file name and path. If the image object base path has been set in the Preferences (see Chapter 2 for more information), you can enter the name of the image file. If you do not know the name, use the browse button to search for the file. After you have selected the image file, click on OK.

*Note: All Stamp Images should be saved in the file path location set in the Preferences. The default location for this is in Shared Documents\Diagnostic Instruments\Spot\ObjImage directory.*

**AutoNumber Value**

Define the starting number used in the AutoNumber feature.

1. Select a whole number that sets the beginning value once the AutoNumber feature is activated. (Numbers subsequent to the initial number will increment by 1).
2. Click on OK.

**Label Options**

Labels can be added to Annotation Objects. If you would like to, you may 1) choose to add labels to specific types of objects, or 2) add objects of any type and then add a label afterward.

To use the first approach, select **Label Options** from the Attributes menu of the Annotations menu bar. The resulting window will have a number of shapes of which you may specify those that you intend to have a custom label. You can then use the Default Label entry line for entering default text that will always show up on the label, and/or insert a variable, either a standard variable or a custom variable.

If you choose to enter information into the Default Label entry, this information will automatically be added to the annotation shape. If you choose not to enter information into the Default Label entry, later when you add that type of object to the image, you will be automatically prompted to add a label. You may choose Cancel if you decide not to add a label.

In the second approach, simply right click on the annotation object that has been placed on the image. From the resulting edit menu, select Add Object Label.

In either approach, the Label window allows you to add text to the object label.
Save as Defaults
Save the current attributes for future annotations, across the board (all annotation objects).

Editing Annotation Objects
Once you have annotated an image, you can edit the annotation objects as needed. There are three ways to edit objects:

- **Use the Attributes menu** - The Attributes menu, as noted in the Defining Annotation Attributes section of this chapter, allows you to either set the attributes for adding specific types of objects, or to select existing objects and modify them as needed. Refer to the Defining Annotation Attributes section for more details.

- **Use the Edit dropdown menu** - The Edit menu contains general editing features such as Undo, Copy, Cut, Send to Back, etc.

- **Right-click on the report object** - Right clicking on a report object brings up a customized editing menu that contains both general editing commands and the attributes that can be edited for that object.

You can also move and size annotation objects:

- To move an object, left click on it and drag the item to a new location. When you drag the item, the cursor becomes a four-pointed arrow.

- To size an object, left click on it and drag the handles to resize the object as needed.

The following sections describe the available editing options from the editing dropdown menu.

**Undo**
Undo the last action. Unlike the image capture/editing Undo feature, the annotation Undo undoes up to ten changes.

**Bring to Front**
Bring the selected annotation in front of all other annotations.

**Move Forward**
Bring the selected annotation one layer forward.

**Move Backward**
Send the selected annotation one layer back.

**Send to Back**
Send the selected annotation behind all other annotations.

**Select All**
Select all annotation objects.

**Unselect All**
Unselect all annotation objects.

**Delete (Windows)/Clear (Mac)**
Delete the selected annotation object(s).
Delete All
Delete all of the annotations on the image.

Copy to Clipboard
Copy the selected annotation clipboard.

Cut
Remove the selected annotation and place it on the clipboard.

Paste
Place the cut or copied annotation from the clipboard into the image.

Calibration Marks, Measurements, and Reticles

The Set Calibration, Add/Edit Calibration Mark, Add/Edit Measurement, and Apply Reticle options enable you to add calibration and measurement references to SPOT images. Each of these features will be discussed in further detail below.

Set Calibration
The Set Calibration option allows you to select or modify the calibration setup to be used for subsequent calibration mark insertions and measurements on this image/image sequence. If there are no calibration setups available in the drop-down list, or if your objective magnification isn’t listed, refer to the Calibration Setup portion of Ch. 2 –for instructions for creating calibrations for your microscope.

Add/Edit Calibration Marks
The Add/Edit Calibration Marks feature allows you to insert a calibration mark into an image capture and to edit its display properties. To add a calibration mark, follow these steps:

1. If you have not already calibrated the objectives on your microscope, do so. Refer to Ch. 4 – The Advanced Program Mode for details.
2. From the Edit menu, choose Set Calibration and select a Calibration Setup (e.g., 10x) for the objective that you are using.
3. From the Edit menu, select Add/Edit Calibration Marks. The Calibration Mark window appears with the selected calibration at the top.
4. Move the cursor to the point in the image where you want to insert the calibration mark and click at that point. The calibration mark appears with the default appearance settings.

5. Using the on-screen mark as a reference, modify the Appearance options:
   - **Orientation** – Check the appropriate box to select either a horizontal or vertical display for the calibration mark.
   - **Line Thickness** – Select a line thickness between 1 (thinnest) and 5 (thickest).
   - **End Length** – Select the size in pixels of the bars at the ends of the calibration lines.
   - **Show Text** – Select this checkbox if you would like the calibration measurement text to be shown along with the calibration line.

Note: If you are not satisfied with the placement of the calibration mark, you can click on and drag the mark to a new position. Clicking on and dragging the bar moves both the bar and the number. Clicking on and dragging the number moves only the number.
• **Decimals** – Select the number of decimals that appear in the calibration mark number. Choose from a range of zero decimals (1) to five decimals (1.00000)

• **Font** – Define the font, point size, and appearance.

• **Rotation** – Specify the orientation of the calibration measurement text relative to the calibration line.

• **Color** – Click on the Color button to define the color of the calibration mark. You can either choose from a palette of basic colors or define a custom color to provide the best display.

• **Size** - Enter the size of the calibration mark. You can modify the size either by entering the number in the Size box, or by using the cursor to stretch the on-screen calibration bar. To adjust the size of the calibration mark, move the cursor to the end of the calibration bar line. The standard cursor changes to a two-headed arrow. Drag the end of the bar to adjust the length. The calibration mark number changes to reflect the new length.

6. Select **Save As Defaults** if you would like these display properties to be the defaults when adding calibration marks in the future.

If you would like to add additional calibration marks, click New and follow the steps above again. If you would like to delete calibration marks, select them individually and select Delete. Click Close when you are finished adding calibration marks to the image.

---

**Note:** Added calibration marks will need to be merged into the image pixel data in order to be displayed by other applications. Choose Edit/Merge/Merge Calibration Marks to merge them into the image.

**Note:** When adding calibration marks or measurements to images in a sequence, if one of the images doesn’t have a calibration setup saved with it, the SPOT software will assign it the same calibration setup as the first image that was edited.

---

**Add/Edit Measurements**

The Add/Edit Measurements option enables you to incorporate measurements into an image capture and to edit their display properties.

To add a measurement, follow these steps:

1. If you have not already calibrated the objectives on your microscope, do so. Refer to Ch. 4 – The Advanced Program Mode for details.

2. From the Edit menu, choose **Set Calibration** and select a **Calibration Setup** (e.g., 10x) for the objective that you are using.

3. From the Edit menu, select **Add/Edit Measurements**. The Measurement window appears with the selected calibration at the top.

4. Check the type of measurement that you want from the dropdown menu and select the Create button.

   - **Straight Line** – Point to point distance measurement
   - **Segmented Line** – Point to point distance with multiple sections
   - **Curve** – Length of a freehand curve
   - **Region** – Area and perimeter of a freehand outline
• **Angle** – Angle measurement

• **Fixed Rectangle** – Length, width, area and perimeter of a software-generated rectangle

• **Arbitrary Rectangle** – Length, width, area and perimeter of a rectangle based on user-drawn line

• **Circle from Diameter** – Radius, diameter, area, and circumference of a circle based on user-drawn diameter

• **Circle from Radius** – Radius, diameter, area, and circumference of a circle based on user-drawn radius

• **Circle from Three Points** – Radius, diameter, area, and circumference of a circle based on three user-selected points

• **Ellipse** – Major axis, minor axis, area and perimeter of an ellipse

• **Orthogonal Distance** – returns the value of a line segment that is perpendicular to an associated line segment.

5. Move the cross-hair cursor to the point in the image capture where you want to begin the measurement.

6. Single click to activate the drawing function.

   • **Straight Line**, move the cross-hair cursor to the end point of the measurement. Single click to deactivate the drawing function and display the length of the line.

   • To create a **Segmented Line**, use the cross-hair cursor to move to next segment and Single click to create a new segment. Double click to end segmented line measurement and display the line length.

   • For a **Curve**, use the cross-hair cursor to trace a freehand line on an image. Single click to deactivate the drawing function and display the length of the freehand line.

   • For a **Region**, use the cross-hair cursor to trace a freehand outline around the area that you want to measure. Single click to deactivate the drawing function and display the measurement. If the area is not completely enclosed by the outline, the SPOT program automatically completes the path by connecting the end point to the starting point with a straight line.

   • For an **Angle**, use the cross-hair cursor to specify the three points that define the angle. Single click to mark the end point of the first side. Move the cross hairs to the vertex and single click again. Move the cross hairs to the end point of the second side, and single click. This last click deactivates the drawing function and displays the angle measurement.

   • For a **Fixed Rectangle**, use the cross-hair cursor to specify where one corner of the rectangle should be positioned. Move the cross hair diagonally to draw the rectangle. Single click to deactivate the drawing function and display the length, width, area, and perimeter of the rectangle.

   • For an **Arbitrary Rectangle**, move the cross-hair cursor to the end point of a line that the rectangle will be based on. Single click and move the cross-hair cursor to draw the rectangle. Single click to deactivate the drawing function and display the length, width, area, and perimeter of the rectangle.

   • For a **Circle from Diameter**, use the cross-hair cursor to specify the diameter of the circle. Single click to deactivate the drawing function and display the radius, diameter, area, and circumference of the circle.
• For a **Circle from Radius**, use the cross-hair cursor to specify the radius of the circle. Single click to deactivate the drawing function and display the radius, diameter, area, and circumference of the circle.

• For a **Circle from Three Points**, use the cross-hair cursor to specify the three points that define the circle. Single click to mark the second point. Move the cross hair to the third point and single click again. This last click deactivates the drawing function and displays the radius, diameter, area, and circumference of the circle.

• For an **Ellipse**, move the cross hair cursor to the end point of a line that the ellipse will be based on. Single click and move the cross-hair to draw the ellipse. Single click to deactivate the drawing function and display the major axis, minor axis, area and perimeter of the ellipse.

After you have completed steps one through six, you can modify the measurement as needed, using the Appearance options:

• **Line Thickness** – Select a line thickness between 1 (thinnest) and 5 (thickest).

• **Decimals** – Select the number of decimals that appear in the measurement. Choose from a range of zero decimals (1) to five decimals (1.00000)

• **Color** – Click on the Color button to define the color of the measurement. You can either choose from a palette of basic colors or define a custom color to provide the best display. If you are editing a monochrome image, you can select either black or white.

• **Font** – Define the font, point size, and appearance.

• **Label** – You may include a custom label for the measurement you apply. You may type up to 30 characters and spaces.

• **Text Rotation** - Specify the orientation of the measurement text relative to the shape drawn.

You can also choose to hide the measurement values or to change their labels:

• Select the measurement values to be hidden by de-selecting the checkboxes next to them in the **Show** column.

• Select new labels by typing them into the **Label** column.

• After adjusting the appearance and display of your measurements, at this point you can:
  - Re-position the measurement labels and values. When you position the cursor over the number, it changes to a four-point arrow. Click and drag on the number to move it to a new location.
  - Erase measurements. Click on the measurement and choose **Delete**.
  - Clear all measurements from the image. Click on the **Delete All** button.
  - Add new measurements. Click on **Create**, select the measurement type and add additional measurements.
  - Save the appearance and display options selected as the defaults. Click on **Save As Defaults**.

7. Click on **Close** when you are finished adding and editing measurements.
Note: Added measurements will need to be merged into the image pixel data in order to be displayed by other applications. Choose Edit/Merge/Merge Measurements to merge them into the image.

Note: When adding calibration marks or measurements to images in a sequence, if one of the images doesn't have a calibration setup saved with it, the SPOT software will assign it the same calibration setup as the first image that was edited.

Apply Reticle

To apply a reticle to a captured image, use the Apply Reticle feature to select a configured Reticle to be applied to the image. The Apply Reticle dialog box will appear with a pull down list of available reticles. Make your selection and click Ok. Also, if there is an existing reticle which you would like to 'erase' from your image, you can check the box to Replace Existing Reticle and then click Ok.

If you wish to have two reticles on the image, do not check the option to Replace Existing Reticle.

Remove Reticle

This option is only available if a Reticle has already been applied to an image. Selecting this option from the menu will automatically remove the reticle which has been applied to the image.

Merge

Use Merge to merge annotations, calibration marks, and measurements into the image pixel data in order for other applications to display them. If the merge is not done, only the Spot software will display the annotations, calibration marks, and measurements. If you have used any two options of annotations, calibration marks, measurements, or reticles you will have the option to Merge all of these features at one time. Choose Edit/Merge and select Merge Annotations, Calibrations Marks, Measurements, and Reticles to conveniently merge all items for viewing in other applications.

Note: Once an Annotation, Calibration Mark, Measurement, or Reticle has been merged to the image, the information of the item being merged into the image will replace the image data at that point. We recommend saving a copy of the unmerged layers before merging these items to preserve the pixel data.
Memo

In the SPOT software, you can attach a memo to image files. To use the Memo option, follow these steps. From the Edit menu, select Memo. The Image Memo window appears for you to enter a new memo or edit an existing memo.

1. Enter the message.
2. Click on OK to attach the memo to the image.

Working with Image Sequences

Image sequence files can be edited in the following ways, as described below:

- The Sequence menu – Rearrange the order of a sequence, add and/or remove images to and from the sequence, extract images from the sequence, and play the sequence. Refer to the Sequence Menu Options section of Ch.8 – Viewing, Editing, and Annotating Images for details.
- The Sequence Controls (Image Sequence) dialog – Set view options and “play” the sequence. Refer to the Image Sequence Controls section of Ch.8 – Viewing, Editing, and Annotating Images for details.

There are three places from which you can edit and play image sequence files:

- The Sequence menu – Rearrange the order of a sequence, add and/or remove images to and from the sequence, extract images from the sequence, and play the sequence.
- The Sequence Controls (Image Sequence) dialog – Set view options and play the sequence.
- The Edit menu - Modify/enhance image sequences using the options on SPOT’s Edit menu. Refer to Editing Images in a Sequence (below) for more information.

Refer to the following sections for details.

Sequence Menu Options

Image sequences are editable. The Sequence menu, which is available only when an image sequence is open, displays the available options. They are as follows:

Extract Images

Extract an image or images from a sequence file. Extracting creates new image(s), leaving the original sequence intact. Click on Extract Images and enter the number(s) of the image(s) that you want to extract. To extract multiple images from a sequence, separate numbers with commas to skip over images and/or dashes to include the images in between the numbers - i.e., 5, 6, 7 or 5-7 or 1 – 5, 6, 9.

Insert Image

Add an image to the sequence. Using Insert Image, you can add an image to a sequence from one of two sources:
Currently Open Document – Add an image from the currently open sequence file. Make sure to specify the Sequence Index – i.e., the number of the image in the sequence.

File – Add an image from disk. If the image comes from a sequence file, make sure to specify the Sequence Index.

When you click on OK, a dialog prompts you to specify the point in the sequence where you want to insert the image.

Append Image

Add an image to the end of the sequence. Using Append Image, you can add an image to a sequence from one of two sources:

Currently Open Document – Add an image from the currently open sequence file. Make sure to specify the Sequence Index.

File – Add an image from disk. If the image comes from a sequence file, make sure to specify the Sequence Index.

Remove Images

Remove an image or images from a sequence file. Removing an image deletes the image from the sequence, which is automatically reordered. Click on Remove Images and enter the number of the image(s) that you want to extract. To extract multiple images from a sequence, separate numbers with commas to skip over images and/or dashes to include the images in between the numbers – i.e., 5, 6, 7 or 5-7 or 1 – 5, 6, 9.

Move Images

Move an image or image(s) to a different point in the sequence. Click on Move Image and enter the number(s) of the image(s) that you want to move. To move multiple images from a sequence, separate numbers with commas to skip over images and/or dashes to include the images in between the numbers – i.e., 5, 6, 7 or 5-7 or 1 – 5, 6, 9.

Play Forward

Continuously play the image sequence forward.

Play Reverse

Continuously play the image sequence backward.

Stop Play/Resume Play

Stop play if the sequence is running and resume place when it is stopped.

Step Forward

Move forward one image.

Step Reverse

Move backward one image.
Image Sequence Controls

The Sequence Controls (Image Sequence) dialog enables you to play image sequences and to set the play options.

Image Index Number

Use the Image Index options to specify the view parameters of the sequence. This can be useful if you have a large image sequence with many frames (images) that do not have information you want to look at. For instance, consider you have a sequence file of 300 images, but only want to view the middle half of the images. In this case, you would set the value for First to 75 and the value for Last to 225. Then, when you play back the sequence only the images 75 through 225 will be shown.

First - Enter the number of the image that should be first in the sequence.

- Current – This field displays the number of the image you are currently viewing. Enter a new number to view a different image.

- Last – Enter the number of the image that should be last in the sequence

Play Options

The features under Play Options allow you to specify how the image sequence displays when playing.

- Interval – The time interval between each image when the sequence is playing. Enter a number in milliseconds or seconds. Alternatively, you can click the Compute from Seq… button to have the software compute an average interval from the sequence time and the image sequence will play back at this calculated interval.

Note: the Compute from Seq…button is only available if timestamp data is associated with the images and they are acquired from SPOT.

- At End – This entry sets the action that takes place when the sequence finishes playing. There are three options.

Stop

With Stop selected, the sequence stops at the last image in the sequence.

Restart

With Restart selected, the sequence begins playing again from the beginning. The sequence will only stop playing when the Stop button is pushed or selected from the Sequence Menu.

Reverse

Selecting Reverse will cause the sequence reverse play when it reaches the end.

Editing Images in a Sequence

Images from a sequential image file can be edited using the same Edit menu options as described earlier in this chapter. After you’ve made a selection from the Edit menu, the SPOT program allows you to specify the individual image or images (including the entire sequence) to which the edits are applied.
• For instance, if you are on image 1 of a sequence and you select Edit/Adjust Image. Once you make the changes desired and press OK, a dialog box will ask you if you would like to apply these changes to only the image that you are on, to all images in the sequence, or specific images within the sequence.

• Select one of the following options when prompted:

  **No Other Images** – The edit applies only to the current image – i.e., the on-screen image.

  **All Other Images in Sequence** – The edit applies to all of the images in the sequence.

  **Specified Image Sequence** – The edit applies to the images that you specify. Enter the number(s) of the image(s) in the box at the bottom of the dialog. To specify multiple images, separate numbers with commas and/or dashes - e.g., 5, 6, 7; or 5-7; or 1 – 5, 6, 9.
Chapter 5 - SPOT Basic Reporting

Using the SPOT Basic’s built-in reporting functionality, you can collect, organize, and present information related to your image captures. This chapter discusses the process of creating and printing reports. It is divided into the following sections:

- Creating a New Report – general overview of the interface changes while in Report mode
- Working in Report Mode – general reporting features and functionality
- Defining View Options – the view of the report definition screen
- Defining Report Attributes – the style and appearance of the report
- Defining Report Objects – the text, field, and image information that appears in the report
- Editing Report Objects – edit options for the report objects
- Saving a Report – outlines options for saving reports in SPOT
- Printing and Distributing Reports – overview of printing options for reports

Creating a New Report

To create a new SPOT report, select New Report from the File menu. The following changes take place in the main window:

- The report definition window appears as a separate window. If an image or image(s) were open, they remain open. When you move between an image window and the report definition window, the menu options change accordingly.
- The Object menu appears. Use these options to specify the fields, text, and images that appear in the report.
- The Attributes menu appears. Use these options to define the appearance and style of the report.
- The View menu options change to reflect report definition function.
- The Edit menu options change to reflect report-editing functions. These options are available only after one or more report objects have been added to the New Report window.

Working in Report Mode

The report mode contains functionality that differs from the image capture and editing functionality. The following is a brief overview of these features.

Cursor Functionality

- Cursor functionality in SPOT reports varies according to which Object menu option is selected.
- If None is selected, the cursor is an editing tool for selecting, sizing, and positioning objects. When creating new reports, None is the default option.
- If a report object is selected, the cursor changes to a cross-hair icon for placing new report objects to the grid.
Sizing and Positioning Report Objects

When sizing and positioning a report object in the report window, you must first select the object by single clicking on it. When an object has been selected, handles appear at the corners; for line objects, the handles appear at each end. You can select multiple report objects by holding the mouse button down and dragging the cursor around both objects. Handles appear around both objects. When selected, report objects can be sized or positioned as needed.

- To size objects, move the cursor either to a point on the object’s border or to one of the handles. The cursor changes to a two pointed arrow.

To resize one dimension of a box, position the cursor on a vertical or horizontal line; click and drag the side to the new size.

To proportionally resize a box, position the cursor on a handle; click and drag the box to the new size.

- To position objects, move the cursor over the selected object. The cursor changes to a four-point arrow. Click and drag the object to a new location. In addition, if an object is selected, you can use the arrow keys to fine-tune its position.

Note: When multiple objects are selected, they can be sized and positioned as a single object.

Using Right/Ctrl-click and Double-click Functionality

When creating a report, you can use the right-click and double-click mouse functions as editing shortcuts.

- Double clicking on a report object enables you to edit the object’s attributes – e.g., the thickness of a line.

- Right clicking (Windows)/[Ctrl] clicking (Mac) on a report object calls an object specific edit menu that contains both general editing options and attribute editing options specific to that object. Right clicking on an Image object, for example, gives you a list of editing options, as shown at right.

- Right clicking (Windows)/[Ctrl] clicking (Mac) on the report grid gives you three options: **Select All** objects, Paste an object that you copied or cut; or **Delete All** of the objects on the grid.

Refer to the Defining Report Attributes and Editing Report Objects sections for more details.

Defining View Options

The **View** menu provides you with nine options:
Zoom
Zoom in or out to six different sizes. From the View menu, select Zoom and enter the desired percentage.

First Page
Go to the first page in the report.

Previous Page
Go back one page in the report.

Next Page
Go forward one page in the report.

Last Page
Go to the last page in the report.

Set Display Grid Size
The report definition window includes an adjustable grid (i.e., the dots on the screen) to assist you in placing and aligning report objects on the report page. By default, the grid is turned on. To turn off or modify the grid, follow these steps:
1. From the View menu, select Set Display Grid Size.
2. To turn off the display grid, deselect the Show Grid box.
3. To modify the spacing, follow steps two through four.
4. Select either inches or millimeters.
5. Enter the spacing for the display grid. The number that you enter represents the space in inches or millimeters between the dots on the grid.
   - If the measurement is inches, enter a number between .04 and 10.
   - If the measurement is in millimeters, enter a number between 1 and 25.
6. Click on OK. The display grid appears.

Set Object Grid Size
In addition to the display grid, you can define a second grid specific to report objects. The object grid controls the movement of objects as you work with them on the display grid. When you select a report object and move it, the object automatically "snaps" to the nearest line in the object grid, allowing you to more precisely align and arrange the objects on your report page.
1. From the View menu, select Set Object Grid Size.
2. If desired, check the Snap to Grid option.
3. Define the spacing for the object grid. In many cases, the object grid and the display grid will have the same spacing. In other cases, you might not want the display grid to be as finely spaced as the object grid (i.e., so the dots do not interfere with the view of the report definition window).
4. If the measurement is inches, enter a number between .04 and 10.
If the measurement is in **millimeters**, enter a number between 1 and 25.

*The default spacing value for the Object Grid is the last entered value.*

Click on OK.

**Show Tools**

Click on the Show Tools option to display a floating palette of navigation buttons and report objects, as shown. Refer to the **Defining Report Objects** section of this chapter for more details.

**Full Screen**

This option allows you to use the entire screen to view a live image, without the SPOT menus/toolbar and the Windows navigation bar.

**Defining Report Attributes**

All of the general style and appearance options (report attributes) can be accessed from the **Attributes** menu. Report attributes can be defined for an entire report or on an object-by-object basis (see the Defining Report Objects section below).

- When a report object is selected, the attribute is defined for the selected object(s) only.
- When nothing is selected, the attribute is defined for all future, relevant objects.

The following sections detail each of the report attributes and the report objects that they affect. On all dialogs below, once a change has been made to an attribute setting, the **Save as Defaults** button is available if you would like re-set the Default attribute setting.

**Colors**

Define the foreground and background colors for all objects. Follow these steps:

1. From the Attributes menu, select Colors.

2. Define the **Text/Lines** color. This is the color of the text, the line, or the border around a text/image box. The default foreground color is black. To select a color click on Color.

3. The next window varies, depending on whether you are using a Windows or a Mac system. Windows allows you to select from a palette of colors or enter specific HSL or RGB color values. Mac OS allows you to select from a palette of colors, enter specific RGB, CMYK, HLS, or HSV values, and enter Internet specific colors.

   Define the **Background/Fill** color. This is the color that appears behind text and in boxes. Lines and images do not display a background color.
Line Thickness

Determine line thickness for the following report objects: Line, Horizontal Line, Vertical Line, Arrow, Box, Rounded Box, Ellipse, Freehand, Polygon, and Polyline.

1. From the Attributes menu, select Line Thickness.
2. Enter a Thickness value between .05 and 10 points.
3. Click on OK.

Image Border and Justification

Determine the line thickness for image borders and define the justification of the image within the display box. This option applies only to the Image report object.

1. To create a border around the image, click on the Border box, and enter a Thickness value between .05 and 10.
2. Select the Justification for the image. This value is the justification of the image within its display box, not the justification on the report page.
3. Click on OK.

Arrow Size and Direction

Specify the size of the arrow head and define the direction that the arrow points.

1. To specify the size of the arrow head, enter a value between 1 and 10.
2. Specify the direction of the arrow:
   - To draw an arrow starting tail first and finishing with the point (head), select Tail to Head.
   - To draw an arrow starting point (head) first and finishing with the tail, select Head to Tail.
3. Click on OK.

Box/Ellipse Fill

Define the appearance of the Box, Rounded Box, and Ellipse objects.

1. Specify whether you want a fill for the object.
   - If you do not want the box to be filled (i.e., you want a transparent box), click on OK.
   - If you want to specify a fill pattern for the box, check the Fill Box/Ellipse. The Pattern options appear.
2. Specify a pattern by clicking on one of the seven options.
3. Click on OK.

**Text Font**

Define the appearance of the text for the **Text**, **Date**, and **Time** objects.

1. Select a **Font**, a **Font Style**, and a point **Size**. The Sample box displays a preview of the font.
2. Define any Strikeout or Underline effects.
3. Click on OK.

**Text Border, Justification, and Background**

Define the appearance of the text boxes for the **Text**, **Date**, and **Time** objects.

1. Specify whether the text box should have a border. To add a border, click on the **Border** box, and enter a Thickness value between .05 and 10.
2. Define the **Justification** of the text. This justification applies to the position of the text in the box, not the position of the text on the page.
3. Define the Background. Select either **Transparent** or **Opaque**.
4. Click on OK.

**Title**

Define the criteria for the titles of the files saved.

1. Specify whether the titles should include the path and/or the file name extension
2. Click on OK.

**Time**

Define the Time units associated with an object.

1. Specify whether the units should be indicated in seconds or milliseconds.
2. Click on OK.
Defining Report Objects

All of the components of your report, including the formatting, text, images, and fields are known as objects. Using the objects, you can specify the information that your report will contain. Before discussing the individual report objects, review the following general procedure for inserting an object into a report:

From the Object menu, select the type of item (i.e., Lines, Connected Lines, etc…) that you want to add to the image. The cursor's functionality varies according to whether a report object type (i.e., line, text) is selected.

If a report object type is selected, the cursor changes to a cross-hair icon that is used to add new report objects to the grid.

If None is selected, the cursor is an editing tool that is used to select and position objects. Use the mouse to drag the cross hair to the location where you want to insert the object.

Left-click at the insertion point.

If you selected a line or a box, hold down the mouse button and drag the line/box to the desired size.

If you selected any of the other report objects, the object will appear and you will be prompted to enter the associated information (e.g., static text, the location of an image file, the database field, etc…).

Once it appears on screen, you can resize, reposition, and edit an object as needed.

Resize - Select (click on) the object and drag the handles in the direction of the resize.

Reposition – Left click and drag the object to the new area.

Edit – Select the object and choose an option from either the Edit menu or the Attributes menu. You can also edit an object by right clicking (Windows)/ [Ctrl] clicking (Mac) on it.

The following section describes the Basic application’s report objects:

None

Select **None** when you want to use the cursor to edit and position the objects.

Lines

**Unconstrained Line**

Add a straight-line annotation to the report.

**Horizontal Line**

Add a horizontal line annotation to the report.

**Vertical Line**

Add a vertical line annotation to the report.

**Arrow**

Add an arrow to the report. Either select Arrow from the Object menu, or click on the Tools box button. Left click on the report and drag toward the area that the arrowhead will point to.
Connected Lines

**Polygon**
Add a closed polygon to the report. Either select Connected Lines>Polygon from the Object menu, or click on the Tools box button. Left click and release, and then drag the mouse to create a side. Left click again to start a new side. Double click to finish the polygon. The program automatically adds any additional lines needed to close the figure.

**Polyline**
Add an open polygon to the report. Either select Connected Lines>Polyline from the Object menu, or click on the Tools box button. Left click and release, and then drag the mouse to create a side. Left click again to start a new side. Double click to finish the polyline.

**Freehand**
Add a freehand line to the report.

Shapes

**Rectangular Box**
Add a square cornered box to the report.

**Rounded Box**
Add a round cornered box to the report.

**Ellipse**
Add an elliptical object to the report. Ellipses are drawn inside of the rectangular area that you define. Ellipses touch the top, bottom, right and left sides of this rectangle.

Either select Shapes>Ellipse from the Object menu, or click on the Tools box button. To draw an ellipse, left click at the point where you want to position one vertex of the rectangle and drag the cursor to the point of the opposite vertex.

**Circle**
Add a circle to the report.

Image
Add an image to the report.
1. From the Object menu, select Image.
2. Left click at the point on the display grid where you want to insert the Image box, and holding down the mouse button, drag the cursor to create the desired shape and size for the image (it can also be resized/re-positioned at a later point). When you release the mouse button, the Image dialog box appears.
3. Specify the file source for the image:
   - **Currently Open Image** – Add a currently open image to the report. If you have one or more open images, SPOT lists the file name(s) and path(s) in the drop-down box. Select from the list.
Image File – Add an image from disk to the report. Specify the file name and location either by entering the path in the Name box, or clicking on the selection box to the right.

4. Click on OK. The image appears on your report grid.

Text
There are a few Text object options available:

Text
Add text to the report.

Date
Add a date text box to the report. The current date is the default.

Time
Add a time text box to the report. The current time is the default.

Current User Name
Add a user name to the report. The user currently logged on to the computer appears as the default.

Image User Name
Add the name of the person who was logged on when the report image was captured.

Editing Report Objects
Once you have created a report, you can edit the report objects as needed. There are three basic ways to edit a report object:

• Use the Attributes menu - The Attributes menu, as noted in the Defining Report Attributes section of this chapter, allows you to either set the attributes for adding specific types of objects, or to select existing objects and modify them as needed. Refer to the Defining Report Attributes section (above) for more details.

• Use the Edit menu - The Edit menu contains general editing features such as Undo, Copy, Cut, Send to Back, etc…

• Right-click (Windows)/[Ctrl] click (Mac) on the report object – Right/[Ctrl] clicking on a report object brings up a customized editing menu that contains both general editing commands and the attributes that can be edited for that object. Refer to the Working in the Report Mode section for more information on the right click function.

The Edit Menu
The Edit menu provides general editing features for arranging, copying, and sizing report objects. Edit menu options are active only when a report object is selected.

Undo
Undo the last action. The Undo feature allows you to undo up to ten actions.

Bring to Front
Bring a selected object in front of all other objects.
Move Forward
Bring a selected object one layer forward.

Move Backward
Send the selected object one layer back.

Send to Back
Send a selected object behind all other objects.

Select All
Select all of the object in the report.

Delete
Delete the selected object(s).

Delete All
Delete all of the objects in the report.

Copy to Clipboard
Copy the selected object(s) to the Windows clipboard. You can then paste the object(s) into:

- A new SPOT report
- A different location in the same report

This feature is particularly useful when you are creating a new report and want to use objects from an existing report.

Cut
Cut the selected object(s) for pasting into a new report or to a new location in the existing report.

Paste
Paste the object that you cut or copied to its new location.

Duplicate
Create additional copies of a report object. To duplicate a report object, follow these steps:
1. Select the object(s) that you want to duplicate.
2. Select Duplicate from the Edit menu. The program prompts you to enter the number of duplicate copies.
3. Enter the number of copies, and click on OK.
4. The duplicate object(s) appear at the top of report window.

Set Position, Alignment, and Size
The Set Position, Alignment, and Size option allows you to specify precise sizing and position values for single or multiple selected report and annotation objects.

The Position options enable you to:

- Align top/bottom edges of multiple objects.
• Align left/right edges of multiple objects.
• Align the centers of multiple objects.
• Center an object(s) on the page.
• Enter exact values in inches or millimeters to position the object.

The *Size* options enable you to enter:
• Exact width/height in inches or millimeters for one or more objects.
• Set the width/height dimension for multiple objects the to smallest or largest object’s value in inches or millimeters.

### Add Page

Add a page to your report. When you add a page, the program prompts you with the Add Page dialog box:

1. Specify whether the page that you want to add will be inserted Before or After a specified page.
2. Specify the Page Number that the additional page will precede or follow.
3. Click on OK.

SPOT reports can have a maximum of ten pages.

### Delete Page

Delete a page from your report. When you select the Delete Page option, the program prompts you to specify the page number.

### Add images

Add a static image to your report.

### Saving Reports

To save a newly created report, follow these steps:

1. Select the **Save** option from the File menu.
2. When saving a new report (.rpb file type), SPOT prompts you with the default file location – i.e., *C:SpotCam\Reports* folder (Windows) or *Users\Shared\SPOT Files\Reports* (Mac). Either save to the default location or specify a new location. If you plan to save many reports without compressing the image files, you may want to consider saving them to an external hard drive or network drive.

*Note: Mac users will see the .rpb file type extension only if the Add Extensions to File Names on Save option is selected on the Preferences window.*
3. Enter a file name for the report.
4. Define the Compression for the image(s) in the report by selecting from None, JPEG and JPEG 2000. The **JPEG 2000 Compression** box is checked as a default. If you are using JPEG 2000 Compression, select either lossless or lossy from the checkbox associated with JPEG 2000. A value of from 1 to 1000 must be entered in the value box is lossy is selected.
5. To turn on JPEG compression, select that box. If you are using JPEG Compression, enter a number between one and 100. A value of 1 is the most compressed. File size and image resolution are decreased to the maximum extent. A value of 100 is non-compressed. File size remains large and the image resolution remains high.
6. Click on Save. You can now use the SPOT program to open and view the report at a later time.

**Printing and Distributing Reports**

To print a report, follow these steps:

1. Open the report.
2. Select the printer. If you have Adobe Acrobat, you can create a PDF version of your report by selecting *Acrobat PDF Writer* as the printer of choice: select the Printer from the **Page Setup** dialog – i.e., File>Printer Setup>Printer. PDF files can be distributed to anyone with the Acrobat Reader software, which, as described below, is available from Adobe as a free download.
3. Click on Properties to define the printer’s properties, if needed.
4. Specify the page range if you are not printing an entire report.
5. Specify the number of copies.
6. Click on OK.

If you intend to distribute SPOT image reports to people who do not have the SPOT program, we recommend that you purchase Adobe Acrobat. Using Acrobat, you can convert the SPOT report (.rpb) files to PDF files, which can be distributed to users who do not have the SPOT software. They can view the reports with the free Acrobat Reader software, which is included on the SPOT software CD. The latest version of the Acrobat Reader can also be downloaded from the Adobe’s web site [www.Adobe.com](http://www.Adobe.com).
Chapter 6 - SPOT Basic Image Printing

Introduction

The SPOT Basic application offers a simple interface for printing one or multiple images. Please note: some of the Printer options are dependent on your own printer, so those areas will be more general. The SPOT Basic application’s options will be explained in detail.

Example Printing Workflow:

1. To begin Printing from SPOT Basic, select Print from the File Menu or click on the Print icon on the toolbar.

The Print Layout Editor will appear with access to your printer’s preferences and the page layout.

2. Click on Setup to access general page layout options such as margins, units of measure, and paper orientation and size.
3. Arrange single or multiple images in the Print Layout Editor. This section will be explained in detail in the following sections.

4. Click the Print button to access your printer’s print settings. Click on the Printer’s Print dialog Print button to finish printing your images.

Print Layout Editor – Printing Single or Multiple Image Files

The SPOT Basic application offers the Print Layout Editor shown here for customizing the way your images will print.

To print images from the SPOT software, follow these steps, either select Print from the File menu, or click on the Print toolbar button.

The Print Layout Editor appears with a preview of the active image and the print canvas. The following sections are available for scripting the print canvas.

Layout

Under the layout section, the Printable Area is displayed and the following buttons are available:

Setup

The Setup button allows access to general page layout options such as margins, units of measure, and paper orientation and size as shown above.
Add

In the Print Layout Editor, you can print multiple images on one print canvas. Use the Add button to add more images to the canvas. There are two ways you can select images to add:

Currently Open Image
Add one or all of the currently open images. Select either the desired image or <All Images> from the Title drop-down list. Ensure that you enter the Sequence Index (i.e., the number of the image in the sequence) if you are adding an image from a sequence file.

File
Add a file from disk. Check the Image File option, and click on the square next to the box. Browse for the desired image, and click on Select. Ensure that you enter the Sequence Index (i.e., the number of the image in the sequence) if you are adding an image from a sequence file.

Auto-Arrange Images
If you check the Auto-Arrange Images box, the SPOT program automatically sizes and positions the images to fit on the print page, so you can add multiple images without having to resize them. For example, if you add five images, the preview will show six images (the original and five added) of equal size, distributed proportionally across the page.

If you did not use the Auto-Arrange Images option, the images will be stacked on top of each other for you to arrange. See below for arrangement options.

Click on the OK button to add the images to the print page and return to the Print window. The images appear in the preview box.

Remove

The Remove button allows you to remove an image from the printing canvas. When you click on it, the topmost image (highlighted in green) will be removed from the printing canvas.

Arrange

The arrange button allows you to set the arrangement of multiple images on a print canvas. When you click on the Arrange button, the Arrange Images dialog appears.

The Arrangement section allows you to select the number of row(s) and column(s) you would like for your print document.

The Spacing section allows you to enter a value for the spacing between the images on the printout in inches or millimeters.

Select Apply to all Pages to make the arrangement applicable to every page. This feature is only available when printing an image sequence which falls on more than one page of the print document. See below for more information on printing image sequences.

Top Image

The Top Image section has controls which dictate the placement and appearance of the topmost image. The topmost image is outlined in green. This can be very useful when printing multiple images on the same print canvas.
Image Position and Size Controls

Left
The value in the Left entry sets the distance between the left side of the printable area and the left side of the image. Use the up and down arrows or you can type in a value.

Top
The value in the Top entry sets the distance between the top of the printable area and the top of the image. Use the up and down arrows or you can type in a value.

Alternatively instead of typing in the values for image position, you can position the cursor on the image. The cursor will appear as a four pointed arrow and you can then left-click and drag the image to the desired location.

Width
The width of the image can be adjusted by changing the value in the Width entry. Use the up and down arrows or you can type in a value.

Height
The height of the image can be adjusted by changing the value in the Height entry. Use the up and down arrows or you can type in a value.

Alternatively to typing in values for the image size, you can position your cursor on a side or a corner of the image. The cursor turns into a two-ended arrow. Use the two-ended arrow cursor to drag a side or corner to enlarge or reduce the image. The resized image maintains the height to width ratio of the original image.

Note: The aspect ratio of the image will be maintained whether you adjust the Width or the Height of the image.

Note: If you select values that are outside the printable range of the paper, the values will be displayed in red font.

Image Appearance Controls

Show Annotations, Calibration Marks, Measurements and Reticles
In SPOT, any annotations, calibration marks, measurements and/or reticles are saved in separate layers which can be turned on and off for viewing and here, for printing. This option will be available unless the annotations, calibration marks, measurements and/or reticles have been merged into the image. Each layer can be turned on or off for printing individually. Check the appropriate box to have the layer print, or uncheck the appropriate box to not print the layer. If you do not have an annotation, calibration mark, measurement or reticle on the image, these check boxes will all be inactive.
Print Layout Editor – Printing Sequential Image Files

Printing images from a sequential image file is very similar to printing individual or multiple image files. See the above section for shared features.

When you select the **Print** option for a sequential image file, the program prompts you to specify the image(s) in the sequence that you want to print. There are two options:

- **All Images in Sequence**  
  Use this option to add all images from the sequential image file to the printing document.

- **Specified Images**  
  Use the option for Specified Images to select either a single image or multiple images from the sequential image file. Separate multiple images with commas and/or dashes – e.g., 1, 2, 3; 1-3; or 1, 2, 3-6.

- After your selection is complete, click the Ok button and the program will prompt you to specify how many images to print on each page. Make your selection and click OK to return to the Print Layout Editor to arrange the images if necessary.

- When back in the Print Layout Editor, if multiple pages have been created, use the pull down menu to move between pages of the print document.

- Click on Print when you are ready to print your document.

Print Controls

**Close Window After Printing**

If you would like the Print Dialog Editor to remain open for other printing jobs within SPOT, uncheck the box to **Close Window After Printing**.

**Print**

Click on the **Print** button and your printer’s normal Print Dialog should appear with additional settings for printing, such as print quality and Color options.

Click on the appropriate buttons (Ok and/or Print) to send the information to the printer.
Close
Click the Close button to close the Print Layout Editor. This will be necessary when you are done printing images and you have not selected the Close Window After Printing option (above).

Help
Click on the Help button to open the Help files relating to Printing.
SECTION III –
THE SPOT ADVANCED APPLICATION

Chapter 1- Introduction

Introduction: Using the SPOT Advanced Application

The SPOT Advanced Application is an enhanced and expandable version of the SPOT software. It is designed for more advanced users who want greater control over the way images are captured and edited, and who want to make use of the image archiving database, the report generator, and the calibration mark imprinting and measuring functions. Additionally, it includes macro scripting which allows the user to automate image capture and post-processing procedures. Furthermore, a Taskbar feature allows the user to customize an onscreen taskbar with one touch initiation of virtually any function found in the SPOT Advanced Software program. The optional add-on Modules offer additional functionality for users who are doing Quantitative Imaging, Extended Depth of Focus, Peripheral Device Control, or who need Extended TWAIN support. See Section V for more information about the optional SPOT Software Modules.

This chapter is an introduction to the operating environment of the SPOT Advanced application. Detailed discussions of the each feature of this application are found in the rest of the chapters within this section. This introduction chapter is divided into three sections:

• Opening the SPOT Advanced Application

• The SPOT Advanced Application Overview

• Typical Imaging Process

Opening SPOT Advanced

1. Double-click on the SPOT icon on your desktop.

2. If you have enabled the SPOT Users that SPOT is handling, you will need to select your user name from the list and provide the password. See more about this option in Chapter 2's Setup Menu Section.

3. Since you have installed the SPOT Advanced application, you will be presented with an interface selection dialog upon the first launch of the application. Select the icon for SPOT Advanced.

4. The SPOT Advanced application will open and be ready for imaging needs.

Note: If you check the box to Do Not Ask Me Again, the SPOT Advanced application will automatically open at step 1 above. See more about this preference in Ch. 2 – SPOT Advanced Image Setups, Live Image Controls and the Setup Menu.
The SPOT Advanced Application Overview

Once the connection has been established with the SPOT Camera, click on the Live Image button on the toolbar and the Live Image Controls button on the Live Image Display Window. The interface can be arranged to look similar to that below. Each of the areas of the interface will be described in further detail in the subsequent chapters.
The Viewing and Editing Window

When you open or capture an image, it appears in the main viewing and editing window. All of the image save, view, edit, and annotation functions are accessed from this window, which consists of three areas:

- The Menu Bar
- The Toolbar
- The Status Bar

The Menu Bar

The menu bar in the Advanced application varies according to whether an image is open or not. The section below briefly describes each menu, indicates whether an image must be open in order to see it, and provides a reference to the chapter that discusses the menu options in more detail:

If you have not yet either captured a new image or opened an existing image, the following menus are available:

File, Database, Camera, Setup, Macro, and Help

If you have either captured a new image or opened an existing image, the following menus are available:

File, Database, Edit, Sequence (if an image sequence file is open), View, Camera, Setup, Macro, Window, and Help

- The File menu contains file open and save options, which for the most part, are identical to the standard file open and save options. Refer to Opening and Saving Files (below) for details. In addition, the File menu contains the report creation and viewing options. Refer to Chapter 9 – SPOT Advanced Reporting for more details.
- The Database menu allows you to create, access, and modify SPOT image databases. See Chapter 8 – SPOT Advanced Databases for additional details on Databases.
- The Edit menu contains image-editing options. Additional details can be found in Chapter 4 – SPOT Advanced Viewing and Editing Image Documents.
- The Sequence menu offers viewing and play options for image sequences. See Chapter 4 – SPOT Advanced Viewing and Editing Image Documents for more on working with image sequences.
- The View menu contains different options for viewing captured images. Refer to Chapter 4 – SPOT Advanced Viewing and Editing Image Documents for details. View selections are limited to “Full Screen” when an image has not yet been captured.
- The Camera menu contains initialization, image capture, white balance, flatfield correction, and live imaging options. Refer to Chapter 3 – SPOT Advanced Image Captures and the Camera Menu for additional details.
- The Setup menu contains options used to define operating preferences. Refer to Chapter 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu for details.
- The Macro menu allows you to easily create, edit, and play automated image acquisition routines. See Chapter 6 – SPOT Advanced Macros and Variables for additional details on macro scripting.
• The **Window** menu contains standard Windows display options. Refer to Chapter 4 – SPOT Advanced Viewing and Editing Images Documents for details.

• The **Help** menu contains information about the SPOT software and enables you to access the on-line help system.

**The Toolbar**

The Toolbar appears underneath the Menu Bar and contains all of the image capture, editing, and annotation functions in the SPOT Advanced application. When you first open the program, the toolbar displays only the image capture options. Once an image is captured, the additional editing, viewing, and save icons will be displayed. Additionally, the database options are only available if a database has been created.

The following diagram illustrates the Advanced application’s Toolbar, as it appears for an open image:

Refer to Appendix C: Keyboard and Toolbar Button Commands for a complete listing of command equivalents in the SPOT program.

---

**Note:** If you are using a monochrome camera, or are using the monochrome position of a slider camera, the **Compute White Balance Values** option is inactive.

---

**Note:** When the camera is on, but no image has been captured or loaded from an image file, only a limited number of toolbar icons will be functional.

**Likewise, when the camera is off or not connected, only a limited number of toolbar icons will be available and functional.**

Refer to the following chapters for more details on each of these toolbar functions.
The Status Bar

The status bar, which appears at the bottom of your screen, displays information about the image that is on screen. The following is an illustration of the view status bar, as it appears for an open image:

| Auto-Save ON | -21.7C | 2048x2048 24bpp | [865,545] | 162,95,73 | Fit to Win | Modified |

Note: The status bar displays values for captured images, not for live images.

Each of the sections is described below.

- **Auto-Save ON** – If Auto-Save is enabled in the Image Setup, Auto-Save ON will be displayed. If Auto-Save is not enabled the first section of the status bar will be empty.

- **Temperature** – The current temperature of the CCD. This value will only be displayed when using an Xplorer or Pursuit camera.

- **Image size** – The number of columns by the number of rows of pixels in the image.

- **Pixel bit depth (bits per pixel - bpp)** - The pixel bit depth at which the image was captured. This value reflects the pixel bit depth for the image setup that was used to capture the image. For a detailed discussion of pixel bit depth, refer to Chapter 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu.

- **X, Y pixel coordinates** - As you move your cursor over an image, the status bar displays the x, y coordinates of the cursor in pixels. For example, the values for the upper left corner pixel would be (0, 0).

- **Brightness values** - As you move your cursor over an image, the status bar indicates the pixel brightness values at the indicated x, y pixel coordinates. The values depend on the pixel bit depth (see Chapter 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu) for the image. For example, if a color image is open, the status bar displays separate red, green, and blue brightness values [e.g., (226, 193, 174)]. If a monochrome image is open, the status bar displays only one brightness value [e.g., (176)].

- **Size Settings** - In the illustration above, the view status bar displays **Fit to Win** (Fit to Window), the default image capture setting.

  If the Fit to Window option has been deselected, this area displays the word Normal. If you are in zoom mode, this area displays the magnification level (e.g., 100%, 200%…)

- **Modified Status** - If you open an image file or take a picture, the section to the right of the magnification setting will read **New** until you modify that image. Once that image has been modified, the word **Modified** appears here. Use the Undo command to return to the **New** state.

- **Image Setup** - The far right end of the view status bar displays the currently active Image Setup (e.g., Untitled). This is the image setup that the program uses to capture images. From this part of the view status bar, you can:
  - Change the currently active image setup.
  - Modify an existing image setup.
  - Add a new image setup to the list.
Refer to Chapter 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu, for more information on image setups.

**Typical Image Acquisition Process**

1. Open SPOT Advanced either from the desktop icon, or the application selection dialog.
2. Open the Live Image and Live Image Controls.
3. Select or create an Image Setup.
4. Adjust the focus and frame the specimen.
5. Adjust the image appearance using the Image Settings’ tabbed controls.
6. Acquire images.
7. View, Edit and Annotate your images and Save them.

The following chapters will explain in detail the functionality of each of the controls and displays encountered in the SPOT Advanced application.
Chapter 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu

The SPOT Advanced application provides many useful and powerful features for capturing your images and customizing the interface to suit your needs. There are Image Setups, Calibrations, Reticles, Palettes, Taskbars, Custom Variables, and Preferences available for you to make SPOT your very own. All of these features are available from the Setup Menu and are discussed in further detail below or in later chapters.

Image Setups and Live Image Controls

Image Setups and the Live Image Controls are closely related in the SPOT Advanced application. The Live Image Controls affect the way the Live Image looks, while the Image Setup dictates how the Captured Image will look.

For most users, you will most likely enhancing and/or adjusting your images from the Live Image Controls and have all of your settings linked to the accompanying Image Setup, resulting in your captured image being the same as your Live image. For some, you may need to have some disparity in your Live vs Captured Images and this is where the Link/Unlink options become useful. Some fluorescence applications may benefit from the option to Unlink your Live Image from your captured image. For instance, if you have a fast fading specimen, you may want to have certain features turned on or up higher for your Live Image to accommodate faster live image display (sometimes at the expense of resolution or image quality) while you frame, focus and scan your specimen. You would then want different settings to obtain the best quality and highest resolution image for your captured image. This is one situation when the Unlink options become useful. See example screenshots of this type of scenario below.
If you want your Live Image to be the same as your Captured Image, you will most likely use the Live Image Controls as they are the central place for adjusting your image. If you need to have different settings for your Live Image vs. Captured Image, you will likely utilize both the Live Image Controls and the Image Setups.

This section will begin with the Image Setups as it is a more comprehensive list of all features available. The Live Image Controls will then be discussed and how they relate when the Link option is activated or deactivated.

Image Setups

Introduction: What is an Image Setup?

An image setup serves two crucial purposes:

- It defines the way a picture will be taken.
- It defines the way a picture will be modified after it is taken.

Image setups are defined to optimize the picture taking process for different types of images or microscopy techniques. They can be created, saved, and recalled as needed.

Accessing the Image Setup Window

To define a new image setup or to edit an existing setup, follow these steps:

From the Setup menu, select the Image Setups option. The Image Setups window appears.

Either double-click on a setup to open it, or select one of the following options:

Add - To create a new image setup, click on Add. The New Image Setup dialog box appears with a list of templates (image types) that serve as the basis for the new image setup. Additionally, when a captured image is open, you may select the option of creating an image set-up from that which was used to capture the open image, saving significant time.

When you select the Add option the New Image Setup window appears with a few options for creating your new Image Setup.

You may choose one of three ways options for creating a new image setup. You can choose to Base the New Setup On a (an):

Template
Use a predefined template. The pre-defined templates (referred to as 'image types' within the Image Setup dialog – see below) are indicated by brackets < >. The 11 pre-defined image types (14 for Slider cameras) correspond to commonly used microscopy techniques.

To define a new image setup using this method, you must select an image type as a template for defining the new setup. The image type provides a baseline set of values for that setup, according to the microscopy technique you are using. The following section describes SPOT’s pre-defined image types.

- Brightfield-Transmitted Light
  Stained specimens on glass slides using transmitted light microscopes.

- Darkfield-Transmitted Light
  Bright specimens on dark backgrounds using transmitted light darkfield technique.
• Fluorescence
  Fluorescence specimens not fluorescing in a single red, green, or blue primary color. The camera exposes images using all three colors.

• Fluorescence – red (Slider cameras only)
  Fluorescence specimens fluorescing in red. Exposure time is reduced because only one color is exposed.

• Fluorescence – green (Slider cameras only)
  Fluorescence specimens fluorescing in green. Exposure time is reduced because only one color is exposed.

• Fluorescence – blue (Slider cameras only)
  Fluorescence specimens fluorescing in blue. Exposure time is reduced because only one color is exposed.

• Nomarski DIC/Hoffman
  Specimens being viewed using Nomarski DIC or Hoffman techniques.

• Phase Contrast
  Specimens being viewed using the phase contrast technique.

• Polarized Light
  Specimens being viewed with a polarized light microscope.

• Bright-field-Reflected Light
  Polished metallurgical specimens and semi-conductors using a microscope with a vertical illuminator.

• Dark-field Reflected Light
  Bright areas of specimens being viewed with darkfield, reflected light techniques.

• Stereo/Macro-No Glints
  Matte specimens without bright glints.

• Stereo/Macro-Shiny Glints
  Shiny specimens with bright glints.

• Stereo/Macro-Metallic Glints
  Metallic specimens with intense glints.

Existing Setup
Use a setup that has been previously created. The Image Setup dialog will appear for modifications.

Open Image
Use the setup from an image that has been previously captured and is currently open in the SPOT Advanced program. If more than one image is open, you must select from a list.

All of the above methods of creating a new Image Setup will open the Image Setup dialog for modifications. See below for details on the Image Setup features.

Modify
To edit an existing image setup, select a setup from the list, and click on Modify. The Image Setup dialog appears.

Delete
To delete an image setup, select a setup from the list and click on Delete.
Current
To make a setup the active setup, select the setup from the list and click on Current.

Import and Export
The SPOT Software’s Import and Export feature allows the user to transfer and create backups of many of their personalized settings. Refer to Section I, Ch. 4 – Custom Configuration to learn what SPOT offers as importable features.

To import an image setup, select Import and select a file of type SPOT Export (spx).

To export an image setup, select the image setup and click on Export. Select a location and file name and click Save.

Close
To exit the dialog box, click on Close.

Note: Current Image Setups are stored for each SPOT camera that you use with your SPOT software. Therefore, the Image Setup will change when you move from selecting one SPOT camera to another.

The drop down box in the bottom right (PC), or top right (Mac), corner of your screen displays the current image setup being used. This drop down box allows you to:

- Quickly change from one Image Setup to another from this drop down box by left-clicking on the drop down box and selecting a different Image Setup.
- Add a new Image Setup by right-clicking on the drop down box and selecting Add.
- Easily access the Image Setup dialog for modifications by right-clicking the drop down box and selecting Modify.

Alternatively, use the F12 key on your keyboard to open the current Image Setup dialog box for modifications. On a Mac use ⌘ + F12 to access the Image Setup dialog.

Note: Right-click options on the image setup drop down box should be available on the Mac by using the Option or ⌘ (Command) key.

The Image Setup Dialog
The Image Setup dialog consists of several options, each with a different window pane. Each window pane has a menu on the left that allows you to navigate to any of the window panes. The right side of the dialog includes options specific to that menu topic. The menu topics and features on the window panes depend on the camera model being used.

General
You will note that the header provides a consistent reminder of the following information, no matter which of the windows you are in.

- Name
- Locked
- Acquired Image
  - Bit Depth
Section III – Ch. 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu

- Color / Monochrome

Name

Use this box to enter the name of a new image setup, or to modify the name of an existing setup. If you modify the name of an existing setup, the program prompts you (when you click OK) to save this as a new setup or overwrite the original setup.

Locked

The Locked option allows you to freeze the settings for an Image Setup that you have defined. This is useful in cases where multiple users have access to the program and you want to preserve the settings that you defined.

To lock an Image Setup, click on the Locked box. When another user opens the Image Setup, the settings are unavailable for entry until the Locked box is unchecked. The Locked box, along with the appearance of the window, serves as a message that the settings should not be modified.

Acquired Image

The Acquired Image section options enable you to define the characteristics of captured images. This includes Bit Depth - Bits per Pixel

Bit Depth

Bit Depth is the number of bits per pixel (bpp) that the camera uses to create an image. The SPOT program provides different options, depending on which camera model you are using.

Select a Pixel Bit Depth by clicking on the Bit Depth drop-down box.

- **8 Bits per Channel** –
  With monochrome cameras, captured images are 8 bits per pixel monochrome providing 256 levels of grayscale. With color cameras, captured images are 24 bits per pixel RGB color providing 16.58 million color representations. This option results in smaller, more manageable image sizes, and is best for images that do not require extensive modification.

- **10 Bits per Channel** –
  With monochrome cameras, captured images are 10 bits per pixel monochrome providing 1024 levels of grayscale. With color cameras, captured images are 30 bits per pixel RGB color providing 10.7 billion color representations. This option results in smaller, more manageable image sizes, and is best for images that do not require extensive modification.

- **12 Bits per Channel** –
  With monochrome cameras, captured images are 12 bits per pixel monochrome providing 4096 levels of grayscale. With color cameras, captured images are 36 bits per pixel RGB color providing 68.6 billion color representations. This option reduces banding problems that can result with modified images, but also results in larger file sizes. When saving 12 bit per channel images, SPOT prompts you to select either 12 bits per channel or 16 bits per channel. If you use Adobe's Photoshop for image editing, you should select the 16 bit per channel option because Photoshop cannot read 12 bit per channel images.

- **14 Bits per Channel** –
  With monochrome cameras, captured images are 14 bits per pixel monochrome providing 16,384 levels of grayscale. With color cameras, captured images are 42 bits per pixel RGB color providing 4.4 trillion color representations. This option further reduces banding problems that can result with modified images, but also results in even larger file sizes.

See Ch. 4 – SPOT Advanced Viewing and Editing Image Documents for the image file format options available depending on the bit depth of the image.
Color/Monochrome – (available on 3-shot and slider cameras only)

3-shot and slider cameras are able to capture either color or monochrome images by using this feature. The Color/Monochrome setting changes the functionality of the color filter on the camera.

The selection of Color or Monochrome here will change the Filter options listed under the Exposure Window (Below).

Note: Slider cameras: If you select Color or Monochrome, the software does not change the position of the filter: this must be done by physically sliding the filter of the camera to the desired position. See the Preferences section of this chapter for tips on setting helpful hints about the camera’s slider position.

Exposure

The Exposure selections tell the camera what settings to use when taking a picture. Carefully considered definition of these settings helps to ensure that your images come out as planned. The Exposure options vary according to two variables:

- The camera model that you have
- The Bit Depth setting

Each Exposure option is described below. If an option is unique to a specific camera, this is indicated parenthetically.

Use Live Image Values

When you select this checkbox, the image settings for image acquisition will mimic the settings you have set in the Live Image Controls window of the Live Image Viewing Window. Note that other image setting options are “grayed out” (made nonfunctional) when this checkbox is selected.

Note: When you select “Use Live Image Controls” in any of the exposure windows (Exposure, Auto-Exposure, or Manual Exposure), the other exposure windows are adjusted accordingly.

Type

In addition to using the Live Image settings to capture an image, you can specify either automatic exposure adjustment or manual exposure adjustment in the Exposure window. The selection you make between Auto and Manual will then allow you to make subsequent setting choices in the subordinate window panes (below).
Note: If you prefer to utilize Auto or Manual Exposure types, you may select that type in the Exposure Window or its respective subordinate window. You then define the settings for either selection in the Auto-Exposure or Manual Exposure subordinate windows.

Auto
When you select Auto the camera samples light levels in the image plane (as the initial part of the image capture) and uses the values to calculate the final exposure time.

Manual
When you select Manual, you specify the exposure times. This can be done either by entering a value or values, using the Compute Exposure option, or by the Recall Previous Exposure option (see Ch. 3 – SPOT Advanced Image Captures and the Camera Menu for more information on the Compute Exposure and Recall Previous Exposure features).

The sections that follow detail all of the Exposure options. If an option is available only for specific camera models, only at certain pixel bit depths, or only for either automated or user-defined exposure, this is indicated next to the heading.

Binning
Binning is a pre-exposure option that tells the camera to combine adjacent pixels on the CCD chip. The camera treats each set of combined pixels as one large pixel. The large pixels accumulate electrons faster and are therefore more sensitive to light. Binning has three effects on image processing:

- Light sensitivity is increased.
- Download time is decreased.
- Resolution is decreased.

Binning is particularly helpful when you want to drastically reduce exposure and download times for dim images and you don’t mind a decreased resolution. This gives you higher frame rates and less noisy images. The SPOT camera offers different binning options depending on the model of the camera.

Note: If you bin with a color mosaic camera, the color information will be collapsed and the image will appear monochrome.

Filter Color and Order (available only when Color is selected above)
SPOT Slider and 3-shot cameras use a liquid crystal filter to capture the red, green, and blue data for each pixel. For a color image, you can select between using all three colors, or combinations of only two of the colors. Most color imaging will be best suited by using all three colors of the color filter. However, there may be situations where not all colors are present in the sample and using fewer colors may help shorten the exposure time.

Additionally, you can designate which order the color filter should cycle, thus affecting which color data is acquired first, second and last. This can be useful when you are using a 3-shot camera for fluorescence work and you have a quenching sample with two or more fluorophores. If one fluorophore is brighter than the other, i.e. if the DAPI stain is brighter than Texas Red, you may want to use the Blue state of the color filter before the Red state of the color filter so that you get the best images with the shortest exposure times. In this case, select the drop down choice of BR to expose the blue state of the filter first, followed by the red state.
To ensure a high image quality, SPOT users should select the color that is closest to the color of the specimen. For example, if you are looking at a single stained fluorescent sample, selecting the color filter that most closely matches the color of the stain shortens the time it takes to acquire the image.

**Note:** If you have a slider camera and are using single-pass fluorescence cubes, you should not use the color filter for your fluorescence work. You should use the Monochrome setting and uncheck the option to Use Filter in order to use the monochrome state of the camera. The color filter absorbs a considerable amount of light before it can reach the imaging sensor. Typically, when imaging a fluorescent sample you want as much of the light to reach the imaging sensor as possible. In these cases, the slider is moved into the B/W (black/white, or monochrome) position.

### Use Filter (only available when monochrome, above, is selected on a slider camera)

The option to Use Filter is only available when a slider camera is being used and the selection of Monochrome has been made, above. While using the color filter in a monochrome setting, you can only select one color filter state; either Red, Green, Blue, or Clear. The Clear mode is only available on certain camera models.

The **Use Filter** option does not change the position of the filter; this must be done by physically sliding the camera’s filter to the Color position. See the Preferences section of this Chapter (below) for tips on setting helpful hints about the slider position.

Uncheck the option to **Use Filter** if you would like to take a monochrome image without the color filter in the light path. This is the recommended setting for most fluorescent imaging applications. See Note above.

### Filter Color – without an Order option (only available when monochrome, above, is selected on a 3-shot camera)

The option to select the Filter Color is only available when a 3-shot camera is being used and the selection of Monochrome has been made, above. While using the color filter in a monochrome setting, you can only select one color filter state; either Red, Green, Blue, or Clear. The Clear mode is only available on certain camera models.

### Auto TTL/Sync Output Control

The SPOT cameras provide a TTL pulse that can trigger external devices like fluorescence shutters. When the Auto TTL/Sync Output Control checkbox is selected, the TTL pulse is enabled at the beginning of the exposure and is disabled after the exposure. It may be necessary to enable the TTL pulse before the exposure in order to properly synchronize the external device with the image capture.

For example, typical external shutters take time to open fully. The external shutter should be opened fully before the exposure begins. If the shutter manufacturer states that it takes 1 millisecond to fully open the shutter, enter 1 millisecond in the Delay field. The TTL pulse will be enabled 1 millisecond before the exposure begins. Xplorer and Pursuit model cameras also have the option to have this delay occur before or after an exposure begins.

### Auto – Exposure

#### Use Live Image Values

When you select this checkbox, the image settings for image acquisition will mimic the settings you have set in the Live Image Controls window of the Live Image Viewing Window. Note that
other image setting options are “grayed out” (made nonfunctional) when this checkbox is selected.

Note: When you select “Use Live Image Controls” in any of the exposure windows (Exposure, Auto-Exposure, or Manual Exposure), the other exposure windows are adjusted accordingly.

Image Type
An Image Type tells the SPOT program how to expose image captures. Each of the 11 available Image Types corresponds to a microscopy technique: select the Image Type that matches the technique you are using. The camera will compute exposures and capture the image accordingly. The table below describes typical situations for each image type.

<table>
<thead>
<tr>
<th>Image Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brightfield-reflected light</td>
<td>Polished metallurgical specimens and semi-conductors using a microscope with a vertical illuminator.</td>
</tr>
<tr>
<td>Brightfield-transmitted light</td>
<td>Stained specimens on glass slides using transmitted light microscopes.</td>
</tr>
<tr>
<td>Darkfield-reflected light</td>
<td>Bright areas of specimens being viewed with darkfield, reflected light techniques.</td>
</tr>
<tr>
<td>Darkfield-transmitted light</td>
<td>Bright specimens on dark backgrounds using transmitted light darkfield technique.</td>
</tr>
<tr>
<td>Fluorescence</td>
<td>Fluorescence specimens fluorescing in a single red, green, or blue primary color</td>
</tr>
<tr>
<td>Nomarski DIC/Hoffman</td>
<td>Specimens being viewed with either Nomarski DIC or Hoffman techniques.</td>
</tr>
<tr>
<td>Phase contrast</td>
<td>Specimens being viewed using the phase contrast technique.</td>
</tr>
<tr>
<td>Polarized light</td>
<td>Specimens being viewed with polarized light techniques.</td>
</tr>
<tr>
<td>Stereo/macro-metallic glints</td>
<td>Metallic specimens with intense glints.</td>
</tr>
<tr>
<td>Stereo/macro–no glints</td>
<td>Matte specimens without bright glints.</td>
</tr>
<tr>
<td>Stereo/macro–shiny glints</td>
<td>Shiny or wet specimens with bright glints.</td>
</tr>
</tbody>
</table>

Gain Limit
Normally an auto exposure routine in a digital camera sets the exposure time so that the brightest pixel on the CCD chip is completely “filled” with electrons, or is “full well”. This simple technique works well for bright images, but as an image gets dimmer, exposure times can get uncomfortably long. With the SPOT camera, you can shorten exposure times by filling the brightest pixel on the CCD to less than full well, and then using this lower level as full scale. The inverse fraction of full well that the brightest pixel on the CCD is filled to is known as the gain. For example, filling a pixel to half of full well cuts the exposure time in half. Since the exposure time is cut in half, we call this a gain of 2.

The Gain Limit feature allows you to set an upper limit on the gain options that will be available during the Auto-Exposure process.

For example, with a Gain Limit of 32 the camera can “choose” from a range of gain options. However, if you find that gains of 16 or 32 are too noisy for your images, you can prevent the camera from selecting these options by setting the Gain Limit to 8. When the Gain Limit option is set to 8, the camera is limited to the lower four gain options: 1, 2, 4, or 8. The following table illustrates levels of gain, the fraction of full well that the brightest pixel is filled to for each level, and a sample exposure time for each level:
Gain  Fraction of Full Well | Exposure Time (sample)
---|---
1  | 1 | 80 seconds
2  | 1/2 | 40 seconds
4  | 1/4 | 20 seconds
8  | 1/8 | 10 seconds
16 | 1/16 | 5 seconds
32 | 1/32 | 3 seconds
64 | 1/64 | 1 second

The table below summarizes the relationship between exposure time, background noise, and gain.

<table>
<thead>
<tr>
<th>Gain Limit</th>
<th>Possible Auto – Gain Settings</th>
<th>Exposure Time (dim images)</th>
<th>Background Noise (dim images)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>Longest</td>
<td>Lowest</td>
</tr>
<tr>
<td>2</td>
<td>1, 2</td>
<td>↑</td>
<td>↓</td>
</tr>
<tr>
<td>4</td>
<td>1, 2, 4</td>
<td>↑</td>
<td>↓</td>
</tr>
<tr>
<td>8</td>
<td>1, 2, 4, 8</td>
<td>↑</td>
<td>↓</td>
</tr>
<tr>
<td>16</td>
<td>1, 2, 4, 8, 16</td>
<td>↑</td>
<td>↓</td>
</tr>
<tr>
<td>32</td>
<td>1.2, 4, 8, 16, 32</td>
<td>↑</td>
<td>↓</td>
</tr>
<tr>
<td>64</td>
<td>1.2, 4, 8, 16, 32, 64</td>
<td>Shortest</td>
<td>Highest</td>
</tr>
</tbody>
</table>

To set the Gain Limit, follow these steps:
1. Ensure that the camera is set to use the Auto-Exposure option.
2. Click on the Gain Limit select list, and select the number that you want to limit the gain to.

For more information on the concept of gain, refer to Appendix A: Electronic Imaging Theory and the SPOT Camera.

**Brightness**

The Brightness control allows you to overexpose or underexpose (darken or lighten) the image area. A brightness value of 1, the default value, gives you the correct image brightness for most images. In many cases, an image has varying levels of brightness; to see a specific area better you might want to lighten or darken the image. When using the Brightness control, the SPOT camera uses an algorithm that combines gain and exposure time to provide the fastest possible frame rate in live mode:

- When overexposing images to make them brighter (i.e., entering values between 1.01 and 34), the camera first selects the highest possible gain before lengthening the exposure time. Because gain also brightens an image, less exposure time is needed.
When underexposing images to make them darker (i.e., entering values between 0.24 and 0.99) the camera uses the lowest possible exposure time before lowering the gain.

Minimum Exposure

Because SPOT cameras are capable of extremely short exposure times, light sources with intensities that vary with the waveform of the 60 Hz line supply (e.g., fluorescent lamps, 120 volt incandescent bulbs, and 6 volt 20 watt halogen lamps) can cause the Live Image window to flicker and result in incorrect brightness and color balance readings in captured images. The Minimum Exposure option allows you to correct for these problems by limiting the camera to a minimum exposure time that is greater than the pulse interval of the light source. Consider the illustration. In this case, the pulse interval of the fluorescent light source is 8.3 ms. Entering a Minimum Exposure of 25 ms ensures that the camera’s exposure time is greater than the pulse interval of the light source and that any error is minimized. The greater the value above 25 ms, the more the error is reduced. Alternatively, you can enter any multiple of 8.333 ms. To enter a minimum exposure, check the Minimum box, and enter a value in milliseconds.

Spot Metering Area

Similar to the way photographers spot meter their cameras on a particular location within their subject image plane, the SPOT user can do the same within the microscope’s imaging plane. The spot metering feature allows the user to best select an area of the image to be used as the region of interest for the automatic exposure level determined by the software.

This can be useful when the default auto-exposure settings (full image sampling) do not provide a captured image that provides the detail you need for a particular region of your subject being viewed.

On the Exposure Tab, there are two options:

- **Same as Imaging Area**
  - This selection will meter the exposure based on the entire imaging area.

OR

- **Region**
  - This selection will meter the exposure off of the area in the selected subregion

To set the Spot Metering Area:

- Enter the coordinates of the desired subregion under Spot Metering Area in the Left, Right, Top and Bottom user entry areas.

OR
From the Live Image window, click and drag the mouse to highlight the desired subregion in orange. See later in this Chapter for more about the Live Image Window and its features.

**Manual – Exposure**

**Use Live Image Values**

When you select this checkbox, the image settings for image acquisition will mimic the settings you have set in the Live Image Controls window of the Live Image Viewing Window. Note that other image setting options are “grayed out” (made nonfunctional) when this checkbox is selected.

*Note: When you select “Use Live Image Controls” in any of the exposure windows (Exposure, Auto-Exposure, or Manual Exposure), the other exposure windows are adjusted accordingly.*

**External Trigger**

SPOT gives you several options in the manual exposure window for setting an external trigger. The options available vary depending on the Bit Depth selection. If more than one color channel is selected in the Image Setup’s Filter Color setting (3-shot color cameras only), the only options for the type of External Trigger will be None or Edge. If a single color channel has been selected (3-shot color cameras) or if the camera is monochrome, the External Trigger options available will be None, Edge or Bulb.

The Edge and Bulb Trigger features allow external devices to start an exposure directly in the camera without software intervention via a TTL input signal.

Typical benefits of using the external trigger mode include:

- higher accuracy of the start of the exposure, as potential interrupts on the computer bus are avoided (edge and bulb trigger)
- the ability of external devices to directly start exposures without a software interface (edge and bulb trigger)
- the ability to control both when the shutter opens and also when the shutter closes, again without use of a software interface (bulb trigger only).

*Note: TTL stands for Transistor Transistor Logic and is a signaling I/O common to electronic devices.*

The following discussion highlights the features and use of each external trigger mode.
**Edge Trigger** - In this mode, the exposure is initiated by the rising edge of a TTL signal and is terminated after a software-programmed duration.

To use the Edge Trigger feature in Manual Exposure mode, follow the steps below.

1. From the Setup Menu, select Image Setups and choose to Modify the appropriate Image Setup.

2. In the Manual Exposure Window, check the box to Use Manual Exposure. You may have to first uncheck the box to Use Live Image Values in order for the Manual Exposure check box to become active.

3. Under the External Trigger Type pull down, select Edge from the list.

4. Set the computer controlled exposure time in msec or sec and set the Gain.

5. If you use the Acquire Time Lapse Images feature, you will need to select whether you externally trigger only the first image exposure in the sequence or every image exposure in the sequence. Please refer to Ch. 3 – SPOT Advanced Image Captures and the Camera Menu for more information on capturing time lapse images.

**Pulse Characteristics:**
- Minimum Pulse width: 500ns
- Minimum Exposure: 40 µs
- Delay to Exposure Start: 6.195 µs ± 0.028 µs
- Exposure End: Software Determined
- Voltage Logical High Level: 3.3 – 5.0 volts
- Voltage Logical Low Level: 0.0 - 0.5 volt
**Bulb Mode** – In this mode, the exposure is initiated by the rising edge of the TTL signal. The exposure continues until the TTL signal falls. Exposure time is therefore determined by the pulse width (level trigger).

1. From the Setup Menu, select Image Setups and choose to Modify the appropriate Image Setup.

2. In the Manual Exposure Window, check the box to Use Manual Exposure. You may have to first uncheck the box to Use Live Image Values in order for the Manual Exposure check box to become active.

3. Under the External Trigger Type pull down, select Bulb from the list.

4. Set the Gain.

5. If you choose the Acquire Time Lapse Images function you will need to use the external trigger to begin and terminate every exposure. Please refer to Ch. 3 – SPOT Advanced Image Captures and the Camera Menu for more information on capturing time lapse images.

**Pulse Characteristics:**
- Minimum Reliable Pulse width: 100 ns
- Minimum Exposure: 37.5 µs + Pulse Time
- Delay to Exposure Start: 6.195 µs ±0.028 µs
- Delay to Exposure End: 0.195 µs ±0.028 µs
- Voltage Logical High Level: 3.3 – 5.0 volts
- Voltage Logical Low Level: 0.0 - 0.5 volts
### Trigger Type Summary

<table>
<thead>
<tr>
<th>Trigger Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edge Trigger</td>
<td>Allows you to use an external TTL source to trigger an image capture according to the exposure time(s) entered on the Image Setup window.</td>
</tr>
<tr>
<td>Bulb Trigger</td>
<td>Allows you to use an external TTL source to vary exposure time according to the TTL pulse width.</td>
</tr>
</tbody>
</table>

#### Exposure (s)
Photographically speaking, an exposure is the total amount of time that light is allowed to hit the imaging sensor before it is read out by the camera. The exposure of the image can be manipulated by adjusting the Exposure Time to suit your needs. Type in a value to specify an exposure time and adjust as needed.

Individual exposure times will be available for Red, Green and Blue if your camera is a 3-shot or slider style camera. If you are using the White Balance feature of the SPOT Software to provide properly balanced images, you will want to lock the exposure ratios by ensuring that the graphic lock is closed. Click on the lock graphic to toggle the lock on and off. With the exposure ratios locked, typing in a new exposure value for one value, i.e. Red, will automatically cause the other two values to be updated with respect to their white balanced ratio.

Note: if the lock is opened for the exposure times, adjusting one color will skew the white balance of the image. To regain proper balance, re-lock the lock and perform a new White Balance. See below for additional background information on white balance and Ch. 3 – SPOT Advanced Image Captures and the Camera Menu for detailed information on how to perform a white balance.

#### Gain
When you define your own Exposure, you can enter the precise gain that the camera will use for an image capture. You can manually enter the gain value by using the slider bar to make your selection. The gain value displays to the right of the slider-bar.

To read more about Gain and what it is used for, please refer to the previous section about Gain Limit.

#### White Balance
White balance is the ratio of red, green, and blue exposure times (3-shot cameras) or gains (color mosaic cameras) necessary to achieve the proper color rendition for an image. Many factors impact the coloration of an image capture, including lamp voltage, the coloration of the glass used in the slide, and the coloration of the glass used in the lenses of the microscope’s objectives. To minimize the impact of these factors, use the White Balance feature. When you perform a white balance calculation, SPOT samples the color of the light from your light source after it has passed through the slide and the objective, and then calculates the red, green, and blue exposure times (3-shot cameras) or gains (color mosaic cameras) needed to produce images where the white areas are white and the color areas are true.

You should perform a new white balance calculation when:
- Starting a new image capture session.
- Changing the lamp voltage.
• Switching to a different objective on the microscope.

See Ch. 3 – SPOT Advanced Image Captures and the Camera Menu for additional information on how to perform a white balance.

**Note:** While the values for the White Balance can be manually adjusted, it is recommended to first use the White Balance calculation and then second, the Color Temperature (under Enhancements, below) slider for adjusting the camera’s version of white to match your eye.

**Computation Area**

The area of the sensor which is used to calculate the white balance values can be set to one of two options:

- **Same as Imaging Area**
  
  If you select the computation area to be the same as the imaging area, the software will calculate the white balance values based on the entire imaging area which is currently being used. This selection will work best for the majority of applications.

- **Region**
  
  If desired, a subregion of the imaging area can be used for the white balance calculation. Enter the coordinates of the subregion in the user entry spaces for Left, Right, Top, and Bottom. For easy use of the region function, we recommend setting this from the Live Image Window. See later in this Chapter for more about the features available in the Live Image window.

**TTL/Sync Output/Trigger**

The SPOT cameras produce a 5 volt TTL pulse when an image is captured to enable external device triggering timed with image captures. This TTL pulse can be used to open and close an external shutter, for example. The TTL Output section of the Image Setup allows you to specify the active state of the TTL output.

**TTL/Sync Output Active State**

There are two TTL level options:

- **High** – Set the active state of the TTL output to High.
- **Low** – Set the active state of the TTL output to Low.

**External Trigger Active State**

With some SPOT cameras, you can set the active state of the external trigger in this window. There are two options:

- **High** – Set the active state of the external trigger to High.
- **Low** – Set the active state of the external trigger to Low.

**Note:** This option is available only if your camera model is a Pursuit or Xplorer.
Imaging Area

SPOT allows you to use any rectangular portion of the CCD chip for image capture. Using a portion of the chip is helpful in cases where you want to:

- Keep file sizes small.
- Shorten download times.
- Avoid areas of the image with optical problems (e.g., vignette areas).

Use Live Image Values

When you select this checkbox, the image settings for image acquisition will mimic the settings you have set in the Live Image Controls window of the Live Image Viewing Window. Note that other image setting options are “grayed out” (made nonfunctional) when this checkbox is selected.

- There are three image area options:
  - **Full Chip** – Capture the entire area of the CCD chip.
  - **Center** – Capture a rectangular part of the CCD chip’s area that has the same height - to - width ratio as the full chip, and is centered on the center of the full chip. The percentage that you enter is the percentage of full chip width that the new area’s width will be.
    - **Constrain Aspect Ratio** – With this selection activated, the percentage of the chip will be used to capture an image, however instead of the aspect ratio matching the sensor’s dimensions, the center x% will be displayed with the aspect ratio which is selected below.
    - **Aspect Ratio** – If you have selected to Constrain the Aspect Ratio (above) of the center portion of the sensor, the choice made here will determine the dimensions of the captured image. This aspect ratio will also be used for the Live Image display if the option for the Center % of the sensor is also chosen in the Live Image Controls.
  - **Region** – Capture a specific part of the CCD chip.

If you have pre-determined the exact pixel values of the area that you want to capture, follow these steps:

On the Image Setup window, check Region.
Enter the pixel values for the Left and Right columns and the Top and Bottom rows that form the boundaries of the region that you want to define.
Click on OK. The camera captures the region that you selected.

If you do not know the exact pixel values of the area that you want to capture, follow these steps:

Click on the Full Chip option.
From the Camera menu, select the Get Image (exposure from setup) option. The image capture appears on the screen.
Position the cursor at the upper left edge of the image region that you want to define.
Press and hold the left mouse button, and drag the cursor across the screen. SPOT highlights the area that you selected with a dotted border.
From the Camera menu, select the Set Chip Imaging Region option. The Chip Imaging Region window displays the pixel values for the region that you selected.
Either click OK to save the region values to the current image setup, or select a different image setup.
**Image Orientation**

To match what you see through the eyepieces to what you see on your computer monitor, rotating and/or flipping the displayed image may be necessary. This may be required in situations where the optics provide a mirrored image or the camera is required to be rotated relative to the eyepiece image. Specify whether images will be rotated and/or flipped during the image capture/live image viewing process.

**Rotate**

- Leave the Rotate box unchecked if you do not want the image to be rotated.
- Select **Left** to rotate the image counterclockwise 90 degrees
- Select **Right** to rotate the image clockwise 90 degrees.

**Flip**

- Select **Horizontal** to flip the image from left to right.
- Select **Vertical** to flip the image from top to bottom.
- Select both options to flip the image from left to right and from top to bottom.

**Sensor Cooling (Pursuit – PCI interface only - and Xplorer cameras only)**

This window allows you to regulate the temperature of the CCD in your camera. Since the dark current noise increases as the temperature of the CCD rises, keeping the temperature of the CCD constant will ensure that each image taken has similar dark current characteristics. This is important for quantitative imaging.

Temperature regulation also increases the accuracy of the background subtraction. The temperature should be the same when creating background subtraction files as when using them. Please refer to the section “Get Background Subtraction” in this chapter for more details.

To regulate the sensor temperature, check the Regulate Temperature box, and input the desired temperature in Celsius. The thermoelectric cooler will immediately begin cooling (or heating) the CCD to the target temperature. The temperature of the CCD is displayed on the status bar across the bottom of your screen.

The temperature is read out and updated on the screen every 30 seconds by default. If you wish to view the changes in temperature at a different interval, you can change this in the Temperature Readout section of the Preferences in the Setup menu.

The set point for the regulated temperature should be at least 3 degrees warmer than the maximum cooling capacity of the camera. The maximum cooling capacity of the camera is influenced by the room temperature. For example, if the ambient temperature of the room is 20°C, the maximum cooling temperature of an Xplorer camera should be between -45°C and -49°C. The value for the Regulate Temperature box should be no more than -42°C (-45°C + 3°C = -42°C). If the room temperature is around 25°C, the maximum cooling temperature will be closer to -40°C to -45°C, and thus the maximum (lowest temperature) value that should be used is around -37°C.

To optimize the Regulated Temperature option, it is recommended to perform a small experiment where the Regulated Temperature is turned off and the camera is allowed to run to its maximum cooling possible in the maximum expected room temperature. The SPOT software will display the temperature of the camera in the status bar at the bottom of the application; note this value, add 3°C, and use the resulting value for the Regulated Temperature.

If the temperature of the camera is not within the range set by the Regulated Temperature and the Allowable Variance, an asterisk will be displayed next to the temperature display in the bottom of the SPOT application.
Image Readout

The image readout window allows the user to specify the rate at which data is read off from the CCD. The faster the sensor is read out, the noisier the image will be. The available sensor readout options will vary depending on the camera model.

To select the speed to read out the CCD sensor, select a horizontal readout frequency from the drop-down list.

Enhancements

Use Live Image Values

When you select this checkbox, the image settings for image acquisition will mimic the settings you have set in the Live Image Controls window of the Live Image Viewing Window. Note that other image setting options are “grayed out” (made nonfunctional) when this checkbox is selected.

Correct Colors

The Correct Color Technology option utilizes camera dependent color correction profiles that optimize the matching of colors between your microscope specimen, the live image you view on the screen of your monitor, and the image you capture with your SPOT camera. This is done by transforming the raw camera color data allowing it to be adjusted to display the closest approximation of the same color on your monitor.

In order to get the best results using this feature, you should make sure you set up your imaging system including your computer monitor appropriately. See Appendix C: Correct Color Technology for more information on system set-up.

Note: Color correction transformations that occur when you use Correct Color Technology will be applied to the raw image data, leaving a modified image file. If you will require the raw data for further analysis of your image, you should uncheck the Correct Color Technology checkbox.

Turning on Correct Colors enables the following additional color space manipulations: Contrast, Saturation, and Color Temperature.

Note: If your camera is a three-shot or slider version, Correct Color Technology will only be available in the Image Settings window if RGB is set as the filter color.

Use Defaults

The Use Defaults button will reset the values for Gamma, Contrast, Saturation and Color Temperature to their original default positions of 1 for Gamma, 0 for Contrast and Saturation and 5000K for the Color Temperature. This button may be useful if multiple adjustments have been made to these settings and you would like to start over with a fresh, un-adjusted image. Each of the features is discussed in further detail below.

Gamma

Gamma adjustments are nonlinear operations which smoothly lighten darker areas of an image without burning out bright areas or lightening black areas. This is especially useful for capturing/editing images with a wide range of brightness values (dynamic range) such as fluorescence specimens or macroscopic objects with glints, (e.g., printed circuitry).
When the bright areas of these types of images are correctly exposed, the darker areas can be so dark that they are in effect invisible. Gamma Adjust can remedy this problem. The figures below illustrate the effect of a gamma adjust on a fluorescent image. The image on the left is the original image prior to the gamma adjustment. The image on the right has been gamma adjusted to a value of 1.75. In this instance, the gamma adjustment results in a better display of detail by lightening the darker areas without burning out bright areas or lightening black areas:

Fluorescence image, no gamma adjustment

Fluorescence image, gamma adjusted to 1.75

In the SPOT Software:

- Values between 1 and 4 lighten the darker areas of the image.
- Values between .1 and 1 darken the brighter areas of the image.

Refer to Ch. 4 – SPOT Advanced Viewing and Editing Image Documents for more details on gamma adjustment and color spaces.

Contrast (only available when Correct Colors is enabled)

Contrast is the degree of difference between the brightest and darkest parts of an image. If you would like to exaggerate the differences between bright and dark areas in an image, use the up and down arrows or type in a value between 0.0 and 1.0 to obtain a level which looks suitable to you.

Saturation (only available when Correct Colors is enabled)

Saturation refers to the dominance of hue in a color. Colors which are not fully saturated will be more grey, or pastel, and colors which are fully saturated will be richer in color (hue). Move the Saturation slider to the right if you want to increase the richness, or to the left to decrease the richness of the colors in the image.

Color Temperature

The Color Temperature slider (in Kelvin) is available for users to match the display of their images with their source illumination's color temperature. Below is a list of some general color temperatures for typical light sources. Keep in mind these are averages or ranges and your individual bulb may differ. For the best accuracy, check the specification on your light bulb for the color temperature in degrees Kelvin.
For example, if you are using a Halogen bulb without a daylight blue filter in the light path, adjust the slider for **Color Temperature** to 3200K to best match how the software will display your image with what you see at the eyepieces. See the table below for a list of commonly available light sources and their range of typical color temperatures.

<table>
<thead>
<tr>
<th>Type of Bulb</th>
<th>Typical Color Temperature (K)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Incandescent</td>
<td>2800 – 3400, varies with voltage setting on microscope</td>
</tr>
<tr>
<td>Halogen</td>
<td>3200</td>
</tr>
<tr>
<td>Direct Sunlight</td>
<td>5000</td>
</tr>
<tr>
<td>Mercury</td>
<td>5000 – 6000</td>
</tr>
<tr>
<td>Zenon</td>
<td>6000 – 6200</td>
</tr>
</tbody>
</table>

**Post-Processing**

The final aspect of defining an image setup is to determine the post-processing adjustments (corrections) that you want the SPOT camera/software to make. Each option is described in the sections that follow.

**Black Level Subtract**

The amplifier in the SPOT camera has been adjusted so that the average black (no light) pixel value is between 20 and 25, rather than zero for 12/14 bit downloads. This offset is called the **black level** (sometimes referred to as the “pedestal”). Before each picture, the camera samples the black level by taking a picture with the shutter closed. The software then downloads the pixel values in the first row of the CCD chip, averages them, and stores this value as the black level. When capturing 8-bit monochrome, 24-bit RGB and 36-bit RGB images, the software automatically subtracts the black level from all pixel values so that black pixels are 0 (black) rather than 20-25 (dark gray), and colors are represented accurately.

When capturing 12-bit monochrome images, you can turn off the automatic Black Level Subtract. This is a useful option in cases where you need high accuracy brightness measurements. For example, you may want to adjust the black level of an image on a pixel-by-pixel basis by subtracting a second picture, taken with no light (a “dark frame”), from the original image. When high accuracy measurements are needed, the automatic Black Level Subtract is a problematic because the Black Level is an average of a sampling of black pixel values. Some values are higher, and some values are lower than the average. Subtracting this average value from a black pixel value that is lower than average would normally result in a negative value. But, since there are no negative values, the result is arbitrarily set to zero and the actual value is lost. This diminishes the accuracy of measurements.

**Bright/Dark Level Stretch**

The Stretch Bright and Dark Level (RGB), automatically stretches the darkest luminance or value level in an image to 0 (black) and the brightest luminance or value level to 100 (pure white if Luminance/brightest version of hue if Value) as part of the post-processing of the image.
Chip Defect Correction

When you capture an image, the SPOT program automatically compensates for CCD chip defects, so that they do not appear on your images. The Chip Defect Correction option allows you to turn off this automatic correction. This can be useful in cases when you are performing quantitative measurements of pixel brightness values and need to see precisely where chip defects are.

The Chip Defect Correction box is, as a default, checked when you define a new image setup. To turn off the program’s automatic chip correction, deselect the Chip Defect Correction box.

Noise Filter

The Noise Filter corrects for the effects of electrical or thermal noise. When capturing dim images with lengthy exposure times, the noise filter acts as a "virtual cooler" for the Insight camera, eliminating "hot pixels."

The Noise Filter checks each pixel on the CCD chip as described below:

1. The program compares the value of each red pixel with the values of the eight neighboring red pixels.
2. If none of the eight neighboring red pixels has a value within ±50 % (i.e., the threshold value that the SPOT program uses) of the value for the red pixel being checked, the value for the red pixel being checked is replaced with the average value of the eight neighboring red pixels.
3. The program repeats this procedure for the values of the green and blue pixels being checked.

To use the Noise Filter, follow these steps:

To filter noise, follow these steps:

1. Check the Noise Filter box.
2. Enter a value between 10% and 100%. The Threshold value is set to a default of 50%. Refer to the procedure described above for an explanation of the Threshold value.
3. When you capture an image, the program automatically adjusts the image using the Noise Filter value that you entered.

Note: You can also use the Filter Noise Edit menu option to adjust captured images, as described in Ch. 8 – Viewing, Editing, and Annotating Images.

Image Resize

The Image Resize option is available as part of an image setup in order to allow each image acquired with the image setup to be the same resized size. You can choose to make an image smaller or larger than the original, between 10% of the original up to 200% of the original.

When you select enter a value above 100, the camera interpolates between pixels to create an image that is twice as large. The program reads the red, green, and blue brightness values for the original image and interpolates those values to create a new image that has double the number of columns and rows. The red, green, and blue values for the additional pixels are calculated based on the RGB values of the original pixels.

Image Resizing of above 100% helps to reduce the pixellation of fine detail that often results when you use lower magnification objectives. When used with low magnification images, the additional pixels created via the Image Size Double feature help to smooth out details; this results in a higher resolution appearance.
Bias Frame Subtract

Bias frame subtraction is a process that uses the stored bias frame, subtracting it from a captured image to remove both the system offset and the dark current electrons that accumulated in each pixel while it was waiting to be read out. When this subtraction process has been applied to a short exposure image, the remaining data (and image) is mostly representative of the true image data being captured.

You may select a bias frame to use in the subtraction process within the image set-up post-processing window. Select the checkbox for Bias Frame and then browse to select a Bias Frame correction file from those that have been previously developed and stored.

For a step-by-step explanation for acquiring and saving bias frames (Get Bias Frame), refer to Ch. 3 – SPOT Advanced Image Captures and the Camera Menu.

Note: Bias frame subtraction is available only when a monochrome camera is set up in 12 bit or 14 bit capture and black level subtract is not selected.

Background Subtract

Background Image Subtraction is a technique that allows you to eliminate the dark current accumulated during the exposure time of your captured image. By determining the rate of dark current accumulation in each pixel, we can scale the quantitative effect of the dark current for each pixel in the image plane (the Background Image) based on the time of image exposure and subtract it from the final image. The end result is a processed image that more closely reflects the true data that is collected from the specimen during the image capture.

The SPOT program accomplishes this method of background image characterization by collecting one, or an average of a series of images that reflect the electrons accumulated due to the temperature of the CCD. This information is then stored as the Background Image. For a given experimental condition (i.e. temperature in the room), normally only one set of Background images must be collected, with its data later scaled to correspond to the time of the exposure.

Note: If your camera an Insight, RT, or Flex, the temperature of the CCD may vary over time. This variation will also change the dark current characteristics of the CCD. Because background subtraction frames capture the dark current rate at a certain CCD temperature, background images should be collected as close to the image capture period as possible.

If your camera is a Pursuit or Xplorer, ensure that the background subtraction file is taken with the CCD at the same temperature as it is when you capture pictures.

The Background Image correction data is stored as a file. The user must select it in the Image Setups options prior to image captures. Select the checkbox for Background Subtract and then browse to select a Background Image correction file from those that have been previously developed and stored.

You may select a background image to use in the subtraction process within the image set-up post-processing window. For a detailed description of the steps involved in acquiring a Background Subtraction Frame (Get Background Image), refer to Ch. 3 – SPOT Advanced Image Captures and the Camera Menu.

Flatfield Correct

Flatfield correction is used to correct for display problems associated with uneven intensity or coloration in illumination, or to correct for artifacts (e.g., dust) in the optical system. For the SPOT cameras that use a color mosaic chip, flatfield correction serves another purpose. In the production process for color mosaic CCD chips, the RGB colors are applied directly to the pixels on the chip. This process often results in an uneven color density around the outer 30-40 rows of the CCD chip, causing a “halo” appearance in some image captures, particularly those with low contrast. The Flatfield option can be used to correct this problem.
Flatfield correction works by sampling the brightfield background without the specimen in the field of view. This lets the SPOT software know, on a pixel-by-pixel basis, which areas in the field of view are receiving less illumination than the brightest areas. The flatfield correction function also samples the system offset and dark current by taking a bias frame. After the flatfield correction file is created and saved to the Image Setup, the software uses this information to accurately increase the brightness of each pixel in the dimly illuminated areas. The resulting image gives the appearance of an even illumination.

For a detailed description of the steps involved in creating and saving the flatfield correction file for use in post-processing (Get Flatfield Image), refer to refer to Ch. 3 – SPOT Advanced Image Captures and the Camera Menu.

**Image Display**

**Monochrome Palettes**

The SPOT Advanced application provides Monochrome Palettes which allow you to apply specific hue and saturation values to monochrome images. Palettes are useful in fluorescence applications where a sample is fluorescing at a single wavelength, you are using a monochrome camera to capture the image, and you want the acquired image to display the correct color. For such a case, you could create a palette to represent the color of the fluorescent dye and then apply that palette to the captured image. The Palette option on the Image Setup window allows you to automatically apply a palette to a monochrome image capture.

To apply a palette, select one from the drop down list. There are six pre-defined palettes: Red, Green, Blue, Grayscale, Rainbow, and Reverse Rainbow. Because the Palettes option applies only to monochrome images, palettes will only be applied when images are displayed as monochrome images. You can define custom palettes using the Palettes option on the Setup menu. Refer to later in this chapter for additional information on setting up Palettes.

**Indicate Saturated Pixels in Monochrome Images**

This feature is only applied if the image is monochrome or the image is being displayed in grayscale. With this feature turned on, saturated pixels are indicated in red in the captured image. Use of this feature can help prevent image data loss by too many pixels being saturated. Once the image is captured, the feature can be toggled off under the Edit menu.
**Calibration/Reticle**

**Save Calibration with Image**

If one or more calibrations have been set up, a list will be available in the pull-down menu. Select the appropriate calibration to save to the Profile and be applied to each image captured using the Profile. See later in this chapter for additional details on setting up Calibrations.

**Apply Reticle to Live Images**

If one or more reticles have been set up, a list will be available in the pull-down menu. Select the appropriate reticle to apply to Live Images and save to the Profile. See later in this chapter for additional details on setting up Reticles.

**Apply Reticle to Captured Images**

If one or more reticles have been set up, a list will be available in the pull-down menu. Select the appropriate reticle to apply to Captured Images and save to the Profile. See later in this chapter for additional details on setting up Reticles.

**Auto-Save**

The **Image Auto-Save** feature is available to assist you with your work flow to automatically save images as part of the capture process.

Auto-save functionality can be set individually for Single Image Acquisitions and Time Lapse Image Acquisitions. Both types of acquisitions have the ability to either be saved to individual files or image sequence files and the settings for these options are slightly different.

On the main Auto-Save window pane the following options are available:

**Single Image Acquisition**

Use the **Single Image Acquisition**’s setting to automatically **Save to Individual Files**, or to save each image to an **Image Sequence File**. If Auto-Save is not desired, select **Off**.

**Time Lapse Acquisition**

For **Time Lapse Image Acquisition**, select to automatically save each image individually by selecting **Save to Individual Files** or select to add each image to an **Image Sequence File**. If Auto-Save is not desired, select **Off**.

Whether **Save to Individual Files** or **Save to Image Sequence Files** is selected, additional settings need to be specified on the subordinate window panes.
**Individual Files**

**File Name Prefix**

This prefix appears before the number of each captured image. To enter the File Name Prefix, you can:

- Type only the name (e.g., Cell) in the box. The program automatically saves the image to the last used directory. If you specify the prefix only, you cannot see exactly where the files are being saved. Thus, to avoid having to search for your files, you should verify the location of the last save.

- Type the full path and file name (e.g., C:\Spotcam\T-cells) in the box to specify the location of the image. When entering the file path and name, you can also specify a new directory simply by entering it in the path (e.g., C:\SpotCam\Cells\T-Cells).

- Click on the browse button to select a new file location and file name prefix. All of the image files are saved with the prefix that you enter. Thus, if your Append Number (see below) is 1, the file name for the image would be ‘T-Cells0001’.

You can also click on the browse button to select an existing image sequence or an existing individual TIFF image to which you would like to add images subsequently.

**Format**

Select the file format for your saved images. For more details about image saving options, please refer to Ch. 4 – SPOT Advanced Viewing and Editing Image Documents.

- For individual 8 bit/channel files, there are six options: Windows Bitmap, JPEG, Mac PICT, TIFF Uncompressed, TIFF JPEG, or JPEG2000. For individual 12 bit/channel files, there are three options: JPEG 2000, TIFF Uncompressed (12-bit/chan), TIFF Uncompressed (16-bit/chan). For individual 16 bit/channel files there are two options: JPEG 2000 and TIFF Uncompressed (16-bit/chan).

---

**Note:** Images saved as BigTIFFs may not be viewable in other applications, as this file format is not widely supported.

---

**Append Number**

When Append Number is selected, the individual images will be numbered, beginning with the append number chosen. The append number will be automatically incremented by one for each subsequent image. See Digits (below) for information on how to add more digits to the append number.

**Digits**

The entry for the Digits field works with the Append Number above. Choose the number of zeroes you want to appear before the append number and place it in the Digits field.

**JPEG Quality**

JPEG quality is the level of compression for JPEG images: this option is available only when JPEG or TIFF JPEG is selected as the image file format. Enter an integer between 1 and 100 to set the JPEG quality for images. A value of one is the most compressed (and lowest image quality), while a value of 100 is the least compressed (and highest image quality).

**Compression**
When the JPEG2000 file format is selected, the Image Auto-Save Setup dialog displays compression options:

- **Lossless** – Information is not lost when the image is compressed.
- **Lossy** – Information is lost according to the ratio that you enter: the higher the ratio that you enter, the smaller the file size and the lower the quality of the image.

**Save Thumbnails**

The option to Save Thumbnails is available when either the TIFF or TIFF JPEG file format is selected. Check this box to have a thumbnail preview of your image available.

**File Name Conflict Action**

This section determines how the program will respond if it finds an image file with the same name as an image from the current session. Select one of the following options:

- **Overwrite Existing File** – The program overwrites the existing file with the new image capture.
- **Display Warning** – The program displays a warning message indicating that a file of the same name already exists, and stops the image capture.

**Image Display**

Make a selection from the options below in order to determine how image captures will be displayed.

- **Display Each Image in a New Window** – The program opens a window for each new image capture. This option works well if you plan to capture a limited number of images in the session. If you plan to capture many images, however, displaying numerous windows uses up memory and could interfere with use of other programs.
- **Display Only Current Image** – The program sequentially displays each image in the same window. Each image displays only until the next image is captured. This is useful when you have numerous captures where you do not want to be concerned with running out of memory.
- **Don’t Display Images** – The program automatically saves all of the image files to the specified location without displaying them.

**Image Sequence Files**

**File Name Prefix**

This prefix appears before the number of each captured image. To enter the File Name Prefix, you can:

- **Type only the name (e.g., Cell) in the box**. The program automatically saves the image to the last used directory. If you specify the prefix only, you cannot see exactly where the files are being saved. Thus, to avoid having to search for your files, you should verify the location of the last save.
- **Type the full path and file name (e.g., C:\Spotcam\T-cells) in the box** to specify the location of the image. When entering the file path and name, you can also specify a new directory simply by entering it in the path (e.g., C:\Spotcam\Cells\T-Cells).
• Click on the browse button to select a new file location and file name prefix. All of the image files are saved with the prefix that you enter. Thus, if your Append Number (see below) is 1, the file name for the image would be ‘T-Cells0001’.

You can also click on the browse button to select an existing image sequence or an existing individual TIFF image to which you would like to add images subsequently.

Format
Select the file format for your saved images. For more details about image saving options, please refer to Chapter 4.

• For image sequences of 8 bit/channel files, there are two options: TIFF Uncompressed or TIFF JPEG. For image sequences of 12 bit/channel files, you can save the sequence only as TIFF Uncompressed. For image sequences of 16 bit/channel files, you can save the sequence only as TIFF Uncompressed.

• The BigTIFF file format has been added to support larger file sizes. This is especially useful with image sequence files. This format should be available for all bit/channel settings.

Note: Images saved as BigTIFFs may not be viewable in other applications, as this file format is not widely supported.

Append Number
When Append Number is selected, the individual images will be numbered, beginning with the append number chosen. See Digits (below) for information on how to add more digits to the append number.

Digits
The entry for the Digits field works with the Append Number above. Choose the number of zeroes you want to appear before the append number and place it in the Digits field.

Increment Number after Each Time Lapse Acquisition
Checking the box to Increment Number after each Time Lapse Acquisition will cause the software to add 1 to the Append Number (above) for each new image sequence file. Without this box activated, the action taken will depend on the selection made For Time Lapse Acquisitions:

For all New Image Sequence Acquisitions:

• Overwrite Existing Files – With this option selected, you will automatically overwrite the saved file with the new acquisition information. If the saved file is still open within the SPOT application, a message will be displayed and when you click on Ok, you will be prompted to provide a new name. If you want to overwrite the file, you will have to Cancel out of the file renaming and then close the file.

• Append Existing Files – With this option selected, any new image sequence data will be added to the last image sequence file. In this way, an image sequence file which starts out with 3 images, will have 3 + n images, where n = the number of images in the current acquisition.
• Display Warnings if Files Exist – With this option selected, you will be asked if you want to overwrite the existing file. If you choose “Yes” any existing data in the image sequence file will be replaced with the new data. If you choose “No” you will then be prompted to give the file a new name.

**Image Metadata**

In general terms, Image Metadata is information associated with an image. The SPOT Software allows each user to set up the specific datum to be associated with an image. The possibilities are endless; however some common categories of data would be wavelength, x, y, or z position, time, magnification, etc. Image Metadata can be set by using our custom variables.

If Custom Variables have been set up for Image Metadata, they will be available for use within the Image Metadata pane of the Image Setup. See Ch. 4 – SPOT Advanced Viewing and Editing Image Documents for more information about Custom Variables and Image Metadata.

**Live Images**

**Close Live Image Window on Acquisition**

Select the option to Close Live Image Window on Acquisition to automatically close the Live Image window so that your image acquisition is revealed. Without this feature activated, the Live Image window will remain on top and acquired images will stack up behind the Live Image window.

**Maximum Exposure**

The Maximum Exposure setting allows you to set the maximum exposure time that is allowed while using the Auto Exposure feature. Computed auto exposures that would require an exposure time that exceeds this limit will result in an **Image Too Dim** error message. This allows you to configure what exposure time is considered out of range for the type of imaging you are performing.

Without this setting the software could try to calculate a multi-hour exposure due to the common user error of not having the microscopes light path selector to send light to the camera. Typically the value is set to between 1-2 seconds for brightfield and bright fluorescence images. Longer exposures may benefit from manual exposure setting or test bracketing of sample specimens. The range of valid values is dependent upon the type of camera you are using.

**Neighborhood Size for Focus Contrast Computation**

The setting for the Neighborhood Size for Focus Contrast Computation works in conjunction with the Focus Gauge feature of the Live Image Window. In general, if you want to discern smaller details, you would want to use a smaller neighborhood size. Likewise, if you want to discern larger details, a larger neighborhood size can be used. Please see Ch. 3 – SPOT Advanced Image Captures and the Camera Menu for additional details on the Live Image window features.
Live Image Window and Live Image Controls

The SPOT software allows you to view real-time black and white or color previews of your specimens — i.e., your potential image captures. Using the Live Image preview, you can scan, zoom, focus, and frame images so that they are optimally adjusted for the image capture. After focusing and positioning the image, you can then capture it. See Ch. 3 – SPOT Advanced Image Captures and the Camera Menu for additional details on capturing an image.

The Live Image Window

- To open the Live Image window, either click on the Live Image toolbar button, or select the Live Image option from the Camera menu.

- The title bar at the top of the Live Image window displays the status of the live image view - Running, Computing Exposure, or Paused. Double-click on the title bar to "roll up" the live image display. This pauses the live image display. Double-click again to display the whole window and resume the live image display.

- The Full Screen option (accessed via the View menu or [F 7]) can be used with live images. To access live image viewing options while in the full screen view, right click on the live image.

- To exit the full screen view, either press [F 7], move the cursor to the edges of the screen and click on the Exit Full Screen Mode button that appears, or move to the top of the screen and select the View/Full Screen from the menu bar that appears.

- The following options are available on the Live Image window:

  Pan Window
  When this box is checked, if the Live Image is zoomed in beyond the ‘Fit to Window’ mode, the pan window will automatically appear for easy navigation.

  Display Zoom Level Indicator and Slider Bar
  This button will change its label depending on how the Live Image is displayed; Actual Size, Fit to Window, Fit Width, Fit Height, Fill Window, or a percent Zoom. The slider to the right of this button also allows for easy changes to the zoom level. See more on these options in the Preferences section of this chapter.

  Restart
  Resample the brightness of the image, compute new exposure times, and restart the live image display. This is useful for updating exposure times when specimen brightness has changed.
Pause/Resume

Pressing the Pause button freezes the live image display. This is useful when you are changing a specimen and want to preserve the last view. In addition, to use the Transfer option (see below), you must first Pause the live image view. Click on Resume to restart the live image view using the same exposure computations as when the Pause button was pressed.

Transfer

The Acquire Single Image function should be your first choice for capturing a single image. However, a second option is available, the Pause/Transfer button.

This option is helpful in situations with rapidly changing or moving samples. If you see something that you like, you can Pause the live image before it changes. Then, you can Transfer the paused image to a SPOT editing window and save it to file. The Transfer option is not active until the Pause button is pressed.

If you do not want to Transfer the paused image, you can resume the Live Image display by either pressing Resume or Restart (see above for more details).

Controls

The Live Image Controls are the central location for settings to script your Live Image. From this dialog box, you can define the viewing/capture area, and adjust gamma, brightness level, and dim image quality. You can also elect to display either the full chip or a region of interest. Click on the Controls button to toggle the Live Image Controls Dialog box. The Live Image Controls can be resized and repositioned for your convenience. Please see below for details on each feature available on the Live Image Controls.

Histogram

Clicking the Histogram button opens the Live Image window histogram window. The Live Image histogram window provides a real-time monitor of the live image’s readings. The readings in the histogram window can be converted to log scale using the checkbox. The Live Image Histogram window can be resized and moved for convenience. Double-clicking on the histogram’s title bar will roll up the window. Double-click the title bar again to roll the histogram back down. To close the Live Image Histogram, click on the Histogram button again, or click on the X on the Histogram window. For more information on the use of Histograms, see Ch. 4 – SPOT Advanced Viewing and Editing Image Documents.

Measure

This button opens the Measure dialog for Live Image measurements. The Measurement Dialog freezes the Live Image to facilitate the accurate drawing of the measurement tool options on the paused image.

The intent of the Live Image Measurement tool is to provide you with an easy way to make a measurement while ‘on-the-go’ and viewing the Live Image as a rough estimate of the measurement. The easiest measurements are applied to captured images (See Ch. 4 – SPOT Advanced Viewing and Editing Image Documents for more about measurement tools and how to apply them to captured images).

While the Measurement dialog is open and after a measurement is applied to the image, you can choose to Export the Measurement. Please see Ch. 4 – SPOT Advanced Viewing and Editing Image Documents for details.

There are two methods for applying Live Image Measurements to a captured image, the option you choose will mostly depend on whether your sample is moving or not.
For moving specimens, capturing the specimen before it moves out of the field of view and freezing its motion during the measurement process is of primary importance. To achieve this, the user should select the Pause button at the bottom of the Live Image window when the specimen is in an acceptable position. This will freeze the Live Window Image then the Measurement button should be selected, measurements made, and the dialog closed. The final step is to select the Transfer button at the bottom of the Live Image Window. This will Transfer thePaused Live Image to a Captured Image Window allowing for its further editing, annotation and saving.

Note: If the user transfers the image prior to the closing the measurement dialog the measurements will not be displayed on the transferred image. To display the measurement on the transferred image, first close the Measurement dialog and then click the Transfer button on the Live Image window. Alternatively, the measurements can re-applied to the Captured Image Window using the Add/Edit Measurements feature in the Edit Menu.

For non-moving specimens, Go to the Preferences dialog found in the Setup Menu (below), Select the Image Acquisition pane and check the box for Apply Live Image Measurements to Captured Images.

Note: If no calibration has been saved with the Profile, the default calibration will be ‘Uncalibrated’ and the measurements will be expressed in pixels. Once a Calibration Setup is added to the Image the Measurements will be displayed in the measurement units of the calibration.

Magnifier
This button toggles the magnifier on and off and turns your mouse cursor into a magnifier tool when placed over the image while toggled on. See additional details in this chapter’s Preference section.

Focus Gauge
The Focus Gauge feature is designed to be an aid in focusing the selected region of the Live Image window. As the focus is adjusted at the microscope the blue bar lengthens and shortens showing the current focus level. The red line acts as a high water mark showing the highest level of focus over the last few seconds. Check the box for Show Focus Gauge to activate this feature. See below, Select, for more about the setting the area used for the Focus Gauge.

Acceleration
Acceleration enables you to “speed up” the live image display (higher frame rates) in cases where you are willing to sacrifice some resolution for a higher frame rate. The options available for Acceleration will depend on the camera model you have. Some cameras have a single check box to turn Acceleration on and off while other cameras have a slider control. Moving the slider towards the right increases the acceleration.

Close
Click the Close button to close the Live Image Display window.

Select (Sub-region)
The SPOT software allows for the selection of specific areas of the Live Image to be targeted for various functions. Once you select a function, you can use that region for a specific function.
The rectangular area will be indicated on the live image window in the color associated with the function.

The select dropdown menu will always show the last type of area selection applied. The reset button will reset that indicated area type. Once selected, the reset button will change to Reset All if other area selections had also been applied to the Live Image. This will allow you to clear all selections.

If you would like to remove only one specific selection area type, choose that type from the dropdown menu, then select the reset button again.

These functions include the following:

**Imaging**

This function allows the user to select the area of greatest interest within the Live Image. This function will automatically reset the Live Image window to the image area selected.

**Spot Metering**

Using the Spot Metering function allows you to select a sub-region of the Live Image to use in determining auto-exposure settings. See more about the Spot Metering feature in earlier in this chapter.

**White Balance**

If you would like to select a subsection of the Live Image to use in determining the white balance values, use the White Balance function to select the area. See more about White Balance earlier in this chapter.

**Histogram**

The Histogram function allows you to select a subsection of the Live Image to use when monitoring Live Window Histogram values. See more about the Histogram above and in Ch. 4 – SPOT Advanced Viewing and Editing Image Documents.

**Focus**

You can fine tune where the Focus Gauge calculates the focus from by selecting a sub-region of the Live Image. Select the Focus function to select the sub-region of your choice. See more about the Focus Gauge above in this chapter.

**Live Image Controls**

The SPOT Advanced application’s Live Image Controls are used for scripting the Live Image display of your sample. The settings of the Live Image Controls and those above in the Image Setups are mirrored in a way to offer maximum flexibility over the way you work in SPOT.

Some SPOT users will want their Live Image Controls to script their Live Image as well as their captured image so that what you see in the Live Image is exactly what you will see in the captured image. This behavior is achieved by Linking all of the Live Image Controls to the Image Setup. The settings in the Live Image Controls will take precedence over any like setting in the Image Setup. This can be visualized by the graying out of the feature in the Image Setup dialog.

Other SPOT users will want their Live Image Controls to only be used for their Live Image and have a separate set of parameters for their captured images. Unlinking the Live Image Controls from the Image Setup will provide the opportunity to set different values for like features in the Image Setup compared to the Live Image Controls.
Exposure

Auto vs. Manual
When you select Auto the camera samples light levels in the image plane (as the initial part of the image capture) and uses the values to calculate the final exposure time.

When you select Manual, you specify the exposure times. This can be done either by entering a value or values.

Color/Monochrome – (available on 3-shot and slider cameras only)
3-shot and slider cameras are able to capture either color or monochrome images by using this feature. The Color/Monochrome setting changes the functionality of the color filter on the camera.

The selection of Color or Monochrome here will change the Filter options listed under the Exposure Window (Below).

Note: On Slider cameras, if you select Color or Monochrome, the software does not change the position of the filter: this must be done by physically sliding the filter of the camera to the desired position. See the Preferences section of this chapter for tips on setting helpful hints about the camera’s slider position.

Filter Color and Order (available only when Color is selected above)
SPOT Slider and 3-shot cameras use a liquid crystal filter to capture the red, green, and blue data for each pixel. For a color image, you can select between using all three colors, or combinations of only two of the colors. Most color imaging will be best suited by using all three colors of the color filter. However, there may be situations where not all colors are present in the sample and using fewer colors may help shorten the exposure time.

Additionally, you can designate which order the color filter should cycle, thus affecting which color data is acquired first, second and last. This can be useful when you are using a 3-shot camera for fluorescence work and you have a quenching sample with two or more fluorophores. If one fluorophore is brighter than the other, i.e. if the DAPI stain is brighter than Texas Red, you may want to use the Blue state of the color filter before the Red state of the color filter so that you get the best images with the shortest exposure times. In this case, select the drop down choice of BR to expose the blue state of the filter first, followed by the red state.

To ensure a high image quality, SPOT users should select the color that is closest to the color of the specimen. For example, if you are looking at a single stained fluorescent sample, selecting the color filter that most closely matches the color of the stain shortens the time it takes to acquire the image.

Note: If you have a slider camera and are using single-pass fluorescence cubes, you should not use the color filter for your fluorescence work. You should use the Monochrome setting and uncheck the option to Use Filter in order to use the monochrome state of the camera. The color filter absorbs a considerable amount of light before it can reach the imaging sensor. Typically, when imaging a fluorescent sample you want as much of the light to reach the imaging sensor as possible. In these cases, the slider is moved into the B/W (black/white, or monochrome) position.
Use Filter (only available when monochrome, above, is selected on a slider camera)

The option to Use Filter is only available when a slider camera is being used and the selection of Monochrome has been made, above. While using the color filter in a monochrome setting, you can only select one color filter state; either Red, Green, Blue, or Clear. The Clear mode is only available on certain camera models.

The Use Filter option does not change the position of the filter; this must be done by physically sliding the camera’s filter to the Color position. See the Preferences section of this chapter for tips on setting helpful hints about the slider position.

Uncheck the option to Use Filter if you would like to take a monochrome image without the color filter in the light path. This is the recommended setting for most fluorescent imaging applications. See Note above.

Filter Color – without an Order option (only available when monochrome, above, is selected on a 3-shot camera)

The option to select the Filter Color is only available when a 3-shot camera is being used and the selection of Monochrome has been made, above. While using the color filter in a monochrome setting, you can only select one color filter state; either Red, Green, Blue, or Clear. The Clear mode is only available on certain camera models.

Binning

Binning is a pre-exposure option that tells the camera to combine adjacent pixels on the CCD chip. The camera treats each set of combined pixels as one large pixel. The large pixels accumulate electrons faster and are therefore more sensitive to light. Binning has three effects on image processing:

- Light sensitivity is increased.
- Download time is decreased.
- Resolution is decreased.

Binning is particularly helpful when you want to drastically reduce exposure and download times for dim images and you don’t mind a decreased resolution. This gives you higher frame rates and less noisy images. The SPOT camera offers different binning options depending on the model of the camera.

Note: If you bin with a color mosaic camera, the color information will be collapsed and the image will appear monochrome.

Specific to Auto-Exposure:

Image Type

An Image Type tells the SPOT program how to expose image captures. Each of the 11 available Image Types corresponds to a microscopy technique: select the Image Type that matches the technique you are using. The camera will compute exposures and capture the image accordingly. The table below describes typical situations for each image type.

<table>
<thead>
<tr>
<th>Image Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brightfield-reflected light</td>
<td>Polished metallurgical specimens and semi-conductors using a microscope with a vertical illuminator.</td>
</tr>
</tbody>
</table>
Spot Software User Guide

Section III – Ch. 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu

<table>
<thead>
<tr>
<th>Brightfield-transmitted light</th>
<th>Stained specimens on glass slides using transmitted light microscopes.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Darkfield-reflected light</td>
<td>Bright areas of specimens being viewed with darkfield, reflected light techniques.</td>
</tr>
<tr>
<td>Darkfield-transmitted light</td>
<td>Bright specimens on dark backgrounds using transmitted light darkfield technique.</td>
</tr>
<tr>
<td>Fluorescence</td>
<td>Fluorescence specimens fluorescing in a single red, green, or blue primary color</td>
</tr>
<tr>
<td>Nomarski DIC/Hoffman</td>
<td>Specimens being viewed with either Nomarski DIC or Hoffman techniques.</td>
</tr>
<tr>
<td>Phase contrast</td>
<td>Specimens being viewed using the phase contrast technique.</td>
</tr>
<tr>
<td>Polarized light</td>
<td>Specimens being viewed with polarized light techniques.</td>
</tr>
<tr>
<td>Stereo/macro-metallic glints</td>
<td>Metallic specimens with intense glints.</td>
</tr>
<tr>
<td>Stereo/macro–no glints</td>
<td>Matte specimens without bright glints.</td>
</tr>
<tr>
<td>Stereo/macro–shiny glints</td>
<td>Shiny or wet specimens with bright glints.</td>
</tr>
</tbody>
</table>

**Brightness**

The Brightness control allows you to overexpose or underexpose (darken or lighten) the image area. A brightness value of 1, the default value, gives you the correct image brightness for most images. In many cases, an image has varying levels of brightness; to see a specific area better you might want to lighten or darken the image. When using the Brightness control, the SPOT camera uses an algorithm that combines gain and exposure time to provide the fastest possible frame rate in live mode:

- When overexposing images to make them brighter (i.e., entering values between 1.01 and 34), the camera first selects the highest possible gain before lengthening the exposure time. Because gain also brightens an image, less exposure time is needed.
- When underexposing images to make them darker (i.e., entering values between 0.24 and 0.99) the camera uses the lowest possible exposure time before lowering the gain.

**Gain Limit**

Normally an auto exposure routine in a digital camera sets the exposure time so that the brightest pixel on the CCD chip is completely “filled” with electrons, or is “full well”. This simple technique works well for bright images, but as an image gets dimmer, exposure times can get uncomfortably long. With the SPOT camera, you can shorten exposure times by filling the brightest pixel on the CCD to less than full well, and then using this lower level as full scale. The inverse fraction of full well that the brightest pixel on the CCD is filled to is known as the gain. For example, filling a pixel to half of full well cuts the exposure time in half. Since the exposure time is cut in half, we call this a gain of 2.

The Gain Limit feature allows you to set an upper limit on the gain options that will be available during the Auto-Exposure process.

For example, with a Gain Limit of 32 the camera can “choose” from a range of gain options. However, if you find that gains of 16 or 32 are too noisy for your images, you can prevent the camera from selecting these options by setting the Gain Limit to 8. When the Gain Limit option is set to 8, the camera is limited to the lower four gain options: 1, 2, 4, or 8. The following table illustrates levels of gain, the fraction of full well that the brightest pixel is filled to for each level, and a sample exposure time for each level:

<table>
<thead>
<tr>
<th>Gain</th>
<th>Fraction of Full Well</th>
<th>Exposure Time (sample)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>80 seconds</td>
</tr>
</tbody>
</table>
The table below summarizes the relationship between exposure time, background noise, and gain.

<table>
<thead>
<tr>
<th>Gain Limit</th>
<th>Possible Auto – Gain Settings</th>
<th>Exposure Time (dim images)</th>
<th>Background Noise (dim images)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>Longest</td>
<td>Lowest</td>
</tr>
<tr>
<td>2</td>
<td>1, 2</td>
<td>↑</td>
<td>↓</td>
</tr>
<tr>
<td>4</td>
<td>1, 2, 4</td>
<td>↑</td>
<td>↓</td>
</tr>
<tr>
<td>8</td>
<td>1, 2, 4, 8</td>
<td>↑</td>
<td>↓</td>
</tr>
<tr>
<td>16</td>
<td>1, 2, 4, 8, 16</td>
<td>↑</td>
<td>↓</td>
</tr>
<tr>
<td>32</td>
<td>1, 2, 4, 8, 16, 32</td>
<td>↑</td>
<td>↓</td>
</tr>
<tr>
<td>64</td>
<td>1, 2, 4, 8, 16, 32, 64</td>
<td>Shortest</td>
<td>Highest</td>
</tr>
</tbody>
</table>

To set the Gain Limit, follow these steps:
1. Ensure that the camera is set to use the Auto-Exposure option.
2. Click on the Gain Limit select list, and select the number that you want to limit the gain to.
For more information on the concept of gain, refer to Appendix A: Electronic Imaging Theory and the SPOT Camera.

Auto Brightness

Live Image Auto-Brightness is a feature that will recalculate brightness levels automatically. This feature is useful when you are changing objectives or changing between brighter and darker samples because the software will automatically recalculate the proper exposure based upon the brightness level as opposed to you clicking on the Live or Recompute Exposure (see below) buttons. Live Image Auto-Brightness is only available when you are using Auto exposure and viewing a live image.

Maximum Exposure

The Maximum Exposure setting allows you to set the maximum exposure time that is allowed while using the Auto Exposure feature. Computed auto exposures that would require an exposure time that exceeds this limit will result in an Image Too Dim error message. This allows you to configure what exposure time is considered out of range for the type of imaging you are performing.
Without this setting the software could try to calculate a multi-hour exposure due to the common user error of not having the microscopes light path selector to send light to the camera. Typically the value is set to between 1-2 seconds for brightfield and bright fluorescence images. Longer exposures may benefit from manual exposure setting or test bracketing of sample specimens.

The range of valid values is dependent upon the type of camera you are using.

Specific to Manual Exposure
Exposure Time(s)
Photographically speaking, an exposure is the total amount of time that light is allowed to hit the imaging sensor before it is read out by the camera. The exposure of the image can be manipulated by adjusting the Exposure Time to suit your needs. Use the slider-bar or type in a value to specify an exposure time and adjust as needed.

Individual exposure times will be available for Red, Green and Blue if your camera is a 3-shot or slider style camera. If you are using the White Balance feature of the SPOT Software to provide properly balanced images, you will want to lock the exposure ratios by ensuring that the graphic lock is closed. Click on the lock graphic to toggle the lock on and off. With the exposure ratios locked, typing in a new exposure value for one value, i.e. Red, will automatically cause the other two values to be updated with respect to their white balanced ratio.

Note: if the lock is opened for the exposure times, adjusting one color will skew the white balance of the image. To regain proper balance, re-lock the lock and perform a new White Balance. See Ch. 3 – SPOT Advanced Image Captures and the Camera Menu for more about the white balance feature.

Gain
When you define your own Exposure, you can enter the precise gain that the camera will use for an image capture. You can manually enter the gain value by using the slider bar to make your selection. The gain value displays to the right of the slider-bar.

To read more about Gain and what it is used for, please refer to the previous section about Gain Limit.

Imaging Area
Area
SPOT allows you to use any rectangular portion of the CCD chip for image capture.
Using a portion of the chip is helpful in cases where you want to:
- Increase the live preview or captured frame rates
- Keep file sizes small.
- Shorten download times.
- Avoid areas of the image with optical problems (e.g., vignette areas).

The following are the options available:

Full Chip
In order to obtain the largest field of view, use the option Full Chip. This will capture an image using the entire area of the sensor.

Selection
Capture a specific part of the sensor that you designate with the cursor. To set the area, use the Select button on the Live Image Window, choose Imaging Area and click and drag the region on the Live Image. See above in this chapter for additional details on the Live Image Window. Once a selection has been made, choosing Selection will automatically change the displayed image to reflect the selection.

**Center %**

Capture a rectangular part of the sensor’s area that has the same height - to - width ratio as the full chip, and is centered on the center of the full chip. The percentage that you enter is the percentage of full chip width that the new area’s width will be.

**Constrain Aspect Ratio**

This option is only available if you are using the Center % of the sensor (above).

With this selection activated, the percentage of the chip will be used to capture an image at the specified aspect ratio in the Image Setup. See the Image Setup section (above) in this chapter for details.

**Area from Image Setup (only available if unlinked)**

The Live Image Controls take precedence over the Image Setup’s settings, so if you would like to have an imaging area used for your Live Image which has been set in your Image Setup, you can Unlink the Link for the Imaging Area section of the Live Image Controls and then select the button to use an Area from Image Setup as the imaging area for the Live Image display.

**Always Display Full Chip Area**

The option to Always Display Full Chip Area ensures that you will always see the Full Chip view when viewing a live image. Keep in mind that the selection that you make here determines how the live image displays when viewing a region of the chip.

**Enhancements**

**Correct Colors**

The Correct Colors option utilizes camera dependent color correction profiles that optimize the matching of colors between your microscope specimen, the live image you view on the screen of your monitor, and the image you capture with your SPOT camera. This is done by transforming the raw camera color data and allowing it to be adjusted to display the closest approximation of the same color on your monitor.

In order to get the best results using this feature, you should make sure you set up your imaging system including your computer monitor appropriately. See Appendix C: Correct Color Technology for more information on system set-up.

---

**Note:** Color correction transformations that occur when you use Correct Color Technology will be applied to the raw image data, leaving a modified image file. If you will require the raw data for further analysis of your image, you should uncheck the Correct Color Technology checkbox.

Turning on Correct Colors enables the following additional color space manipulations: Contrast, Saturation, and Color Temperature.

---

**Note:** If your camera is a three-shot or slider version, Correct Color Technology will only be available in the Image Settings window if RGB is set as the filter color.
**Use Defaults**

The **Use Defaults** button will reset the values for Gamma, Contrast, Saturation and Color Temperature to their original default positions of 1 for Gamma, 0 for Contrast and Saturation and 5000K for the Color Temperature. This button may be useful if multiple adjustments have been made to these settings and you would like to start over with a fresh, un-adjusted image. Each of the features is discussed in further detail below.

**Gamma**

Gamma adjustments are nonlinear operations which smoothly lighten darker areas of an image without burning out bright areas or lightening black areas. This is especially useful for capturing/editing images with a wide range of brightness values (dynamic range) such as fluorescence specimens or macroscopic objects with glints, (e.g., printed circuitry).

When the bright areas of these types of images are correctly exposed, the darker areas can be so dark that they are in effect invisible. Gamma Adjust can remedy this problem. The figures below illustrate the effect of a gamma adjust on a fluorescent image. The image on the left is the original image prior to the gamma adjustment. The image on the right has been gamma adjusted to a value of 1.75. In this instance, the gamma adjustment results in a better display of detail by lightening the darker areas without burning out bright areas or lightening black areas:

![Fluorescence image, no gamma adjustment](image1)

![Fluorescence image, gamma adjusted to 1.75](image2)

In the SPOT Software:

- Values between 1 and 4 lighten the darker areas of the image.
- Values between .1 and 1 darken the brighter areas of the image.
- Refer to Ch. 4 – SPOT Advanced Viewing and Editing Image Documents for more details on gamma adjustment and color spaces.

**Contrast (only available when Correct Colors is enabled)**

Contrast is the degree of difference between the brightest and darkest parts of an image. If you would like to exaggerate the differences between bright and dark areas in an image, adjust the Contrast slider to the right to a level which looks suitable to you.
**Saturation (only available when Correct Colors is enabled)**

Saturation refers to the dominance of hue in a color. Colors which are not fully saturated will be more grey, or pastel, and colors which are fully saturated will be richer in color (hue). Move the Saturation slider to the right if you want to increase the richness, or to the left to decrease the richness of the colors in the image.

**Color Temperature**

The Color Temperature slider (in Kelvin) is available for users to match the display of their images with their source illumination's color temperature. Below is a list of some general color temperatures for typical light sources. Keep in mind these are averages or ranges and your individual bulb may differ. For the best accuracy, check the specification on your light bulb for the color temperature in degrees Kelvin.

For example, if you are using a Halogen bulb without a daylight blue filter in the light path, adjust the slider for **Color Temperature** to 3200K to best match how the software will display your image with what you see at the eyepieces. See the table below for a list of commonly available light sources and their range of typical color temperatures.

<table>
<thead>
<tr>
<th>Type of Bulb</th>
<th>Typical Color Temperature (K)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Incandescent</td>
<td>2800 – 3400, varies with voltage setting on microscope</td>
</tr>
<tr>
<td>Halogen</td>
<td>3200</td>
</tr>
<tr>
<td>Direct Sunlight</td>
<td>5000</td>
</tr>
<tr>
<td>Mercury</td>
<td>5000 - 6000</td>
</tr>
<tr>
<td>Zenon</td>
<td>6000 - 6200</td>
</tr>
</tbody>
</table>

**Image Display**

**Display Images in Grayscale (3-shot and Slider cameras only)**

Grayscale imaging provides a “Black and White” version of your colored monochrome image. This feature provides a higher contrast, more easily visualized version of colored fluorescence images. The reason the human eye can visualize grayscale images better than monochrome color images is related to the fact that white light stimulates all three color receptors in the eye, providing higher perceived brightness and resolution. Use the **Display Images in Grayscale** to use this feature.

**Indicate Saturated Pixels**

For monochrome cameras, or color cameras in monochrome mode (i.e. color mosaic using binning), this feature will be available. If you select it in the live image controls window, saturated pixels will appear as red in the live image window. You can then adjust the brightness setting (auto exposure) or the exposure time setting.
Calibrations

The SPOT program allows you to create calibrated images. Calibrations facilitate the SPOT Measure, Reticle and Calibration Mark Features. Multiple calibrations can be made to accommodate the multiple magnifications available on your imaging system.

There are two types of calibrations available, Calculated and User-Defined.

The Calculated Calibration type is generally used when only an approximate order of magnitude reference mark or measurements are needed. They are the easiest to make and will be sufficient for many applications.

The User-Defined Calibration type is generally used when quantitative data is required. They are derived from an empirical measurement of a known reference standard and therefore compensate for production variations that are a source of error in the Calculated calibrations.

Note: A few remaining errors that need to be considered for any serious quantitative work are optical distortion of the imaging system and operator repeatability and reproducibility.

This section discusses the setup of calibrations; please refer to Ch. 4, SPOT Advanced Viewing and Editing Image Documents for more information on assigning calibrations, as well as using reticles, calibration marks and measurement functions.

Creating a Calculated Calibration

To setup a Calculated calibration, follow the steps below.

1. From the Setup Menu, select Calibrations. The Calibration Setup Dialog will be displayed.

2. For a new calibration, choose Add, or for an existing calibration you can select Modify.

3. The Calibration Editor dialog appears (see right).

4. Enter a name for the calibration if the calibration is New. Typically either the objective magnification or zoom level magnification is used, in this example, 10X.

5. Select the Calculated setting.

6. Enter the objective, adapter, and auxiliary/body magnifications into the Objective, Relay and Other fields, respectively. Note that missing or no lens elements should be set to 1.

7. Select the standard units you require from the drop down and the SPOT program will calculate the appropriate calibration in the units you specify for the camera you have connected. If the units you desire to use are not available, you can type it into the entry field too.
Section III – Ch. 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu

**Note:** Calculated Calibrations are, in reality, mathematical estimates based upon the accuracy of the values input by the user. Because there may be tolerances to consider on any optical element in the system, or simply inaccuracies between “nominal” and actual values, the resulting calibration should be close, but is not a true calibration. For exacting work, it is best to manually calibrate your optical system by following the directions in the User-Defined calibration method.

**Creating a User-Defined Calibration**

To set up a User-Defined calibration, you will need a base image to use for the calibration. You can either use a captured image or the Live Image as the base image. If you have a captured image and the Live Image open, both options will be available to you (below), otherwise only the option available will be listed in the Calibration Editor dialog (below). Note, before you begin these steps you must have either the Live Image open or a captured image displayed.

To begin:
1. Place a stage micrometer under the objective.
2. Use the Live Image preview to adjust the microscope to display as much of the stage micrometer as possible and align the stage micrometer square to the field of view. Refer to Chapter 3 – SPOT Basic Image Captures and the Camera Menu for details on using the live image display.
3. You can either work off of the Live Image or you can capture an image of the stage micrometer. Refer to Ch. 3 – SPOT Advanced Image Captures and the Camera Menu for details on capturing images.
4. From the Setup menu, select Calibrations. The Calibration Setup dialog appears (see right).

**Note:** Set the zoom level to an appropriate level on either the Live Image or the Captured Image prior to proceeding to the next step. Once the Calibration Editor dialog opens, the zoom level of the image will be locked. If the Live or Captured image is open with the pan window enabled and the zoom is on, the image will scroll as you draw your line (step 8) thus making for more accurate placement of the cursor on the image pixels. (See Ch. 3 and 4 of this section for more information about using the Zoom options in the Live and Captured images, respectively.

5. Click on Add. The Calibration Editor dialog appears.
6. Enter the name of the calibration setup. Typically this corresponds to the magnification of the objective (e.g., 10x).
7. Select the User-Defined setting.
8. Using the mouse, draw the calibration line along the length of the stage micrometer image. When you draw the line, keep these guidelines in mind:
   - Keep the line as straight as possible.
   - Make the line as long as possible.
   - Use the largest unit of measurement that the micrometer allows for.

To draw the line, follow these steps:
   - Position the crosshair cursor over the stage micrometer mark that represents the start point of your calibration line.
• Left click on the mouse.
• Drag the cursor to the stage micrometer end mark
• Left click on the mouse again.
  The length of the line in pixels appears on the Calibration Setup window.

To adjust the start or finish points of the calibration setting line, click and drag the edit
handles at either end of the line.

To redraw the calibration setting line, click on the line to select it and press the delete key.
You can then redraw the line.

9. Enter the length and units of the line that you drew.
10. Click on OK.

This magnification setup is now calibrated and you are ready to perform measurements. Repeat
steps one through ten for each optical magnification.

Importing and Exporting Calibrations
You can move your calibration setups to and from another computer.

To export calibration setups, follow these steps:
1. Choose Calibrations from the Setup menu.
2. Highlight the calibration setups that you would like to export. To select multiple calibration
   setups, hold down the Control button while selecting them.
3. Click on Export.
4. Select a File name and location and choose Save.

To import calibration setups, follow these steps:
1. Choose Calibrations from the Setup menu.
2. Click on Import.
3. Select the calibration file that you would like to import. This will be a file of type SPOT Export
   (spx).
4. Choose Open. The calibration setups will appear in the Import menu.
5. Select the calibration setups that you require and choose Import.

The calibration setups will now be available for you to use.

Reticles
Reticles are calibrated geometric image overlays that are used as a comparison reference for
sizing, qualifying (Go/No-Go) or counting objects in the underlying image.

Reticles are available for use on both Live and Captured Images. They are easily generated and
customizable. Reticles provide objects such as cross-hairs, rulers, grids, concentric circles or
rectangles, and allow for the combination of several different reticle objects into one reticle setup.

There are two steps to implementing reticles:
1) Creation of the Reticle Setup
2) Linking a Reticle Setup to an Image Profile.

The following section will cover the creation of Reticle Setups. For details on Linking a Reticle Setup to an Image Profile, see Chapters 2 and 4 of this section.

Creating a reticle

To create a new reticle or to Modify an existing reticle, follow these steps:

1. From the **Setup** menu, select **Reticles**.

2. The **Reticles** dialog box will appear. Click the **Add** button to create a new reticle. If you would like to modify an existing reticle, click on the name of the reticle and click the **Modify** button to modify it.

3. The **Add/Modify Reticle** dialog box will appear which will ask if you want to create your reticle based upon a **Currently Open Image** (only available if an image is open) or if you want to use a **Blank Image**.

   Select **Currently Open Image** to use an actual image on which to base your reticle. Select the appropriate image title from the pull down list and click **Ok**.

   Select **Blank Image** if you would like to create reticles on an empty, grey image document. Set the blank image’s dimensions in pixels and then provide it with an appropriate calibration if available. The check box to **Display in Fit to Window Mode** is checked by default, which allows you to see the entire image within the image document window. Click on **Ok**.

   **Note:** If no calibration is assigned to the Currently Open Image or the Blank Image, you can still create and apply a reticle, but the reticles will not have a unit of measurement associated with them. Later, if an uncalibrated image with a reticle applied is assigned a calibration, the units will adjust accordingly.

4. The **Reticile** dialog box will appear which has all the tools for specifying which objects you would like in each reticle file you create. One reticle file may contain as many objects as you would like. Select the type of reticle object you want by clicking on the appropriate object button.

**Reticle Objects**

**Select Tool**

The Select Tool enables cursor based manipulation of reticle objects using their edit handles. When this tool is active, use your mouse to click on and select an object. Once active, edit handles appear as small white and yellow features attached to reticle objects. Edit handles will typically allow you to free hand resize, rotate or reposition an object. More precise object manipulation can be achieved selecting an object and then typing in desired dimensions to the control fields for that object. (See the following sections)
To select multiple objects, hold the *Control* button while you click or, if you click and drag the cursor across reticle objects while, all objects which fall in the highlighted region will be selected. When multiple objects are selected, changes made to available settings will affect all objects.

**Line**

Use the Line Reticle element to create a horizontal and/or vertical line on your image.

Set the *Line Thickness* and *Color* to be applied to the lines of the reticle. Type in the thickness value or use the up and down arrows to set the thickness. Click on the *Color* button to open the *Select Color* dialog.

Check the box to *Show Text* if you would like to display the numerical units for the ruler marks. Use the *Font* button to pick the font characteristics you would like to use. Use the pull down list to select the number of *Decimal* places you would like displayed.

Choose whether you want *Horizontal* and/or *Vertical* Lines by selecting the appropriate check boxes. Each line’s individual characteristics can be set. Choose a *Length of Image Width/Image Height* to fill the entire width/height of an image with the horizontal or vertical line. Alternatively, set the length of the line by typing in the number of units you wish to display.

Select whether or not you want to display *Major* or *Minor Ruler Marks* and set the spacing for the major ruler marks.

You can also choose to start the numbering from *Left* or *Center* for *Horizontal* lines and the *Top* or *Center* for *Vertical* lines.

Adjust the placement of the reticle object by typing in X,Y coordinates, or use the *Center on Image* button to have the reticle centered.

The angle of the line can be set by providing a value in the *Rotation* input box. Either type in a value, or use the up and down arrows. Values from -180 to +180 degrees are valid.

**Rectangle**

Use the Rectangle Tool to place one or multiple concentric rectangles on your image.

Set the *Line Thickness* and *Color* to be applied to the lines of the reticle. Type in the thickness value or use the up and down arrows to set the thickness. Click on the *Color* button to open the *Select Color* dialog.

Check the box to *Show Text* if you would like to display the numerical units for the lengths of the rectangle. Use the *Font* button to pick the font characteristics you would like to use. Use the pull down list to select the number of *Decimal* places.
you would like displayed.

Set the Initial Size of the Rectangle to be displayed. Units will be displayed according to the base image’s specified calibration units.

Specify a set number of rectangles to be displayed on the image, or check the box to Fill the Entire Image with rectangles and set the Height/Width increment to be used. The units displayed will be based on the calibration of the base image.

The angle of the rectangle(s) can be set by providing a value in the Rotation input box. Either type in a value, or use the up and down arrows. Values from -180 to +180 degrees are valid.

**Circle**

Use the Circle Tool to place one or multiple concentric circles on your image.

Set the Line Thickness and Color to be applied to the lines of the reticle. Type in the thickness value or use the up and down arrows to set the thickness. Click on the Color button to open the Select Color dialog.

Check the box to Show Text if you would like to display the numerical units for the diameter of the circle. Use the Font button to pick the font characteristics you would like to use. Use the pull down list to select the number of Decimal places you would like displayed.

Set the Initial Size of the Circle to be displayed. Units will be displayed according to the base image’s specified calibration units.

Specify a set number of circles to be displayed on the image, or check the box to Fill the Entire Image with circles and set the Diameter increment to be used. The units displayed will be based on the calibration of the base image.

**Grid**

Use the Grid Tool to place a defined grid pattern over an image.

Set the Line Thickness and Color to be applied to the lines of the reticle. Type in the thickness value or use the up and down arrows to set the thickness. Click on the Color button to open the Select Color dialog.

Define the Grid dimensions by selecting the number of Rows and Columns for the reticle. The number can be an exact value or you can select to Fill Image Height or Fill Image Width. The Row Height and Column Width can also be set. Units displayed will be according to the base image’s specified calibration.
Choose between Row and Column Labels of None, Numeric, Alpha, or Roman. The direction of the label can be set to start from Top or Bottom for the Rows and from the Left or Right for the Columns. If preferred, you can turn off the Row and Column size labels by un-selecting the box for Show Grid Size.

5. Once you have selected the first Reticle object, click on the base image to place the reticle object.

6. The placement of the reticle object can be manipulated by moving the cursor over a line of the reticle, and clicking and dragging when the mouse cursor changes to a crosshair. Alternatively, once a reticle object has been added to the base image, the placement can be adjusted by using the discrete, type in values for the x, y coordinates of the center of each reticle object or by simply clicking the Center on Image button to center the reticle object.

7. If you need to start over, you can use the Delete button to erase the highlighted and active reticle object or the Delete All button to delete all reticle objects on the base image.

8. Provide a Name for the Reticle and click on Ok.

9. The reticle will now be available for adding to images. See Ch. 4 – SPOT Advanced Viewing and Editing Image Documents for more information on how to add a reticle to an existing image or above in this Chapter’s Image Settings section for how to apply reticles to Live and Captured images.

Note: When manually entering X, Y coordinates, be advised that (0, 0) is the top left corner.

Palettes

The Palettes option on the Setup menu allows you to define new palettes and edit existing palettes. SPOT color palettes allow you to apply specific hue and saturation values to monochrome images. Palettes are useful in fluorescence applications where a sample is fluorescing at a single wavelength, and you want the acquired image to have the correct color. For such a case, you could create a palette to represent the color of the fluorescent dye and then apply that palette to the captured image. There are two ways to apply a palette to an image:

- You can associate a palette with an Image Setup, as discussed in earlier in this chapter.
You can apply a palette to a captured image by selecting the **Set Palette** option from the **Edit** menu. Refer to Ch. 4 – SPOT Advanced Viewing and Editing Image Documents for more details.

To define a new palette, follow these steps:

1. From the **Setup** menu, select **Palettes**.
2. Click on **Add**. The Color Palette dialog appears as shown here:
3. Either use the **Wavelength or Hue** and **Saturation** selection lists or move the cross-hairs on the color wheel to enter the values.

**Wavelength** allows the user to specify the exact wavelength ranging in value from 400nm to 700 nm. Wavelengths will automatically correspond to various Hues at full (100%) saturation. **Hue** is the designation for the actual color, as distinguished from others in the color spectrum. Hue is derived from the color wheel and is expressed in the color's angular location (in degrees) on the wheel. (e.g., 0° to 360°).

**Saturation** is the proportion of perceived pure hue in the color. Saturation (in the SPOT software) is measured on a numerical scale of 0 to 100, where zero is pure gray and 100 is pure hue (e.g., day glow).

4. Click on **OK**.

You can move your palettes to and from another computer. To import palettes, follow these steps:

1. Choose **Palettes** from the Setup menu.
2. Click on Import.
3. Select the palette export that you would like to import. This will be a file of type SPOT Export (spx).
4. Choose Open. The palette export will appear in the Import menu.
5. Select the palette export and choose Import. The palette will now be ready for you to use.

To export palettes, follow these steps:

1. Choose **Palettes** from the Setup menu.
2. Select the palettes that you would like to export. To select multiple palettes, hold down the Control button while selecting them.
3. Click on Export.
4. Select a File name and location and choose Save.

**Taskbars**

The taskbar option, when selected, will open a taskbar development window, allowing the user to add, modify, or delete taskbar buttons from the floating taskbar. Please see Ch. 5 – SPOT Advanced Taskbars for a detailed discussion regarding the development and use of the timesaving Taskbar feature.
Custom Variables

Custom Variables can be useful in situations when you need even more flexibility with creating automation than is available from the standard set of variables in the SPOT Software. Variables, in general, are used within macros to help automate repetitive tasks.

When Custom Variables is selected from the Setup Menu, the Custom Variable List Dialog appears. From here you can Add, Modify, Delete, Import or Export Custom Variables.

Click on Add to create a new Custom Variable. The Custom Variable Editor Dialog will open.

The following options are available for defining each Custom Variable.

Name
Enter a title for the Custom Variable so that it can easily be identified amongst other variables. The Name can be up to 30 characters.

Data Type
Choose the appropriate type of variable from the following options:

Text
Text variables are stored text strings which can be used for display purposes throughout various locations in the SPOT Software.

Numeric
Numeric variables are stored values which can be used for mathematical computations in various locations throughout the SPOT Software.

Boolean
Boolean variables are stored values for assigning if something is True or False, On or Off, etc. for use in various locations throughout the SPOT Software.

Preserve File Path Delimiter Characters (only available for Text Data Type Variables)
Normally, the SPOT Software will replace special characters such as ‘: / \ ‘ with spaces or dashes. If a Text Variable is to be used as part of a file path, these special characters play an integral part in finding and/or creating the appropriate file path. In these cases, use the check box to Preserve File Path Delimiter Characters in order to maintain the appropriate file path.
Image Metadata

In order to create custom Image Metadata, you must do so using the Custom Variables and assigning the variable to be available for Image Metadata. Learn more about Image Metadata and using Image Metadata variables in the Image Setup section of this chapter.

Source Variable (only available if Image Metadata is selected)

The Source Variable option is available only when Image Metadata is selected. The Source Variable is the variable from which the Image Metadata obtains its value. In this way, the Source Variable can be used as a dynamic variable which is then assigned to an Image Metadata variable. The Source Variable would be set at another location in the SPOT Software.

Image Sequence Index (only available if Image Metadata is selected)

The Image Sequence Index field is available for ordering images within an image sequence.

Enumeration (only available for Text and Numeric Data Types)

Enumeration variables are useful when a pre-determined list of values are desired from which the appropriate value will be selected. Examples of when someone may use enumeration variables would be for selecting microscope objective magnification or user names.

Show in Variables Window (only available if Image Metadata is not selected)

When there has been extensive programming with the use of macros and custom variables, the list of variables may grow to be rather long and large. A list of all variables (standard and custom) and their current value, or content, are viewable from the View menu by selecting Show Variables. If you need to see a custom variable’s content in this display, you can check the box to Show in Variables Window. Otherwise, if this check box is left unchecked, the variable will not be displayed with all the others.

The option to use a Custom Variable will be available in many different places throughout the SPOT interface, including Custom Dialogs, Taskbars, Macros, etc.

You can read more about macros and the use of variables in Ch. 6 – SPOT Advanced Macros.

SPOT Users and Change Password

SPOT Users

Many of us like to have our computers and desks arranged in a certain way with our most used items at our fingertips and we like it when we come back to our desk and things are where we left them. With the SPOT Users feature, you can have everyone in your facility set up with their own SPOT User account so that everyone can have their favorite and user specific Image Setups, Palettes, Taskbars, Calibrations, Reticles, Custom Variables, and Preferences.

Having multiple SPOT Users means that when User A creates an Image Setup, or any of the items listed above, these items will only be available for their own use. When User B logs on to SPOT, all of their settings will be recalled and presented for their use.

Until a SPOT User is created, the default setting is for one SPOT User, in which everyone shares everyone’s Image Setups, Palettes, etc.

The SPOT Users menu item is only available when no User accounts have been created for SPOT or if you have an Administrator User account.
To setup SPOT Users, go to the Setup Menu, select SPOT Users and chose from one of the following three options below which are available in the SPOT Users dialog box:

**All Users Share Settings (single SPOT User)**
If there is a single SPOT User, everyone using the SPOT Software will have the same set of Preferences, Image Setups, Palettes, Calibrations, Reticles, Custom Variables, and Taskbars available to them. If custom interfaces for different users or user groups are desired, use one of the options below.

**User Accounts Handled by the OS**
When you choose to have the User Accounts Handled by the OS, the SPOT Software will automatically use the user account which was used to log on to the computer in order to reveal the related Image Setups, Palettes, etc which were created by that user account.

**User Accounts Handled by SPOT**
If you would like for the SPOT Software to handle the SPOT Users instead of the Operating System (above), choose to have the User Accounts Handled by SPOT.

To add SPOT Users, click on the Add button. The SPOT User dialog box will appear and prompt you for the User Name and Password. Additionally, there is a checkbox to enable a user to be an Administrator. Check this box if you want the user to be able to have control over the SPOT User accounts.

When SPOT handles the user accounts, a SPOT logon dialog will appear when you first launch the application with a pull down list of all SPOT users which have been created.

**Change Password**
Once multiple Users have been created, only Administrator level Users will be able to see SPOT Users but everyone has the ability to Change (their) Password. When you click on Change Password, the Change SPOT Password dialog box will open and prompt you for your old password as well as your new password. Click on OK to save the changes.

**Preferences**
Use the Preferences option to specify:
- Application selection (only available with SPOT Advanced installed)
- How new image windows are displayed
- Image window arrangement
- Magnifier settings
- Size of the onscreen toolbar
- Sequential imaging memory settings
- Thumbnail appearance
- Spell checking options
- Shorthand settings
• Image capture settings
• The relative bus width used during image capture (Firewire cameras only)
• File type extension setting (Macs only)
• Temperature readout interval (Xplorer and Pursuit cameras only)
• Image print resolution choices
• Image Cache file path settings
• Helpful messages selection

To open the Preferences window, select Preferences from the Setup menu. Each preference is discussed in detail below.

Application Selection (only available if SPOT Advanced is installed)

The Application Selection pane will only be available to users who have installed the SPOT Advanced Application in addition to the Basic application. There are three options for how to launch the SPOT program if both applications have been installed.

Always run SPOT Basic

If Always run SPOT Basic is selected in the Preferences, every time you click on the SPOT icon on your desktop, the SPOT Basic application will always open without asking for your selection.

Always run SPOT Advanced

If Always run SPOT Advanced is selected in the Preferences, every time you click on the SPOT icon on your desktop, the SPOT Advanced application will always open without asking for your selection.

Ask which application to use

If Ask which application to use is selected, clicking on the SPOT icon on your desktop will launch the application selector dialog for you to make you selection every time you start the SPOT Software.

Image Display

View Mode

The view mode defines how images will be displayed when they are captured. Source Image Size, Display Canvas Size, Zoom Level.

Normal – When selected, images will be displayed and the mouse cursor will function as a selector tool for cropping and setting some regions of interest in image settings.

• Zoom Level – this setting defines the percentage zoom your image will be displayed if Normal or Zoom (below) are selected.

Fit to Window – When selected, the image is sized to fit into the Live Image Window. Choose this setting to provide a full field of view at the maximum size that will still fit into the Live Image Window. In most cases, this will result in the displayed image appearing at lower resolution that what is available in the image. The magnifier can be used to look at image details in this case.
**Fit Height** – When selected, the display zoom level of the image will automatically adjust to the maximum setting which allows the entire image height to be viewable within the display canvas. This may result in unused areas of the Live Image Window or portions of the display screen while in Full Screen mode.

**Fit Width** – When selected, the display zoom level of the image will automatically adjust to the maximum setting which allows the entire image width to be viewable within the display canvas. This may result in unused areas of the Live Image Window or portions of the display screen while in Full Screen mode.

**Fill Window** – This feature will resize the image to entirely fill the preview window or full screen. Note that horizontal or vertical areas of the image will not be seen since they will be out of the image window field of view.

**Zoom** - When selected, any image captured is automatically zoomed to a predefined level and the functionality of the mouse cursor works as a zooming tool. Right-click to zoom in, left-click to zoom out.

- **Zoom Level** – this defines the amount of zoom your image will display if you select the Zoom option or Normal (above).

**Show**

**Annotations** - When selected, any annotations previously added to the image will be displayed upon opening it.

**Calibration Marks** - When selected, any calibration marks previously added to the image will be displayed upon opening it.

**Measurements** - When selected, any measurements previously added to the image will be displayed upon opening it.

**Reticles** – When selected, any reticles previously applied to the image will be displayed upon opening it.

**Enable Pan Window**

When selected, a pan window will open coincident to the captured image. This is useful for navigating captured images when using normal or zoom levels as a preference.

**Auto Arrange Windows**

When selected, each successive image taken will be placed next to the preceding image in a horizontal or vertical orientation. Each image is resized appropriately to show all images.

**Window Arrangement**

Set the number of columns or rows to be allowed when Auto-Arrange Vertically or Horizontally has been selected above.

**Magnifier**

Set the dimension and magnification factor of the magnifier window. Define the magnifier window size in pixels and the magnification with a numerical value.

**Toolbar**

This selection allows the user to specify whether the onscreen toolbar icons in the SPOT program should be shown at all, as well as if they should be displayed in small or large format.
Image Sequences

Memory Usage Limit
Specify how much memory is allocated for image acquisition. Note that the entry parameters are system dependent.

Cache Images During Play
When ‘playing’ an image sequence (see Ch. 8), the SPOT program allows you to select how it loads the displayed images.

If Cache Images During Play is selected…The program pre-loads as many images from the sequence as your computer’s RAM allows. This enables a faster display of the image sequence. But, if you have a sequence with many images, the size of the combined images could exceed the RAM, and in this case, the SPOT program will load as much of the sequence as possible, play that part of the sequence, and then pause to load the remaining images.

If Cache Images During Play is not selected…The program loads each image in the sequence individually. In cases where you have a large sequence with many files, this allows you to work without being restricted by RAM limitations. The display of images will be somewhat slower than a display where images are cached.

Thumbnails
Select a thumbnail size to be used for the Show Image File Thumbnails option. There are four options available from which to choose:

- Small (60 x 60 pixels)
- Medium (90 x 90 pixels)
- Large (120 x 120 pixels)
- User Defined

Minimum width and height = 20 pixels
Maximum width and height = 200 pixels

Secondly, you can specify the resolution of image thumbnails (Show Image File Thumbnails option). Select from one of the following 4 options:

- Small (54 pixels)
- Medium (84 pixels)
- Large (114 pixels)
- User Defined

Minimum resolution = 16 pixels
Maximum resolution = 200 pixels

Spell-Checking
Select whether or not to use the spell checking offered by the SPOT program. You can also select to Add a Dictionary if you have one loaded on your local machine.
Shorthand

If you are typing the same text repeatedly, you may want to use the Shorthand feature. Use the Add button to create a new Shorthand entry where the Key is the shorthand keyed strokes you will type to auto fill the Text entry.

Image Acquisition

**Specify whether you would like to utilize a shutter sound on image capture.**

The Make Shutter Sound option, when checked, will provide a “click” sound during the camera exposure sequence, confirming that the image capture is complete. If the image capture is relatively quick, you will hear a single click. If the exposure is longer (i.e. greater than one second) you may hear a “beginning exposure” click and an “ending exposure” click.

**Apply Live Image Measurements to Captured Images**

Select this box if you would like your Live Image Measurements to appear on your captured images. Read more about the options available for Live Image Measurements in Chapter 3.

**Monitor Color Filter Position for Image Capture (Slider cameras only)**

If this option is selected the SPOT software will produce an error message if the color filter isn’t in the proper position while capturing an image. The Monitor Camera Color Filter Position box is checked by default.

**Monitor Color Filter Position for Live Images (Slider cameras only)**

If this option is selected the SPOT software will produce an error message if the color filter isn’t in the proper position while viewing the Live image. The Monitor Camera Color Filter Position box is checked by default.

**Use Single Channel Readout for Live Images** (Insight, Flex, Pursuit, Xplorer cameras)

Many SPOT cameras normally use two channels to read out their Live Image in order to provide faster focusing. However, with two channels reading out the image, there is a chance for a slight mismatch in the shading between the two sides of the live image display.

To avoid this mismatch, you can choose to readout live images using a single channel, thus eliminating any shading mismatch, but this selection will result in slower effective focusing of the camera.

*Note: All SPOT cameras, except for the Insight Gigabit, always capture images in single channel mode, thereby eliminating any chance of shading mismatch in the acquired images.*

**Bus** (Firewire cameras only)

This setting allows the user to specify the relative bandwidth to be utilized when the camera is capturing and transferring data to the computer. The three choices are High, Medium, and Low.

**Temperature Readout** (Xplorer and Pursuit only)

This option enables the user to specify the time interval between sensor temperature readings in seconds.
Image Print Resolution

This option is available for users who wish to set the print resolution of images in pixels per unit area. For example, a full size image from a SPOT 4Mp camera such as the IN1420 would be 2048 pixels wide by 2048 pixels tall. If you wanted to set the printing size to be 2.048 inches by 2.048 inches, you would set the image print resolution to 1000 pixels per inch. In this way, the larger the number of pixels per inch you select, the smaller the image will print and vice versa.

The Image Print Resolution is used within the SPOT Software’s Print Dialog Editor and is passed with the image information to other image applications such as Photoshop. See Ch. 10 – SPOT Advanced Image Printing for more on the Print Dialog Editor.

The Image Print Resolution set here will affect all images acquired. If you need to change the Image Print Resolution on a single image after it is acquired, you can do so from the Edit Menu. Please see Ch. 4 – SPOT Advanced Viewing and Editing Image Documents for more on this option.

Add Extensions to File Names on Save (Mac)

When selected, the Add Extensions to File Names on Save option automatically appends the file type extension (e.g., JPG, tiff, bmp, etc…) to your image file. This enables cross platform file sharing, because Windows based programs require a file type extension, while Mac based programs do not. Once the file type extension is added, Windows based programs can recognize the Mac file.

Macro

The Macro section allows the user to specify a macro to be played upon startup of the SPOT Application. This option is useful in situations where a macro has been scripted to prompt a user through a set of steps to do their imaging, to initiate a certain set of parameters for an experiment, etc. To maintain portability between computer systems, first set the base File Path (below) for macros. Check the box to Play Macro on Startup and then click on the browse button to select the macro file which you want to play automatically when the SPOT Software is opened.

File Paths

Image Cache File Path

Use this setting to set the path and save cached images to a hard disk instead of RAM.

Base Object Image File Path

Use this feature to set the default file path where Objects which are Images reside on your local computer. This may include object images such as those used in Reports, Annotations, or Custom Dialogs.

Base Macro File Path

This feature allows you to set the default file path for where macros are stored to and accessed from on your local computer. Setting this file path is critical when creating taskbars, dialogs and when using the option to Play Macro on Startup (above) or to move taskbar, dialogs, or macros between computers.

Base Dialog File Path

If custom Dialogs have been created (see Ch. 7 – SPOT Advanced Custom Dialogs for more information on designing and using Custom Dialogs), it is strongly recommended that you set the Base Dialog File Path in order for the dialog feature to work properly and to allow for portability.
between computers. Use the browse button to select the path to where Custom Dialogs will be stored and referenced.

Messages

Select **Show All Informational Messages** to display helpful prompts from the SPOT program to walk you through such features as Compute White Balance, etc. It is only recommended to turn this feature off for expert users of the SPOT program.
Chapter 3 – SPOT Advanced Image Captures and the Camera Menu

Introduction

Chapter 2 covered details surrounding all the features on scripting a Live Image and a captured image. This chapter will discuss the options available for capturing images and the remainder of the features under the Camera Menu.

The actual capture of a digital image (taking the picture) is similar to traditional photographic techniques. In digital photography, however, it is possible to continually capture, refine, and recapture images until you have an optimal representation: the first image that you capture might be only one of several that you use to produce a publishable product. A sample image capture process, from start to finish might proceed as follows:

- Adjust the Preferences as needed (see previous chapter).
- Open the Live Image window, or select Display Live Images from the Camera menu.
- Frame and focus the image as needed.
- Click on the Controls button on the Live Image window toolbar button to access the Live Image Controls and adjust the live image view settings (see previous chapter).
- Click on the Acquire Single Image toolbar button to capture the final image.

In the Advanced application, image capture settings and live image view settings can be defined in two different places, the Live Image Controls and the Image Setup. This gives you ultimate flexibility of being able to have different settings for your Live Image compared to your captured image (Image Setup). See the previous chapter for how to Link your Live Image Controls to your Image Setups so that you capture the same image that you see in your Live Image window.

Display Live Images

Before you capture an image, you may find it easier to see a live preview of your specimen. The Display Live Images option enables you to see a real time preview of your specimen/image capture. For instance, you can use the Live Image window to:

- Scan the image for an area of interest.
- Zoom in on an area of interest.
- Focus on an area of interest.
- Frame an area of interest.
- Define image capture settings – See Ch. 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu for more details.

To open the Live Image window, either click on the Live Image toolbar button, or select the Display Live Images option from the Camera menu.

The details of the Live Image Window and the Live Image Controls can be found in Ch. 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu.
Capturing the Final Image

There are a few ways to capture a single image in the SPOT Advanced software: Acquire Single Image (exposure from setup), Acquire Single Image (last used exposure) and Pause/Transfer on the Live Image window. All options are discussed in further detail below.

Acquire Single Image (exposure from setup)

The Acquire Single Image option should be your primary means of capturing images. Using this feature ensures the image will be at full resolution and the set bit depth you have indicated. There are three different ways to access the Acquire Single Image option:

- From the Camera menu, select Acquire Single Image
- Press the Acquire Single Image button on the toolbar
- Press [F9] on your keyboard

Either option above captures an image according to the Image Settings that you defined (see previous sections).

The Acquire Single Image status dialog box appears. Status messages display as the camera computes the gain and exposure times. If the live image window is open, the image capture uses the gain and exposure times calculated for the live image and skips the exposure computation (step 1 below). The status messages are as follows:

1. **Computing Exposure** – The camera is sampling brightness levels in the image in order to determine proper gain and exposure time.

2. **Exposing** – A countdown clock displays when the exposure will last longer than 2 seconds. This informs the user that the electronic shutter is open and counts down the minutes: seconds remaining until it closes.

3. **Reading Image Data** – The camera is downloading the image to the computer.

   **Note:** For 3-Shot Color and Slider cameras, steps #2 and #3 will occur from 1 to 3 times, depending upon which color filters have been selected.

4. **Processing** – The camera is preparing to display the image.

   The newly captured image appears on screen. If the live image screen is open, the captured image will appear behind the live image screen. To view it, simply close the Live Image window or roll it up by double clicking on the Live Image window’s title bar.

Acquire Single Image (last used exposure)

In addition to the options to Acquire Single Image and Acquire Time Lapse Images, which were detailed above, you can choose to Acquire Single Image using the last used exposure.

The Acquire Single Image (last used exposure) option captures an image using the exposure times and gain from the previous exposure. In all other respects, it works in exactly the same way as the Acquire Single Image (exposure from setup) option. This option shortens the time required to capture an image because it skips the initial auto-exposure sequence. This is convenient when you are satisfied with the appearance of an image and want to use the same settings to capture a similar image in the same session. If you close the software, and re-open it, the Acquire Single Image (last used exposure) option is unavailable until you capture an image using the Acquire Single Image (exposure from setup) option.

To use the Acquire Single Image (last used exposure) option, follow these steps:
1. Prepare the microscope and specimen for the next image capture.

2. Either select Acquire Single Image (last used exposure) from the Camera menu, or click on the toolbar button.

The Acquire Single Image status window appears, and the camera captures the image using the last used exposure times. It only displays the exposure time and the gain because the camera no longer needs to sample image brightness.

**Note:** This feature will retain the image settings from the previous capture even if you delete the previously captured image from the screen.

### Pause/Transfer

The Acquire Single Image function should be your first choice for capturing a single image. However, a second option is available, the **Pause/Transfer** button.

This option is helpful in situations with rapidly changing or moving samples. If you see something that you like, you can **Pause** the live image before it changes. Then, you can **Transfer** the paused image to a SPOT editing window and save it to file. The **Transfer** option is not active until the **Pause** button is pressed.

If you do not want to Transfer the paused image, you can resume the Live Image display by either pressing Resume or Restart (see above for more details).

**Note:** Images created in this way have two restrictions. First, all transferred images are 8 bit per channel (color). Second, because live images are read out via two amplifiers, the right and left sides of the image might not be perfectly matched. The transfer option should not be used for image captures that require highly accurate brightness measurements.

### Capturing Time Lapse Images

The Acquire Time Lapse Images option allows you to capture a sequence of images. SPOT’s time lapse image capture process enables you to save an image sequence in two different ways:

- You can save a sequence as a group of individual image files.
- You can save a sequence as a single (TIF or BigTIFF format), "sequence image file" that is composed of multiple images. Refer to the Viewing, Editing, and Annotating Images section for details on viewing and modifying image sequence files.
Acquire Time Lapse Images

- The **Acquire Time Lapse Images** option allows you to capture a sequence of images over time. The images can be saved into a sequence or as individual files. If saved into a sequence, the sequence can then be exported for use in other applications. The number of images that can be acquired is limited to 100,000.

To use the Acquire Time Lapse Images option, follow these steps:

1. Select the image setup that you want to use for the sequential image captures. Either define a new image setup, or select an existing setup from the drop down list on the status bar (bottom right corner).
2. From the Camera menu, select the Acquire Time Lapse Images option. The Acquire Time Lapse Images window appears. The following section describes each option available.
3. After you have entered all of the options, click on **Begin** to start the image capture sequence. Refer to Ch. 4 – SPOT Advanced Viewing and Editing Image Documents for details on viewing and modifying image sequence files.

**Number of Images**

Enter the number of images (values from 1 to 100,000 are allowed by the software) you would like to capture as part of the time lapse acquisition.

**Period**

Use this option if you would like to capture images over a set period of time. Make your selection in hours, minutes, and/or seconds.

**Until Stopped**

This option will acquire images until the user tells the software to stop. You also have the option to keep all of the images, only the last number of images that you specify, or only the last images for the time span that you specify.

**Compute Each Exposure before Each Image (not shown)**

Select this option if you would like the SPOT software to recalculate the exposure before each image capture. Using this feature would be beneficial when the brightness level of the specimen may change over the span of the time lapse acquisition. If the brightness level is expected to remain constant and timing is an issue, you may want to consider leaving this box unchecked so as to minimize computation time between image captures.
Note: The option to Compute Each Exposure before Each Image is only available if your current image setup is set to use an Auto Exposure.

Require Trigger Before Each Image (not shown)
This feature is only available and selectable if you are using a Edge trigger for beginning an exposure. See Ch. 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu for more information on triggers.

If the check box to Require Trigger Before Each Image is not selected, the time lapse images will only require a trigger pulse for the first exposure. Each subsequent exposure will occur at the time interval set below.

If the check box to Require Trigger Before Each Image is selected, each exposure during the time lapse image sequence will only occur after the trigger sends a pulse. When this option is enabled, the Time Interval options are automatically disabled since the interval will depend on the next trigger signal.

If you have selected a Bulb trigger (See Ch. 2 – SPOT Advanced Image Setups, Live Image Controls and the Setup Menu for more on triggers), the option to Require Trigger Before Each Image is automatically selected and the Time Interval options greyed out and inactive since each image’s exposure is dictated by the length of the trigger pulse.

Time Interval

As Short as Possible
If you select as short as possible, the camera will begin exposing the next image as soon as the previous image data has been downloaded.

With Xplorer and Pursuit cameras only, selecting as short as possible will enable the camera to begin exposing the next image while downloading image data from the first image. This enables these cameras to capture sequential images very quickly. However, if your computer doesn’t have enough memory to support this, your images may be overexposed. If this occurs, unselect the as short as possible checkbox and type in 0 as the time interval. This will prevent the camera from beginning the next exposure until the image data download has finished.

Discrete Time Interval
If the parameters of your time lapse acquisition dictate discrete timing where perhaps certain events are occurring at a certain time, or if you merely need to capture images every set period of time, you can use the option to enter a discrete time interval instead of using the above option As Short as Possible. Enter the time interval between the start of one image capture to the start of the next image capture in hours, minutes, and seconds.

Place Images into an Image Sequence
There are two options for file output when acquiring time lapse images. You can choose to have each image be its own image document and available for saving as its own image file. Alternatively, if this box is selected, the SPOT software will automatically add the captured images into an image sequence document as they are being captured. If the current Image Profile has Auto-Save activated for Time Lapse Images being saved to Image Sequence Files, this option will be inactive. See Chapter 4 for more on Image Auto-Save options.
Defer Image Processing/Display until Done

The process of capturing and displaying an image requires some processing time by the computer. This processing takes a small amount of time and can delay sensitive and short time interval time lapse acquisitions. In order to minimize any delays by the computer’s processing time, use the option to Defer Image Processing/Display until Done. When this feature is selected the entire sequence is completed before displaying or saving the images.

Display Images During Acquisition

This option is only available if the option to Defer Image Processing/Display until Done (above) is turned off. Select this feature to view your captured images while the image sequence is being acquired. You can also set the maximum frame rate for display.

Maximum Display Frame Rate

When you choose to Display Images During Acquisition you will need to input a desired Maximum Display Frame Rate for the SPOT Software to try to display images during the acquisition. The frame rate indicated here may not be achievable depending on the exposure settings, etc.; this setting is merely a maximum.

Fit to Window

The Fit to Window option is only available when the option to Display Images During Acquisition is selected. Turning on the Fit to Window option will allow you to see the entire imaging area without the use of scroll bars; instead the image will be displayed within the Acquire Time Lapse Images dialog box, which is resizable.

Show Acquisition Statistics when Done

When this feature is selected, a dialog box will appear at the end of the image sequence with the total number of images acquired, the total acquisition time, and a mean frame rate.

The Camera Menu’s Additional Options

Aside from the acquisition options under the Camera menu, there are also features for camera communication, exposure options, correction frames, and limited peripheral device communication. Each of these features will be discussed in further detail below.

Select Device

Selecting this option from the dropdown menu will allow the user to switch between SPOT cameras running on the same computer. When an alternate device is selected, for example from an Insight camera to an RT camera, the menu and toolbars will adjust to acknowledge the appropriate options and settings for the new device. The SPOT program, however, will not shut down. This on the fly device switching capability can be very convenient for the user with the need for multiple cameras during the day.

Initialize

If you turned on the SPOT power supply after you opened the program, you need to initialize the camera in order to activate all of the capture and editing options. To do so, select the Initialize option from the Camera menu.
Disconnect

This feature allows the user to disconnect their SPOT camera from the SPOT software so as to make it available for other software applications to access it. Enable this feature by selecting Disconnect from the Camera Menu.

Set Imaging Area

The Set Imaging Area selects a specific portion of the CCD chip. This option is available once an image has been captured. Using just a small portion of the available area on the CCD chip is useful because:

- The download time will be shorter.
- The file size will be smaller and easier to manage.

To avoid confusion when defining the region of the image that you want to capture, it is important to realize that there are two separate coordinate systems in use:

- The coordinate system of the CCD chip
- The coordinate system of the displayed image

The coordinates displayed on the Status Bar as the cursor is moved over a displayed image are always “displayed image” coordinates. The coordinates displayed in the Set Imaging Area dialog box are always CCD chip coordinates. These coordinate systems match only if the orientation of an image has not changed (i.e., it has not been flipped or rotated).

Because the SPOT software tracks orientation changes, you can select a Chip Imaging Area on any displayed image, regardless of whether the orientation has changed: the Set Imaging Area dialog box will correctly display the region of the CCD chip that you designated as the imaging region. However, because of the different coordinate systems, the coordinates that you see on the Status Bar (i.e., when moving the cursor over the displayed image) may not match the coordinates that appear in the Set Imaging Area dialog box if the image was flipped or rotated.

To set an image region, follow these steps:

1. Position the cursor at the upper left edge of the image region that you want to capture.
2. Press and hold the mouse button (left mouse for PC users) and drag the cursor across the screen. A dotted border appears around the region that you select.
3. From the Camera menu, select Set Imaging Area. The Imaging Area window displays the pixel locations for the borders of the region that you selected.
4. Click OK to save the region values to the current image setup, or select a different image setup. The region values are now saved to the designated image setup.
5. Recapture the image using either Acquire Single Image (exposure from setup) or the Acquire Single Image (last used exposure) option. The new image capture displays only the region that you selected.

Set Spot Metering Area

Spot metering is a method for selecting a region of interest on a desired image and then allowing the SPOT camera to automatically set the exposure time to allow for the best possible balance of image quality and contrast. This can be useful when the default auto-exposure settings (full image sampling) do not provide a captured image that provides the detail you need for a particular region of your subject being viewed.
The Set Spot metering area feature in the SPOT software allows you to zero in on a rectangular region of the live image. To set the Spot Metering Area from the Camera Menu option, follow these steps:

1. Start by acquiring an image.
2. Select the area of the image by clicking and then dragging the mouse across an area on the image.
3. Select Set Spot Metering Area from the Camera dropdown menu.
4. Save it to an Image Set-up file for future image captures.

The Spot Metering Area can also be set in the Image Setup dialog. Please refer to Chapter 2 for how to set the Spot Metering Area from within the Image Setup dialog.

Set White Balance Area

In addition to selecting a sub-region for the Spot Metering area, a sub-region for the White Balance area can also be set. Most of the time you will want to use the entire sensor for computing a white balance as the software will detect the brightest pixels and assign them as white. However, if for some reason you have a shiny object with glints in it which are not actually white, the camera and software may inadvertently assign white to these glints, when in fact they are not white. In these situations, or when there is white and off-white in the image, you may achieve better color rendition by forcing the camera and software to compute the white balance from the exact location you choose. See earlier in this Chapter for more on White Balance theory and the steps involved.

To Set the White Balance Area from captured image, follow these steps:

1. Start by acquiring an image.
2. Select the area of the image by clicking and dragging the mouse across an area on the image.
3. Select Set White Balance Area from the Camera menu.
4. Select the appropriate Image setup to save the coordinates to for future image captures.

The White Balance Area can also be set in the Image Setup dialog and in the Live Image window. Please refer to Chapter 2 and earlier in Chapter 3, respectively, for additional details.

Compute Exposure

Compute Exposure determines the correct exposure time and gain for an image. By calculating exposure times and gain ahead of time, you can avoid the auto-exposure sequence that takes place each time that you use Get Image (exposure from setup). Using Compute Exposure also changes your current image setup:

- The computed exposure values are added to your current image setup.
- The current image setup, if set to Auto Exposure, is changed to Manual Exposure.

To compute exposure, follow these steps:
1. Select Compute Exposure from the Camera menu. The Status message changes to **Computing exposure**... When the camera finishes sampling the light, the Exposure window displays the values.

2. Select an image setup from the Save to Setup drop-down box. The current image setup is the default.

3. Click on OK. When you open the Image Setup window, the new exposure value displays.

4. Select Get Image (exposure from setup) to capture the image using the new exposure values.

### Recall Previous Exposure

Recall Previous Exposure assigns the exposure time and gain from your last image capture to an image setup. The Recall Previous Exposure feature is available only after you have taken a picture.

To recall previous exposure values, follow these steps:

1. Capture an image.

2. From the Camera menu, select Recall Previous Exposure. The Exposure window displays the value from the last image capture (see above).

3. Select an image setup from the drop-down box.

4. Click OK.

5. Use Get Image (exposure from setup) to capture an image with the new exposure and gain values.

### Compute White Balance Values (Color cameras only)

White balance is the ratio of red, green, and blue exposure times (3-shot cameras) or gains (color mosaic cameras) necessary to achieve the proper color rendition for an image. Many factors impact the coloration of an image capture, including lamp voltage, the coloration of the glass used in the slide, and the coloration of the glass used in the lenses of the microscope’s objectives. To minimize the impact of these factors, use the White Balance feature. When you perform a white balance calculation, SPOT samples the color of the light from your light source after it has passed through the slide and the objective, and then calculates the red, green, and blue exposure times (3-shot cameras) or gains (color mosaic cameras) needed to produce images where the white areas are white and the color areas are true.

You should perform a new white balance calculation when:

- Starting a new image capture session.
- Changing the lamp voltage.
- Switching to a different objective on the microscope.
To compute new white balance values, follow these steps:

1. Set the illumination and the objective that you will use for the image capture.

2. Select the appropriate Image Setup. Each Image Setup has its own set of white balance values. Any white balance values that you compute for an image setup remain linked to that image setup until you compute new values. When selecting a new image setup, remember that you will be using the white balance values linked to that image setup.

3. Show the camera a sample of white light. This step varies according to microscopy technique and Image Type (sample), as shown in the table below.

4. Click on the White Balance button. By default, a Compute White Balance dialog will appear with instructions on how to properly perform a white balance. If the preference to show helpful Messages has been turned off, this step will be skipped.

   Note: If you are comfortable with performing White Balances, you can check the box for Do not show this message again. If you desire, you can always turn this message back on in the Preferences (see Chapter 2 for more information).

5. Click on Begin to start the calculation. The camera computes the white balance values and they are automatically saved to the image settings for the image type that you selected.

<table>
<thead>
<tr>
<th>Image Type</th>
<th>White Balance Technique</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brightfield-transmitted light</td>
<td>Position the slide so that the specimen is not in the field of view, but light is going through the slide near the specimen.</td>
</tr>
<tr>
<td>Darkfield-transmitted light</td>
<td>Perform the white balance using the brightfield mode on your microscope. See Brightfield – transmitted light above.</td>
</tr>
<tr>
<td>Fluorescence</td>
<td>Use the Match Color feature</td>
</tr>
<tr>
<td>Nomarski DIC/Hoffman</td>
<td>For Nomarski DIC: Adjust the Nomarski prism until the image is in either the “brightfield” or the “gray scale” view. For Hoffman: Perform the white balance directly on the Hoffman image.</td>
</tr>
<tr>
<td>Phase contrast</td>
<td>Position the slide so that the specimen is not in the field of view, but light is going through the slide near the specimen.</td>
</tr>
<tr>
<td>Polarized light</td>
<td>Place all polarizers and compensators into the light path and then position the slide so that the specimen is not in the field of view, but light is going through the slide near the specimen.</td>
</tr>
<tr>
<td>Brightfield-reflected light</td>
<td>Replace your sample with a mirror.</td>
</tr>
<tr>
<td>Darkfield-reflected light</td>
<td>Perform the white balance using the brightfield mode on your microscope. See Brightfield – reflected light above.</td>
</tr>
<tr>
<td>Stereo/Macro (all three options)</td>
<td>Using an EPI-illuminator (shining a light on the top of your specimen from off to one side), replace your sample with a white sheet of paper.</td>
</tr>
</tbody>
</table>
Acquire Bias Frame

Bias frame subtraction is a process that uses the stored, acquired bias frame, subtracting it from a captured image, to remove both the system offset (bias) and the dark current electrons that accumulated in each pixel while it was waiting to be read out. When this subtraction process has been applied to a short exposure image, the remaining data (and image) is mostly representative of the true image data being captured.

In addition to following the steps below, you may also select an existing bias frame to use in the subtraction process within the image set-up post-processing window. Refer to Chapter 2 for details on how to activate a Bias Frame for an Image Setup.

**Note:** Bias frame subtraction is available only when a monochrome camera is set up in 12 bit or 14 bit capture and black level subtract is not selected.

For a detailed explanation of Bias Frames and other correction frames, please refer to Appendix A: Electronic Theory and SPOT Cameras.

To use Bias Frame Subtraction, follow these steps:

1. From the Camera menu, select Acquire Bias Frame. The Acquire Bias Frame dialog box appears.
2. The program will ask for the number of image frames to capture to determine the Bias Frame reference noise level. You may select a number from 1-50 frames. The more frames you choose, the more accurate the result should be, however, the process will take a longer time.
3. Select Bias Frame File Name.
4. Select an Image Setup to save the Bias Frame to.
5. Cover the optical train or find another method to block light to the camera's CCD. Click on OK. The program will acquire the number of short dark frame exposures required to calculate the Bias Frame.
6. The program will acquire the bias frames and save the file to the image setup you selected.
7. Move the specimen back into the field of view, and perform the image capture.

Acquire Background Image

Acquire Background Image is a function that allows you to collect data to minimize the effect of thermal noise in your captured image or to remove any background glow from fluorescence images. For a more detailed discussion of the theory and benefits of the Dark Noise Subtraction process, refer to Appendix A: Electronic Theory and SPOT Cameras.

To use Acquire Background Image, follow these steps:

1. From the Camera menu, select Acquire Background Image. The Acquire Background Image dialog box appears.
2. The program will ask for the number of image frames to capture to determine the Background Image reference noise level. You may select a number from 1-50 frames. The more frames you choose, the more accurate the result should be, however, the process will take longer.

3. Select the Background Image File Name.

4. Select the Image Setup to save the Background Image to.

5. The Acquire Background Image window will direct you to “Move to Background or block light”. If you are performing the background subtraction to minimize the effect of thermal noise, block all of the light to the camera. If you are performing the background subtraction to remove the background glow in fluorescence images, move to the background. Click on Begin. The program will acquire the number of exposures required to calculate the Background Image.

6. The Acquire Background Image window will direct you to “Block all light from the camera”. If you already blocked the light to the camera in step #5, click OK. If you moved to the background, block all of the light to the camera and click OK.

7. The program will finish creating the Background Image.

8. Move the specimen back into the field of view, and perform the image capture.

**Note**: Flatfield correction and background subtraction files cannot be imported or exported to a different computer. These will need to be copied over manually or re-captured on the new computer.

### Acquire Flatfield

The Flatfield option can be used to correct for display problems associated with uneven intensity or coloration in illumination, or to correct for artifacts (e.g., dust) in the optical system. For a more detailed discussion of the theory and benefits of the Flatfield correction process, refer to Chapter 2 - Image Setups, Live Image Controls and the Setup Menu.

**Note**: Flatfield correction with the SPOT camera refers only to the correction of uneven lighting. It should not be confused with the correction of optical field flatness.

To use Flatfield Correct, follow these steps:

1. Ensure that the specimen is under the desired objective and in focus.

2. From the Camera menu, select **Acquire Flatfield Image**. The Acquire Flatfield dialog box appears.

3. Choose a number of frames to average. Larger numbers of frames will increase the accuracy of the flatfield correction, but will also increase the length of time it takes to create the flatfield image. The default number of frames to average is 3.
4. Choose a flatfield file name. Because flatfield image files are different for each objective, you might want to name the file according to the objective’s magnification (e.g. 10x).

5. Specify the image setup that will be associated with this flatfield image file when using the Flatfield Correct option.

6. Remove the slide from the field of view.

7. When the program finishes acquiring the frames, it will prompt you to block all of the light to the camera. This can be accomplished by installing the dust cap that was supplied with the camera or by adjusting the microscope’s optical path. After the light is blocked, click on OK. The program computes another frame.

8. Move the specimen back into the field of view, and perform the image capture. Refer to Ch. 3 – SPOT Advanced Image Captures and the Camera Menu for more details on the image capture process.

**Set Exposure Conversion Factor (some RT cameras only)**

The Set Exposure Conversion Factor function enables you to match the light intensity in the live mode with what is present in the capture mode. This compensates for the differences due to the use of different electronic circuitry in the live mode as compared to the capture mode. To use Set Exposure Conversion Factor, follow these steps:

1. From the Camera menu, select Set Exposure Conversion Factor. The Set Exposure Conversion Factor dialogue box appears with a default conversion factor displayed.

2. Select Compute. A dialog box will prompt you to “Move to sample for exposure computation”. Ensure that your sample is in field of view and click OK.

3. The SPOT software will compute the appropriate conversion factor. Click OK to finish.

**Save Image Display Values**

With an image open in the SPOT application, the option to Save Image Display Values will be available. If you like the values that you have used on an image for the Monochrome Palette selection or the option to Indicate Saturated Pixels, you can use those values from the image and save them to the Image Setup of your choice. Refer to Chapter 2 for more information on Monochrome Palette and Indicate Saturated Pixels.

**Set TTL/Sync Output Active**

The Set TTL/Sync Output Active option enables a TTL/Sync Output pulse manually. This pulse can be used to trigger external devices, like fluorescence shutters. There are options for automatically triggering the device when an exposure begins and for setting the active state of the TTL/Sync output in the image setup. See Chapter 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu for additional details.

**Set TTL/Sync Output Inactive**

The Set TTL/Sync Output Inactive option disables the TTL pulse manually. This pulse can be used to trigger external devices, like fluorescence shutters. There are options for automatically triggering the device when an exposure begins and for setting the active state of the TTL/Sync output in the image setup. See Chapter 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu for additional details.
Chapter 4 – SPOT Advanced Viewing and Editing Image Documents

Introduction
This chapter will cover details about the software features available for working with image files. Topics will include:

- The File Menu options
- Viewing Images
- Editing Images
- Saving Images
- Working with Image Sequence Files

The File Menu
All of the file open and save options in the SPOT program are accessed from the File menu. These options are described below.

Open Image File
Open image files of a specified format (i.e., JPEG, TIFF, BMP, etc.). In addition to using this menu option, you can open images by dragging an image file from the Desktop or Explorer onto the SPOT program window.

Show Image File Thumbnails
Display thumbnail previews of specified files and open images from the preview screen. To show file thumbnails, follow these steps:

1. From the File menu, select the Show Image File Thumbnails option. The Thumbnail File Spec window displays all of the image files in the directory.
2. Navigate to the directory for the image files that you want to display.
3. Use the Files of type drop down box, to specify the file type.
4. Select the file or files for which you want to display thumbnails. If you do not select a file or files, the program displays thumbnails for all files of the specified type in the directory.
5. Click on Open. The Thumbnails preview window appears. For each thumbnail, you can:
   - Double-click (Mac and Windows) on a thumbnail to open an image for viewing or modification.
   - Right-click (Windows)/ [⌘] Click (Mac) on a thumbnail to display a list of options. The right-click menu enables you to perform a variety of actions directly from the thumbnail window:
     - Select Image
     - Open Image
     - Delete Image
     - Print Image
- Move/Rename Image File
- Copy Image
- Add Image to Image Sequence (see below)
- Add Image to Report (see below)
- Select All Images in the thumbnail view. When you use this option, the right-click menu expands to include the above options for multiple images

Click and drag with the mouse to select two or more images.

Open Image Sequence File

An image sequence file is a single TIFF format file that contains multiple images. Select this open to open a saved image sequence file. Refer to the Taking a Picture section of Chapter 3 for more information on capturing time lapse/image sequence files.

Open Database Image

Open images from a SPOT database. The database must be open in order to use this feature. Refer to Ch. 8 – SPOT Advanced Databases for details on working with databases and database images.

Create New Image Sequence

This option allows you to create a new image sequence file from single images. The images can come from an open image or an image on disk (from file). The two options are:

From Files

Select this option to browse through your computer for image files to add to the image sequence. Multiple images can be selected by holding the Control button while you click to select images in the browser window.

From Open Images

If all of the images that you would like to add to an image sequence are open, select the option to create the sequence From Open Images. A dialog box will appear asking if you

Additional images can be added to the image sequence file in one of two ways:

The File menu’s Add Image to Image Sequence option allows you either to add an open, non-sequence (individual) image to a sequence or to create a new image sequence from the image. See below for more information.

When an image sequence is open, the Sequence menu has additional options for adding images. Refer to Working with Image Sequence Files later in this chapter for more details.

New Report

Create a new SPOT Advanced report. Refer to Ch. 9 – SPOT Advanced Reporting for more details.

Open Report

Open a SPOT Advanced report. Refer to Ch. 9 – SPOT Advanced Reporting for more details.
Run Report
Run a SPOT report. Reports can be run in three ways - previewed, printed, or saved to file. Refer to Ch. 9 – SPOT Advanced Reporting for details.

New Dialog
Create a new custom Dialog. Refer to Ch. 7 – SPOT Advanced Dialogs for details.

Open Dialog
Open an existing custom Dialog for editing. Refer to Ch. 7 – SPOT Advanced Dialogs for details.

Show Dialog
Reveal an existing custom Dialog for use. Refer to Ch. 7 – SPOT Advanced Dialogs for details.

Reload
Reload the image from the hard drive (or other media). All changes made since opening the image file are lost. This option appears only when a saved image is open.

Save
Save a previously unsaved image to new file, or update the changes to an existing file. This option appears only when an image is open. When you save a new image, you will also have the ability to select from the following file formats. The format options which are available are dependent on the bit depth of the image. This setting is made in the Image Setup. Please refer to Ch. 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu for more information on bit depth.

Individual Files:
For individual 8 bit/channel files, there are six options: Windows Bitmap, JPEG, Mac PICT, TIFF Uncompressed, TIFF JPEG, or JPEG2000.
For individual 12 bit/channel files, there are three options: JPEG 2000, TIFF Uncompressed (12-bit/chan), TIFF Uncompressed (16-bit/chan).
For individual 16 bit/channel files there are two options: JPEG 2000 and TIFF Uncompressed (16-bit/chan).

Image Sequence Files:
For image sequences of 8 bit/channel files, there are two options: TIFF Uncompressed or TIFF JPEG.
For image sequences of 12 bit/channel files, you can save the sequence only as TIFF Uncompressed.
For image sequences of 16 bit/channel files, you can save the sequence only as TIFF Uncompressed.

Note: Images with higher than 8 bit/channel may not open correctly in other applications.
The BigTIFF file format is available to support larger file sizes, beyond the standard limit of 4GB in a TIF file. This is especially useful with image sequence files. This format should be available for all bit/channel settings.

Note: Images saved as BigTIFFs may not be viewable in other applications, as this file format is not widely supported.

Note: When saving images with a bit per channel setting above 10 bits per channel, you may have the option to Promote Data to 16-bits per channel.

Save As
This option appears only when an image is open. Use the Save As option to save an image to a new file name and/or file location.

Save to Database
Save an image to a database file. This option appears only when a database is open.

Save All
If you have a large number of images to save, you may want to use the Save All feature to save all open image files. The program prompts you for the name and file location of each image.

Close
This option appears only when an image is open. Use this option to Close an image document. If the image has not been saved or if changes have been made to the image document, the program will ask you if you would like to save the changes made to the image or not. Select Yes to re-write the original file or save a new image to file. Select No to throw away your changes and close the image document. If you select Cancel, the image document will remain open.

Move/Rename
This option differs from the Save As option in that it does not retain a copy of the original file in the original location. Using Move/Rename is comparable to cutting and pasting a file. When you select this option, a browser window will open asking you to set the new destination and name of the image file.

Delete
When you select Delete from the File menu, you will be asked to verify that you really do want to delete the file. Select Yes to delete the file and select No to cancel the deletion and keep the image. This option is only available when an image document is open.

Export Movie File (available only when image sequence is open)
Image sequence files are only viewable within the SPOT application. If you want to view your image sequence outside of SPOT, you will need to export it to a suitable file format. Use the
Export Movie File feature to export a SPOT image sequence file to either *.AVI (PC) or *.MOV (Mac). To export the image sequence, follow these steps:

1. Open a SPOT image sequence. Refer to Chapter 3 for details on capturing image sequences/time lapse images.
3. Enter the File Name for the avi file.
4. Specify the location where you want to save the avi file.
5. Specify which images in the sequence that you want to Export. Select either:
   a) All Images – the avi file will contain all of the images in the sequence.
   b) Specified Images - the avi file will contain only the images that you specify (i.e., below the radio button).
6. Specify the Frame Rate in frames per second.
7. Specify the Compression Settings. When you click on the Compression Settings button, the Video Compression dialog displays the compression application(s) available on your computer. Because each computer will have different installed applications, the Video Compression options will vary.

After you have entered all of the desired settings, click on Save. The program displays a status message as it exports the file.

Add Image to Image Sequence

Add an open, non-sequence image to an open image sequence, or create a new image sequence from an open image. To use this option, the non-sequence image must be the active window and the image sequence must be open in the background.

When you click on Add Image to Image Sequence, SPOT prompts you to specify either the Image Sequence or a new image sequence. If more than one image sequence is open, select the sequence from the drop-down list.

Add Image to Report

Add a selected open image to an open SPOT report. When you select this option, SPOT prompts you to select from a list of reports. If you have not defined a report, SPOT automatically creates a new report for you and inserts the image as a Static Image object. Refer to the Creating Reports section of this chapter for more details.

Duplicate Image

The Duplicate Image option allows you to easily create copies of your images, with or without layers (annotations, calibration marks, measurements, and reticles) being merged into the pixel data. Additionally, the bit depth of the copied image can be altered at this point. When you select this option from the File menu, the Duplicate Image dialog box will appear.

The following options are available to you under the Duplicate heading:
Actual Data
If the original image has been modified or annotations, calibration marks, measurements, or reticles have been added to the image and you do not want to have these edits be permanently merged into the pixel data, select the Actual Data option. When you make this selection, the option to Merge Object in Layers is automatically deactivated so as to keep the layers separate from the pixel data.

As Displayed
For a quick and easy way to make a copy of an image with the layers merged into it, use the As Displayed option with the Merge Objects in Layers option checked (below). Merging the layers into the image can be useful for sharing your edited images with non-SPOT users. See more about Merging layers under the Editing Images section of this chapter.

New Image Bit Depth
When duplicating images, the New Image Bit Depth setting allows you easy access to changing the bit depth of the image. For more information on selecting an appropriate bit depth, please refer to the Change Bit Depth feature in the Editing section of this chapter.

Merge Objects in Layers
This feature works hand in hand with the As Displayed option above. Check this box if you would like to merge your layers into the pixel data of your copied image. For more information about merging layers, please see the Editing Images section of this chapter.

Merge Images
The feature to Merge multiple Images together is available in two places, the File menu and the Edit menu.

Use Merge Images to combine two or three monochrome images into a single composite image. Traditional uses of this feature include merging of single color fluorescent images, however you can also merge full color images, or even lay out images next to each other to create an image montage. The Merge Images option is used primarily in fluorescence imaging when specimens have been stained with more than one dye, and a triple filter cube is not available. In this circumstance, each dye can be excited individually, and a monochrome image can be captured for each.
excitation. The Merge Images feature then allows you to combine these images to create a composite image that shows all the dyes.

Merging images requires at least two source images. The source image can be from the following sources:

**Currently Open Document**
If the images which you want to merge are open in the SPOT application, it is easiest to select Currently Open Document for your source images. Select the appropriate Image Title from the drop down list.

**File**
If you do not have the images open which you want to merge, you can use the File option and use the browse button to locate each image. Once an image is selected, its Name will appear in the Name field.

**Sequence Index Number**
If one of the image documents selected in either the Currently Open Document or the File is an Image Sequence File, you will need to indicate which image you would like to select from the Image Sequence File.

**Database: Image ID (Windows only)**
If a database is open, the option to input the Database ID will be available. Simply type in the Database ID of the image you want to merge with others. You may need to first search the Database to locate the Database ID of the picture you wish to use. See Ch. 8 – SPOT Advanced Databases for additional information.

**Palette**
If you are working with monochrome images, the Palette button will be available for you to apply a color palette to each image. Press the Palette button to access all available color palettes.

If you press the Palette button and the image is color, you will receive an error message that the palette cannot be applied to the image because it is color, not monochrome. For more information about color Palettes, please refer to the Palette section (below) in this Chapter.

You can also adjust the brightness and position of the images which are being merged. The right hand side of the Merge Images dialog has settings for the positioning of the images to be merged as well as the relative intensity of the images’ brightness levels.

**Scale Factor**
The Scale Factor feature allows you to scale the brightness of a source image before it is merged. Values between 0.01 and 1 darken the image and values between 1 and 5 brighten the image.

**Position Offsets**
Changing filters for an image capture can cause its position to shift from that of the previous capture. This can be problematic when trying to merge two or three images captured with different filters. The Position Offsets for each individual image in the merged image allow you to compensate for such shifts by specifying Horizontal and Vertical Position Offsets in pixels.

Specify the Horizontal and/or Vertical position offset you require to align images properly. The position offset will be applied in the merged image.
Include Non-Overlapping Areas in Final Image

To retain the non-overlapping areas, ensure that the Include Non-Overlapping Areas in Final Image box is selected. If you do not select the box, the final image automatically discards any non-overlapping areas.

Auto – Scale Brightness

Whereas the Scale Factors are applied to individual images before they are Merged, the Auto-Scale Brightness feature automatically adjusts the brightness of the merged image to prevent overlapping bright areas from burning out.

Merge as Displayed

The Merge as Displayed option is available in the event that you have added annotations, calibration marks, measurements or reticles and you would like to merge the images with these layers into the final image. If you do not select this box and you have an annotation calibration mark, measurement, or reticle on one of the images to be merged, it will only show up in the final image as a layer. These layers are viewable within SPOT, however in order to view these layers in other applications, the layers will need to be merged into the image.

Apply

Click on Apply to apply your settings and view the merged image. When you click on Apply, the Merge Images dialog remains open, allowing you to experiment with different Scale Factors and Position Offsets. A new image document will be displayed on top of the source images (if open) and any changes you make to the settings in the Merge Images dialog will be visualized in the new image document.

Shrink/Expand

Once you have set the images you want as your source image documents, you can click on the Shrink button to reduce the size of the Merge Images dialog. When you click the Shrink button you will be left with the ability to adjust the Scale Factor and the Position Offsets. This minimizes the amount of space that the Merge Images dialog uses in the window and makes it easier to see your new merged image if you have clicked Apply (above). If you need any other feature, simply click on the Expand button to open the entire Merge Images dialog.

OK

When you are satisfied with the appearance of the merged image, click on OK to apply the settings and close the Merge Images dialog.

Export Measurements

Export and save image measurements to a .csv or .txt file. Exporting Measurements is a feature available in a few places. From the File Menu, all measurements on an image document will be transferred to a .csv or .txt file. For additional flexibility, you can export measurements from the Image Information dialog. See later in this chapter for additional details on the Image Information dialog. Additionally, you can export measurements directly from the Measurement dialog. See later in this chapter for additional details on the Measurement dialog.

Print

Use the Print option to print images from the SPOT application. Refer to Chapter 6 – SPOT Basic Image Printing for more information on the Printing options available in SPOT.
Log Off (User Name)
If you are using the SPOT Users feature, you can use the Log Off feature to log out of SPOT and automatically re-launch the software to allow a different user to log in.

Note: This feature is only available if you have selected to have SPOT handle the SPOT Users.

Exit
Select Exit from the File menu when you are ready to close and Exit the SPOT program.

Shortcuts
Directly underneath the Exit menu item, there will be a divider and below it is a list of the ten most recently viewed images or image sequences. This list is intended to allow for quick access to these documents without having to browse to them with the Open Image menu item.

Viewing Images
After opening or capturing an image, you can adjust the way you view images in the SPOT application.

All of the image viewing options are accessible from two menus:
- View – Contains options for how images should be displayed within their individual window
- Window – Contains options for how multiple image windows should be displayed within the SPOT application window.

The View Menu
To help you view and analyze your image captures, the View menu contains the following options:
- Actual Size
- Fit to Window
- Fill Window
- Fit Width
- Fit Height
- Set Zoom Mode
- Show Magnifier
- Zoom Level
- Show Pixels when Zoomed or Stretched
- Show Grid Lines
- Link Image Window Zoom Level
- Enable Pan Window
- Link Image Window Scrolling
- Show Image Information
• Show Annotations
• Show Calibration Marks
• Show Measurements
• Show Reticles
• Show Taskbars
• Hide all Taskbars
• Show Variables
• Full Screen

Actual Size
When selected, each pixel from the camera image is represented by a single pixel in the display image. In many cases, this will result in the displayed image appearing with scroll bars since the camera resolution is usually greater than the screen resolution.

Fit to Window
When selected, the image is sized to fit into the Live Image Window. Choose this setting to provide a full field of view at the maximum size that will still fit into the Live Image Window. In most cases, this will result in the displayed image appearing at lower resolution than what is available in the image. The magnifier can be used to look at image details in this case.

Fill Window
This feature will resize the image to entirely fill the preview window or full screen. Note that horizontal or vertical areas of the image will not be seen since they will be out of the image window field of view.

Fit Width
When selected, the display zoom level of the image will automatically adjust to the maximum setting which allows the entire image width to be viewable within the display canvas. This may result in unused areas of the Live Image Window or portions of the display screen while in Full Screen mode.

Fit Height
When selected, the display zoom level of the image will automatically adjust to the maximum setting which allows the entire image height to be viewable within the display canvas. This may result in unused areas of the Live Image Window or portions of the display screen while in Full Screen mode.

Set Zoom Mode
Zoom Mode can be activated from the View menu or by clicking on the Zoom toolbar button. When in Zoom Mode, the cursor changes to a magnifying glass, and the Zoom toolbar button becomes active.

The benefit of using Zoom Mode is that the cursor can be used to zoom in or zoom out. To accomplish this, position the mouse over the center of the area that you want to zoom in or out on and either left click to zoom in, or right click to zoom out. To return to the normal view mode, deselect the Zoom option from the View menu or the Toolbar button.
The Zoom feature works in conjunction with the pan window (see Show Pan Window below), which allows you to see where you are in relation to the larger image while zoomed in.

| Note: While in Zoom Mode, all of the standard save, view, and edit options are available, however, if you select one of the following options – Add Calibration Mark, Add Measurement, or Annotate – the Zoom Mode function will be turned off. To re-enter Zoom Mode, follow Step 1 above. |

**Show Magnifier**

The Show Magnifier option enables you to use your mouse cursor as a magnifier. This option can also be selected by toggling the toolbar icon on and off.

When this option is turned on and you move your mouse over an image, the image area will be displayed in a user-definable arrangement of pixels (i.e. 200X200 pixels) and a user-defined magnification (i.e. 10x). See Preferences in Ch. 2. – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu for more on customizing the magnifier option.

**Zoom Level**

The Zoom Level option, like the Zoom Mode option enables you to view zoomed images. However, unlike the Zoom Mode option, the Zoom Level feature gives you the option to add annotations, including text, calibration marks, and measurements, to the zoomed image without being forced back out of the Zoom Level. To use the Zoom Level option, select Zoom Level from the View menu and select a percentage option from the list.

Like the Zoom Mode option, the Zoom Level option can be used in conjunction with the pan window (see Enable Pan Window below), which allows you to see where you are in relation to the larger image while zoomed in.

**Show Pixels When Zoomed or Stretched**

Since a digital image is compiled of individual pixels, when these are displayed on a monitor, it is possible to actually see the individual pixel data if the image is zoomed in far enough. For most instances of reviewing images for qualitative purposes, seeing the individual pixel data is not necessary. The default selection for this feature is Off so that the pixels are smoothed and the information at the edges of the pixels is blended together so that you do not see the individual squares of data. If for some reason you want to see where the individual pixels are, you can toggle this feature on and off for each image. Additionally, this preference can be set globally in the Preferences’ Image Display pane. See Ch. 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu for additional details for this global setting.

| Note: Not all video drivers and Hardware Acceleration settings will support this feature. You may need to turn off Hardware Acceleration in order to have this feature be available. The SPOT Application will not display this option if the computer’s hardware does not support the feature. |

**Show Grid Lines**

Show Grid Lines clearly defines pixel borders, which are often invisible in low contrast areas of an image. Clearly defined borders help in positioning the cursor at an exact row and column location (i.e., using the readouts at the bottom of the screen), which then allows you to view the brightness value for the individual pixel.
To show the grid lines on an image, follow these steps:

1. Position the magnifying glass in the center of the area that you want to zoom in on.
2. Zoom to either 8x or 16x. If you are using the Zoom Level option, select a percentage of 800 or greater.
3. From the View menu, select the Show Grid Lines option. Grid lines appear around each pixel.

Note: The Show Grid Lines option is available only when you zoom in on an image.

**Link Image Window Zoom Level**

Link Image Window Zoom Level allows the user to have multiple images open at once and zoom all of them to the same level with one click of the mouse. Once this feature is activated for an image, it will automatically be applied to all subsequent opened or captured images.

The user has two options for zooming in and out once the Link Image Window Zoom Level is activated.

- Go to the View Menu, select Zoom Level and choose a pre-set value for all of the images to which be zoomed.
- Use the Set Zoom Mode feature (either from the View Menu or the magnifying glass icon on the toolbar) and use your mouse's left- and right-click options to zoom in or out, respectively.

This feature can be quite useful when used in conjunction when the Link Image Window Scrolling and Enable Pan Window features.

**Enable Pan Window**

Enable Pan Window allows you to navigate around an image while zoomed in at high magnifications. When you select the Enable Pan Window option, the program highlights your location in relation to the whole image, and, by dragging the highlighted area around the pan window; you can explore the image, piece by piece. Without the Enable Pan Window option, the process of moving to a new point while in high magnification would involve several steps:

1. Zooming in to the first area of interest.
2. Zooming out to determine where you are.
3. Determining a new area of interest.
4. Re-zooming in to the new area of interest.

The pan window replaces this tedious process. When you select Enable Pan Window, a smaller version of the image appears with a grey and highlighted box over the zoomed area of the image.

To use the pan window, follow these steps:

1. Either select Enable Pan Window from the View menu, or click on the Enable Pan Window toolbar button.
2. Position the cursor on the image in the pan window: it changes from a magnifying glass to hand with a pointing finger.

3. To move to a different area of the image, either left click on the rectangle and drag it to the new location, or left click on the new location. The cursor will change to a grabbing hand while left clicking within the pan window.

**Note:** Annotations will appear in the pan window along with the underlying image. When you make modifications or additions to any annotation, the pan window will also immediately reflect the changes.

---

**Link Image Window Scrolling**

When you have multiple captured images open at one time, and they are not set to “Fit to Window” mode, you may choose to link the scrolling action of one image to the other(s). This feature allows you to more easily review different images of the same specimen in order to compare and contrast their condition over time.

Enable the Link Image Window Scrolling in the dropdown menu. You will notice that the scroll bars will "synchronize" with each other, regardless where they were positioned prior to enabling this feature.

When you begin to scroll one window, the other(s) will also scroll in sync, whether you use the scroll bars (vertical or horizontal) or the mouse wheel (vertical).

**Note:** To get the most function out of the Zoom and Scrolling Link options, you must activate both of these features on at least one open image. Once you Link the Zoom and Scrolling for one image, all open images will be Linked. Now, when the Pan Window is activated, all images will display at the same zoom level and the same region of the image for easy comparison viewing.

If only the Link Zoom level is selected with multiple images open, when using the Pan Window or Window Scrolling, only the active image will react to the movement. Likewise, if only the Link Scrolling option is activated, it is possible for images to be displayed at various zoom levels.

---

**Show Sequence Controls**

The Show Sequence Controls option displays the play controls for image sequences. This option appears only when an image sequence is open. Using the Image Sequence dialog you can:

- Play all or part of an image sequence in forward or reverse order.
- Set the display interval between images.
• Set the action that takes when the image sequence finishes playing – i.e., stop, restart, or reverse.

Refer to the **Working with Image Sequences** section for details.

### Show Image Information

**General**

When you select **General**, file information related to the image is presented. This will include "general" information including the filename, its path location, its size, the format it has been stored in, the captured image size in pixels, and the bit depth of the captured image.

**Image Date/Time**

The **Image Date/Time** feature pulls up the date and time associated with the capture of an image. When you capture an image, the SPOT software remembers the date and time of the image capture. When you save the image, even if this is many hours later, the program sets the created date and time of the image file to the date and time of the original image capture.

When image files are transferred over networks, the created date and time is sometimes reset to the date and time of the transfer, making it an unreliable indicator of the image capture time. Because TIFF and JPEG format images have tags both for the created date and the original capture date and time, they are not affected by network transfers. If reliable image capture date and time information is important to your work, you should save images in either TIFF or JPEG format.

When you select the Image Date/Time option from the View menu, a dialog box displays the date and time associated with the capture.

- For non-TIFF, non-JPEG format image files, this is the **Created** date/time, as explained above.
- For TIFF and JPEG format image files, this is the TIFF/JPEG tag date and time.

- For SPOT Database images this is the original date and time that was stored in the database file.

**Acquisition Information**

When selected from the dropdown menu, **Acquisition Information** will display the image capture settings that were associated with the open image file. The information displayed will include such settings as user name, camera type used to capture the image, image setup used, exposure type, gain setting, read speed of the camera, filter color (color cameras), binning setting, chip area, gamma setting, etc.
Annotations

The **Annotations** window indicates any annotations that have been associated with this saved image. Once you have highlighted one of the listed annotations, you may use the find button to locate it on the open image. When you select Find, the annotation will flash one time.

Measurements

The **Measurements** window indicates any measurements that have been associated with this saved image. Click the + on a listed measurement, and the actual value of the measurement will be shown.

Once you have highlighted one of the listed measurements, you may use the find button to locate it on the open image. When you select Find, the measurement will flash one time.

You may also use this window to export the measurement as a database value to an existing or a new file. Highlight all desired measurements in the image information box by holding the Control key while you select the measurements with your mouse.

Additionally, measurements can be exported from the File menu and the measurement dialog. See the respective sections of this chapter for additional details.

Memo

The **Memo** Window, when selected from the dropdown menu, will display the memo that is associated with the open image file. To Edit the text, click the Edit button.

The Image Memos stored with an image in SPOT can be read by other programs which properly handle TIFF images. If you desire other programs to be able to read the information stored in the Image Memo, select the TIFF file format upon saving. Other file formats (such as JPEG, JPEG2000, etc.) will not likely be able to have their SPOT Image Memo read by another program. See earlier in this Chapter’s Save section for more on file formats.
**Metadata**

If an image has metadata associated with it, you will be able to view it here. For more about Image Metadata and how to set it up, please refer to Ch. 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu.

**Show Annotations**

When Show Annotations is selected, any annotations that have been added to the image will be shown. The Show Annotations option is inactive if no annotations have been added to the image.

**Show Calibration Marks**

When Show Calibration Marks is selected, any calibration marks that have been added to the image will be shown. The Show Calibration Marks option is inactive if no calibration marks have been added to the image.

**Show Measurements**

When Show Measurements is selected, any measurements that have been added to the image will be shown. The Show Measurements option is inactive if no measurements have been added to the image.

**Show Reticles**

When Show Reticles is selected, any reticles applied to an image will be displayed. The Show Reticles option is inactive if no reticle has been applied to the image.

**Show Taskbars**

When you select this command from the dropdown menu, you can choose which taskbar(s) to display. If you choose to display more than one taskbar they will be positioned on top of each other. To re-position them so that you can view multiple taskbars simultaneously, place the cursor over the taskbar, hold the mouse button down, and drag the taskbar to the location you desire. If you have not yet developed a taskbar, these can be created by choosing Taskbars from the Setup menu. See Chapter 5 – SPOT Advanced Taskbars for a complete discussion regarding taskbar development and use.

**Hide all Taskbars**

If you have displayed more at least one Taskbar, the option to Hide All Taskbars will be available. Selecting this option will promptly close all open Taskbars in the SPOT Software, this makes for quick and easy clean up of the user interface if many taskbars have been opened. Alternatively, if multiple Taskbars have been opened and only you only want to close one, use the toggle feature under the Show Taskbars feature (above) to turn off a selected Taskbar.

**Show Variables**

The Show Variables dialogue displays the current values of text and numeric variables that can be called in other parts of the SPOT software. The values can be added, modified or deleted from this dialog. If numbers are entered as text variables, they will be treated as text. Text cannot be entered as numeric variables.
**Full Screen**

View a full screen version of an image – i.e., without the SPOT menus or toolbars or the Windows navigation bar. This option allows you to utilize the entire window for previewing images. Press \[F 7\] to view a full screen image or click on the **Full Screen** toolbar button. Press \[F 7\] again to exit the full screen view. Alternatively, Windows users can exit the full screen view by moving the cursor to the top of the window and clicking on the **Exit Full Screen Mode** button that appears.

While working in Full Screen mode, Windows users can access SPOT menu options using standard keystroke combinations, as illustrated in the table below:

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Menu Option</th>
</tr>
</thead>
<tbody>
<tr>
<td>[Alt] + A</td>
<td>Attributes (Report mode)</td>
</tr>
<tr>
<td>[Alt] + C</td>
<td>Camera</td>
</tr>
<tr>
<td>[Alt] + D</td>
<td>Database (Advanced mode)</td>
</tr>
<tr>
<td>[Alt] + E</td>
<td>Edit</td>
</tr>
<tr>
<td>[Alt] + F</td>
<td>File</td>
</tr>
<tr>
<td>[Alt] + H</td>
<td>Help</td>
</tr>
<tr>
<td>[Alt] + O</td>
<td>Object (Report mode)</td>
</tr>
<tr>
<td>[Alt] + Q</td>
<td>Sequence</td>
</tr>
<tr>
<td>[Alt] + S</td>
<td>Setup</td>
</tr>
<tr>
<td>[Alt] + V</td>
<td>View</td>
</tr>
<tr>
<td>[Alt] + W</td>
<td>Window</td>
</tr>
</tbody>
</table>

**The Window Menu**

The Window menu options include Cascade, Tile, Arrange Horizontally, Arrange Vertically, Close All, and a list of currently open image documents. For descriptions of these features, refer to your operating system’s help.

**Note:** The Window menu options include Cascade, Arrange Horizontally, Arrange Vertically, Arrange Icons, and Close All. For descriptions of these features, refer to the standard Windows help.

**Editing Images**

All of the editing options in the Basic program mode are accessed via the Edit menu. There are six editing categories in the Basic program mode which offer you ways to modify your images. Each of these categories will be explored in detail.

- Basic Editing
- Image Position
- Image Quality
- Annotation
- Calibration Marks, Measurements, and Reticles
- Memos
Basic Editing
The Edit menu contains several functions that are common to most operating systems.

**Undo**
Undo the last edit that you made. The Undo option only allows for one level of edits: in other words, you can only undo the immediately preceding edit. To Undo an action, select Undo from the Edit menu or click the Undo toolbar icon.

**Redo**
Redo the last edit to the image to which you just applied the ‘Undo’. The Redo option only allows for one level of edits: in other words, you can only redo the immediately preceding undone edit. To Redo an action, Select Redo from the Edit menu or click the Redo toolbar icon.

**Cut (Mac)**
Cut text fields within the SPOT program.

**Copy to Clipboard (PC)/Copy (Mac)**
Copy all or part of an image onto the clipboard for insertion into another program. These options are identical to the Windows [Ctrl C] command and the Mac [⌘ C] command.
1. Press and hold the left mouse button (PC)/mouse button (Mac).
2. Drag the cursor over the image until the dotted rectangle covers the area of the image that you want to copy. If you copy without “cutting out” a specific portion of the image, SPOT selects the entire image.
3. Either select the Copy to Clipboard/Copy option from the Edit menu, or press [Ctrl C] (PC)/[⌘ C] (Mac). The image is now ready to be pasted into another application.
4. Open the application that you want to paste the image into, and select from the available pasting options.

**Paste (Mac)**
Paste text fields in the SPOT program. See Appendix B for a list of other shortcut options for the PC and Mac. The Paste field is grayed when editing images.

**Clear (Mac)**
Clear a text field in the SPOT program. The Clear field is grayed when editing images.

**Select All (Mac)**
Select an image for copying into another application.

**Image Position and Size**
From the Edit menu, you can:
- Resize images
- Match the on-screen orientation of a specimen to the microscopic view
• Crop an image to better reflect the area of interest
• The following options are available for adjusting the position of your image.

**Resize**

Use the Resize option to reduce or enlarge an image. When you reduce or enlarge an image, the resolution and file size change accordingly. The SPOT program maintains aspect ratio so enlarged and reduced images will not be distorted. When you reduce or enlarge an image, keep the following in mind:

• Reduction - Resolution (number of pixels) and file size decrease.
• Enlargement - Resolution (number of pixels) and file size increase.

The trade off for higher resolution images is increased file size. The Resize option lets you specify the percentage by which you want to increase or decrease the linear dimensions of the image.

The program reads the red, green, and blue brightness values for the pixels in the original image and uses those values to create a new image where the number of rows and columns is reduced or enlarged by the percentage that you specify.

Two circumstances where you might want to enlarge or reduce an image are listed here:

• **You captured an image using a low magnification objective (e.g., 5x or below)** - In this case, enlarging the image adds pixels, which helps to smooth out the pixellation of high contrast, fine details. This makes it easier to view and interpret the structure of these details. Enlarging also makes large format prints appear smoother and less pixellated.

• **You want to save file space and resolution is not the primary concern** - In this case, reducing the image reduces the file size.

To resize an image, follow these steps:

1. From the Edit menu, select the resize option. The Resize Image window appears.

2. Do one of the following:
   - If you want to change the size of an image by a specific percentage, type in a value between 10% and 200%, or move the slider bar accordingly. The linear dimensions (width or height) of the image will change by this percentage factor.
   - If you want to specify the dimension in pixels, enter a number in either the Width or the Height box. The SPOT program automatically calculates the dimension not entered in order to maintain the proper aspect ratio.
   - If you would prefer, you can also set the image size by using the Print Resolution settings. Enter the number of pixels per unit length and the Width and Height values will automatically be recalculated. Or, you can set the Print Width or Height in a unit of length and have the remaining values calculated by the SPOT software. See more about Image Print Resolution in Ch. 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu.
3. Click on OK. The newly sized image replaces the original image on the screen.

---

**Note:** If you want to create two differently sized images of an image for comparison purposes, use the Save As [Ctrl A] command to save the resized image with a different file name.

---

**Rotate Right**
Rotate an image clockwise in 90-degree increments.

**Rotate Left**
Rotate an image counter-clockwise in 90-degree increments.

**Flip Horizontal**
Flip an image from right to left.

**Flip Vertical**
Flip an image from top to bottom.

**Crop**
Cut out a portion of an image. To crop an image, follow these steps:

1. Press and hold the left mouse button.
2. Drag the cursor over the image until the dotted rectangle covers the area of the image that you want to crop.
3. From the Edit menu, select Crop. The Crop Area window displays the pixel coordinates of the rectangle that you selected. From this window you can fine-tune the crop area by modifying the pixel coordinates. If you select the Crop option directly from the menu (i.e., without specifying a crop area), the Crop Area window displays the values for the entire image.
4. Click on OK to crop the image. The cropped image appears on-screen.

---

**Note:** When you crop an unsaved image, the program automatically discards the area of the image outside the crop. To give yourself the opportunity to change the crop area, you should save the image before you crop it.

---

**Image Quality**

The image quality editing options provide you with a wide array of powerful and easy to use tools for changing the appearance of an image after it has been captured. These tools enable you to enhance the appearance of an image in ways that are not possible with conventional photography. All of these tools are available under the Edit menu.

With the exception of Make Negative, Convert to Monochrome and Change Pixel Bit Depth, all of the image quality editing options utilize **thumbnail** images to preview the edits being made to the main image. As illustrated at right, a thumbnail of the image capture appears in the adjustment window, and the Modify Main Image box is checked as the default.

- **If you leave the box selected**... As you make editing adjustments, the changes appear in both the main image and the thumbnail.
• **If you deselect the box...** As you make editing adjustments, the changes appear only in the thumbnail image. After you click on OK, the changes appear in the main image.

Properly utilized, thumbnail images can be very helpful as part of the image editing process. Consider the following:

• **You can use thumbnails to speed the editing process.** The SPOT software often cannot update all the pixels in the main image as quickly as you can adjust the edit controls. In cases where the thumbnail image is sufficient to judge the effect of the edits, you can save time by deselecting **Modify Main Image**, so that the main image is updated only after you close the editing window. Deselecting **Modify Main Image** also makes the editing feel more “real time.”

• **The thumbnail can be used to display a smaller, magnified section of an image.** When you select a specific image area (i.e., by dragging the cursor) before selecting an edit function, only the selected area appears in the thumbnail. This is useful for Sharpen, an edit function that affects only the fine structure of an image. This is also useful when you are analyzing histograms, and want the histogram to represent only the section of the image that interests you.

### Image Editing and the Concept of Color Space

A color space is a coordinate system that is used to mathematically represent color. In order to satisfy the imaging requirements of different microscopy techniques, the SPOT program allows you to adjust brightness, color, and contrast in three color spaces: RGB, HSL, and HSV.

The color space options and their suggested uses are as follows:

- **Adjust RGB** (Red Green Blue) – Use for monochrome images
- **Adjust HSL** (Hue Saturation Luminance) – Use for all color images except fluorescence
- **Adjust HSV** (Hue Saturation Value) – Use for fluorescence images

Each color space is described below.

#### RGB

The RGB color space operates by assigning a red, green, and blue value to each pixel in an image. Because red, green, and blue are the primary colors for emissive light, this is the method that color computer monitors use to display images. However, the RGB color space is not intuitive to users.

#### HSL

The HSL color space is a more intuitive model based on the three attributes that are common to all colors: hue, saturation, and luminance. Instead of assigning a red, blue, and green value to each pixel, the HSL color space assigns a value for each color attribute (e.g., hue, saturation, and luminance). These attributes are defined as follows:

- **Hue** – Hue is the designation for the actual color, as distinguished from others in the color spectrum. Hue is derived from a color wheel and is expressed in the color's angular location (in degrees) on the wheel. (e.g., +180° to –180° for the SPOT software).
• **Saturation** – Saturation is the proportion of perceived pure hue in the color. Saturation (in the SPOT software) is measured on a numerical scale of 0 to 100, where zero is pure gray and 100 is pure hue (e.g., day glow).

• **Luminance** – Luminance is the relative brightness or darkness of a hue. Luminance (in the SPOT software) is measured on a numerical scale of 0 to 100. A saturated color starts out as black at a luminance of 0, reaches full brightness as a saturated color at a luminance of 50, and then transitions through lighter pastel shades to white at a luminance of 100. This mimics the human perception of increasing brightness for images that are illuminated with light that contains a broad spectrum of wavelengths.

**HSV**

The HSV color space was added to the SPOT software to optimize fluorescence image editing. Both the RGB and the HSL color spaces are problematic when used to edit color fluorescence images. Increasing gamma in RGB can cause dimmer sections of the image to lose saturation (look “washed out”) and change hue. Increasing gamma or brightness in HSL causes the brighter areas of an image to look unnaturally pastel or even white. The HSV color space avoids both problems. The HSV color space is similar to the HSL color space in that it also uses the intuitive concepts of hue and saturation. However, instead of luminance for brightness, it uses Value. Value is like Luminance in that a value of 0 is black. Value differs from Luminance in that a Value of 100 (in the HSV color space) is the brightest version of the original hue whereas a Luminance of 100 (in the HSL color space) is always white. For example, a dim cherry red changes to a bright cherry red when its Value is increased from 30 to 100. When its Luminance is increased from 30 to 100, a dim cherry red turns white. HSV works well for fluorescence images because the dyes in fluorescence images emit single wavelength light. This light is, by definition, highly saturated. Editing in the HSV color space ensures that all areas of the image retain their saturated colors. Thus, using the HSV color space, images can be modified without causing the bright areas to look unnaturally pastel or white.

**Adjust RGB/Adjust HSL/Adjust HSV**

The process by which the program applies edits to an image capture differs according to the color space that you select. The following table briefly describes the edit process in each of the three color spaces and lists the recommended usage for each color space.

<table>
<thead>
<tr>
<th>Color Space</th>
<th>Editing Process</th>
<th>Recommended Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>RGB</td>
<td>Adjustments are applied separately to the red, green, and blue pixel values.</td>
<td>The RGB option is ideal for monochrome images.</td>
</tr>
</tbody>
</table>
| HSL         | 1. RGB pixel values are translated to HSL (hue, saturation, and luminance) values.  
2. Adjustments are applied to the hue, saturation, or luminance.  
The HSL values are translated back to the RGB pixels. | The HSL option is ideal for all color images except fluorescence images. |
| HSV         | 1. RGB pixel values are translated to HSV (hue, saturation, and value) values.  
2. Adjustments are applied to the hue, saturation, or value.  
The HSV values are translated back to the RGB pixels. | The HSV option is ideal for fluorescence images. |
The Adjust RGB, Adjust HSL, and Adjust HSV options are each made up of several image-editing functions. The table below lists the parallel RGB, HSL, and HSV functions:

<table>
<thead>
<tr>
<th>Adjust RGB</th>
<th>Adjust HSL</th>
<th>Adjust HSV</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust Brightness (additive)</td>
<td>Adjust Hue, Saturation, and Luminance</td>
<td>Adjust Hue, Saturation and Value</td>
</tr>
<tr>
<td>Adjust Brightness (multiplicative)</td>
<td>Adjust Luminance (multiplicative)</td>
<td>Adjust Value (multiplicative)</td>
</tr>
<tr>
<td>Adjust Contrast</td>
<td>Adjust Contrast</td>
<td>Adjust Contrast</td>
</tr>
<tr>
<td>Adjust Gamma</td>
<td>Adjust Gamma</td>
<td>Adjust Gamma</td>
</tr>
<tr>
<td>Stretch Bright and Dark Level</td>
<td>Stretch Bright and Dark Level</td>
<td>Stretch Bright and Dark Level</td>
</tr>
<tr>
<td>Adjust Histogram</td>
<td>Adjust Histogram</td>
<td>Adjust Histogram</td>
</tr>
</tbody>
</table>

Many of the Adjust edit functions are duplicated in all three color spaces. To avoid unnecessary repetition, we have grouped together discussions of edit functions that are the same in different color spaces. The color space associated with the option appears parenthetically in the heading.

**Adjust Brightness (additive) (RGB)**

Use Adjust Brightness (additive) to lighten or darken an entire image. This function adds or subtracts the specified number(s) from the red, green, and blue values for every pixel in the image. Because this is an additive function, it affects bright and dark areas equally. You can change an image's brightness either by adjusting all three values (e.g., red, green, and blue) together, or adjusting each value individually.

To Adjust Brightness (additive), follow these steps:

1. From the Edit menu, select Adjust RGB and Adjust Brightness (additive). The Additive Brightness Adjust window appears, with a thumbnail preview of the open image.
   - The Lock RGB and Modify Main Image boxes are checked as defaults. To adjust the RGB values individually, deselect the Lock RGB box.
2. Change the brightness of the image.
   - To modify an image's brightness equally for red, green, and blue values, ensure that the Lock RGB box is checked, and either enter a number in any one of the three boxes, or use one of the slider bars to specify a number between -255 and 255 (8 bit), -4095 and 4095 (12 bit), and -16,383 and 16,383 (14 bit).
   - To modify an image's brightness by specifying separate red, green, and blue values, deselect the Lock RGB box, and enter a value for each color.
3. Click on OK. The new image appears on-screen.
Adjust Hue, Saturation, and Luminance (HSL)
Adjust Hue, Saturation, and Value (HSV)

Use the Adjust Hue, Saturation, and Luminance and the Adjust Hue, Saturation, and Value options to make additive changes to the HSL or HSV values in an image. This process converts the RGB values for each pixel in the image to HSL or HSV values. After you make the adjustments, the program converts the HSL/HSV values back to RGB color space values.

To change the HSL or HSV values for an image, follow these steps:

1. From the Edit menu, select Adjust HSL, Adjust Hue, Saturation, and Luminance or Adjust HSV, Adjust Hue, Saturation, and Value:

2. Either type in the HSL/HSV values, or use the slider bars to select the values. Each value uses its own scale, and must be entered separately.

Hue - Enter an angle value between -180° and 180°. This number represents the amount that the color wheel is rotated for each pixel in the image.

Saturation - Enter a number between -100 and 100. This number is added to the saturation value (e.g., a number between 0 - pure gray and 100 - day glow) of each pixel in the image.

Luminance or Value - Enter a number between -100 and 100. This number is added to the Luminance/Value value (e.g., a number between 0 - pure black and 100 - pure white for Luminance/brightest version of hue if Value) of each pixel in the image.

Note: The scales used to measure HSL/HSV values are not standardized. Thus, the scales used by the SPOT software might differ from those of other programs.

3. Click on OK. The new image appears on-screen.

Adjust Brightness (multiplicative) (RGB)

Use Adjust Brightness (multiplicative) to make the bright areas of an image brighter or darker. This function multiplies the red, green, and blue values for every pixel in the image by the number(s) that you specify. Because this option is multiplicative, it affects bright areas more than dark areas: black areas tend to stay black while lighter areas get brighter. Like the Adjust Brightness (additive) option, the multiplicative option enables you to either adjust the RGB values together or as individual units.

To use the Adjust Brightness (multiplicative) function, follow these steps:

1. From the Edit menu, select Adjust RGB > Adjust Brightness (multiplicative). The Multiplicative Brightness Adjust window appears, with a thumbnail preview of the open image.
The Lock RGB and Modify Main Image boxes are checked as defaults. To adjust the RGB values individually, deselect the Lock RGB box.

2. Change the brightness of the image.

To modify an image's brightness equally for red, green, and blue values, ensure that the Lock RGB box is checked, and either enter a number in any one of the three boxes, or use one of the slider bars to specify a number between 0 (darkest) and 5 (brightest).

To modify an image's brightness by specifying separate red, green, and blue values, deselect the Lock RGB box, and enter a value for each color.

3. Click on OK. The new image appears on-screen.

**Adjust Luminance (multiplicative) (HSL)**

**Adjust Value (multiplicative) (HSV)**

Adjust Luminance (multiplicative) and Adjust Value (multiplicative) make the bright areas of an image brighter or darker when editing in the HSL and HSV color spaces. These functions multiply the Luminance or Value values for every pixel in the image by the number that you specify. Because these options are multiplicative, they affect bright areas more than dark areas.

To Adjust Luminance (multiplicative) (HSL) or Adjust Value (multiplicative) (HSV), follow these steps:

3. From the Edit menu, select Adjust HSL, Adjust Luminance (multiplicative) or Adjust HSV, Adjust Value (multiplicative):

4. Change the Luminance or Value of the image. Use the slider bar to specify a number between 0 (darkest) and 5 (brightest).

5. Click on OK. The new image appears on-screen.

**Adjust Contrast (RGB)**

Use Adjust Contrast to exaggerate or subdue the differences between the bright and dark areas in an image. The Adjust Contrast option, when accessed from the Adjust RGB menu item, enables you to make adjustments to the red, green, and blue values either together, or as individual units.

To adjust the contrast in an image, follow these steps:
1. From the Edit menu, select Adjust RGB and Adjust Contrast. The Contrast Adjust window appears.

   The Lock RGB and Modify Main Image boxes are checked as defaults. To adjust the RGB values individually, deselect the Lock RGB box.

2. Change the contrast of the image.

   To change the contrast equally for red, green, and blue values, ensure that the Lock RGB box is checked, and either enter a number in any one of the three boxes, or use a slider bar to specify a number between 0 (pure gray - no contrast) and 5 (maximum contrast).

   To modify an image's contrast by specifying separate red, green, and blue values, deselect the Lock RGB box, and enter a value for each color.

3. Click on OK. The new image appears on-screen.

**Adjust Contrast (HSL)**

**Adjust Contrast (HSV)**

The Adjust Contrast (HSL) and Adjust Contrast (HSV) options, like the Adjust Contrast (RGB) option, exaggerate or subdue the differences between the bright and dark areas in an image. Unlike the Adjust Contrast (RGB) process, the Adjust Contrast (HSL/HSV) process works only on the Luminance/Value values for an image as opposed to the specific red, green, and blue values.

To use Adjust Contrast (HSL/HSV), follow these steps:

1. From the Edit menu, select Adjust HSL and Adjust Contrast or Adjust HSV and Adjust Contrast.

   The Modify Main Image box is checked as a default.

2. Enter a value between .1 and 4, or use the slider bar to select a value. The thumbnail changes as you adjust the value.

   To exaggerate the contrast of an image, enter a value above one (the base value). To subdue the contrast of an image, enter a value below one (the base value). Click on OK. The new image appears on-screen.
**Adjust Gamma (RGB)**

Gamma Adjust smoothly lightens darker areas of an image without burning out bright areas or lightening black areas. This is especially useful for editing images with a wide range of brightness values (dynamic range). Gamma adjustment corrects an image by creating a new version of the original. Refer to Ch. 5 – Preparing to Take a Picture for a more detailed explanation of gamma adjustment.

To adjust gamma, follow these steps:

1. From the Edit menu, select Adjust RGB and Adjust Gamma. The Gamma Adjust window appears. The Lock RGB and Modify Main Image boxes are checked as defaults.

2. Adjust the gamma.

To adjust the gamma equally for red, green, and blue values, ensure that the Lock RGB box is checked and either enter a number in any one of the three boxes, or use a slider bar to specify a number between .1 and 4.

To gamma adjust an image by specifying separate red, green, and blue values, deselect the Lock RGB box, and enter a value for each color.

3. Click on OK. The new image appears on screen.

**Adjust Gamma (HSL)**

**Adjust Gamma (HSV)**

Like the Adjust Gamma (RGB) option, the Adjust Gamma (HSL) and Adjust Gamma (HSV) options allow you to smoothly lighten darker areas of an image without burning out bright areas or lightening black areas. This is useful when modifying images with a wide dynamic range, meaning the range of brightness values recorded by the CCD chip. Unlike the Adjust Gamma (RGB) option, Adjust Gamma (HSL) and Adjust Gamma (HSV) work only on the luminance or value values (respectively) for an image as opposed to the specific red, green, and blue values. Refer to Ch. 5 – Preparing to Take a Picture for a more detailed explanation of gamma adjustment.

To Adjust Gamma (HSL/HSV), follow these steps:

1. From the Edit menu, select Adjust HSL, Adjust Gamma or Adjust HSV, Adjust Gamma.
2. Enter a value between .1 and 4, or use the slider bar to select a value. The thumbnail preview of the image changes as you adjust the value.

To lighten the mid-tones of an image, enter a gamma value above one. To darken the mid-tones of an image, enter a gamma value below one.

3. Click on OK. The new image appears on-screen.

**Stretch Bright and Dark Level (RGB)**

The Stretch Bright and Dark Level (RGB) option stretches the darkest level in an image to 0 (black) and the brightest level to full scale. Full scale is 255 for 8 bit monochrome and 24 bit RGB images, 4,095 for 12 bit monochrome and 36 bit RGB images, and 16,384 for 14 bit monochrome and 42 bit RGB images.

Stretching the bright and dark level (RGB) for a 24 bit RGB image with a range of brightness values between 50 and 150 has the following effects:

- The lowest value pixels (50) are stretched down to 0.
- The highest value pixels (150) are stretched up to 255.

This one-step process provides a quick and easy way to increase image contrast in low contrast specimens. To use Stretch Bright and Dark Level (RGB), select Adjust RGB, Stretch Bright and Dark Level from the Edit menu. The picture automatically adjusts itself.

**Stretch Bright and Dark Level (HSL)**

Like Stretch Bright and Dark Level (RGB), the Stretch Bright and Dark Level options in the HSL and HSV color spaces stretch the darkest luminance or value level in an image to 0 (black) and the brightest luminance or value level to 100 (pure white if Luminance/brightest version of hue if Value). Using the HSL or HSV (for fluorescence images) color space to stretch images, as opposed to the RGB color space, reduces the potential for washed out images and color shifts.

To stretch bright and dark level HSL or HSV, select Adjust HSL, Stretch Bright and Dark Level or Adjust HSV, Stretch Bright and Dark Level from the Edit menu. The picture automatically adjusts itself.

**Adjust Histogram (RGB)**

A histogram is a graphical representation of the number of pixels at each brightness level in an image. SPOT’s histogram displays the red, green, and blue histograms on the same graph. It serves two main purposes:
• It is a point of reference for examining the distribution of brightness levels for the red, green, and blue components in an image.

• It can be used to reset the zero and full-scale points for an image. This is known as stretching. Like the aforementioned Stretch Bright and Dark Level function, the Adjust Histogram option enables you to stretch the darker areas of your image to pure black and at the same time lighten the brighter areas of the image.

Note: Full scale for 8 bit monochrome and 24 bit RGB images is 255. Full scale for 12 bit monochrome and 36 bit RGB images is 4,095. Full scale for 14 bit monochrome and 42 bit RGB images is 16,383.

To adjust an RGB histogram, follow these steps:

From the Edit menu, select Adjust RGB, Adjust Histogram. The RGB Histogram window appears. Set the display parameters for the histogram:

Determine the color or colors that you want to display brightness values for. As a default, the histogram displays all three values. To display a different combination of colors, deselect the Show box for the unwanted color(s).

To display the histogram according to a logarithmic scale (as opposed to a linear scale), check the Log Scale box. This makes the vertical axis more sensitive to small numbers and compresses the range for larger numbers.

From the RGB Histogram screen you have three viewing/editing options.

1. Examine the number of pixels at each brightness level.
   Do one of the following:
   Move the cursor along the graph to display the number of pixels with red, green, and blue values at each brightness level and the total number of pixels at that level.
   Type the same brightness level into both boxes under Number of Pixels. The histogram readouts display the number of pixels with red, green, and blue values at that brightness level, as well as the total number of pixels at that level.

2. Examine the number of pixels between two brightness levels.
   Do one of the following:
   Position the cursor over one brightness level on the graph, and left click and drag the cursor to the second brightness level. The histogram readouts display the number of pixels with red, green, and blue values between the two brightness levels as well as the total number of pixels.
   Type the two brightness levels into the boxes under Number of Pixels. The histogram readouts display the number of pixels with red, green, and blue values between the two brightness levels, as well as the total number of pixels.

3. Stretch the image.
   Follow these steps
   • Either drag the left triangle (on the X axis) to the brightness level that you want to define as zero, or enter the value, in the form of a percentage, in the Bottom box. All red, green, and blue values that are less than or equal to this level are now reset to zero.
• Either drag the right triangle (on the X axis) to the brightness level that you want to define as full scale, or type in the value, in the form of a percentage, in the Top box. All red, green, and blue values that are greater than or equal to this level are now reset to full scale.

    The program automatically multiplies all red, green, and blue values between the new zero point and full scale values by the factor necessary to make the new full scale setting equal to actual full scale after the new zero point setting (if you have defined one) has been subtracted.

• Click on OK to save the image with the new zero point (Bottom) and full scale (Top) values.

**Adjust Histogram (HSL)**  
**Adjust Histogram (HSV)**

HSL and HSV histograms are identical to RGB histograms, except that instead of displaying the number of pixels for the RGB components, they display the number of pixels at each luminance or value level. As with the RGB histogram, HSL and HSV histograms are typically used for two purposes:

• Examining the distribution of luminance or value levels in an image.

• Resetting the zero and 100 % luminance/value points in an image. This is known as *stretching*. The Adjust Histogram (HSL) and Adjust Histogram (HSV) options allow you to stretch the darker areas of your image to pure black and lighten the brighter areas to either pure white, if using the HSL color space, or the brightest version of the hue, if using the HSV color space.

To Adjust Histogram (HSL) or Adjust Histogram (HSV), follow these steps:

1. From the Edit menu, select Adjust HSL, Adjust Histogram or Adjust HSV, Adjust Histogram. The Luminance Histogram or Value Histogram window appears.

2. If you want to display the image's histogram according to a logarithmic scale, check the Log Scale box. Checking the Log Scale box makes the vertical axis more sensitive to small numbers and compresses the range for larger numbers.

From the Luminance/Value Histogram window you have three viewing/editing options.

• Examine the number of pixels at each Luminance/Value level. 

    Do one of the following:

    Move the cursor along the graph to display the number of pixels at each Luminance/Value level. Type the same Luminance/Value level into both boxes under Number of Pixels. The histogram readouts display the number of pixels at that Luminance/Value level.

• Examine the number of pixels between two brightness levels. 

    Do one of the following:
Position the cursor over one luminance or value level on the graph, and left click and drag the cursor to the second Luminance/Value level. The histogram readouts display the number of pixels between the two levels.

Type the two Luminance/Value levels into the boxes under Number of Pixels. The histogram readouts display the number of pixels between the two Luminance/Value levels.

- **Stretch the image.**
  Follow these steps:

  - Either drag the left triangle (on the X axis) to the Luminance/Value level that you want to define as black (0 % Luminance/Value), or enter the Luminance/Value number in the **Bottom** box. All Luminance or Value values that are less than or equal to this level are now reset to black (0 % Luminance/Value).

  - Either drag the right triangle (on the X axis) to the Luminance/Value level that you want to define as full scale (100 % Luminance/Value), or enter the Luminance/Value number in the **Top** box. All Luminance/Value values that are greater than or equal to this level are now reset to full scale (100 % luminance/value). The program automatically multiplies all Luminance/Value values between the new black and full scale values by the factor necessary to make the new full scale value equal to 100 % Luminance/Value after the new black value (if you have defined one) has been subtracted. The thumbnail sample image updates automatically so you can gauge the effect of your adjustments.

  - Click on OK to save the image with the new black and white Luminance/Value values.

*Equalize Histogram (RGB)*

This feature works best to bring our hidden details in dark portions of an image. If you have a good quality image and you want to alter the histogram, try adjusting the appropriate histogram instead.

**Filter**

The Filter menu option contains five options for modifying images:

- Smooth
- Sharpen
- Unsharp Mask
- Filter Noise
- Median Filter

*Smooth*

Use Smooth to smooth out grainy images. The smooth option works by lightening the darker side of contrast boundaries and darkening the lighter side. Because the Smooth option removes the high frequency details from an image, some fine image detail is also lost.

To smooth the appearance of an image, follow these steps:

1. From the Edit menu, select **Filter > Smooth.**
   To preview images on the thumbnail image only; deselect the Modify Main Image box.

2. Either use the slider bar to select a Strength value between one and 100, or enter the value in the box.
3. When you have determined a suitable value, click on OK. The smoothed image appears.

**Sharpen**

Use Sharpen to improve the appearance of soft or blurry looking pictures. The Sharpen option works by darkening the darker side of a contrast boundary and brightening the brighter side of a contrast boundary.

To sharpen the appearance of an image, follow these steps:

1. From the Edit menu, select **Filter > Sharpen**.
   To preview changes on the thumbnail image only, deselect the Modify Main Image box.
2. Either use the slider bar to select a Strength value between one and 100, or enter the value in the box.
3. When you have determined a suitable value, click on OK. The sharpened image appears.

**Unsharp Mask**

Use the Unsharp Mask filter to improve the appearance of an image’s high frequency details. The Unsharp Mask option sharpens an image by subtracting a brightness-scaled, low-pass-filtered image from the original image.

To apply the Unsharp Mask filter, follow these steps:

1. From the Edit menu, select **Filter > Unsharp Mask**.
2. To preview changes on the thumbnail image only, deselect the Modify Main Image box.
3. Either use the slider bar to select a Strength value between one and 100, or enter the value in the box.
4. When you have determined a suitable value, click on OK. The sharpened image appears.

**Filter Noise**

The Filter Noise corrects for the effects of electrical or thermal noise. When capturing dim images with lengthy exposure times, the noise filter acts as a “virtual cooler” for non-cooled camera models, eliminating “hot pixels.”

The Noise Filter checks each pixel on the CCD chip as described below:

1. The program compares the value of each pixel with the values of eight neighboring pixels of the same color.
2. If none of the eight neighboring pixels has a value within the threshold value set (±15 %) for the pixel being checked, the value for the pixel being checked is replaced with the average of the eight neighboring pixels.

---

Note: On color mosaic cameras, this procedure is performed on each, the red, green and blue sets of pixels.
To filter noise, follow these steps:

1. From the Edit menu, select **Filter > Filter Noise**.

2. Enter a value between **10%** and **100%**. The Threshold value is set to a default of 15%, but will default to the last used setting thereafter. Refer to the procedure described at the start of the Filter Noise section for an explanation of the Threshold value.

3. Click on OK. The filtered image appears on-screen.

   **Note:** Image Profiles can be defined to automatically use the noise filter when capturing an image. Refer to Ch. 2 for details.

**Median Filter**

The Median Filter corrects for the effects of shot noise. This filter functions by considering a sample pixel and its surrounding 8 pixels. The values of all nine pixels are compared and the median value of the group is substituted for the sample pixel. In this process, all pixels are always being modified, unless, of course, the sample pixel is the median value of the group.

Unlike the Filter Noise function, there is no need for any user inputs regarding the median filter process.

This approach negates any impact that a hot pixel might have on the filtered value of another neighboring (sample) hot pixel.

   **Note:** Filtering algorithms always utilize original data for each sample pixel being considered. In other words, filtered (substituted) pixel data is not used in the filtering process.

**Make Negative**

Make Negative creates a color negative (with complimentary colors) of an image. From the Edit menu, select Make Negative. The Program automatically converts the image to a negative.

**Match Color**

The Match Color feature is typically used in two situations:

- You want to change the colors of an image on the screen to match the way that you think the specimen looks.

- You want to set the white balance for pictures taken with a microscopic technique that never has white in its images. A prime example of this situation is fluorescence microscopy.

If you use the Match Color option on a captured, previewed, or Live image, you can follow these steps to adjust the white balance.

   **Note:** The Set White Balance button appears only for a newly captured, unsaved, and unedited image.

1. Click on the Match Color button.
2. The mouse cursor will change to an eye dropper. Use the cursor to select (click) the color which needs to be adjusted to white.

Note: The R, G, and B values of the pixel that you select must all be less than full scale, i.e. 255 for 8 bit images, 1023 for 10 bit images, 4095 for 12 bit images and 16383 for 14 bit images.

3. The Match Color dialog appears with information about the pixel that you selected:

- **Hue** – The actual color, as distinguished from others in the color spectrum. Hue is derived from a color wheel and is expressed in the color’s angular location (i.e., 0 to 360 degrees).

- **Saturation** – The richness of perceived pure hue in the color. Saturation (in the SPOT Software) is measured on a numerical scale of 0 to 100, where zero equals pure grey and 100 equals pure hue (i.e. ‘day glow’).

4. Click the Make White/Grey button to rebalance the red, green, and blue ratio to make the selected pixel ‘white’.

5. To use these new values for the white balance values, click the Set White Balance button and click OK.

Note: If you use the following options on a Live Image, the change you make will only be reflected in the current image frame. While you use the Match Color feature, the Live Image is paused and the below changes will only be reflected in the displayed paused image frame. As soon as you click the OK button on the Match Color dialog box, the Live Image will resume and any modifications you made will revert back to the original colors. To retain the settings, click the **Set White Balance** button.

If you use Match Color on a captured or previewed image, you can also adjust a color which is not being displayed as you see it with your eyes.

To use the Match Color feature for this purpose, follow these steps:

1. Click on the Match Color button.

2. The mouse cursor will change to an eye dropper. Use the cursor to select (click) the color which needs to be adjusted to a different color.

Note: The R, G, and B values of the pixel that you select must all be less than full scale, i.e. 255 for 8 bit images, 1023 for 10 bit images, 4095 for 12 bit images and 16383 for 14 bit images.
3. The Match Color dialog box appears with information about the color you selected as outlined above (Hue and Saturation).

4. The color you selected can be adjusted by a few different methods, aside from the Set White Balance option described above:

   - The Hue and Saturation inputs which are best used for minor adjustments or to set fluorescent colors to saturation.

   - The Select Color option is available for assigning a color correction to the image. This is accomplished by moving the crosshairs on the color wheel to the desired location by clicking on the new location or clicking and dragging.

For any of these adjustments, you can click the “Modify Main Image” check box to see your changes on the source image as you make them.

5. Click on OK to accept the adjusted image.

**Change Bit Depth**

Users can use the Change Pixel Bit Depth option to convert the pixel bit depth for a captured image to a different setting. This may be useful when the image setup was created for capturing high bit depth images and the user later wants to save a lower dynamic range picture in a different file format (move this to Change Pixel Bit Depth discussion section). See more about the File Saving options in the Save section of this chapter.

Use Change Bit Depth to change the bit depth of the currently open image. To change the pixel bit depth for an image, follow these steps:

1. From the Edit menu, select the Change Bit Depth option. The Change Bit Depth window displays the current Bit Depth for image.

2. Select the pixel bit depth that you want to change the image to.

   - Changing from one monochrome bit depth to another monochrome bit depth or from one RGB bit depth to another RGB bit depth does not require the addition of any color channeling information. In this case, select the new pixel bit depth and click on OK.

   - Changing from an RGB color image to a monochrome image requires the entry of color channeling information. When you select the new pixel bit depth, the color channeling information appears.

3. Select the color channel(s) that you want to use. Select either a single color or the All Channels option, which is the default.

   - If you select a single color channel, the program uses only the values for that color (in the original image) when it creates the monochrome image.

   - If you select All Channels, the program uses a mathematical algorithm to combine the red, green, and blue values from the original image when it creates the monochrome image.
In order to have the image retain its new bit depth setting, you will have to save the image to file. For more on image saving options, please refer to the Save section in this chapter, above.

**Convert to Monochrome**

Use this feature to quickly change a color image to its corresponding monochrome image. For instance, this feature will take a 24 bit RGB image and convert it to an 8 bit monochrome image with one simple click. Choose the Convert to Monochrome feature from the Edit menu. This feature is not available for monochrome images.

For maximum flexibility with your bit depth setting, you can use the Change Pixel Bit Depth option instead.

*Note: When Convert to Monochrome is applied, all color data is removed from the image and is not retrievable.*

**Subtract Image**

Use Subtract Image to subtract an image from a selected, open image. Follow these steps:

1. From the Edit menu, select **Subtract Image**.
2. Select the Source of the image that you want to subtract from the currently open, selected image. The image can come from one of the following three sources:
   - **A Currently Open Document** - Subtract an image from a currently open image. If the path for the image you are editing does not appear in the Title box, select it from the Title drop-down list, which lists all open images. If the file is an image sequence, specify the number of the image in the sequence (the Sequence Index).
   *Note: It is possible to subtract an image from itself.*
   - **An Image File** – Subtract a file from disk from the currently open, selected image. Either enter the file path in the box, or click on the browse button to the right of the box to search for and select the file. If the file is an image sequence, specify the number of the image in the sequence (the Sequence Index).
   - **A Database** (Windows only) – Subtract a file from a SPOT database from the currently open, selected image. To subtract an image from a SPOT database you must enter the Image ID for that image. You can determine the eight-digit Image ID number by searching the database for the image that you want to add. The search results display the Image ID number.

*Note: To subtract a database file, the database must be open. For more information on using SPOT databases, refer to Chapter 8 – SPOT Advanced Databases.*

3. Enter a Scale Factor between 0.01 and 5. The Scale factor adjusts the brightness of the image that you are subtracting. Numbers between 0.01 and 1 darken the image and numbers between 1 and 5 lighten the image.
4. Click on OK to add or subtract the image. The combined image replaces the original.
Merge Images –

Use Merge Images to combine two or three monochrome images into a single composite image. Traditional uses of this feature include merging of single color fluorescent images, however you can also merge full color images, or even lay out images next to each other to create an image montage. The Merge Images option is used primarily in fluorescence imaging when specimens have been stained with more than one dye, and a triple filter cube is not available. In this circumstance, each dye can be excited individually, and a monochrome image can be captured for each excitation. The Merge Images feature then allows you to combine these images to create a composite image that shows all the dyes.

Merging images requires at least two source images. The source image can be from the following sources:

**Currently Open Document**

If the images which you want to merge are open in the SPOT application, it is easiest to select Currently Open Document for your source images. Select the appropriate Image Title from the drop down list.

**File**

If you do not have the images open which you want to merge, you can use the File option and use the browse button to locate each image. Once an image is selected, its Name will appear in the Name field.

**Sequence Index Number**

If one of the image documents selected in either the Currently Open Document or the File is an Image Sequence File, you will need to indicate which image you would like to select from the Image Sequence File.

**Database: Image ID (Windows only)**

If a database is open, the option to input the Database ID will be available. Simply type in the Database ID of the image you want to merge with others. You may need to first search the Database to locate the Database ID of the picture you wish to use. See Ch. 8 – SPOT Advanced Databases for additional information.
Palette

If you are working with monochrome images, the Palette button will be available for you to apply a color palette to each image. Press the Palette button to access all available color palettes.

If you press the Palette button and the image is color, you will receive an error message that the palette cannot be applied to the image because it is color, not monochrome. For more information about color Palettes, please refer to the Palette section (below) in this Chapter.

You can also adjust the brightness and position of the images which are being merged. The right hand side of the Merge Images dialog has settings for the positioning of the images to be merged as well as the relative intensity of the images’ brightness levels.

Scale Factor

The Scale Factor feature allows you to scale the brightness of a source image before it is merged. Values between 0.01 and 1 darken the image and values between 1 and 5 brighten the image.

Position Offsets

Changing filters for an image capture can cause its position to shift from that of the previous capture. This can be problematic when trying to merge two or three images captured with different filters. The Position Offsets for each individual image in the merged image allow you to compensate for such shifts by specifying Horizontal and Vertical Position Offsets in pixels.

Specify the Horizontal and/or Vertical position offset you require to align images properly. The position offset will be applied in the merged image.

Include Non-Overlapping Areas in Final Image

To retain the non-overlapping areas, ensure that the Include Non-Overlapping Areas in Final Image box is selected. If you do not select the box, the final image automatically discards any non-overlapping areas.

Auto – Scale Brightness

Whereas the Scale Factors are applied to individual images before they are Merged, the Auto-Scale Brightness feature automatically adjusts the brightness of the merged image to prevent overlapping bright areas from burning out.

Merge as Displayed

The Merge as Displayed option is available in the event that you have added annotations, calibration marks, measurements or reticles and you would like to merge the images with these layers into the final image. If you do not select this box and you have an annotation calibration mark, measurement, or reticle on one of the images to be merged, it will only show up in the final image as a layer. These layers are viewable within SPOT, however in order to view these layers in other applications, the layers will need to be merged into the image.

Apply

Click on Apply to apply your settings and view the merged image. When you click on Apply, the Merge Images dialog remains open, allowing you to experiment with different Scale Factors and Position Offsets. A new image document will be displayed on top of the source images (if open) and any changes you make to the settings in the Merge Images dialog will be visualized in the new image document.
**Shrink/Expand**

Once you have set the images you want as your source image documents, you can click on the Shrink button to reduce the size of the Merge Images dialog. When you click the Shrink button you will be left with the ability to adjust the Scale Factor and the Position Offsets. This minimizes the amount of space that the Merge Images dialog uses in the window and makes it easier to see your new merged image if you have clicked Apply (above). If you need any other feature, simply click on the Expand button to open the entire Merge Images dialog.

**OK**

When you are satisfied with the appearance of the merged image, click on OK to apply the settings and close the Merge Images dialog.

**Set Palette**

The Set Palette option enables you to apply a specific color palette to a captured monochrome image. There are four pre-defined color options: Grayscale, Red, Green, and Blue. To define a custom palette, use the Palettes option (Setup>Palettes). Refer to Ch. 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu for more details on setting up Palettes and applying them as part of the image capture process.

**Indicate Saturated Pixels**

This feature is only available if the image is monochrome or the image is being displayed in grayscale. With this feature turned on, saturated pixels are indicated in red in the captured image. From the Edit menu this feature can be turned on and off and functions to show you saturated pixels in your captured image. Please refer to Ch. 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu for how to use this function as part of your imaging in the Image Setups and Live Image Controls.

**Annotate**

Image annotation is useful when you want to prepare captures for formal presentation, or inclusion in an article or reference work. Using SPOT’s image annotation features, you can:

- Add text to an image.
- Use an arrow, line, rectangle, or ellipse to emphasize a particular area in an image.
- Add a graphic stamp such as a company logo to an image.
- Add freehand lines to an image.
- Number objects in an image.
- Add the current user name to an image.

Other annotations are also available. To annotate an image, select Annotation from the Edit menu. Several changes take place in the SPOT image-editing environment:

- The Edit menu options change to reflect annotation editing.
- The Object menu appears with options for inserting drawing objects, text, images, and image related information onto an image.
- If None is selected, the cursor is an editing tool for selecting, sizing, and positioning objects. When creating new reports, None is the default option.
• If an annotation object is selected, the cursor changes to a cross-hair icon for placing new objects on the image. Refer to Adding Annotation Objects to SPOT Images (below) for descriptions of each object.

• The View menu changes to reflect annotation mode:

• The two zoom options and the Show Grid Lines options are no longer displayed.

• The Show Tools option is present – this option displays the Tools dialog box, which contains shortcuts for inserting annotation-drawing objects.

• The Attributes menu appears with options for specifying annotation qualities. See below, Defining Annotation Attributes for descriptions of each option.

• The Done! Menu allows you to switch back to the image capture/edit mode. The Done! Menu has only one option, End Annotation Mode. When you select this option the SPOT program reverts back to the standard SPOT image-editing environment. If the Tools are in view, you can also click on the Done button.

Adding Annotation Objects to SPOT Images

Once in Annotation mode, Annotation objects can be added to images in one of two ways:

• Through the Object menu.

• Through the Tools dialog box. To access the Tools dialog box, select the Show Tools option on the View menu. The Tools dialog box, as illustrated above, displays shortcut buttons to the eleven drawing objects on the Object menu:

Before discussing the individual objects, review the following general procedure for inserting an annotation object into an image:

1. From the Object menu, select the type of item (i.e., Lines, Connected Lines, etc…) that you want to add to the image. The cursor’s functionality varies according to whether an object type (i.e., line, text) is selected. If an object type is selected, the cursor changes to a cross-hair icon that is used to add new report objects to the grid. If None is selected, the cursor is an editing tool that is used to select and position objects.

2. Use the mouse to move the cross hair to the location where you want to insert the object.

3. Left-click at the insertion point.

   If you selected a line, box, or other shape, hold down the mouse button and drag the object to the desired size.

   If you selected one of the other objects, the object will either appear (e.g., Image Time) or the program will prompt you to enter the associated information (e.g., Text, Image Memo, etc…).

4. After you have added the object, there are three options:

   Add another object of the same type, as described in step 3.

   Note: In some cases, the procedure varies to fit the object’s characteristics. The specifics are noted in the descriptions of the individual objects.
Add a different type of object - select from the Object menu options, the toolbox.
Resize, reposition, or edit an object. To do so, select None from the Object menu.
  o To resize an object, select (left-click) the object and drag the handles to make the
    object larger or smaller.
  o To reposition an object, left-click and drag the object to the desired area of the image
    document.
  o After the object has been added, it can be edited. To edit an annotation object select
    the object and choose an option from either the Edit menu or the Attributes menu.
    You can also edit an object by right clicking on it.

5. When finished, choose End Annotation Mode from the Done! Menu, or click the Done button
   on the Tool box.

6. To merge the annotation into the image so that they can be displayed when the image is
   opened in other applications, access the Edit menu, choose Merge, and then Merge Annotations.
   The annotations will then be merged into the pixel data. Please see the Merge feature, later in
   this chapter, for more information on Merging layers into your image.

The following section describes each Annotation object in detail.

None
Select None when you want to use the cursor to edit and position the objects. For a shortcut, use
the Escape key on your keyboard to change the functionality of your cursor to a select tool, None.

Lines
Unconstrained Line - Add a straight line annotation to the image
Horizontal Line - Add a horizontal line annotation to the image.
Vertical Line - Add a vertical line annotation to the image.
Arrow – Add an arrow to the image. Either select Lines>Arrow from the Object menu, or click on
the Tools box button. Left click on the image and drag toward the area that the arrowhead will
point to.

Connected Lines
Polygon – Add a closed polygon to an image. Either select Polygon from the Object menu, or
click on the Tools box button. Left click and release, and then drag the mouse to create a side.
Left click again to start a new side. Double click to finish the polygon. The program automatically
adds any additional lines needed to close the figure.
Polyline – Add an open polygon to an image. Either select Polyline from the Object menu, or
click on the Tools box button. Left click and release, and then drag the mouse to create a side.
Left click again to start a new side. Double click to finish the polyline.
Freehand - Add a freehand line to the image.

Shapes
Rectangular Box – Add a square cornered box to the image.
Rounded Box - Add a round cornered box to the image.
Ellipse – Add an elliptical object to the image. Ellipses are drawn inside of the rectangular area
that you define. Ellipses touch the top, bottom, right and left sides of this rectangle.

Either select Ellipse from the Object menu, or click on the Tools box button. To draw an ellipse,
left click at the point where you want to position one vertex of the rectangle and drag the cursor to the point of the opposite vertex.

**Circle** – Add a circle to the image.

**Images**

**Image** – Add an image to the image.

1. From the Object menu, select Image.
2. Left click at the point on the display grid where you want to insert the Image box, and holding down the mouse button, drag the cursor to create the desired shape and size for the image (it can also be resized/re-positioned at a later point). When you release the mouse button, the Select Image dialog box appears.
3. Specify the file source for the image:
   - **Currently Open Image** – Add a currently open image. If you have one or more open images, SPOT lists the file name(s) and path(s) in the drop-down box. Select from the list.
   - **Image File** – Add an image from disk. Specify the file name and location either by entering the path in the Name box, or clicking on the selection box to the right.
   - **Database** (Windows only) – Add an image from a SPOT database. In order to insert a database image, the database must be open. Enter the Image ID for the file. If you do not know the database image ID, search the database – the display table indicates the Image ID for each file.

   **Note:** Because the Mac edition does not have database functionality, Mac users will not be able to use the Database option.

4. Click on OK. The image appears on your report grid.

**Stamp** – Insert a selected image onto the image capture. From the Object menu, select Stamp. The last selected image appears on your image. To select a new image to insert, choose the Stamp option from the Attributes menu.

**Text**

Add text to the image.

1. Either select **Text** from the Object menu, or click on the Tools box button.
2. Left click at the point where you want to insert the text. The Text window appears.
3. Enter the text.
4. Click on OK. The text box appears.
5. Resize the box as needed to display the text.

**Current Date** - Add the current date to the image. This date defaults to the date set on the computer you are using.

**Current Time** - Add the current time to the image. This time defaults to the time set on the computer you are using.

**Current User Name** – Add the current user’s name to the image. This defaults to the user who is logged on the computer.

**Image User Name** – Add the name of the person who captured the image to the image. This will be blank when added to the image if the image user name was not recorded with the image when it was taken.
Image Date - Add a date to the image. This date defaults to the date that the image was captured. To change the date, double click on the box, and enter the desired date.

Image Time - Add the image capture time to the image. This time defaults to the time that the image was captured. To change the time, double click on the box, and enter a new time. The time that appears here varies according to whether the file was transferred across a network, and whether the file is a SPOT database image. Refer to the Image Date/Time section of this chapter for more details.

Image Title - Add a title to the image. The title automatically defaults to the file name and location of the open image, e.g., C:\images\cells\fluor1. To change the title, double click on the box and enter a new title.

Image Memo – Add a previously defined TIFF image memo. Click at the point where you want to insert the text box. To change the memo, double click on the box and modify the text as needed. Changing the text in the memo annotation does not affect a memo that is attached to the image file.

Image Sequence Index (sequence images) - Add the Sequence Index (number) to the image. This is the number of the image within the sequence – i.e., the Sequence Index for the first image in the sequence is “1,” the second image “2,” etc…

Image Sequence Size (sequence images) – Add the total number of images in the sequence to the image.

Image Sequence Elapsed Time (sequence images) – Add the elapsed time between the image being annotated and an image that you specify. After selecting Object>Text>Image Sequence Elapsed Time, the program prompts you to enter the Reference Image Index Number. If you specify a number that comes after the image being annotated, the elapsed time will be negative. For instance, if you are annotating image number five in a sequence of 10, and you specify a Reference Image… of eight, the elapsed time will be a negative value.

AutoNumber – Adds numbering to the image starting at 1 and incrementing by 1 for each click of the mouse. Good for counting and tracking objects in an image. You may elect to change the starting number to a value greater than one by defining Autonumber’s attributes (see section below).

Defining Annotation Attributes

All of the general style and appearance options can be accessed from the Attributes menu. Annotation attributes can be defined for an entire report or on an object-by-object basis (see the Adding Annotation Objects to SPOT Images section above).

• When an annotation object is selected, the attribute is defined for the selected object(s) only. In addition, when you right click on an object, the menu displays the attribute options for that object.

• When nothing is selected, the attribute is defined for all future, relevant objects.

The following section details each of the annotation attributes and the report objects that they affect.

Colors

Define the foreground and background colors for all objects. Follow these steps:

1. From the Attributes menu, select Colors.
2. Define the **Text/Lines** color. This is the color of the text, the line, or the border around a text/image box. The default foreground color is black. To select a color click on Color.

3. The next window varies, depending on whether you are using a Windows or a Mac system. Windows allows you to select from a palette of colors or enter specific HSL or RGB color values. Mac OS allows you to select from a palette of colors, enter specific RGB, CMYK, HLS, or HSV values, and enter Internet specific colors.

4. Define the **Background/Fill** color. This is the color that appears behind text and in boxes. Lines and images do not display a background color.

You may set your selections as the default by selecting the Save as Defaults checkbox.

**Line Thickness**

Determine line thickness for the following objects: Line, Horizontal Line, Vertical Line, Arrow, Box, Rounded Box, Ellipse, Freehand, Polygon, and Polyline.

1. From the Attributes menu, select Line Thickness.
2. Enter a Thickness value between 1 and 5 pixels.
3. Click on OK.

You may set your selections as the default by selecting the Save as Defaults checkbox.

**Box/Ellipse Options**

Define the appearance of the Box and Ellipse objects.

Specify whether you want a fill for the object.

1. If you do not want the box to be filled (i.e., you want a transparent box), click on OK.
2. If you want to specify a fill for the box, check the Fill Box/Ellipse.
3. Click on OK. The background will fill with the color selected in the Attributes/Colors/Background/Fill selection.

You may set your selections as the default by selecting the Save as Defaults checkbox.

---

**Note:** In order to define a background/fill color for a Box or a Rounded Box, a fill must be selected. Similarly, in order to define a background/fill color for a text box, the background (see Text Border, Justification, and Background below) must be set to Opaque.

---

**Image Options**

The Image Options dialog allows you to set how images used as annotation objects will appear on the base image.

**Border**

Images used as annotation objects can have a border around them. To have a borderless image, uncheck the Border box. To set the thickness (in pixels) of a border...
line, check the Border box and enter a value between 1 and 15.

Retain Original Resolution

Check this box if you would like to have the annotation image object retain its original resolution. Otherwise if left unchecked, the annotation image object will take on the base image's resolution.

Show Annotations, Show Calibration Marks, Show Measurements, Show Reticles

Each layered object in a SPOT saved image can be independently turned on or off on the annotation object (as long as these layers have not already been merged to the image data). Check or uncheck each box to indicate which layers you would like to have shown on the annotation object.

Arrow Size and Direction

Specify the size of the arrowhead and define the direction that the arrow points.

1. To specify the size of the arrowhead, enter a value between 1 and 10.

2. Specify the direction of the arrow:
   - To draw an arrow starting tail first and finishing with the point (head), select Tail to Head.
   - To draw an arrow starting point (head) first and finishing with the tail, select Head to Tail.

3. Click on OK.

The Arrow Size and Direction attribute is not available for Mac users. For Mac users, arrows are always drawn Tail to Head.

Text Font

Define the appearance of the text for the Text, Image Date, Image Time, Image Title, Image Memo objects.

1. Select a Font, a Font Style, and a point Size. The Sample box displays a preview of the font.

2. Define any Underline effects.

3. Click on OK.

Text Options

Define the appearance of the text boxes for the Text, Image Date, Image Time, Image Title, Image Memo objects.

1. Specify whether the text box should have a border. To add a border, click on the Border box, and enter a Thickness value between .05 and 10.

2. Define the Justification of the text. This justification applies to the position of the text in the box, not the position of the text on the page.
3. Define the Background. Select either Transparent or Opaque.

4. Define the orientation at which the text should be displayed relative to the text box. Select 0, 90, -90 or 180 degrees.

5. Click on OK.

**Title Options**
Define the appearance of the title associated with the captured image(s).

1. Specify whether the title should include the computer file storage path as part of the image title.
2. Specify whether the title should include the computer file name extension as part of the image title.
3. Click on OK.

**Time Options**

1. Specify whether the time stamp should include seconds.
2. Specify whether the time stamp should include milliseconds.
3. Click on OK.

**Stamp Image**
Use the Stamp Image option to select the image that you want to use for the Stamp option. To select the image, choose Stamp Image. The Stamp Image dialog box prompts you to enter a file name and path. If the image object base path has been set in the Preferences (see Chapter 2 for more information), you can enter the name of the image file. If you do not know the name, use the browse button to search for the file. After you have selected the image file, click on OK.

*Note: All Stamp Images should be saved in the file path location set in the Preferences. The default location for this is in Shared Documents\Diagnostic Instruments\Spot\ObjImage directory.*

**AutoNumber Value**
Define the starting number used in the AutoNumber feature.

1. Select a whole number that sets the beginning value once the AutoNumber feature is activated. (Numbers subsequent to the initial number will increment by 1).
2. Click on OK.
**Label Options**

Labels can be added to Annotation Objects. If you would like to, you may 1) choose to add labels to specific types of objects, or 2) add objects of any type and then add a label afterward.

To use the first approach, select **Label Options** from the Attributes menu of the Annotations menu bar. The resulting dialog will have a number of shapes of which you may specify those that you intend to have a custom label. You can then use the Default Label entry line for entering default text that will always show up on the label, and/or insert a variable, either a standard variable or a custom variable.

If you choose to enter information into the Default Label entry, this information will automatically be added to the annotation shape. If you choose not to enter information into the Default Label entry, later when you add that type of object to the image, you will be automatically prompted to add a label. You may choose Cancel if you decide not to add a label.

In the second approach, simply right click on the annotation object that has been placed on the image. From the resulting edit menu, select Add Object Label.

In either approach, the Label Options dialog allows you to add text and/or variables to the object label. Variables will display in the Label Options dialog as the name of the variable surrounded by % signs. For example, in the screen shot here, the Default Labels shown are both for Custom Variables; the entry for Boxes is the label "Biopsy Date: %Date of Biopsy%" where "Date of Biopsy" is the name of a Custom Variable which would have been set in another point in the software. See Ch. 2 – SPOT Advanced Image Setups, live Image Controls, and the Setup Menu for additional details on Custom Variables.

**Save as Defaults**

Save the current attributes for all future annotation objects.

**Editing Annotation Objects**

Once you have annotated an image, you can edit the annotation objects as needed. There are three ways to edit objects:

- **Use the Attributes menu** - The Attributes menu, as noted in the Defining Annotation Attributes section of this chapter, allows you to either set the attributes for adding specific types of objects, or to select existing objects and modify them as needed. Refer to the Defining Annotation Attributes section for more details.

- **Use the Edit dropdown menu** - The Edit menu contains general editing features such as Undo, Copy, Cut, Send to Back, etc.

- **Right-click on the report object** - Right clicking on a report object brings up a customized editing menu that contains both general editing commands and the attributes that can be edited for that object.
You can also move and size annotation objects:

- To move an object, left click on it and drag the item to a new location. When you drag the item, the cursor becomes a four-pointed arrow.
- To size an object, left click on it and drag the handles to resize the object as needed.

The following sections describe the available editing options from the editing dropdown menu.

**Undo**

Undo the last action. Unlike the image capture/editing Undo feature, the annotation Undo undoes up to ten changes.

**Bring to Front**

Bring the selected annotation in front of all other annotations.

**Move Forward**

Bring the selected annotation one layer forward.

**Move Backward**

Send the selected annotation one layer back.

**Send to Back**

Send the selected annotation behind all other annotations.

**Select All**

Select all annotation objects.

**Unselect All**

Unselect all annotation objects.

**Delete (Windows)/Clear (Mac)**

Delete the selected annotation object(s).

**Delete All**

Delete all of the annotations on the image.

**Copy to Clipboard**

Copy the selected annotation clipboard.

**Cut**

Remove the selected annotation and place it on the clipboard.

**Paste**

Place the cut or copied annotation from the clipboard into the image.

**Calibration Marks, Measurements, and Reticles**

The Set Calibration, Add/Edit Calibration Mark, Add/Edit Measurement, and Apply Reticle options enable you to add calibration and measurement references to SPOT images. Each of these features will be discussed in further detail below.
Set Calibration

The Set Calibration option allows you to select or modify the calibration setup to be used for subsequent calibration mark insertions and measurements on this image/image sequence. If there are no calibration setups available in the drop-down list, or if your objective magnification isn't listed, refer to the Calibration Setup portion of Ch. 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu for instructions for creating calibrations for your microscope.

Add/Edit Calibration Marks

The Add/Edit Calibration Marks feature allows you to insert a calibration mark into an image capture and to edit its display properties. To add a calibration mark, follow these steps:

1. If you have not already calibrated the objectives on your microscope, do so. Refer to Ch. 4 – The Advanced Program Mode for details.
2. From the Edit menu, choose Set Calibration and select a Calibration Setup (e.g., 10x) for the objective that you are using.
3. From the Edit menu, select Add/Edit Calibration Marks. The Calibration Mark window appears with the selected calibration at the top.
4. Move the cursor to the point in the image where you want to insert the calibration mark and click at that point. The calibration mark appears with the default appearance settings.
5. Using the on-screen mark as a reference, modify the Appearance options:
   - Orientation – Check the appropriate box to select either a horizontal or vertical display for the calibration mark.
   - Line Thickness – Select a line thickness between 1 (thinnest) and 5 (thickest).
   - End Length – Select the size in pixels of the bars at the ends of the calibration lines.
   - Show Text – Select this checkbox if you would like the calibration measurement text to be shown along with the calibration line.
   - Decimals – Select the number of decimals that appear in the calibration mark number. Choose from a range of zero decimals (1) to five decimals (1.00000)
   - Font – Define the font, point size, and appearance.
   - Rotation – Specify the orientation of the calibration measurement text relative to the calibration line.
   - Color – Click on the Color button to define the color of the calibration mark. You can either choose from a palette of basic colors or define a custom color to provide the best display.
   - Size - Enter the size of the calibration mark. You can modify the size either by entering the number in the Size box, or by using the cursor to stretch the on-screen calibration bar. To adjust the size of the calibration mark, move the cursor to the end of the calibration bar line. The standard cursor changes to a two-headed arrow. Drag the end of the bar to adjust the length. The calibration mark number changes to reflect the new length.
6. Select Save As Defaults if you would like these display properties to be the defaults when adding calibration marks in the future.

If you would like to add additional calibration marks, click New and follow the steps above again. If you would like to delete calibration marks, select them individually and select Delete. Click Close when you are finished adding calibration marks to the image.
**Add/Edit Measurements**

The Add/Edit Measurements option enables you to incorporate measurements into an image capture and to edit their display properties.

To add a measurement, follow these steps:

1. If you have not already calibrated the objectives on your microscope, do so. Refer to Ch. 4 – The Advanced Program Mode for details.

2. From the Edit menu, choose **Set Calibration** and select a **Calibration Setup** (e.g., 10x) for the objective that you are using.

3. From the Edit menu, select **Add/Edit Measurements**. The Measurement window appears with the selected calibration at the top.

4. Check the type of measurement that you want from the dropdown menu and select the **Create** button.

   - **Straight Line** – Point to point distance measurement
   - **Segmented Line** – Point to point distance with multiple sections
   - **Curve** – Length of a freehand curve
   - **Region** – Area and perimeter of a freehand outline
   - **Angle** – Angle measurement
   - **Fixed Rectangle** – Length, width, area and perimeter of a software-generated rectangle
   - **Arbitrary Rectangle** – Length, width, area and perimeter of a rectangle based on user-drawn line
   - **Circle from Diameter** – Radius, diameter, area, and circumference of a circle based on user-drawn diameter
   - **Circle from Radius** – Radius, diameter, area, and circumference of a circle based on user-drawn radius
   - **Circle from Three Points** – Radius, diameter, area, and circumference of a circle based on three user-selected points
   - **Ellipse** – Major axis, minor axis, area and perimeter of an ellipse
   - **Orthogonal Distance** – returns the value of a line segment that is perpendicular to an associated line segment.
5. Move the cross-hair cursor to the point in the image capture where you want to begin the measurement.

6. Single click to activate the drawing function.

   • **Straight Line**, move the cross-hair cursor to the end point of the measurement. Single click to deactivate the drawing function and display the length of the line.

   • To create a **Segmented Line**, use the cross-hair cursor to move to next segment and single click to create a new segment. Double click to end segmented line measurement and display the line length.

   • For a **Curve**, use the cross-hair cursor to trace a freehand line on an image. Single click to deactivate the drawing function and display the length of the freehand line.

   • For a **Region**, use the cross-hair cursor to trace a freehand outline around the area that you want to measure. Single click to deactivate the drawing function and display the measurement. If the area is not completely enclosed by the outline, the SPOT program automatically completes the path by connecting the end point to the starting point with a straight line.

   • For an **Angle**, use the cross-hair cursor to specify the three points that define the angle. Single click to mark the end point of the first side. Move the cross hairs to the vertex and single click again. Move the cross hairs to the end point of the second side, and single click. This last click deactivates the drawing function and displays the angle measurement.

   • For a **Fixed Rectangle**, use the cross-hair cursor to specify where one corner of the rectangle should be positioned. Move the cross hair diagonally to draw the rectangle. Single click to deactivate the drawing function and display the length, width, area, and perimeter of the rectangle.

   • For an **Arbitrary Rectangle**, move the cross-hair cursor to the end point of a line that the rectangle will be based on. Single click and move the cross-hair cursor to draw the rectangle. Single click to deactivate the drawing function and display the length, width, area, and perimeter of the rectangle.

   • For a **Circle from Diameter**, use the cross-hair cursor to specify the diameter of the circle. Single click to deactivate the drawing function and display the radius, diameter, area, and circumference of the circle.

   • For a **Circle from Radius**, use the cross-hair cursor to specify the radius of the circle. Single click to deactivate the drawing function and display the radius, diameter, area, and circumference of the circle.

   • For a **Circle from Three Points**, use the cross-hair cursor to specify the three points that define the circle. Single click to mark the second point. Move the cross hair to the third point and single click again. This last click deactivates the drawing function and displays the radius, diameter, area, and circumference of the circle.

   • For an **Ellipse**, move the cross hair cursor to the end point of a line that the ellipse will be based on. Single click and move the cross-hair to draw the ellipse. Single click to deactivate the drawing function and display the major axis, minor axis, area and perimeter of the ellipse.

After you have completed steps one through six, you can modify the measurement as needed, using the Appearance options:

   • **Line Thickness** – Select a line thickness between 1 (thinnest) and 5 (thickest).

   • **Decimals** – Select the number of decimals that appear in the measurement. Choose from a range of zero decimals (1) to five decimals (1.00000)
• **Color** – Click on the Color button to define the color of the measurement. You can either choose from a palette of basic colors or define a custom color to provide the best display. If you are editing a monochrome image, you can select either black or white.

• **Font** – Define the font, point size, and appearance.

• **Label** – You may include a custom label for the measurement you apply. You may type up to 30 characters and spaces.

• **Text Rotation** - Specify the orientation of the measurement text relative to the shape drawn.

You can also choose to hide the measurement values or to change their labels:

• Select the measurement values to be hidden by de-selecting the checkboxes next to them in the **Show** column.

• Select new labels by typing them into the **Label** column.

• After adjusting the appearance and display of your measurements, at this point you can:
  - Re-position the measurement labels and values. When you position the cursor over the number, it changes to a four-point arrow. Click and drag on the number to move it to a new location.
  - Erase measurements. Click on the measurement and choose **Delete**.
  - Clear all measurements from the image. Click on the **Delete All** button.
  - Add new measurements. Click on **Create**, select the measurement type and add additional measurements.
  - Save the appearance and display options selected as the defaults. Click on **Save As Defaults**.
  - Use the **Export Measurement** button to export all measurements to a .csv or .txt file. Measurements can also be exported from the File Menu or the Image Information dialog. Please see the respective sections of this chapter for additional details.

7. Click on **Close** when you are finished adding and editing measurements.

---

**Note:** Added measurements will need to be merged into the image pixel data in order to be displayed by other applications. Choose Edit/Merge/Merge Measurements to merge them into the image.

**Note:** When adding calibration marks or measurements to images in a sequence, if one of the images doesn't have a calibration setup saved with it, the SPOT software will assign it the same calibration setup as the first image that was edited.

---

**Apply Reticle**

To apply a reticle to a captured image, use the **Apply Reticle** feature to select a configured Reticle to be applied to the image. The **Apply Reticle** dialog box will appear with a pull down list of available reticles. Make your selection and click Ok.
Also, if there is an existing reticle which you would like to ‘erase’ from your image, you can check the box to Replace Existing Reticle and then click Ok. If you wish to have two reticles on the image, do not check the option to Replace Existing Reticle.

**Remove Reticle**

This option is only available if a Reticle has already been applied to an image. Selecting this option from the menu will automatically remove the reticle which has been applied to the image.

**Merge**

Use Merge to merge annotations, calibration marks, and measurements into the image pixel data in order for other applications to display them. If the merge is not done, only the Spot software will display the annotations, calibration marks, and measurements. If you have used any two options of annotations, calibration marks, measurements, or reticles you will have the option to Merge all of these features at one time. Choose Edit>Merge and select Merge Annotations, Calibrations Marks, Measurements, and Reticles to conveniently merge all items for viewing in other applications.

---

*Note: Once an Annotation, Calibration Mark, Measurement, or Reticle has been merged to the image, the information of the item being merged into the image will replace the image data at that point. We recommend saving a copy of the unmerged layers before merging these items to preserve the pixel data.*

**Memo**

In the SPOT software, you can attach a memo to image files. To use the Memo option, follow these steps.

1. From the Edit menu, select Memo. The Image Memo dialog appears for you to enter a new memo or edit an existing memo.

2. Enter the message with standard text entry or use the Insert Variable button to insert one of the many standard or custom variables. See below for more information.

3. Click on OK to attach the memo to the image.

**Insert Variable**

When you click on the Insert Variable button you will have a pull down list of available Standard and Custom variables. For example, under the Standard variables list, you can select a Time Stamp to be placed in the image memo. Once you select the appropriate Time Stamp, you will be prompted to enter which information you would like to show in the memo.

The Insert Variable dialog will change to reflect characteristics of which more information is required to
define that specific variable. Press OK to close the Insert Variable dialog and insert the variable placeholder into the Image Memo.

Some variables will not have an additional dialog box. For these variables, once you select the variable from the pull down menu the variable placeholder will be added to the Image Memo text. The variable placeholder will be displayed as the name of the variable surrounded by % signs. Once the image memo is closed and reopened, the variable placeholder will be replaced with the value of the variable. See below for an illustration of the Image Date variable placeholder and the variable value.

Refer to Chapter 6 – SPOT Advanced Macros and Variables to learn more about standard and custom variables and how they can be used to collect information from the image capture process.

Working with Image Sequences

There are three places from which you can edit and play image sequence files:

- The **Sequence** menu – Rearrange the order of a sequence, add and/or remove images to and from the sequence, extract images from the sequence, and play the sequence.

- The **Sequence Controls (Image Sequence)** dialog – Set view options and play the sequence.

- The **Edit** menu - Modify/enhance image sequences using the options on SPOT’s Edit menu. Refer to **Editing Images in a Sequence** (below) for more information.

Refer to the following sections for details.

Sequence Menu Options

Image sequences are editable. The **Sequence** menu, which is available only when an image sequence is open, displays the available options. They are as follows:

**Extract Images**

Extract an image or images from a sequence file. Extracting creates new image(s), leaving the original sequence intact. Click on **Extract Images** and enter the number(s) of the image(s) that you want to extract. To extract multiple images from a sequence, separate numbers with commas to skip over images and/or dashes to include the images in between the numbers - i.e., 5, 6, 7 or 5-7 or 1 – 5, 6, 9.
Add Images

Add an image to the sequence. Using Add Image, you can add an image to a sequence from one of two sources:

**From Files** – Add an image from disk. Multiple image files can be chosen by using the Ctrl key and clicking on all the files you wish you to add. If an image sequence file is selected, only the first image of the sequence will be added.

When you click on OK, a dialog prompts you to specify the point in the sequence where you want to insert the image. You can choose from: Insert at Beginning of Sequence, Append to End of Sequence, Insert Before a specified Image, Insert After a specified Image, or Insert Ordered, i.e. using a timestamp to add images in order of time, either Ascending or Descending.

**From Open Images** – Add an image from the currently open sequence file. If you are adding images from another image sequence, you will have the option to Include all Images in Sequence or, if this box is left unchecked, only the displayed image in the open image sequence document window will be added.

Order Images

Once an image sequence is open with more than one image, you can use the Order Images menu option to sort the order of the images by either Ascending or Descending Timestamps.

Move Images

Move an image or image(s) to a different point in the sequence. Click on Move Image and enter the number(s) of the image(s) that you want to move. To move multiple images from a sequence, separate numbers with commas to skip over images and/or dashes to include the images in between the numbers - i.e., 5, 6, 7 or 5-7 or 1 – 5, 6, 9.

Remove Images

Remove an image or images from a sequence file. Removing an image deletes the image from the sequence, which is automatically reordered. Click on Remove Images and enter the number of the image(s) that you want to extract. To extract multiple images from a sequence, separate numbers with commas to skip over images and/or dashes to include the images in between the numbers - i.e., 5, 6, 7 or 5-7 or 1 – 5, 6, 9.

Play Forward

Continuously play the image sequence forward.

Play Reverse

Continuously play the image sequence backward.

Stop Play/Resume Play

Stop play if the sequence is running and resume place when it is stopped.

Step Forward

Move forward one image.

Step Reverse

Move backward one image.
Image Sequence Controls

The Sequence Controls (Image Sequence) dialog enables you to play image sequences and to set the play options.

Image Index Number

Use the Image Index options to specify the view parameters of the sequence. This can be useful if you have a large image sequence with many frames (images) that do not have information you want to look at. For instance, consider you have a sequence file of 300 images, but only want to view the middle half of the images. In this case, you would set the value for First to 75 and the value for Last to 225. Then, when you play back the sequence only the images 75 through 225 will be shown.

First - Enter the number of the image that should be first in the sequence.

- Current – This field displays the number of the image you are currently viewing. Enter a new number to view a different image.

- Last – Enter the number of the image that should be last in the sequence

Play Options

The features under Play Options allow you to specify how the image sequence displays when playing.

- Interval – The time interval between each image when the sequence is playing. Enter a number in milliseconds or seconds. Alternatively, you can click the Compute from Seq… button to have the software compute an average interval from the sequence time and the image sequence will play back at this calculated interval.

Note: the Compute from Seq… button is only available if timestamp data is associated with the images and they are acquired from SPOT.

- At End – This entry sets the action that takes place when the sequence finishes playing. There are three options.

Stop
With Stop selected, the sequence stops at the last image in the sequence.

Restart
With Restart selected, the sequence begins playing again from the beginning. The sequence will only stop playing when the Stop button is pushed or selected from the Sequence Menu.

Reverse
Selecting Reverse will cause the sequence reverse play when it reaches the end.
Editing Images in a Sequence

Images from a sequential image file can be edited using the same Edit menu options as described earlier in this chapter. After you’ve made a selection from the Edit menu, the SPOT program allows you to specify the individual image or images (including the entire sequence) to which the edits are applied.

For instance, if you are on image 1 of a sequence and you select Edit/Adjust Image. Once you make the changes desired and press OK, a dialog box will ask you if you would like to apply these changes to only the image that you are on, to all images in the sequence, or specific images within the sequence.

Select one of the following options when prompted:

**No Other Images** – The edit applies only to the current image – i.e., the on-screen image.

**All Other Images in Sequence** – The edit applies to all of the images in the sequence.

**Specified Image Sequence** – The edit applies to the images that you specify. Enter the number(s) of the image(s) in the box at the bottom of the dialog. To specify multiple images, separate numbers with commas and/or dashes - e.g., 5, 6, 7; or 5-7; or 1 – 5, 6, 9.
Ch. 5 – SPOT Advanced Taskbars

Introduction

The SPOT Advanced application allows you to customize your program by developing Floating Taskbars containing timesaving onscreen buttons that can initiate menu functions, start a macro, or open a custom dialog. The Taskbars serve as an onscreen dashboard of the menu functions, macros, or dialogs that you commonly use in your imaging/post processing work, where, with a single click, those functions can be easily initiated without searching through dropdown menus.

As an example, let’s assume that you commonly need to open image files, save image files, add image borders, cut objects from images, use Annotation Tools, and/or run your favorite Macro program.

You can develop a taskbar with buttons that give you quick access to all of these functions and Macro programs. It might look like the taskbar below.

 If you have several users who operate the SPOT software at different times, you can also set up customized taskbars for each user. Each user can display their individual taskbar when they are working with the software. The user-specific display of specific taskbars can be achieved automatically when SPOT Users are utilized. See Ch. 2 – Image Setups, Live Image Controls, and the Setup Menu for how to set up SPOT Users.

Developing a Taskbar

To set up a Taskbar, follow these steps:

1. Go to the Setup menu and select Taskbars. The Taskbar Setup dialog will appear.
2. Click on the Add button to create a new Taskbar. The Taskbar Layout dialog will appear.

3. Give your new Taskbar a Name and then click on Add to add a button to the Taskbar. The Taskbar Button Editor dialog will appear.

4. In the Taskbar Button Editor dialog, there are three options available for what type of Action you would like to associate with each button. Select the appropriate action for your button from the pull down menu. These options are described in detail here:

**Execute Menu Command**

The Execute Menu Command offers easy push button access to all of the Menu Commands in the SPOT Software. Expand the desired section and click to select the appropriate Menu Command to assign the command to the button.

**Play Macro**

The Play Macro option allows you to specify a previously created macro to be played when the taskbar button is pushed. Use the browse button “…” to navigate to your macro. For ease in portability and to reduce the chance of taskbar buttons referencing moved files, be sure to save all your macro files in one place and use the Preferences’ File Path’s Macro File setting to locate the common location (See Ch. 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu and Ch. 6 – SPOT Advanced Macros for details). When the default path is used and a macro file is referenced in the Taskbar Button Editor, just the portion of the file name beyond the root file path will be displayed.

Additionally, the Insert Variable button is available for the purpose of automatically reassigning or altering the Macro Command assigned to this button as set up in other areas of the SPOT Software. See Ch. 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu for more about Variables.

*Note: The Macro taskbar pushbutton uses a defined computer path to search for the stored Macro file. If you have not used the Preference’s File Path setting and you move macro files between computers, you will have to update the taskbar button by redefining the path. See below Importing and Exporting Taskbars for more information.*

*Note: You are limited to a taskbar with 50 buttons.*

**Show Dialog**

The Show Dialog option behaves much like the Play Macro command, above as it allows you to specify a previously created Dialog to be opened and available for use when the taskbar button is pushed. Use the browse button “…” to navigate to your saved dialog file. For ease in portability and to reduce the change of taskbar buttons referencing moved files, be sure to
save all your dialog files in one place (See Ch. 2 – SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu and Ch. 7 – SPOT Advanced Custom Dialogs for details) and use the Preferences' File Path’s Dialog File setting to locate the common location. When the default path is used and a macro file is referenced in the Taskbar Button Editor, just the portion of the file name beyond the root file path will be displayed.

Additionally, the Insert Variable button is available for the purpose of automatically reassigning or altering the Macro Command assigned to this button as set up in other areas of the SPOT Software. See Ch. 2 – SPOT Advanced Image Setups, Live Image Controls for more about Variables.

5. Once the button has been assigned an action, the attributes of the button can be set. The attributes available are:

**Button Text**

The Button Text will, by default, fill with the name of the Macro, OS command or Menu Command etc. This default text can be overridden by simply typing in the text you wish to appear on the button.

**Button Color**

Click on the Button Color button to re-assign a color of your choice to the button. Each button may be assigned its own color for easy identification of buttons.

**Text Color**

Click on the Text Color button to reassign a color of your choice to the text which appears on the button. Each button can have different text colors for easy identification.

**Font Size and Bold/Italic/Underline**

Just like the Button Color and Text Color, the Font style can be set differently for each button. Make your selections using the pull down menu for Font Size and the check boxes for the Bold, Underline and Italic settings.

**Hot Key**

You may assign hot keys as an additional method to select taskbar buttons in lieu of using your mouse. To assign a hot key, click your cursor in the hot key dialog box, and then select the keyboard key you would like to represent the taskbar button function that you have defined.

*Note: Hot keys will only work once the associated taskbar has been opened. Remember, you can roll-up the open taskbar by double clicking on the title bar.*

*Note: Not all keyboard strokes will be accepted as Hot keys.*
6. After all the button’s attributes have been set, click on OK to add the button to the taskbar.

7. Continue to add buttons to the taskbar using the Taskbar Layout and Taskbar Button Editor dialogs until you have all of your favorite and commonly used functions.

8. When you are finished designing the taskbar, be sure you have given it a name and then decide if you want to ‘Show Taskbar when Done’. Check the box to have the Taskbar automatically appear when you are finished designing it. If you do not check the box to Show Taskbar when Done, you can display taskbars from the View Menu’s Show Taskbar feature.

**Modifying Taskbar Appearance**

After developing taskbars, you may choose to modify their appearance by changing button colors, button names, text fonts, the position of the buttons on the taskbar, or the appearance of the taskbar.

Any of these changes can be easily accomplished through the Taskbar Editor window. Simply select the function or macro that you wish to change by highlighting it from the list. Then select the modify button, make the changes using the same procedures you used to develop the buttons originally. Click the OK button when you are finished and the Taskbar will be immediately modified.

You can change the relative position of the buttons on the taskbar by simply highlighting the function and moving its position up or down on the Taskbar Editor screen. Additionally, you may change the number of columns that the taskbar window is divided into using the column feature in the taskbar setup window.

*Note: If you choose a number of columns that does not divide equally into the number of functions and macro buttons you have developed, the grid of the floating taskbar window will automatically fill the “extra boxes” with non-functional buttons in the default beige color.*

You will notice, at times, that the font on certain buttons will appear faded. This indicates that the particular function is not available due to other circumstances present at the time. For example, if an image has not been captured yet, certain edit features will not be available. However, as soon as an image is acquired, the font on those buttons will become more contrasted to the button color, indicating that the function is now available.

*Note: Until you select annotate, any buttons that relate to annotation will not be functional, even after you have captured an image. Once you select annotate from the drop down menu or as a taskbar button of its own, the annotation function buttons will become functional.*
Taskbar Size and Location

As an onscreen tool, the taskbar window can “float” on the screen in front of any open image windows (captured or live images) or other taskbars. The position of taskbars is not arbitrary, but instead can be set by the user. If a taskbar hinders your viewing of any images, you can do one of four things: modify its size, change its location, “roll it up”, or make it disappear from the screen.

Modify Taskbar size

Like most windows, simply highlight the taskbar and resize it by dragging one of its handles to make it larger or smaller. A side handle will change the width of the taskbar, a top or bottom handle will change the height of the taskbar, and a corner handle will change both height and width proportionately.

Change Taskbar location

Simply grab the taskbar’s title bar by placing the cursor over it and holding down the mouse button (left button on a PC). Then move the taskbar around the screen until you are satisfied with its location. Release the mouse button.

Roll up a Taskbar

Double click on the taskbar’s title bar and the buttons will roll up under the title bar. You may also right click on the title bar and select roll up from the pop up menu.

Repeating these procedures will roll out the buttons from under the title bar.

Make a Taskbar disappear

Click on the close box in the right upper corner of a taskbar. Alternately, right click on the title bar and select close from the pop up menu. In either case, you will need to access the View drop down menu, select Show Taskbar, and re-select the Taskbar to make it reappear on the screen.

Lock Taskbar Location

To Lock the location of a Taskbar, place the Taskbar in the desired location and then right-click on the title bar to select Lock in Place. The placement of the Taskbar can be unlocked by right-clicking on the title bar and selecting Unlock.

Importing/Exporting Taskbars

You can move your taskbars to and from another computer. This is where the Preference’s section for the File Path default can be very useful if you have assigned any macros to the taskbar buttons. If the File Path is in location X on Computer A, and you want the File Path location to be in Z on Computer B, the easiest way to move files is to use the File Path default location when the taskbar is developed. In this way, you can make set the new File Path on Computer B and any Macros used in the moved taskbar will run from the chosen File Path location.
To import taskbars, follow these steps:

1. Choose Taskbars from the Setup menu.
2. Click on Import.
3. Select the taskbar export that you would like to import. This will be a file of type SPOT Export (spx).
4. Choose Open. The taskbar export will appear in the Import menu.
5. Select the taskbar export and choose Import. The taskbar(s) will now be ready for you to use.

To export taskbars, follow these steps:

1. Choose Taskbars from the Setup menu.
2. Select the taskbars you would like to export. To select multiple taskbars, hold down the Control button while selecting them.
3. Click on Export.
4. Select a File name and location and choose Save.
Chapter 6 – SPOT Advanced Macros

Introduction

A powerful feature of the SPOT software is the ability to do Macro Scripting (hereafter referred to as Macros). Macros offer the user the ability to automate many of the repetitive tasks associated with image capture and processing. As a result, the user can spend more time evaluating and analyzing results, and less time manipulating test set-ups, variables and other settings. Some new features may not be documented here with their corresponding macro command; however, understanding the software feature without a macro should be sufficient to understand how to use the macro command.

**Macro** – a program to automate a task or set of tasks that you perform repeatedly or on a regular basis. It is a series of commands and actions that can be stored and run whenever you need to perform that task.

Benefits

A robot benefits an industrial user by accurately repeating redundant procedures. Macros can provide the same benefits to researchers and scientists for capturing images. Like a robot, a Macro requires the preparation of a program of commands that perform an operation. Once saved, that program can be modified and supplemented to create multiple procedures that do not require the researcher to replicate all of the program steps again and again.

**Benefits of using Macros**

- *Time savings*
- *Accurate reproduction of image capture techniques*
- *Macros are modifiable, allowing the user to maintain an original macro while modifying it for a slightly different result, with minimal effort*

We will begin by discussing directions for accessing, navigating, and using the Macro Window. New commands introduced in the Macro menu will be discussed.

Creating a Macro

There are two methods for creating a macro. The first involves utilizing a Macro Window to develop a macro program by adding commands line-by-line. The second involves using a record feature within Macros that develops a macro by monitoring and recording, on-the-fly, the individual commands that the user selects while in the process of carrying out an imaging procedure.

After your first macro is completed and saved, further macros can be developed as new, recorded, or can be developed by modifying an existing macro and saving it under a new filename (see Edit).

Both methods of macro development can be initiated through the Macro drop down menu. We will begin by discussing the first method, line-by-line development, in order to gain a greater understanding of the Macro Window.

Let’s get started.
Accessing and Navigating the Macro Window

From the drop down menu on the Spot Advanced Software Screen, select Macro. The drop down menu will always offer four choices. They include the following:

- New
- Edit
- Record
- Play
- Protect

In addition, the dropdown menu will list up to ten shortcuts to the most recently played macros.

You can access the Macro Window directly by selecting the New option. You may also access it by selecting Edit and then selecting a macro file to edit from your computer (Once you have created and saved a macro).

New

Select New from the Macro menu. The Macro Window will open.

Macro Window

You will note that the Macro Window is a split into two active panes. The pane to the left includes a selection menu and provides all of the available commands that can be incorporated into any macro. The pane on the right represents the active macro development pane or a reflection of the Macro program, command line by command line. When “New Macro” is selected, the screen will open with the default commands of Begin Macro and End Macro on the right window. All commands are placed in between these commands when developing your personal macro.

The menu screen on the left can be formatted in two different ways. The first is logically grouped into eight main functions. They include:

1. Frequently Used
2. Camera
3. Image
Each of the main topics can be expanded by clicking on the [+1] next to the topic name, similar to an expandable Windows menu. For example, the Camera topic expands as indicated below.

Table A. Expanded Menu with Command Selections

<table>
<thead>
<tr>
<th>Topic</th>
<th>Command</th>
<th>Interactive Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Freq. Used</td>
<td>Variable depending upon User Preferences (see Right Click options, below to develop this feature)</td>
<td></td>
</tr>
<tr>
<td>2. Camera</td>
<td>Select Camera</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Select Image Setup</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Get Image</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Get Sequential Images</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Compute Exposure</td>
<td>Yes</td>
</tr>
<tr>
<td>Topic</td>
<td>Command</td>
<td>Interactive Mode</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>----------------------------------------------</td>
<td>------------------</td>
</tr>
<tr>
<td>Recall Previous Exposure</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Compute White Balance</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Get Bias Frame</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Get Background Image</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Get Flatfield</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Start Live Image</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Stop Live Image</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Set TTL Output Active</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Set TTL Output Inactive</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3. Image</td>
<td>Open Image File</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Save Image File</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Save Image File As</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Open Database</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Close Database</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Save Image to Database</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Print Images</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Set Selection Area</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Resize</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Rotate Right</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Rotate Left</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Flip Horizontally</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Flip Vertically</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Crop</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Adjust RGB Additive Brightness</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Adjust RGB Multiplicative Brightness</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Adjust RGB Contrast</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Adjust RGB Gamma</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Adjust RGB Bright and Dark Level</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Adjust RGB Histogram</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Equalize RGB Histogram</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Adjust Hue Saturation and Luminance</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Adjust HSL Multiplicative Luminance</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Adjust HSL Contrast</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Adjust HSL Gamma</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Adjust HSL Bright and Dark Level</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Adjust HSL Histogram</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Adjust Hue Saturation and Value</td>
<td>Yes</td>
</tr>
<tr>
<td>Topic</td>
<td>Command</td>
<td>Interactive Mode</td>
</tr>
<tr>
<td>-------------</td>
<td>---------------------------------------------------</td>
<td>------------------</td>
</tr>
<tr>
<td>Adjust HSV</td>
<td>Multiplicative Value</td>
<td>Yes</td>
</tr>
<tr>
<td>Adjust HSV</td>
<td>Contrast</td>
<td>Yes</td>
</tr>
<tr>
<td>Adjust HSV</td>
<td>Gamma</td>
<td>Yes</td>
</tr>
<tr>
<td>Adjust HSV</td>
<td>Bright and Dark Level</td>
<td>Yes</td>
</tr>
<tr>
<td>Adjust HSV</td>
<td>Histogram</td>
<td>Yes</td>
</tr>
<tr>
<td>Smooth</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Sharpen</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Unsharp Mask</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Filter Noise</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Median Filter</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Make Negative</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Set Palette</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Change Bit Depth</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Convert to Monochrome</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Subtract Image</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Merge Images</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Duplicate Image</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Add Annotation</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Set Calibration</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Add Calibration Mark</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Add Measurement</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Merge Annotations</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Merge Calibration Marks</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Merge Measurements</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Set Image Memo</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>4. Sequence</td>
<td>Create New Image Sequence</td>
<td>Yes</td>
</tr>
<tr>
<td>Extract Sequence Images</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Append Sequence Images</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Remove Sequence Images</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Play Sequence Forward</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Play Sequence Reverse</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Step Sequence Forward</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Step Sequence Reverse</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5. View</td>
<td>Set Fit To Window</td>
<td></td>
</tr>
<tr>
<td>Set Zoom Mode</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Set Zoom Level</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Link Image Zoom</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Topic</td>
<td>Command</td>
<td>Interactive Mode</td>
</tr>
<tr>
<td>------------</td>
<td>-------------------------------------------------------</td>
<td>------------------</td>
</tr>
<tr>
<td></td>
<td>Show Pan Window</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Link Image Window Scrolling</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Show Image Date/Time</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Show Taskbar</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Set Full Screen</td>
<td></td>
</tr>
<tr>
<td>6. Window</td>
<td>Cascade Windows</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Tile Windows</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Arrange Windows Horizontally</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Arrange Windows Vertically</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Bring Image Window to Front</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Close Image Window</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Close all Image Windows</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Close all Image Sequence Windows</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Close all Document Windows</td>
<td></td>
</tr>
<tr>
<td>7. Macro</td>
<td>Block</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Loop</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Escape Block/Loop</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Delay</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Wait Until</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Pause</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Wait for Sensor Temperature (Xplorer and Pursuit only)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>If</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Else</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Save Timestamp</td>
<td></td>
</tr>
<tr>
<td></td>
<td>End Macro</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Play Macro</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create Variable</td>
<td></td>
</tr>
<tr>
<td>8. Other</td>
<td>Set Variable</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Save Variables</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Recall Variables</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Play Sound</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Prompt User</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>Run Report</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Log</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Execute OS Command</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Drop File</td>
<td></td>
</tr>
</tbody>
</table>
Interactive Mode

As listed in the previous table, many of the accessible commands in the Macro Command Selection Pane include an option that is used to prompt the user to provide input during the playback of the Macro. This is referred to as an Interactive Mode.

When a command with an interactive mode option is selected, the command window will appear with an unchecked box in the upper left corner. The user must select the Interactive feature of the command in order to be asked for data (in the case below, the filename) during the playback of the Macro program. When the interactive mode is not selected, the Macro Window may require immediate input before it can accept the command as part of the macro being constructed.

In the example below, if the interactive mode is not selected, a filename must be input before this window can be closed and added to the Macro program.
Developing a Macro in the Macro Window

To begin developing your macro, you will want to copy commands from the left command selection pane into your active macro development screen in the right pane. You may do this by highlighting the command you would like to add from the left command selection pane and then clicking the Add button just below the pane. The first added command will be copied between Begin Macro command and the End Macro command.

As a second option, Windows users may double click on the command in the command selection pane. The command will be placed into the Macro in the development pane on the right.
After the first command has been added, you will note that the Modify, Copy, and Delete buttons become active on the right side of the Macro Window. The default Begin Macro and End Macro commands cannot be modified or deleted, however, all commands added in between them can be.

You will also note that any subsequent commands you add will be placed just below the highlighted command in the development pane. When a command is in a position and you would like to change its position, simply highlight that command and use the up and down arrow buttons to the right of the development pane to reposition it. You will note in the case above, that the Get Image command can only be repositioned upward. A downward reposition would place it outside of the End Macro command, which is not allowed.

Right Click Options in the Macro Window

When creating a macro, you may find it efficient to make use of the right click feature of the SPOT program. Once you have selected a command in the Macro Command list, click the right button on the mouse. An option will be presented allowing you to add the command to the macro (Add to Macro) in the development pane. This option essentially
replaces the add button below the Macro Command pane.

Additionally, you can choose to add any command to the Frequently Used list, to maximize your own efficiency. The command will be immediately available under the Frequently Used Category, but will not be added to the developing macro.

Once a command has been added to the development pane of the Macro window, you may highlight it and right click to access any of the applicable edit features listed below the development pane.

Other Options on the Macro Window

Comment – The user may also add comments to the Macro through the use of the comment button located just above the development pane on the right.
Once a comment is placed with the Macro, it remains hidden during editing and playback and can be accessed only when the comment button is pushed. It is associated with the Macro, and not any particular command lines in the Macro. It is simply a virtual notepad for the user to add a reminder that becomes part of the specific Macro program. It can be edited at any time by accessing the Macro comment window, modifying the comment, and saving the updated Macro program.

**Modify** – This command allows the user to modify any of the settings associated with any command in the development pane. The modify command can only be accessed with commands that have underlying user defined settings.

**Copy** - This command allows you to copy individual or multiple commands within a macro.

**Paste** – This command allows you to paste the copied commands at specified places in your macro.

**Delete** – The delete button will delete any and all highlighted commands within the Macro development pane. The only exception to this is deletion of the Begin Macro and last End Macro command in the Macro. These cannot be deleted.

**Disable** – The disable command box located just below the development pane allows the user to selectively turn off (disable) any commands located between the Begin Macro and End Macro commands. This allows a user to temporarily remove certain procedures from a Macro without having to delete them.

If you would like to select a group of commands, highlight the first in the group in the development pane, hold the control key (Windows) and continue to highlight all other commands you would like to disable. Once all commands are selected, activate the Disabled box. All selected commands will be placed in parentheses, thus indicating that they are no longer commands that will be executed as part of the Macro.

**Line Comment** – Use this feature to attach a comment to the command listed in the macro. This comment will not be visible on macro playback, but will be displayed next to the Line Comment button when the associated command is highlighted in the Macro Development Pane.

**Save** – The user may save the macro at any time by selecting this button. Like any program or application being developed, this saves all modifications being made to limit the loss of data in the event of a program interruption or crash. The user will be prompted for a filename only once when a new macro is being developed. After that, Save automatically saves to the active filename.

**Save As** – Like the save command, this allows the user to actively save the modified program at any time. However this command is best utilized for saving the modified file under a new file name, thus maintaining the original file structure with the original filename. In this case, the user will be prompted to select a filename for the Macro to be saved. The default filename will be the current filename of the open Macro.

**Record** – This allows the user to quickly exit the Macro Window and begin developing the macro through use of the record feature. This feature is explained in greater detail in the following pages.

**Play** – This command allows the user to immediately begin playing the active macro or any other macro without having to manually close the macro Window.

**Close** – This command allows the user to close the Macro Window. If commands have been added to a new macro or if an existing macro has been modified, a window will appear and ask if the user would like to save the macro.

**Help** – This command allows the user to access the online help area of the SPOT software without closing the macro window.
Macro Window - Quick Reference

Comment – allows for the addition of a stored comment to the macro program

Add – adds a command to the macro from the command selection pane

Modify – allows modification of the settings associated with the selected command in the macro development pane

Copy - copies the selected command(s)

Paste - pastes the copied command(s)

Delete – deletes the selected command in the macro development pane

Line Comment - adds a comment related to the command highlighted in the development pane

Disable – makes the selected command(s) inactive when the macro plays

Save – saves the macro program immediately under the current filename

Save As – saves the macro program under a modified filename

Record – activates the macro recording mode of macro development

Play – plays the active macro immediately

Close – closes the active macro

Help – activates the help window in the SPOT program
Record

This handy feature allows the user to develop a macro without using the macro window to add commands line-by-line. Instead, the user selects record from the macro dropdown menu, a taskbar button, or from within the Macro Window. A window will appear informing the user that a new macro is recording.

Once this has been indicated, all commands selected from the Spot Software menus, toolbar, or taskbar (except other macro programs) are sequentially added to the developing macro. While the macro is being recorded, the Macro Recorder dialogue box will be displayed. To roll up this dialogue box to conserve space, double click on the Macro Recorder toolbar. Repeating this procedure will roll out the dialogue box again.

Developing a Macro Using the Record Feature

For example, if the first command is to be Get Image, the Camera dropdown would be opened, and the user would select the Get Image command.

This command would automatically be added as the first command following the Begin Macro command in the macro development.

Thereafter, all selected commands would be added after the Get Image command, in sequence, until you choose to end the macro. To end the macro, simply choose the stop button on the Macro Recorder window.

When you choose to end the macro recording, another window will prompt you by asking whether you would like to save the recorded macro. If you select yes, a subsequent window will appear asking you to name and save the macro.

Recording a macro is an excellent way for developing a “rough draft” of a macro program. Once the macro is recorded, you can use the edit macro command to review all of the commands you recorded and modify the macro program in order to refine it.

Spot software users who are used to developing their imaging procedures using the dropdown menus may find this to be a comfortable and expedient method for initially developing a macro.

Edit

This command is used to review and edit an existing macro that has been saved. When the user selects the edit option from the macro dropdown menu, an Open Macro Window will appear, prompting the user to select a stored macro or browse for a stored macro.

Once the macro is found, it can be opened by double clicking on the name (Windows users), single clicking on the name (which places the name in the File Name box) followed by clicking the open button, or by typing the name into the File Name box followed by clicking the open button. SPOT macros can be identified by their “*.spm” filename extension.
Once selected, the Macro Window will open and the Macro program will show in the development pane on the right.

At this point, the user can choose to simply review the program or choose to edit any or all of the available commands. The range of editing options includes adding new commands or deleting existing commands, disabling (but not deleting) commands, modifying commands (available only when subcommand windows are attached to the command), re-sequencing commands, defining or redefining variables, and adding or revising comments.

You can also choose to simply play the macro from this window. This allows the user to review the macro to verify that it is the proper procedure prior to setting up an experiment, playing the macro, and obtaining resulting images.

Play

The play option automatically initiates the macro program. For the user who knows which macro is the exact procedure to use to get the desired results, this is the fastest way to gain them (short of setting up a taskbar button to play the specific macro – See Taskbars). Once Play is selected from the macro dropdown menu, a window will appear prompting the user to select the desired macro to be played. Once the macro is selected, it begins to play immediately, without further prompting or warning.

A Macro Playing window will appear anytime the macro is processing commands. You may interrupt the macro program at anytime by selecting the Stop button on the Macro Playing Screen. You can also roll up the Macro Player dialogue box by double-clicking on the Macro Player toolbar. Repeating this procedure will roll it out again.

When the macro has completed playing on its own, the Macro Player window Status changes to Done, and the stop button changes to a Play button. If you would like the Macro Player window to close after the macro is completed in the future, select the Close this Dialog When Done checkbox.
Protect

The protect option allows a user to lock a macro that is scripted so that it can only be used with a certain camera serial number. Selecting this option will bring up a browse window for you to locate your Macro file.

Once a file has been indicated, the Protect Macro dialog box will appear showing the original file and the new file that will be created and protected. Protected Macros have a file extension of *.sm2 instead of the original file extension of *.spm. The serial number that is entered in this dialog box is the only camera that can be used for the Macro to function.

Macro-specific Commands

The Macro feature in the Spot program introduces a number of new commands specific to the development of the macro program. In the following section we will review and further explain the commands. The following approach will be used with each command:

COMMAND NAME

- Purpose and Use
- The Macro Window and COMMAND NAME
- Windows specific to COMMAND NAME
- Generic Example using COMMAND NAME

Purpose and Use – Explains the basic function of the command and why and when it is most useful in developing a macro program.

The Macro Window and COMMAND NAME – Describes what happens on-screen in the macro development pane when the command is selected in the command selection pane.

Windows specific to COMMAND NAME - Describes the appearance, function, and how to input data for any window that results from selecting one of the new macro commands. Note that some, but not all, commands have a data input window associated with the command.

Generic Example using COMMAND NAME - Provides one or more examples of the use of the specified command in conjunction with other generic commands.

The new commands associated with the Macro Scripting feature can be classified into four groups. They include the following:

- Conditional Commands......................... BLOCK, IF, ELSE, LOOP, ESCAPE
- Variable Commands.............................. CREATE VARIABLE, SET VARIABLE, SAVE VARIABLES, RECALL VARIABLES
- Timing Commands................................. DELAY, WAITUNTIL, PAUSE, WAIT FOR SENSOR TEMPERATURE, END MACRO
- Communication Commands.................... PLAY SOUND, PROMPT USER, RUN REPORT, LOG, EXECUTE OS COMMAND, PLAY MACRO, DROP FILE
Conditional Commands

Conditional Commands arise from the IF Command and determine what the Macro program will do next.

**BLOCK**

*Purpose and Use*

The BLOCK Command is used to group a series of commands together, to be performed sequentially prior to any further commands being performed.

The BLOCK Command is very useful in conjunction with IF Commands (see IF Command) as it allows for the group of commands in the BLOCK to be skipped should the IF Command prove to be false.

*The Macro Window and BLOCK*

When the BLOCK Command is selected from the command screen, both a Begin Block and an End Block command are simultaneously added, and the Begin Block command will be shaded in the development pane, indicating that the next command selected will be placed below the Begin Block command.

*Window specific to BLOCK*

No specific window appears to further define the BLOCK Command.

*Generic Example using BLOCK*

A simple command sequence using BLOCK might be:

<table>
<thead>
<tr>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Begin Macro (automatically added when the window is opened)</td>
</tr>
<tr>
<td>Begin Block</td>
</tr>
<tr>
<td>Command A1</td>
</tr>
<tr>
<td>Command B1</td>
</tr>
<tr>
<td>Command C1</td>
</tr>
<tr>
<td>Command D1</td>
</tr>
<tr>
<td>End Block</td>
</tr>
</tbody>
</table>
In this example, the macro would process Commands A1, B1, C1 and D1 in sequence prior to any other subsequent commands being processed. Once the block A1 through D1 is completed, the program will move on and process Command E1.

This is not a terribly effective use of the BLOCK Command. Why? Because even without the Begin Block and End Block commands, the macro would process Commands A1 through E1 in the same sequence. As you will see, the true value of the Block command is when used in conjunction with the IF-ELSE commands.

**IF**

*Purpose and Use*

The IF Command is used to write a conditional statement, otherwise known as a test statement. The result of the IF Command test is always yes (true) or no (false). When the result of the IF test proves to be true, the macro program will continue by executing the next program line after the IF Command. When the result of the IF Command proves to be false, the macro program will skip the command (or command set – see BLOCK and LOOP) immediately following the IF Command and continue with the 2nd command following the IF Statement.

The IF Command is a powerful tool when your macro program contains a number of different options as part of your imaging routine, but you only want to complete certain options for a given experiment condition.

*The Macro Window and IF*

When the IF Command is selected from the command screen, it is added to the development pane below the highlighted command in the pane.

*Window specific to IF*

When the IF Command is chosen from the command selection pane (left pane of the Macro Window), another window will open on top of the Macro Window. It will appear as shown below.

The purpose of this window is to develop the test condition that will be proven true or false when evaluated. You will note the following features of the IF window.
When a variable is selected in the lower Variable Box, you will note that the corresponding operator and Test Value boxes become active. Additionally, the “and/or” options become available. The “and/or” options allow for an expansion of the IF Command to include two tests. The “and” option requires both tests to be true. The “or” option requires at least one of the tests to be true.

**Generic Example using IF**

**Example X**

```
IF Command
Command A1
Command B1
Command C1
Command...
```

When the IF Command is true, the program will execute Command A1, followed by Command B1, Command C1, etc.
Should the IF Command prove to be false, the macro will skip the next command line or command set following the IF Command, and will continue with the first command following that command or command set.

In the preceding Example X, when the IF Command is false, the program will skip Command A1 and will execute Command B1, followed by Command C1, etc.

If a group of commands are to be executed after the IF Command is evaluated, the user should use the BLOCK Command to execute the group (see BLOCK Command).

**Example Z**

<table>
<thead>
<tr>
<th>IF Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Begin Block</td>
</tr>
<tr>
<td>Command A1</td>
</tr>
<tr>
<td>Command A2</td>
</tr>
<tr>
<td>Command A3</td>
</tr>
<tr>
<td>End Block</td>
</tr>
<tr>
<td>Command B1</td>
</tr>
<tr>
<td>Command C1</td>
</tr>
<tr>
<td>Command…</td>
</tr>
</tbody>
</table>

In Example Z, when the IF Command is true, the program will execute the block of commands including A1, A2 and A3. It will then execute commands B1, C1, etc.

When the IF Command is false, the program will skip the block of commands including A1, A2 and A3 and will execute the commands B1, C1, etc.

**ELSE**

*Purpose and Use*

The Else Command is used in conjunction with an IF Command, allowing a choice between two subsequent commands depending upon the outcome of the IF Command evaluation.

*The Macro Window and ELSE*

When the ELSE Command is selected from the command screen, an Else command is placed in the macro program below the existing highlighted command.

*Window specific to ELSE*

No specific window appears to further define the ELSE Command.
Generic Example using Else

When the ELSE Command follows an IF Command, it is the default command should the IF Command turn out to be false. In this “false” case, the command following the ELSE Command is executed.

Compare the difference between the IF only program to the IF-Else program below.

In Example X, Command B1 is always carried out and the IF command only decides whether the Command A1 is executed or not.

In the Example X.1, the IF-ELSE combination decides between Command A1 and Command B1. When true, Command A1 is run followed by Command C1, when false Command B1 is run followed by Command C1.

Example X

<table>
<thead>
<tr>
<th>IF Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command A1</td>
</tr>
<tr>
<td>Command B1</td>
</tr>
<tr>
<td>Command C1</td>
</tr>
<tr>
<td>Command…</td>
</tr>
</tbody>
</table>

≠

Example X.1

<table>
<thead>
<tr>
<th>IF Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command A1</td>
</tr>
<tr>
<td>Else</td>
</tr>
<tr>
<td>Command B1</td>
</tr>
<tr>
<td>Command C1</td>
</tr>
<tr>
<td>Command…</td>
</tr>
</tbody>
</table>

Example Z and Z.1 illustrate the same structure utilizing BLOCK commands.

Example Z

<table>
<thead>
<tr>
<th>IF Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Begin Block</td>
</tr>
<tr>
<td>Command A1</td>
</tr>
<tr>
<td>Command A2</td>
</tr>
<tr>
<td>Command A3</td>
</tr>
</tbody>
</table>
Example Z.1

IF Command
Begin Block
Command A1
Command A2
Command A3
End Block
Else
Begin Block
Command B1
Command B2
Command B3
End Block
Command C1

In Example Z, the BLOCK containing the Commands B1, B2, B3 is always carried out and the IF command only decides whether the Block containing Commands A1, A2, A3 is executed or not.

In the Example Z.1, the IF-ELSE combination decides between the BLOCK containing Commands A1, A2, A3 and the BLOCK containing Commands B1, B2, B3. When true, the BLOCK containing Commands A1, A2, A3 is run followed by Command C1, when false the BLOCK containing Commands B1, B2, B3 is run followed by Command C.

LOOP

Purpose and Use
The LOOP Command instructs the Macro program to complete a series of commands (within the loop) and then repeat those commands a defined number of times (iterations) or by an exit test condition (evaluated by an If statement) before continuing the Macro program.

This can be quite helpful when a repetitive procedure defined by a series of commands must be completed.
The Macro Window and LOOP

When the LOOP Command is selected from the command selection pane in the Macro Window a Begin Loop and an End Loop command will be inserted into the Macro program in the development pane. The Begin Loop command will be highlighted in the development pane, indicating that the next selected command will be placed just below the Begin Loop command. Other commands to be carried out as part of the loop must be placed between the Begin Loop and End Loop commands.

After all commands are added between the Begin Loop and End Loop commands, the loop procedure is defined. Upon playing the Macro, the program will proceed through the series of Loop commands until it reaches the End Loop command. It will then return to the Begin Loop command and repeat the Series of commands for as many times as defined.

Window specific to LOOP

When LOOP is selected a Loop window will appear over the Macro Window. It will ask the user to enter or select a value. The Loop window will look like this:

The Loop window includes a drop down menu that allows the user to:
1) Enter a defined number of loop iterations
2) Select a variable that will contain the number of loop iterations
3) Select the “Infinite” setting which will require an exit test condition defined by an IF statement. The “Infinite” setting is used when the number of loop iterations is unknown and will be determined by a process within the loop itself. An IF statement is used to evaluate an escape test condition and if found to be “true” an ESCAPE BLOCK/LOOP Command (see next section) is executed to exit the loop.

The commands following the END LOOP Command with execute once the prescribed number of loop iterations are completed or when the IF statement allows for the escape from the loop.

**Generic Example using LOOP**

Once you have selected the LOOP Command in the Macro Development pane, the command sequence entered might be:

| Begin Macro (automatically added when the window is opened) |
| Begin Loop |
| Command A1 |
| Command B1 |
| Command C1 |
| Command D1 |
| End Loop |
| Command E1 |
| End Macro (automatically added when the window is opened) |

This macro would process Commands A1, B1, C1 and D1 in sequence, repeating the sequence for as many iterations as were specified in the LOOP Command. Once that number of iterations is completed, the program will move on and process Command E1.

The example of the “Infinite” setting which will require an exit test condition defined by an IF statement will be covered in the ESCAPE BLOCK/LOOP section.

**ESCAPE BLOCK/LOOP**

*Purpose and Use*

The ESCAPE BLOCK/LOOP command is used to leave a programmed block or loop prior to completion of the block or loop.

The ESCAPE BLOCK/LOOP Command can be useful when placed in a block following an IF Command, allowing the program to exit the loop should a predetermined condition be met.

*The Macro Window and ESCAPE BLOCK/LOOP*

When the ESCAPE BLOCK/LOOP Command is selected from the command screen, it is added to the development pane below the highlighted command in the development pane.
Window specific to ESCAPE BLOCK/LOOP

No specific window appears to further define the ESCAPE BLOCK/LOOP Command.

Generic Example using ESCAPE BLOCK/LOOP

<table>
<thead>
<tr>
<th>Begin Macro</th>
</tr>
</thead>
<tbody>
<tr>
<td>Begin Loop</td>
</tr>
<tr>
<td>Command A1</td>
</tr>
<tr>
<td>Command B1</td>
</tr>
<tr>
<td>IF Command</td>
</tr>
<tr>
<td><strong>Escape Block/Loop</strong></td>
</tr>
<tr>
<td>Command C1</td>
</tr>
<tr>
<td>Command D1</td>
</tr>
<tr>
<td>End Loop</td>
</tr>
<tr>
<td>Command E1</td>
</tr>
<tr>
<td>End Macro</td>
</tr>
</tbody>
</table>

In the generic example above, the macro will begin the loop series by completing Commands A1 and B1. If the test in the IF Command is false the ESCAPE BLOCK/LOOP is skipped and the commands C1 and D1 are run. The End Loop statement is then evaluated to determine if the Loop iterations are to be completed or not. Once the IF Command proves to be true, the ESCAPE BLOCK/LOOP Command will be executed and the loop exited. At that point, Command E1 will be run.

Note: If the Loop iteration setting is “Infinite” the only way to exit the Loop is via the IF Command test and an Escape Block/Loop Command.
Variable Commands

CREATE VARIABLE (Macro Variables)

Purpose and Use

The CREATE VARIABLE Command allows users:

1) To have more variables than the standard default selections for Text and Number Variables.
2) To CREATE macro VARIABLES that will only be accessible and utilized from within the macro in which they were created thereby reducing conflicts between macros inadvertently using variables of the same name.

Note: Once the macro that created this class of variables is closed these CREATED MACRO VARIABLES will cease to exist and their values will be lost. If your intent is to create variables that will persist between executions of the same or different macros you should create CUSTOM VARIABLES using the SETUP menu item CUSTOM VARIABLES.

Flexibility of the CREATE VARIABLE Command is maximized by the Data Type and Scope options. The user can define whether the variable data should be Text or Numeric under the Data Type selection. The Scope selection allows the user to choose either:

Local: CREATES a MACRO VARIABLE that is ONLY accessible and usable from within the macro that created it and NOT from sub-macros called by the macro that created it.

- OR -

Global: CREATES a MACRO VARIABLE that is accessible and usable from within the macro that created it AS WELL AS from sub-macros called by the macro that created it.

Note: A Global Variable created in a sub-macro is not accessible by the macro that called it unless the macro that called it created a global variable of the same name and data type.

The Macro Window and CREATE VARIABLE

When the CREATE VARIABLE Command is selected from the command screen, it is added to the development pane below the highlighted command in the development pane.

Window specific to CREATE VARIABLE
When the CREATE VARIABLE Command is chosen from the command selection pane (left pane of the Macro Window), another window will open on top of the Macro Window. It will appear as shown below.

These CREATED MACRO VARIABLES can later be assigned values in the Set Variable command.

Generic Example using CREATE VARIABLE

To create a new variable, assign a name to it and then make the selection for Data Type and the Scope of the variable. A Local variable will only be active in the macro itself and NOT in any sub-macro called, while a Global variable can be used throughout the entire macro and in any sub-macros (PLAY MACRO Command) the creating macro calls.

(MAIN LINE MACRO)

Begin Macro (automatically added when the window is opened)

Command A1-Creates Numeric Global Variable 1

Command B1-Sets Variable 1 = 1

(SUB MACRO 1)

Begin Macro (automatically added when the window is opened)

Command A1-Creates Numeric Global Variable 1

Command B1-Sets Variable 1 = 10

Command C1-Creates Numeric Global Variable 2

Command D1-Sets Variable 2 = 20

End Macro (automatically added when the window is opened)
The output of the Main Line Macro prompts are:

Variable 1 = 10
Variable 2 = 1

Variable 1’s value is changed by Sub Macro 1 because it was set as a global variable in the Main Line Macro. This means it can be used in Sub Macro 1 which set it to 10 and also allowed the value to be returned to the Main Line Macro for display in its Prompt Command.

Variable 2’s value is NOT changed by Sub Macro 1 because it was set as a local variable in the Main Line Macro. This means it is NOT used in Sub Macro 1 which created and set an identically named variable to 20. This local variable was the destroyed when Sub Macro 1 ended and no value was returned to the Main Line Macro. The Main Line Macro’s identically named local variable “Variable 2” was still present with its originally set value of 1 which is displayed in its Prompt Command.

Note: Created Macro Variables must be defined before they will show up in drop down lists. Sub-macros MUST create the same variables* that were created in the macro which called them; otherwise the created macro variable will not show up in the drop down lists. *The same variable with the exact same attributes-name spelling, text/numeric, and must be set to Global.

SET VARIABLE

Purpose and Use

The SET VARIABLE Command allows the user to set or modify a text or numeric value assigned to a variable.

This can be useful when the value of a variable changes from one imaging procedure to another and the user wants to be able to modify that value without modifying the remainder of the macro program.

The SET VARIABLE Command can also be used to convert the values of numbers between text and numeric variable formats.

The Macro Window and SET VARIABLE

When the SET VARIABLE Command is selected from the command selection pane in the Macro Window a SET VARIABLE Command will be inserted into the Macro program in the development pane below the highlighted command.

Window specific to SET VARIABLE

When SET VARIABLE is selected a Set Variable window will appear over the Macro Window. It will ask the user to select the variable to be defined and also to place an initial value on that variable.

The Variable label box on the left has a drop down menu allowing you to select from a list of preset variable labels: TextVar1…TextVar5 or NumVar1…NumVar5 as well as any custom or Created macro variables. Select from the list.

The right hand box allows the user to choose from a drop down menu of variables in order to allow the user to assign the values of variables to each other.
Text Label Example

Text or Numerical values can be entered in any of the available spaces; however, if the variable being assigned was a Text Variable, any numerical values will be treated as text format. This is the example of changing the numeric value from Numeric format to Text format.

Using the Insert Variable and Text Copy options, the definition of the variable is extremely flexible as the permutations are limitless.

Numeric Label Example

Text or numerical format variables can be entered into any of the spaces available, thereby allowing the conversion of Text Formatted Numbers into Number Formatted Numbers. It also allows for the extraction of numbers from a mixed number-text¹ string of characters. It should be noted that when setting a Numeric Variable equal to a Text Variable the first number² that is encountered is the number that is used to set the Numeric Variable.

(Note 1-The number can be integer or real i.e. - a number containing a decimal pt.)
Example: Set Variable [NumVar1] = [Bob 12.345 Ted 67.890]
would result in:
NumVar1= 12.345

(Note 2 -Text is considered as any non-number including commas and spaces)
Example: Set Variable [NumVar1] = [Bob 12,345 Ted 67.890]
would result in:
NumVar1= 12.000

(since the comma is considered a delimiter character and not part of the number)

With the Operation set to Numeric, there are mathematic and logic operators available in the pull down menu. Once a selection is made from this menu list, a new data entry box will be available to either add a value or use another variable from the Insert Variable button and list.

INCREMENT VARIABLE (no longer available, see note below)

Note: The Increment Variable command is no longer available. The functions associated with Increment Variable are now available in the Set Variable command window (above). If you created a macro that utilized Increment Variable in a previous version of SPOT, the macro will still function as the Increment Variable information will be transferred into the Set Variable Command in the newer version of SPOT.

SAVE VARIABLES

Purpose and Use

The SAVE VARIABLES Command can be used to save a selection of Variables to a file so that they can be utilized at a later time via the RECALL VARIABLES Command.

The SAVE VARIABLE Command is useful for:

1) Saving initialization parameters.
2) Creating a virtual stack.
3) Creating a virtual array using variables for the array dimension pointers.

Saved Variable data values are saved as a file type *.var

The Macro Window and SAVE VARIABLES

When the SAVE VARIABLES Command is chosen from the command screen, it is added to the development pane below the highlighted command in the development pane.

Window specific to SAVE VARIABLES

When the SAVE VARIABLES Command is chosen from the command selection pane (left pane of Macro Window) another window will open on top of the Macro Window. It will appear as shown below.

The FILE Entry box allows you to select a directory and set a name for the file containing the Variable values selected from the list below.

The 3-DOT button at the right end of the File entry box allows you to browse to the directory you desire.

The INSERT VARIABLE button allows you to insert variables into the File name. The ability of inserting variables into the file name allows the creation of arrays using the variables as array pointers.
The Lower scroll box lists all the variables known to this particular macro. Select the variables you wish to store by clicking on each one; use the control key to select more than one variable.

Note: Saving out a Variable does not affect its value within the macro. In other words, it does not clear its value.

Generic Example using SAVE VARIABLES

See next section on RECALL VARIABLES for an example on how these commands work together in macro scripting.

RECALL VARIABLES

Purpose and Use

The RECALL VARIABLES Command is used to call back previously saved variables.

The variables recalled could be saved by this macro or by some other macro; it does not matter as long as the following Variable Parameters are identical: Variable Name, Variable Type (numeric/text), Variable Scope (Local/Global-if applicable).

A few notes of caution:

1) When Creating Macro Variables and saving them and recalling them from two different macros, each macro will need to have a CREATE VARIABLE Command creating the variable with the exact same parameters: Variable name, Variable type, Variable scope (if applicable).

2) Deleting custom variables may lead to Macros that contain Variable Commands using the deleted variables, thus causing the Macro not to work.

3) Moving the location of file folders and macros may lead to error messages in Macros containing any Save, Open or Recall commands. (pertinent for Image files and for Variable files). This happens because the file path name does not find the requested file.

The Macro Window and RECALL VARIABLES

When the RECALL VARIABLES Command is chosen from the command screen, it is added to the development pane below the highlighted command in the development pane.
Window specific to RECALL VARIABLES

When the RECALL VARIABLES Command is chosen from the command selection pane (left pane of Macro Window) another window will open on top of the Macro Window. It will appear as shown below. You can select which variables you want to recall from your previously saved variables file.

Generic Example using SAVE and RECALL VARIABLES Commands

Using the Save and Recall Variables Commands together can help with the initialization of variables for a new experiment setup. This is accomplished by running an initialization Macro which executes a Save Variable Command and then the User Runtime Macro can access the saved variable values via the Recall Variable Command.

Step One: Write Initialization Macro that sets the default values and then saves them out to a Persistence file. During the setup of the equipment and programs you play this Macro to provide the initial values for all the variables.

Initialization Macro
Begin Macro
Set Variables…
Save Variables-Save a set of variables to “Persistence File”
End Macro

Step Two: The User Run-Time Macro loads the initialization values in for the macro, runs using these variable values and possibly changes them. Then upon completion the macro can save out the set of variables to this file thus recording any changes the user may have made.

User Run-Time Macro
Begin Macro
Recall Variables- from “Persistence File”
Body of macro (works on variables and possibly changes them)
Save Variables- Save the set of Variables to “Persistence File”
Alternatively, the user may not want to save the change and instead always start the macro at the standard initialization values. In this case, the user would not save out the variables at the end of the run-time macro.

Timing Commands

DELAY

*Purpose and Use*

The DELAY Command is used to pause the playing of the macro program for a set period of time.

The DELAY Command can be useful when the user needs a prescribed delay period between commands being carried out.

*The Macro Window and DELAY*

When the DELAY Command is selected from the command screen, it is added to the development pane below the highlighted command in the development pane.

*Window specific to DELAY*

When the DELAY command is selected, in addition to the Macro Window command insertion noted above, a Delay window will appear over the Macro Window. It will require the user to define the amount of time that the macro program should wait before carrying out the next command in the sequence. The delay can be referenced to the current time, or one of many user defined timestamps.

![Delay Window](image)

*Generic Example using DELAY*

```plaintext
Begin Macro (automatically added when the window is opened)
Begin Loop
Command A1
Command B1
Command C1
Command D1
Delay
End Loop
Command E1
End Macro (automatically added when the window is opened)
```
In the generic example, the macro will begin the loop series by completing Command A1 through D1 on the first iteration of the loop. At that point, the program will pause for a prescribed period of time before initiating loop iteration #2. The delay will also occur prior to the program leaving the loop and processing Command E1, once all of the loop iterations have been completed.

**WAITUNTIL**

*Purpose and Use*

The WAITUNTIL Command is used to pause the playing of the macro program until a specific restart date and time.

The WAITUNTIL Command can be useful when the user needs to prescribe a defined start time for a series of commands that follow the WAITUNTIL command. This command can allow a user to automatically start an imaging sequence even while he/she is away from the imaging set-up.

*The Macro Window and WAITUNTIL*

When the WAITUNTIL Command is selected from the command screen, it is added to the development pane below the highlighted command in the development pane.

*Window specific to WAITUNTIL*

When the WAITUNTIL Command is selected, a window specific to this command opens over the Macro Window. The user is required to define a date and time.

The date format can be entered in various numerical formats as long as the month, date, and year are separated by spaces, dashes, forward slashes, commas, or periods in that order. Other formats will generate an Invalid Format message.

**Note:** The WAITUNTIL Command is referenced to the time and date set in your computer’s operating system. Please make sure that the operating system time and date are accurate before using this function.

**Generic Example using WAITUNTIL**

```
Begin Macro (automatically added when the window is opened)
WaitUntil
Begin Loop
Command A1
Command B1
Command C1
Command D1
```
In the generic example, the macro will begin running, but will pause until the date and time specified by the WAITUNTIL command. Once that time is achieved, the loop series will begin for the prescribed number of iterations before completing the macro.

**PAUSE**

**Purpose and Use**

The PAUSE Command can be used to pause a macro for an indefinite period of time until the user chooses to resume the macro play.

**The Macro Window and PAUSE**

When the PAUSE Command is selected from the command screen, it is added to the development pane below the highlighted command in the development pane.

**Window specific to PAUSE**

No specific window appears to further define the PAUSE Command.

**Generic Example using PAUSE**

When the PAUSE Command is encountered within a macro, the Macro Player Window will appear on the desktop and the Resume button will appear with the Status: “Paused”. The macro will be paused until the Resume button is pressed.

**WAIT FOR SENSOR TEMPERATURE**  (Pursuit and Xplorer only)

**Purpose and Use**

The WAIT FOR SENSOR TEMPERATURE command is used to pause the macro until the CCD sensor has reached a specified temperature. Since the amount of dark current noise present is proportional to the CCD sensor temperature, using the WAIT FOR SENSOR TEMPERATURE command allows the user to ensure that their Dark Correction frame is valid.

**Note:** It is imperative to set the cooling regulation to “On” and have the preset temperature match the Wait for sensor temperature setting.

**The Macro Window and WAIT FOR SENSOR TEMPERATURE**

When the WAIT FOR SENSOR TEMPERATURE Command is selected from the command selection pane in the Macro Window the command will be inserted into the Macro program in the development pane, just below the previously highlighted command.
Window specific to \textit{WAIT FOR SENSOR TEMPERATURE}

When the \textit{WAIT FOR SENSOR TEMPERATURE} Command is selected, a window specific to this command opens over the Macro Window. The user is required to define a target temperature range.

\textit{Generic Example using WAIT FOR SENSOR TEMPERATURE}

\begin{verbatim}
Begin Macro (automatically added when the window is opened)
Wait for Sensor Temperature
Get Image
Delay
Wait for Sensor Temperature
Get Image
End Macro (automatically added when the window is opened)
\end{verbatim}

In the generic example, the macro will ensure that the two pictures are taken with the same noise characteristics. If this call was not used the temperature would never be checked before taking the image possibly leading to acquisition of initial images before the camera reached regulation.

\textbf{END MACRO}

\textit{Purpose and Use}

The END MACRO Command defines an endpoint to the Macro subroutine. This command is automatically placed as the macro endpoint when a new macro is created. This END MACRO command is supplemental and can be added anywhere throughout the macro program.

This command can be effective when the user would like to end a macro before it has completed all of its program steps. This is useful as a temporary interrupt to a rather large and complex macro that can yield effective results by just running a portion of the macro. The intermediate END MACRO Command can be switched on and off using the disable feature. This allows the flexibility during playback without significant modification to the base complex macro.

More commonly, however, the intermediate END MACRO Command can be used following an IF statement. This allows the user to exit a macro once a specific condition has been met.

\textit{The Macro Window and END MACRO}

When the END MACRO Command is selected from the command selection pane in the Macro Window the command will be inserted into the Macro program in the development pane, just below the previously highlighted command.

\textit{Window specific to END MACRO}

There is no window specific to this command.

\textit{Generic Example using END MACRO}

\begin{verbatim}
Begin Macro (automatically added when the window is opened)
Begin Loop
Command A1
\end{verbatim}
In the generic example, the macro will begin the loop series by completing Command A1 and D1 for as many iterations as were defined. If a condition is proved true for the IF Command, the macro will end prior to carrying out Commands E1, F1, etc.

Communication Commands

PLAY SOUND

Purpose and Use

The PLAY SOUND Command instructs the computer to play an audible sound.

This can be quite useful in notifying the user when a point in the macro program has been reached. This point might indicate a need for user input (interactive mode) or may simply indicate that a portion of the imaging process has been completed.

The Macro Window and PLAY SOUND

When the PLAY SOUND Command is selected from the command selection pane in the Macro Window the command will be inserted into the Macro program in the development pane just after the previously highlighted command.

Window specific to PLAY SOUND

When PLAY SOUND is selected a Play Sound window will appear over the Macro Window. It will ask the user to define the sound file (.wav) to be used during playback. The Play Sound window will look like this:

The user may define the path used to access the sound file, or may use the browse button to search for a particular sound file located on the computer or the network, selecting it from the browsing window.

Generic Example using PLAY SOUND
In the generic example, the PLAY SOUND command will access and play an audio file to indicate to the user that the macro program has been completed.

**PROMPT USER**

**Purpose and Use**

The Prompt User Command prompts the user to take an action and/or to input data at a certain point in the macro program playback. Entered data is then stored in one of the Variables (NumVar, TextVar, Custom Variables, or Macro Variables) for use in the Macro.

**The Macro Window and PROMPT USER**

When the PROMPT USER Command is selected from the command selection pane in the Macro Window the command will be placed just below the previously highlighted command in the Development pane of the Macro Window.

**Window specific to PROMPT USER**

When PROMPT USER is selected, a Prompt User window will appear over the Macro Window. It will ask the user to define a number of inputs needed to make the PROMPT USER functional during playback. The Prompt User window has many different looks and may appear like the following, depending upon the Input Type selected from the dropdown menu.

The Prompt User window includes a drop down menu that allows for 7 predefined options. These options include OK, Yes/No Buttons, User Text, User Numeric, Push Buttons, Choice List, or File Folder (see Table B. Prompt User Options for more details about this feature).

The Prompt User window also includes a Play Sound checkbox. Select the Play Sound option if you would like a sound to play once when the user is prompted or until they have responded.
To activate the sound feature, follow these steps:

1. Check the box next to Play Sound.
2. Define the path to access the sound file, or use the browse button to locate a sound file.
3. If you would like the sound to repeat until the user has responded, select the Repeat checkbox and specify a time interval between the sounds.

**Generic Example using PROMPT USER**

- Begin Macro (automatically added)
- Begin Loop
- Command A1
- Command B1
- Command C1
- Command D1
- End Loop
- Command E1
- Prompt User
- End Macro (automatically added)

In the generic example, the PROMPT USER command will generate an on-screen message associated with an OK button and play a sound that repeats every second. Once the OK has been pushed, the sound will stop playing and the macro will move on to the next command, in this case, to end the macro.

### Table B. Prompt User Options

<table>
<thead>
<tr>
<th>Prompt Type</th>
<th>Records your response? (to what data location)</th>
<th>General Use</th>
<th>General Response on Macro Playback</th>
<th>Selectable Default Response Available with this command?</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>OK Button</strong></td>
<td>No</td>
<td>To confirm that an action or point in time has occurred in the macro. Allows for a customized message (Prompt Text) to indicate the action or point in time.</td>
<td>Click OK</td>
<td>None</td>
</tr>
</tbody>
</table>
### RUN REPORT

**Purpose and Use**

The RUN REPORT Command instructs the program to automatically execute a report file.

**The Macro Window and RUN REPORT**

When the RUN REPORT Command is selected from the command selection pane in the Macro Window the command will be inserted just below the previously highlighted command in the development pane of the Macro Window.

**Window specific to RUN REPORT**

When RUN REPORT is selected, a Run Report window will appear over the Macro Window. It will ask the user to define a number of inputs needed to define the report to be accessed.

Selections to be made are:

1) Interactive mode will allow the user to select the report they would like to run as well as select the output mode. Output modes available: Printer, Preview Window or File.
A) When selecting the File output the Output File Path Name will input box will become enabled for input and the 3-Dot Button allows selection of the storage directory.

B) Specification of image compression

C) Action to take if file writing encounters an identical file name.

2) Multiple records can either be displayed horizontally or vertically.

Generic Example using RUN REPORT

<table>
<thead>
<tr>
<th>Begin Macro (automatically added when the window is opened)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Begin Loop</td>
</tr>
<tr>
<td>Command A1</td>
</tr>
<tr>
<td>Command B1</td>
</tr>
<tr>
<td>Command C1</td>
</tr>
<tr>
<td>Command D1</td>
</tr>
<tr>
<td>End Loop</td>
</tr>
<tr>
<td>Command E1</td>
</tr>
<tr>
<td>Run Report</td>
</tr>
<tr>
<td>End Macro (automatically added when the window is opened)</td>
</tr>
</tbody>
</table>

In the generic example, the RUN REPORT Command will initiate the opening and display (or printing) of the specified report.

LOG

Purpose and Use

The LOG command allows the user to record information to a file during a macro.

The Macro Window and LOG

When the LOG Command is selected from the command selection pane in the Macro Window the chosen command will be inserted just below the previously highlighted command in the development pane of the Macro Window.

Window specific to LOG

When the LOG Command is selected a Log window will appear over the Macro Window which will ask the user to define which information is to be saved and to which file and location.

In the Text window, type in the text that you would like recorded, or use Insert Variable to record information from a variable.

Select or de-select Append <CR><LF>. The Append <CR><LF> option enables the user to control the spacing in the file. If it's selected, each entry will be on its own line in the file. If not selected, each entry will be added in one line without spaces.
Browse to the file you would like the data saved to, or create a new one and provide its path. Decide the action you would prefer if the file already exists. If Overwrite Existing File is checked, the original file will be deleted and replaced. If it is not selected, the new data will be added to the original file.

**Generic Example using LOG**

```
Begin Macro
Command A1
Command B1
Log
```

**EXECUTE OS COMMAND**

**Purpose and Use**

The EXECUTE OS COMMAND instructs the program to run an executable file from outside of the SPOT program, and allows the user to automatically open that file as part of the macro program. Users who are familiar with DOS will recognize this as a DOS command line.

**The Macro Window and EXECUTE OS COMMAND**

When the EXECUTE OS COMMAND is selected in the command selection pane, the command will be placed just below the previously highlighted command in the development pane of the Macro Window.

**Window specific to EXECUTE OS COMMAND**

When this command is selected, a window will appear over the Macro Window. It will ask the user to define a path to access the executable file. There is a browsing feature that allows the user to search the computer for the appropriate executable filename. Selecting from the browse window automatically determines the path for the macro program.

If the name of the file includes a variable, insert it into the path by using the Insert Variable button and selecting the appropriate variable. Select the Pause Macro until Done checkbox to pause the macro program until the executable file has been completed.

**Generic Example using EXECUTE OS COMMAND**

```
Begin Macro (automatically added when the window is opened)
Begin Loop
Command A1
```
In the generic example, the EXECUTE OS COMMAND opens a program after the loop command series has been completed.

**PLAY MACRO**

*Purpose and Use*

The PLAY MACRO Command instructs the program to play a previously saved Macro program that resides on a path accessible to the SPOT software.

This can be useful when a macro represents a core imaging process that you would like to use in multiple other macro setups.

*The Macro Window and PLAY MACRO*

When the PLAY MACRO Command is selected from the command selection pane in the Macro Window a PLAY MACRO Command will be inserted into the Macro program in the development pane.

*Window specific to PLAY MACRO*

When PLAY MACRO is selected a PLAY MACRO window will appear requiring the user to define the Macro program that is to be played. The browse button allows the user to search various folders and drives on the computer in order to locate the appropriate macro. Variables can also be inserted into the file path.

*Note:* If you change the location of the Macro file called by this command after you have specified the file path in the window above, you must modify the file path in the window. Otherwise, the command will fail upon playback.

**Generic Example using PLAY MACRO:**

An example of the use of the PLAY MACRO Command is presented in the following generic macro.

```
Begin Macro (automatically added when the window is opened)
Command A1
```
In this example, Commands A1 through D1 are carried out. Before Command E1 is carried out, a Macro Program previously specified, is started. When it is completed, Command E1 and other succeeding commands will be carried out.

Like any set of commands, if the PLAY MACRO command is placed inside of a loop, it can be played multiple times without continuous manual restarts.

Drop File

Purpose and Use

The DROP FILE Command is used to open a saved image into an active application other than SPOT, i.e. for further image analysis and processing.

Note: If the dropped file is modified and re-saved with the same file name, there will not be a message to warn you that you are about to overwrite the original file. Please save any modified images as a different file name if the original data needs to be preserved.

The Macro Window and DROP FILE

When the DROP FILE Command is selected from the command screen it is added to the development pane below the highlighted command in the development pane.

Window specific to DROP FILE

When the DROP FILE Command is selected a Drop File dialog box will appear over the Macro window. This window will require the user to enter the name of the application to which the specified file should be dropped. The application title entry is not case sensitive and needs to contain the name of the application as it appears across the header. The use of variables can help with automating this process.

Generic Example using DROP FILE

Once you have selected the DROP FILE Command in the Macro development pane, the command sequence might be:
Show/Hide Application

Purpose and Use

The purpose of the Show/Hide Application is to bring an active program to the front for easy access and to hide the application once you are done using it.

The Macro Window and SHOW/HIDE APPLICATION

When the SHOW/HIDE APPLICATION Command is selected from the command screen it is added to the development pane below the highlighted command in the development pane.

Window specific to SHOW/HIDE APPLICATION

When the SHOW/HIDE APPLICATION Command is selected a SHOW/HIDE APPLICATION dialog box will appear over the Macro window. This window will require the user to enter the name of the application which is to either shown or hidden. The application title entry is not case sensitive but needs to contain the name of the application as it appears across the header. The use of variables can help with automating this process.

Generic Example using SHOW/HIDE APPLICATION

Once you have selected the SHOW/HIDE APPLICATION Command in the Macro development pane, the command sequence might be:

Begin Macro
Command A1...
Open Image File
Drop File
Command C1...

Begin Macro
Command A1...
Show/Hide Application
Prompt User
Show/Hide Application
Command C1...
This section is currently under construction.

Sorry for any inconvenience.

Please check back later.
Ch. 8 – SPOT Advanced Databases

Introduction

In addition to the numerous image capture and editing features, the SPOT software provides you with an easy to use, fully featured image archiving database.

SPOT’s image archiving database features are not available for the Mac edition of the program.

This chapter is divided into the following sections:

- The Database Menu
- The SPOT Sample Database
- Creating and Modifying Databases
- Searching Databases

The Database Menu

The Database menu contains all of the options for accessing, creating, modifying, and searching SPOT databases. When you first open the SPOT program, only the first two options, **New** and **Open** are active. The other options remain inactive (grayed) until you either create a new database or open an existing database. In addition, **Edit Database Record** does not appear on the menu unless a database image is open. Each option is described below.

- **New** – Create a new SPOT database. Refer to the “Creating and Modifying Databases” section for details.

- **Open** – Open or delete an existing SPOT database.

Note: Only one database can be opened per session. If you try to open a second database, the program prompts you to close the open database.

- **Close** – Close a SPOT database.

- **Password** – Define a password to protect a SPOT database.

- **Fields** – Define the text and numeric fields, look-up lists, and default options for your database.

- **Preferences** – Define the location and format of the image files in your database.

- **Search** – Define parameters for database searches.

- **Edit Database Record** - Edit information associated with a database image, including field data, time and date information, file save location, and memo text.
The SPOT Sample Database

For your reference, a fully functional sample database is included with your software. We recommend that you browse through this database to familiarize yourself with the features and functionality. The following section is a “visual tour” of the SPOT Sample Database.

Open the SPOT Sample Database

1. From the Database menu, select Open. The SPOT program prompts you to select the database.
2. Select SPOT Sample Database, and click on Open. SPOT prompts you for a password.

Note that the SPOT database icon appears at the bottom of your Windows screen, indicating that the database is open.

View the Database Structure

From the Database menu, select Fields. The Database Fields window illustrates the different types of fields that you can define for a SPOT database:
Click on the Items button for the Sample Type lookup field to view a list of the sample type options for the SPOT Sample Database.

From the Lookup Field Items window, you can Add, Modify, or Delete items in the lookup list.

### View Database Preferences

From the Database menu, select Preferences

The Preferences window is the starting point for defining:
- Image file/database location
- Image file format
- Thumbnail save options

Refer to the Defining File and Save Preferences section of this chapter for details.
Search the Database

From the Database menu, select **Search**. The Database Search window allows you to:

- Define search and sort parameters
- Save a specific set of search parameters
- Choose display options for search results (i.e., tabular or thumbnail display).

Refer to the **Searching Databases** section of this chapter for details.

Click on Search. Clicking on Search without entering any conditions results in a display of all the records in the database:

Save an Image to the Database

Open an image file, and from the File menu, select **Save to Database**:

All of the required fields must be entered before the image can be saved.
Creating and Modifying Databases

The following sections outline the details involved in creating and/or modifying SPOT databases.

- Setting Up the Database
- Defining Database Fields
- Defining File and Save Preferences
- Saving Images
- Editing Database Image Records
- Moving Existing Database Images

Setting Up a New Database

The initial set up for a new database consists of two steps:

- Naming the database (required)
- Defining a password for the database (optional)

Note: If you do not define a password during the initial definition, you can use the Password option on the Database menu to add a password at a later point.

To set up your database, follow these steps:

1. From the Database menu, select New.
2. Enter a Name for the database.
3. Define a password for the database, if needed. Follow these steps:
   a) Check the Require Password box. The Password and Enter Again boxes are activated.
   b) Enter a 1-10 character alphanumeric password.
   c) Re-enter the password.
4. Click on OK. The Database Preferences window appears. At this point, you can:
   Define the database preferences. Refer to the next section, Defining File and Save Preferences, for details.
   Click on OK to skip defining Database Preferences and proceed directly to defining the database fields and lookup lists (i.e., the Database Fields window). Refer to the Defining Database Fields section of this chapter for details.

Note: Database Preferences can be defined/modified at any future time by selecting the Preferences option on the Database menu.
Defining File and Save Preferences

Before saving images to a database, you should specify your file and save preferences for the database. This includes:

- Location and path for database images
- Image file format
- Thumbnail save preference

All of the file and save preferences are defined from a single point, the **Database Preferences** window. The Database Preferences window automatically appears when defining a new database. If you want to define the file and save preferences at a later point, select the **Preferences** options from the Database menu.

Storing Archived Images – An Important Consideration

Before proceeding to define the file and save parameters for your database, you should carefully plan how and where you will store archived images, as well as how you will accommodate future images. Because each uncompressed image file can be several megabytes in size, saving and storing large quantities of images requires planning. There are a number of options for storing/archiving images including your computer’s hard drive and external storage devices including external hard drives, mini-drives, and your system network. For more details on storage planning, contact your MIS department or a qualified computer or network specialist.
Location and Path of Database Images

SPOT databases are structured so that the database and the images stored in that database do not have to reside in the same location. This structure allows you to keep the relatively small database program files on your hard drive, while storing the larger image files in a different location. The name and location of the database - **SPOT Sample Database** in the illustration above - appears under the path for the database images; it cannot be changed from this window. The database always resides in the default location, `C:\Documents and Settings\All Users\Documents\Diagnostic Instruments\Spot\DBImages`. Although the default location for image files is also `C:\Documents and Settings\All Users\Documents\Diagnostic Instruments\Spot\DBImages`, we recommend that you define an alternative location such as an external hard drive or a network drive. If you plan to save images to removable media, you should, at this point, define the volume label for the disk. Because a single database of images can span more than one disk, defining unique volume labels for each disk provides a reference so that you can conveniently access images in the future.

To define a volume label for a disk, follow these steps:

1. Ensure that the removable media is in the drive.
2. From the Windows Explorer, single click on the appropriate drive icon.
3. From the File menu, select the Properties option; or, right click on the drive and select the Properties option. The Properties window appears. If you do not see a view similar to that in the illustration at right, click on the General tab.
4. Enter a name in the Label box. For ease of reference, you should name the volume so that it tells you both the name of the database and the disk number.
5. Click on OK.
6. Write the volume label on the removable media disk. This way, when you search a multi-disk image database, and the program prompts you to enter the disk number, you will be able to find the information.

Repeat steps 1 – 6 for each disk of images associated with a database.

If you are saving images to an existing database, you can click on the **Current Image File Locations** button to display the location of the saved image files and change the location and/or volume label for the disk. The Database Image File Locations window appears.

To change the File Path and/or the Volume label, either double click on the File Path/Volume information, or select the information and click on Modify. The **Image File Location** dialog box appears.

From this window you can:
- Enter a new location for the database images in the Path box; or, click on the button next to the Path box to browse for a new location.
- Enter a new Volume label for the disk.

Image File Format

From the Preferences window, you can define the graphic format of the images saved to a database. There are six options:
Windows Bitmap is the default option. To define image file format, select one of the formats from the drop-down list. Selecting either the JPEG or the TIFF JPEG option activates the JPEG Quality box. This option allows you to compress images (i.e., lower their resolution) so that you can save disk space in cases where high-resolution images are not needed.

To define JPEG Quality, select a value between 1 and 100:

- A value of 1 represents the lowest resolution and the smallest file size.
- A value of 100 represents the highest resolution and the largest file size.
- For JPEG2000 Quality, select between lossless (minimal compression) and lossy. Select a ratio for lossy compression. A higher number equates to greater compression with greater chance of data loss.

**Thumbnail Save Preference**

Determine whether you will **Save Image Thumbnails** for the database. The Save Image Thumbnails option saves a thumbnail of each image in the database. This allows you to visually browse through the images in a database. You can also open a database image from a thumbnail. The recommendation is to enable this feature for faster display of search results.

**Defining Database Fields**

The Database Fields window is a centralized point for defining the details associated with a database. There are three processes associated with the definition of database fields:

- Naming and defining **Text/Numeric Fields** – The textual/numeric fields that you define represent the data you want to be associated with an image. Typical text fields include patient name and ID number. Typical numeric fields include height and weight.
• Naming and defining **Lookup Fields**—Lookup fields also represent data that you want to be associated with an image. Lookup fields are used in cases where the data item has a limited number of discrete options (e.g., blood type). Each lookup field is associated with a user-defined list of items, enabling you to select an option from a list, as opposed to manually entering it each time an image is saved to the database.

• Setting Default Values for the fields—To speed the process of saving images to a database, you can define default values to automatically appear for a field. This helps you to avoid multiple entries of the same item when numerous images have the same data for a particular field.

**Text/Numeric Fields**

To define a textual/numeric field, follow these steps.

1. On the Database Fields window, enter the name of the field in the Text/Numeric Fields box. You can use up to 30 alphanumeric characters. Entering information in the box activates (un-grays) the four variables to the right of the box.

2. Define the four variables associated with each field.
   - **Required**—Check (click on) the Required box to make the field a required entry when saving images to the database. When this box is checked, images can not be saved until the field has an entry.
   - **Title**—Check the Title box to ensure that the data from the text field appears in the title of the image window and under any thumbnail of the image.
   - **Text**—Click on the Text button to define the field as a text field. This is the default setting for the field type.
   - **Numeric**—Click on the Numeric button to define the field as a numeric field.

   The field type (i.e., text or numeric) is important in terms of how the program searches the database. Text field searches look for textual strings of information while numeric field searches look for a range of values. So, a database field that contains numbers should not automatically be defined as a numeric field. For instance, if your field is a number such as a patient ID, it should be defined as a Text field because it is not a measurement and it is not within a specific range of values.

**CAUTION!**

After you have defined the Text/Numeric fields, you cannot change the Text or Numeric setting. Although you can make changes to an existing field name (i.e., to correct a spelling error or make a more intuitive name), you should not change the meaning of the field. This will render the field useless for searches performed on all previously stored images.

**Lookup Fields and Lists**

Defining a Lookup Field consists of three actions:

1. Naming the Lookup Field
2. Selecting the Required and Title variables
3. Creating the items in the Lookup Field list
The SPOT database allows you to perform these actions in different orders, depending on your situation. Consider the following scenarios:

- You are the database administrator, and you want to define a new database with multiple Lookup Fields for others to use when saving images to the database. You know ahead of time which Lookup Fields you want to define, and you also know all of the items that will be associated with each Lookup Field.
- In this scenario, you can define the Lookup Fields, the Required and Title options, and some or all of the items in Lookup Field list.
- You are an end user and know which Lookup Fields you want to define, but prefer to add items for each field, as needed, when saving images to the database.

You can define one or more Lookup Fields without adding any of the Lookup Field list items. The Lookup Field items can be added either at a later time, or during the process of saving images to the database.

To define a Lookup Field and the associated list, follow these steps:

1. Enter the name of the first Lookup Field.
2. Select the Required and Title options. Required – Check (click on) the Required box to make the field a required entry when saving images to the database. When this box is checked, images can not be saved until the field has an entry. Title – Check the Title box to ensure that the data from the text field appears in the title of the image window and under any thumbnail of the image. You can also leave one or both options unchecked. If you do not want to enter the Lookup Field list items at this time, you can enter any remaining Lookup Fields and click on OK to save the database.
3. Click on the Items button. The Lookup Field Items window appears with the name, as shown at right.
4. Click on Add. The Lookup Item dialog window appears for you to enter the list item.
5. Enter the name of the list item in the box.
6. Click on OK. The program returns you to the Lookup Field Items window. In the illustration to the right, the user has added the A+ item to the Blood Type Lookup Field.

From the Lookup Field Items window, you can:
- Click on Add to add additional items to the Blood Type lookup list.
- Select a lookup list item and click on Modify to edit the item or Delete to remove the item from the list.
- Click on OK to save the lookup list and the associated items. The program returns you to the Database Fields window.
7. Follow steps 1-7 to enter additional Lookup Fields. You can enter up to four per database.
Setting Default Values

As part of the process of defining database fields, you have the option to define default values for each field. The values that you define will appear as default field entries each time you save an image to the database. If desired, you can edit the default entries before saving the image. To enter default values for a field, follow these steps:

1. After you have defined your text/numeric and lookup fields, click on Default Values (at the bottom of the Database Fields window). The Default Field Entries window appears, as shown at right. Unless specified, the SPOT database uses the Last Value for each field. To change this default for a Field, check the box next to the field name. Checking the box activates the Use: options.

2. Select the option that you want:
   - Last Value
     When saving an image to a database, the program uses the data entered for the last image as the entry for the same field in the current image. The last entered data always appears in the entry box for the image that you are saving. Thus, if you select Use: Last for the physician field, and you select Dr. Jarvis for the first image, Dr. Jarvis appears in all subsequent images until you make a different selection.
     To select the Use: Last option, click on the Last button for that field and click on OK to save the settings.
   - Default Value
     When saving an image to a database the program uses the entry that you make (in the box next to the Default button). If desired, you can edit the default entries before saving the image.
     To select the Use: Default option, click on the Default button for the field and enter/select the default entry. Click on OK to save the settings.

   If you do not specify a default value option for a field, all of the fields must be entered/selected each time an image is saved to the database.

Saving Images

Once you have acquired the images that you want to store in your database, the SPOT program makes it easy to save the information. To save an image to a database, follow these steps:

1. From the File menu, select the Save to Database option. The Save Image to Database window appears. The program automatically displays the date and time that you first saved the image. This information can be modified as needed.

2. Enter the information associated with the image in the database fields.
T next to a field indicates that the field is Textual.
N next to a field indicates that the field is Numeric.
To enter data for a lookup field that is not contained in the drop-down list options, simply type the information into the field.

Note: When you save an image to a SPOT database, the program automatically creates an image ID that is stored in the image path folder. This is a reference number that the program uses to access images and associated data.

Note: If you defined a data field as Required on the Database Fields window, the program will not let you save the image without the information.

3. Click on the Memo button to associate a memo with an image. The Image Memo window appears.
4. Enter the text for the memo, and click on OK to save the memo.
5. Click on OK at the Save Image to Database window. If you entered a lookup list item that was not in the drop-down list of options, as described in step 2, the program prompts you to add the item to the list.
6. Click on Yes to add the new item to the lookup list.

Editing Database Image Records

Once you have created a database and saved images to that database, you can edit records as needed. To edit a database image record, follow these steps:

1. Ensure that the database is open.

2. From the File menu, select Open Database Image. The dialog box prompts you to enter the Image ID. If you do not know the Image ID, you can search the database, as described in the Searching the Database section that follows.
3. Click on OK to open the database image.
4. From the Database menu, select the Edit Database Record option. The Image Database Record window appears.
5. Change the Date/Time settings as needed. Use the following format: mm/dd/yy.
6. Edit the Fields data as needed. For the text and numeric fields, simply enter the new data.
For the lookup fields, either select an item from the drop-down list or enter a new item. When you close the Image Database window, the program prompts you to add the new lookup list item. Edit the Image Memo, if necessary. Click on Memo, enter the information, and click on OK.

In addition to the data associated with a database image, the Image Database Record window also allows you to modify the image file location/path information. For example, if you have moved a database image to a new file location, you would need to modify the record to reflect this.

To modify the location/path information for a database image, click on Modify. The Image File Location window appears. Either enter the new file path in the Path box, or click on the button to browse for the information. Enter the new Volume label. Click on OK. Click on OK at the Image Database Record window to save the changes.

**Note:** The image itself cannot be edited while the Image Database Record window is open.

### Moving Database Images

When saving images to a database, the default save location is your computer’s hard drive – C:\Documents and Settings\All Users\Documents\Diagnostic Instruments\Spot\DBImages (or wherever you installed the SPOT software). To move images in a database from your hard drive to a removable storage medium such as a zip disk or a CD, follow these steps.

1. **Determine the file space needed for the database images.**
   a) Open the Windows Explorer.
   b) Navigate to the database image files. In the example at right, you can see that the image files associated with the Histology SPOT database are located in the C:\Documents and Settings\All Users\Documents\Diagnostic Instruments\Spot\DBImages\Histology directory. Note that the status bar at the bottom of the screen displays the number of objects in the Histology folder (45) and the disk space used by these objects (58.2 MB).
2. **Define the volume label for your removable disk.**
   In some cases, you will be able to store all of a database's images on one disk. At a future point, you might want to add additional images to the database that will not fit on the same disk. Defining a volume label enables you to access SPOT databases that span more than one removable disk. To define a volume label, follow these steps:
   a) Insert the removable media in the drive.
   b) In Windows Explorer, right click on the drive letter for the removable disk.
   c) Select the Properties option. You should see a view similar to that shown at right. If you do not see the pie shape, click on the **General** tab.
   d) Enter a name for the Volume Label in the **Label** box. You should use a name that indicates both the name of the database and the disk number (e.g., HISTO1).
   e) Click **OK**.
   f) For future reference, label the disk or CD.

3. **Move the database images to the removable disk.**
   a) If it is not already open, open the SPOT program.
   b) Open the database that contains the images that you want to move. From the Database menu, select **Preferences**.
   c) At the Database Preferences window, click on **Current Image File Locations**. The Database Image File Locations window displays the current file path and volume, as shown at right.
   d) Click on the **Modify** button. The Image File Location window appears, with the current path and volume information for the database images, C:\Documents and Settings\All Users\Documents\Diagnostic Instruments\Spot\DBImages\Histology.
   e) Either click on the square box next to the file path to navigate to the folder that you want to move the images to, or enter the file path in the box. When you click on the square box next to the Path box, the SPOT program prompts you with an Explorer view. Navigate to the D: drive (or whichever letter is used by your PC).
   f) Click on the Create New Folder tab, as shown at right.
g) Enter the name of the new folder, e.g., Histology.

h) Click on Select. The Image File Location dialog reappears.

i) Enter the Volume label that you defined for the Zip disk in step 2, e.g., HISTO1

j) Click on OK. The Database Image File Locations window reappears.

k) Close the Database Image File Locations window. The Database Preference window reappears. Note that the Image Files Saved To path has not changed – it is still C:\Documents and Settings\All Users\Documents\Diagnostic Instruments\Spot\DBImages\Histology. Unless you change this setting, new images added to the database will still be saved to this location.

l) Click on OK.

4. From the Windows Explorer, cut and paste the image(s) from the original location (e.g., C:\Documents and Settings\All Users\Documents\Diagnostic Instruments\Spot\DBImages\Histology) to the new location (e.g., D:\Histology).

a) Navigate to the C:\Documents and Settings\All Users\Documents\Diagnostic Instruments\Spot\DBImages\Histology folder, and click on Histology.

b) From the Edit menu, choose Select All.

c) Cut the images [Ctrl X].

d) Click on the D:\Histology folder.

e) Paste the images [Ctrl V].

Steps one through four describe how to move an entire database of images. However, it is possible to move individual images or groups of images. When moving individual or groups of images from a SPOT database, you must change the path of each image file that you want to move.

To do so, follow these steps:

1. Search the database to find the image(s) that you want to move. For details on entering search conditions, refer to the Searching Databases section below.

2. From the search results display table (the Images window), select an image that you want to move, and click on Edit. You can select only one image at a time for editing. The Image Database Record window appears.
3. Note down the Image ID number – the first item in the Image Information section.
4. Click on the Modify button. The Image File Location dialog appears.
5. Enter the Path and Volume information as described in steps 2d – 2i above.
6. Repeat steps two through five for each image that you want to move.
7. From the Windows Explorer, cut and paste the images from their original location to the new location defined in step five.

Searching Databases

The SPOT program offers a robust, yet easy to use database search function. The **Database Search** window is the central point from which search and display parameters are entered. From this window, you:

- Define search conditions
- Order search results
- Display and edit search results
- Save search criteria
- Load previously saved search criteria

To access the Database Search window, select Search from the Database menu.

Defining Search Conditions

To define database search conditions, follow these steps.

1. Click on the Add button (for Search Conditions) on the Database Search window. The Search Condition window appears.
2. Select the database field that you want to base the search on. The left drop-down box contains a list of all the textual/numeric and lookup fields that you defined for the database. In addition to the fields that you defined, the Date associated with the image and the Image ID appears in the list.
3. Select the criteria for the search from the center drop-down box. The list options vary according to the type of field that you selected, as shown below:
4. Enter the final search parameter in the right hand box. This entry will vary according to the search criteria that you selected. For **Text** and **Numeric** field searches, you are required to enter the information, while for **Lookup** field searches, you can select from a list of the lookup items.

For **Text** fields, asterisks (*) and question marks (?) can be used as “wild card” characters with the **is like** and **is not like** options.

* - The asterisk wild card tells the program that any number of characters can be used with this text field.

For example, if you want to search all patients with “smith” in their name, you can enter *smith*. This search will bring up names such as John Smith, Jane Smithfield, and Joe Hammersmith.

? - The question mark wild card tells the program that any single character can be used where the question mark appears.

For example, if you want to search for patients with either the name Smith or Smyth, you can enter *sm?th*. The asterisk and space in the front of sm?th tells the program to find all first names associated with sm?th. The question mark tells the program to search for one-letter difference variations on the name Smith. This search will bring up names such as John Smith, Anne Smyth, and Fred Smoth, but it will not bring up Jane Smithfield, Harry Hammersmith, or Abigail Smythe.

5. Click on OK to save the search parameters. The Database Search window reappears with the search conditions in the box.

After you have entered a search condition, you can:

- Click on Add to add another search condition.
- Select a condition and click on Modify to change it.
- Select a condition and click on Delete to remove it from the search.
- Define how the search results will be ordered. Refer to the next section for details.
Ordering Search Results

After you have defined the search conditions, the **Order by** options allow you to set the display order of the search results.

To order search results, follow these steps:

1. Click on the Add button to the right of the Order by box. The Record Ordering window appears.
2. Select from the list of drop-down list options to determine how the database search results will be ordered. In addition to the database fields that you defined, the options include Date/Time and Image ID.
3. Check either the Ascending or Descending option:

   - **Ascending** lists display results beginning with the lowest value and progressing to the highest value.
   - **Descending** lists display results beginning with the highest value and descending to the lowest value.

4. Click on OK. The options that you selected appear in the Order by box:

After you have entered an ordering condition, you can:

- Click on Add to add another ordering condition.
- Select a condition and click on Modify to change it.
- Select a condition and click on Delete to remove it from the search.

5. Choose the display options. Refer to the next section for details.

Displaying Search Results

The SPOT software allows you to display database searches either in tabular form or as thumbnails. From the **Send Results to** box, select either Table or Thumbnails. When all the search conditions have been entered, click on Search. The following sections detail the display and editing functionality.

**Send Results to: Table**

Display the search results in a table. From left to right, the column headings for the table are:

- The user-defined database fields
- Date/Time
- Image ID
- Image Format
- Bit Depth
- Size (in bytes)
- The illustration at right shows a search that resulted in one record.

From the table window, you can:
• **Open a database image** – Select the database record item, and click on the thumbnail at the bottom of the window. The image opens for viewing and modification.

• **Edit a database record** – Either select the database record item and click on Edit, or double-click on the database record item. The Image Database Record window appears. Refer to the Editing Database Image Records section below for details.

• **Delete a single database record** – Select the database record item and click on Delete.

• **Delete all of the database records** – Select a database record item and click on Delete All.

• **Switch to the thumbnail view** – Click on the Show as Thumbnails button.

• **Perform another search** – Click on the Search Again button to return to the Database Search window, where you can add or modify search conditions.

---

### Send Results to: Thumbnails

Display the search results in the form of image thumbnails. The illustration to the right shows the thumbnail view of a database search that produced eleven records.

• **Double-click** on a thumbnail to open an image for viewing or modification.

• **Right-click** (Windows) / **[Ctrl] Click** (Mac) on a thumbnail to display a list of options, as shown at right. The right-click menu enables you to perform a variety of actions directly from the thumbnail window. You can:
  - Select an image.
  - Open a database image.
  - Delete an image from the database.
  - Print an image.
  - Edit Database Record - Edit the database image record.
  - Add Image to Image Sequence – Add a database image to an image sequence or create a new image sequence.
  - Add Image to Report Template – Add a database image to a selected report template. When you select this option, SPOT prompts you to select from a list of reports. If you have not defined a report, SPOT automatically creates a new report for you and inserts the image as a Static Image object. Refer to the Creating Reports section of Ch. 10 - Reporting for more details.
  - Select all images in the thumbnail view. When you use this option, the right-click menu expands to include the above options for multiple images.
  - Click and drag with the mouse to select two or more images.
Send Results to: Exported File

Display the search results as fields exportable to a database.

- Include field information from the selected database to a list of information that is to be exported to another database application.
- Select a filename and one of the file type options from the dropdown menu.
- When you click on Begin, the export will take occur, placing the file in the location defined by your path. Use the browse option to quickly define a path. You may also choose to either overwrite or append an existing document with the same path and filename.

Note: The file you export will be created as a delimited file as selected by you in the dropdown menu. Once the file has been created with the exported data, it may be opened with a variety of applications, depending upon the preferences defined in your operating system.

Saving and Reusing Search Criteria

After you have defined the search and display parameters, you can save that set of criteria to be used for future searches on that database. Once saved, you can then reuse the search criteria clicking on the Load button.

To save a search, follow these steps:

1. Enter the search and ordering parameters.
2. Click on Save. The program prompts you to name the database query.
3. Name the query.
4. Click on OK. At this point, you can:
   - Run the search by clicking on Search.
   - Close the Database Search window and reopen the search at a future time.

   To reopen the search at a later time, click on the Load button, and select a search (.qry) file. Click on Open. The Database Search window displays the parameters for that search query.

Editing Database Image Records (from a search)

The SPOT program provides two ways to access and edit database image records:

- Via the Edit Database Record option on the Database menu
- Via the display windows of database search results
In both cases, the Image Database Record window allows you to change the information associated with the database image record.

However, the functionality differs slightly, depending on how the window is accessed:

<table>
<thead>
<tr>
<th>Accessed via the Database Menu</th>
<th>Accessed via a Search Results Display</th>
</tr>
</thead>
<tbody>
<tr>
<td>Modify date/time, database field entries, image memo, and file/path information.</td>
<td></td>
</tr>
<tr>
<td>Modify the database record for the open image only.</td>
<td>Modify the database record for any image in the database.</td>
</tr>
<tr>
<td>Edit the database record only.</td>
<td>Edit the database record and/or the image itself.</td>
</tr>
</tbody>
</table>

To edit a database image record from a search results display window, follow these steps:

1. Open the Image Database Record window.
2. If your results are displayed in a table, either double-click on the record in the table, or select the record and click on Edit. If your results are displayed as thumbnails, right-click on the thumbnail. The Image Database Record window appears. Notice that navigational arrows appear above the thumbnail.
   1. Change the Date/Time settings as needed. Enter the information in **mm/dd/yy** format
   2. Edit the Fields data as needed.

   For the text and numeric fields, simply enter the new data. For the lookup fields, either select an item from the drop-down list or enter a new item. When you close the Image Database window, the program prompts you to add the new lookup list item. Edit the Image Memo, if necessary. Click on the Memo button, enter the information, and click on OK.

   In addition to the data associated with a database image, the Image Database Record window also allows you to modify the image file location/path information. For example, if you have moved a database image to a new file location, you would need to modify the record to reflect this.

   To modify the location/path information for a database image, click on Modify. The Image File Location window appears. Either enter the new file path in the Path box, or click on the button to browse for the information. Enter the new Volume label. Click on OK.

3. At this point, you can either save the changes to the image record or proceed to make changes to another database record.

   To save the changes and return to the search results display, click on OK. To edit another database record without closing the Image Database Record window, use the navigational arrows at the top of the window to browse for the record.

   - Use the two middle arrows to scroll one image at a time through...
the database.

- Use the left arrow to go back to the first image in the database.
- Use the right arrow to go forward to the last image in the database.
Introduction

The SPOT software includes a built-in reporting functionality that can be used either by itself or in conjunction with a SPOT database (Windows) to collect, organize, and present information related to your image captures. This chapter discusses the process of creating and running reports. It is divided into the following sections:

- Overview: The SPOT Sample Report (Windows)
- Creating a Report
- Running a Report
- Distributing Reports

Overview: The SPOT Sample Report

When you create a report in SPOT, you are building a template to be applied to specific situations. Running the report applies the template to an image or images. For example, you might have one template called Histology Report to document histology samples and another template called Cell Pathology Report to document different cell cultures. Similarly, you might want to produce reports for production line analysis. In this case, you could define different templates for different parts, such as Part A Analysis Report, Part B Analysis Report, etc…

For your reference, a fully functional sample report is included with the SPOT software. This report can be used:

- As an introduction to SPOT’s reporting features
- As a basis from which to build additional reports
- The following section is a “visual tour” of the SPOT Sample Report.

Open the SPOT Sample Report

The SPOT Sample Report, Pathology Report, is a database report: it is based on the information associated with the images in the SPOT Sample Database. To open the SPOT Sample Report, follow these steps:

1. Because the SPOT Sample Report is based on the SPOT Sample Database, you must first open this database:
   a. From the Database menu, select Open.
   b. Select SPOT Sample Database.
   c. Click on Open.
2. Open an image from the SPOT database.
   a. From the Database menu, select Search. The Database Search window appears. Do not enter any search conditions at this point.
   b. In the Send Results to box, select Thumbnail Window.
c. Click on Search. The search results display.
d. Click on the John Rowland colon thumbnail to open a database image to report on.

3. Open the SPOT Sample Report. From the File menu, select Open Report. The Open window appears for you to select the file. The file path and name for the SPOT sample report is C:\Spotcam\reports\sampleDBreport.rpt. The report appears in a new window and the menus and menu options in the main window change to reflect SPOT’s report editing functions.

View the SPOT Sample Report Objects

When you open the SPOT Sample Report (or any SPOT rpt file), you are actually opening a template of user-defined report objects that the program uses to create the report output. The call outs on the following illustration of the SPOT Sample Report template identify the different objects used in the design of this report. Refer to the Defining Report Objects section for descriptions of each object.

Run the SPOT Sample Report

To run the Pathology Report for the John Rowland – colon image from the SPOT Sample Database, select Run Report from the File menu. The report sequence is as follows:

1. The Run Report window prompts you to define the Output destination for the report. Select Preview Window.
2. Click on Run.
3. The report then prompts you with the run-time text prompts that have been defined for this report. Because there are three run-time text prompts for the SPOT Sample Report (i.e., to enter the information for the Description, Analysis, and Recommendation fields), you will be prompted to enter run-time text for each field. In the illustration at right, the run-time text has already been entered, but if you were reporting on the image for the first time, you would see only the prompt. Click on OK at each window. When you click on OK at the third Run-Time text window, the report appears, as shown below.

4. Click on Close to close the report without saving or printing it. Refer to the Running Reports section for more details.

### Creating a Report

To create a new SPOT report, select **New Report** from the File menu. The following changes take place in the main window:

- The report definition window appears as a separate window. If an image or image(s) were open, they remain open.
- The **Object** menu appears. Use these options to specify the fields, text, and images that appear in the report.
- The **Attributes** menu appears. Use these options to define the appearance and style of the report.
- The **View** menu options change to reflect report definition function.
- The **Edit** menu options change to reflect report-editing functions. These options are available only after one or more report objects has been added to the New Report window.

**Note:** When you move between an image window and the report definition window, the menu options change accordingly.

This section is divided as follows:

- **Working in Report Mode**—general reporting features and functionality
- **Defining View Options**—the view of the report definition screen
Defining Report Attributes – the style and appearance of the report
Defining Report Objects – the text, field, and image information that appears in the report
Editing Report Objects – edit options for the report objects

Working in Report Mode

The report mode contains functionality that differs from the image capture and editing functionality. The following is a brief overview of these features.

Cursor Functionality

- Cursor functionality in SPOT reports varies according to which Object menu option is selected.
- If None is selected, the cursor is an editing tool for selecting, sizing, and positioning objects. When creating new reports, None is the default option.
- If a report object is selected, the cursor changes to a cross-hair icon for placing new report objects to the grid.

Sizing and Positioning Report Objects

When sizing and positioning a report object in the report window, you must first select the object by single clicking on it. When an object has been selected, handles appear at the corners; for line objects, the handles appear at each end. You can select multiple report objects by holding the mouse button down and dragging the cursor around the objects. Handles appear around both objects. When selected, report objects can be sized or positioned as needed.

- To size objects, move the cursor either to a point on the object’s border or to one of the handles. The cursor changes to a two pointed arrow

To resize one dimension of a box, position the cursor on a vertical or horizontal line; click and drag the side to the new size.
To proportionally resize a box, position the cursor on a handle; click and drag the box to the new size.
- To position objects, move the cursor over the selected object. The cursor changes to a four point arrow. Click and drag the object to a new location. If an object is selected, you can use the arrow keys to fine tune its position.

Note: When multiple objects are selected, they can be sized and positioned as a single object.

Using Right-click and Double-click Functionality

When you are in report mode, you can use the right-click and double-click mouse functions as editing shortcuts.
• Double clicking on a report object enables you to edit the object’s attributes – e.g., the thickness of a line.

• Right clicking (Windows)/ [Ctrl] clicking (Mac) on a report object calls an object specific edit menu that contains both general editing options and attribute editing options specific to that object. Right clicking on an Image object, for example, gives you a list of editing options, as shown at right.

• Right clicking (Windows)/ [Ctrl] clicking (Mac) on the report grid gives you three options: Paste an object that you copied or cut; Select All of the objects on the grid, or Delete All of the objects on the grid.

Refer to the Defining Report Attributes and Editing Report Objects sections for more details.

Defining View Options
The View menu provides you with eight options, each of which is described on the following pages.

Zoom Level
Zoom in or out to six different sizes. From the View menu, select Zoom and enter the desired percentage.

First Page
Go to the first page in the report. (only available when multiple report pages have been created)

Previous Page
Go back one page in the report. (only available when multiple report pages have been created)

Next Page
Go forward one page in the report. (only available when multiple report pages have been created)

Last Page
Go to the last page in the report. (only available when multiple report pages have been created)

Set Display Grid Size
The report definition window includes an adjustable grid (i.e., the dots on the screen) to assist you in placing and aligning report objects on the report page. By default, the grid is turned on. To turn off or modify the grid, follow these steps:
1. From the View menu, select Set Display Grid Size.
To turn off the display grid, deselect the Show Grid box. To modify the spacing follow steps two through four.

2. Select either inches or millimeters.

3. Enter the spacing for the display grid. The number that you enter represents the space in inches or millimeters between the dots on the grid.

   If the measurement is inches, enter a number between .04 and 10.
   If the measurement is in millimeters, enter a number between 1 and 25.

4. Click on OK. The display grid appears.

**Set Object Grid Size**

In addition to the display grid, you can define a second grid specific to report objects. The object grid controls the movement of objects as you work with them on the display grid. When you select a report object and move it, the object automatically “snaps” to the nearest line in the object grid, allowing you to more precisely align and arrange the objects on your report page.

1. From the View menu, select Set Object Grid Size.

2. If desired, check the Snap to Grid option.

3. Define the spacing for the object grid. In many cases, the object grid and the display grid will have the same spacing. In other cases, you might not want the display grid to be as finely spaced as the object grid (i.e., so the dots do not interfere with the view of the report definition window).

   If the measurement is inches, enter a number between .04 and 10.
   If the measurement is in millimeters, enter a number between 1 and 25.

   (The measurement values will convert automatically as you toggle between English and metric units)

   *The default spacing value for the Object Grid is the last entered value.*

4. Click on OK.
Show Tools

Click on the Show Tools option to display a floating palette of navigation buttons and report objects, as shown here. Refer to the Defining Report Objects section of this chapter for more details.

Defining Report Attributes

All of the general style and appearance options (report attributes) can be accessed from the Attributes menu. Report attributes can be defined for an entire report or on an object-by-object basis (see the Defining Report Objects section below).

- When a report object is selected, the attribute is defined for the selected object(s) only.
- When nothing is selected, the attribute is defined for all future, relevant objects.

The following sections detail each of the report attributes and the report objects that they affect. On all dialogs below, once a change has been made to an attribute setting, the Save as Defaults button is available if you would like re-set the Default attribute setting.

Colors

Define the foreground and background colors for all objects. Follow these steps:

1. From the Attributes menu, select Colors.
2. Define the Text/Lines color. This is the color of the text, the line, or the border around a text/image box. The default foreground color is black. To select a color click on Color.
3. The next window varies, depending on whether you are using a Windows or a Mac system. Windows allows you to select from a palette of colors or enter specific HSL or RGB color values. Mac OS allows you to select from a palette of colors, enter specific RGB, CMYK, HLS, or HSV values, and enter Internet specific colors.

   Define the Background/Fill color. This is the color that appears behind text and in boxes. Lines and images do not display a background color.

Line Thickness

Determine line thickness for the following report objects: Line, Horizontal Line, Vertical Line, Arrow, Box, Rounded Box, Ellipse, Freehand, Polygon, and Polyline.

1. From the Attributes menu, select Line Thickness.
2. Enter a Thickness value between .05 and 10 points.
3. Click on OK.

**Image Border and Justification**

Determine the line thickness for image borders and define the justification of the image within the display box. This option applies only to the *Image* report object.

1. To create a border around the image, click on the *Border* box, and enter a *Thickness* value between .05 and 10.
2. Select the *Justification* for the image. This value is the justification of the image within its display box, not the justification on the report page.
3. Click on OK.

**Arrow Size and Direction**

Specify the size of the arrow head and define the direction that the arrow points.

1. To specify the size of the arrow head, enter a value between 1 and 10.
2. Specify the direction of the arrow:
   - To draw an arrow starting tail first and finishing with the point (head), select *Tail to Head*.
   - To draw an arrow starting point (head) first and finishing with the tail, select *Head to Tail*.
3. Click on OK.

**Box/Ellipse Fill**

Define the appearance of the Box, Rounded Box, and Ellipse objects.

1. Specify whether you want a fill for the object.
   - If you do not want the box to be filled (i.e., you want a transparent box), click on OK.
   - If you want to specify a fill pattern for the box, check the Fill Box/Ellipse. The *Pattern* options appear.
2. Specify a pattern by clicking on one of the seven options.
3. Click on OK.
Text Font

Define the appearance of the text for the Text, Date, and Time objects.
1. Select a Font, a Font Style, and a point Size. The Sample box displays a preview of the font.
2. Define any Strikeout or Underline effects.
3. Click on OK.

Text Border, Justification, and Background

Define the appearance of the text boxes for the Text, Date, and Time objects
1. Specify whether the text box should have a border. To add a border, click on the Border box, and enter a Thickness value between .05 and 10.
2. Define the Justification of the text. This justification applies to the position of the text in the box, not the position of the text on the page.
3. Define the Background. Select either Transparent or Opaque.
4. Click on OK.

Title

Define the criteria for the titles of the files saved
3. Specify whether the titles should include the path and/or the file name extension
4. Click on OK.

Time

Define the Time units associated with an object
3. Specify whether the units should be indicated in seconds or milliseconds.
4. Click on OK.

To save the attributes you’ve selected for future report objects, choose Save as Defaults.
Defining Report Objects

All of the components of your report, including the formatting, text, images, and fields are known as objects. Using the objects, you can specify the information that your report will contain, as well as how the report will work.

- You can, using run-time images, produce reports for images as they are captured. This is a good option for situations where you are capturing many images in one sitting.
- You can produce reports for images that are saved to a SPOT database. Refer to Ch. 8 – SPOT Advanced Databases for details on creating and modifying SPOT databases.
- You can produce ad-hoc reports for single or multiple saved images.

Before discussing the individual report objects, review the following general procedure for inserting an object into a report:

- From the Object menu or by clicking on the appropriate Toolbox button, select the type of item (i.e., Lines, Connected Lines, etc…) that you want to add to the image. The cursor’s functionality varies according to whether a report object type (i.e., line, text) is selected.

If a report object type is selected, the cursor changes to a cross-hair icon that is used to add new report objects to the grid.

If None is selected, the cursor is an editing tool that is used to select and position objects.

- Use the mouse to move the cross hair to the location where you want to insert the object.
- Left-click at the insertion point.

If you selected a Line (unconnected line) or a Shape, hold down the mouse button and drag the line/box to the desired size.

If you selected any of the other report objects, the object will appear and you will be prompted to enter the associated information (e.g., static text, the location of an image file, the database field, etc…).

- Once it appears on screen, you can resize, reposition, and edit an object as needed.

Resize - Select (click on) the object and drag the handles in the direction of the resize.

Reposition – Left click and drag the object to the new area.

Edit – Select the object and choose an option from either the Edit menu or the Attributes menu. You can also edit an object by right clicking (Windows)/[Ctrl] clicking (Mac) on it.

For Connected lines use the following procedure. Select the appropriate Connected Lines object from the Object menu, or on the Tools box button. Move the cursor to your first location. Left click and release, and then move the mouse to create a side. Left click again to start a new side. Double click to finish the polyline, polygon, or freehand shape.

None

Select None when you want to use the cursor to edit and position the objects.

Lines

Unconstrained Line
Add a straight-line annotation to the report.

Horizontal Line
Add a horizontal line annotation to the report.
Vertical Line
Add a vertical line annotation to the report.

Arrow
Add an arrow to the report. Either select Arrow from the Object menu, or click on the Tools box button. Left click on the report and drag toward the area that the arrowhead will point to.

Connected Lines

Polygon
Add a closed polygon to the report. Either select Connected Lines>Polygon from the Object menu, or click on the Tools box button. Left click and release, and then drag the mouse to create a side. Left click again to start a new side. Double click to finish the polygon. The program automatically adds any additional lines needed to close the figure.

Polyline
Add an open polygon to the report. Either select Connected Lines>Polyline from the Object menu, or click on the Tools box button. Left click and release, and then drag the mouse to create a side. Left click again to start a new side. Double click to finish the polyline.

Freehand
Add a freehand line to the report.

Shapes

Rectangular Box
Add a square cornered box to the report.

Rounded Box
Add a round cornered box to the report.

Ellipse
Add an elliptical object to the report. Ellipses are drawn inside of the rectangular area that you define. Ellipses touch the top, bottom, right and left sides of this rectangle.

Either select Shapes>Ellipse from the Object menu, or click on the Tools box button. To draw an ellipse, left click at the point where you want to position one vertex of the rectangle and drag the cursor to the point of the opposite vertex.

Circle
Add a circle to the report.

Images

Static Image
A static image is an image that you want to appear on all productions of the report. A logo is a good example of a static image. To define a static image, follow these steps:

- From the Object menu, select Images>Static Image.
Left click at the point on the display grid where you want to insert the Static Image box. As you insert the box, you can also size it by dragging a corner or side.

The Static Image box then prompts you to enter the source for the image file. Select from one of the three options:

- **Currently Open Image**
  - If you have more than one image open, select the image from the drop-down list.

- **Image File**
  - A file from disk. Either enter the file name and path, or click on the browse button (to the right of the Image File box) to search for the file. If you select a sequence file, specify the image number (i.e., the order in the sequence) in the Sequence Index box. Note that, if the Store Image in Report Template is selected, you can view the image from within the report template as well as in the report itself. This feature allows you to quickly generate printed reports, without having to first save the report to file and/or run a preview report. Refer to Instant Reports in the Running a Report section of this chapter for details.

- **Database (Windows)**
  - An image file from a SPOT database. In order to use an image from a database, that must be open. If you are not sure of the Image ID, search the database and view the results table – the image ID appears there.

Click on **OK**. The static image object (or the actual image if you checked the Store Image in Report Template box) appears on the display grid, where you can move or resize the box.

When you run the report, the image is automatically proportioned to fit the dimensions of the box.

**Run Time Image**

A run-time image is an image that is open at the time that you run the report. Run-time image objects allow you to report on images as you capture them, without having to save the images to file or to a database.

To define a run-time image, follow these steps:

1. From the Object menu, select Images>Run-Time Image.
2. Left click at the point the on the display grid where you want to insert the Run-Time Image box. As you insert the box, you can also size it by dragging a corner or side.
   
3. Specify which image (if you have multiple open images) will be the run-time image. The entry in the Offset from Top Image Window box defaults to 0. If you have only one image open, click on **OK**.
   
   If you have more than one open image, you will need to specify the number for that image. For example, if you have five open images, there are five values, from 0 – 4 that correspond to the images, as illustrated in this cascaded view of multiple image windows: If you have multiple open images, selecting a cascade view of the images can help you to determine the proper number. To do this, select the Cascade option from the Window menu
4. Click on **OK**. The Run-Time image box appears on the display grid, where you can move or resize the box. When you run the report, the image is automatically proportioned to fit the dimensions of the box.
Note: Offset is related to the current order of any cascaded images. In other words, if you select an offset value, and then change the order of the image cascade (i.e. which image lies on top of another) the offset value will not reset. Instead, a different image may be selected by virtue of the offset.

Selected Image

The Selected Image options allow you to select one or multiple images to be included on a report at the time that you run the report. Selected images can be:

- Single or multiple open images
- Single or multiple images from file
- Single or multiple database images

To define a selected image or images, follow these steps:

1. From the Object menu, select Images\Selected Image.
2. Click on the point in the display grid where you want to insert the selected image.
3. Size and position the image box as desired.
4. Add any additional report object needed to complete the report.
5. From the File menu, select Run Report.
6. Select the report template either from the Currently Open Template, or from File.
7. Select the Output format. The default choice for running a report is to use the Preview Window, which allows you to view the report before saving or printing it. For more details on the Run Reports options, refer to the Running Reports section of this chapter.
8. Click on Run. The Selected Images dialog appears.
9. Define the Selected Images. You have the following options:

- **Top Open Image** – The report displays only the top-most image, if multiple images are open.
- **All Open Images** – The report displays all open images.
- **Image File(s)** – The report displays the image file or files selected from disk. When you check the Image File(s) option, and click on OK, the Report Images dialog appears for you to select one or more images to be included in the report. To individually select multiple images, hold the Ctrl key and click on each file.
- **Database (Windows only)** – The report displays one or more images from a database. When you check the Database option and click on OK, the Database Search dialog appears. Add search conditions and ordering criteria, as needed, and click on Search. The report displays the Search Results. Refer to Ch. 8 – SPOT Advanced Databases for detailed steps on how to define search and order conditions.

10. Click on OK.

---

**Text**

**Static Text**

Use the **Static Text** option to add text that will be the same for all of the images in a report. Typical static text fields include:

- The title of the report
- Report field headings

To define Static Text, follow these steps:

1. From the Object menu, select **Text>Static Text**.
2. Left click at the point where you want to insert the text. The program prompts you to enter the text. You may also include variables in the Static Text box that will be recalled when the report is run.
3. After you have entered the text, click on **OK**. The Static Text appears in a box.
4. To edit the text, double-click on the box. The Static Text box reappears for you to modify the text.
Run-Time Text
Use the Run-Time Text option to define the data entry prompts that will appear when you run an image report, or to define text that will appear only when you run the report. To prompt the user for data when the report is run, follow these steps:

1. From the Object menu, select Text>Run-Time Text.
2. Left click at the point where you want to insert the text. Check the Prompt User checkbox.
3. Enter the Prompt. When you run a report on an image, you will be prompted to enter information for the prompt. If you would like to use a variable as part of your prompt, click where you would like the variable to be, choose Insert Variable, and select your preferred variable from the drop-down menu.
4. Enter the Default Text, if desired. The Default Text field is useful in cases where the same item is entered for multiple image reports. For example, one lab technician might have drawn the sample for numerous blood samples. In this case, you could enter this technician’s name as the Default Text. You may also include variables in the Run-Time Text box that will be recalled when the report is run.
5. Click on OK. The object displays on the report grid.
6. To edit the text, double-click on the box. The Run-Time Text dialog box reappears for you to modify the text.

To simply display text on the image when it is run, follow these steps:

1. From the Object menu, select Text>Run-Time Text.
2. Left click at the point where you want to insert the text.

Type in the text you would like to display on the report. If you desire, you can insert variables in the text box that will be recalled when the report is run.

Page Number
Add a page number to a report page.

Page Count
Add a display of the total number of pages in your report.

Record Number
Add the number of the record (selected images) to the report. When you run the report, the number for each record is displayed on the page.

Record Count
Add the total number of record (selected images) in the report. When you run the report, the Record Count appears on each page.

Report Date
Insert the current date in your report.

Report Time
Insert the time that you ran the report.
**Current User Name**
Add the user name to the report. This name defaults to the user that is logged on to the computer if SPOT Users has not been set up. (See Ch. 2 of this section for more information on SPOT Users).

**Image Date**
Include the date that an image was captured.
1. After you have inserted an image in the Report, select **Text>Image Date** from the Object menu.
2. Left click at the point where you want the Image Date to appear. The ImgDate box appears on the display grid.

   The number following ImgDate is associated with the image or images in your report. Thus, if the report has more than one image, the program prompts you to define the image that the date should be associated with.
3. Enter the Report Image Number. When you insert images, the program automatically assigns it a number. The first image you insert is 1, the second image 2, etc…
4. Click on OK. When you run the report, the image date displays.

**Image Time**
Include the time of day that an image was captured.
1. After you have inserted an image in the Report, select **Text>Image Time** from the Object menu.
2. Left click at the point where you want the Image Time to appear.

   The number following ImgTime is associated with the image or images in your report. If the report has more than one image, the program prompts you to define the image that the time should be associated with.
3. Enter the Report Image Number.
4. Click on OK. When you run the report, the Image Time displays.

**Image User Name**
Add the name of the user who was logged in when the image was captured.

**Image Title**
Insert the file path and name that is associated with an image.
To insert the Image Title, follow these steps:
1. After you have inserted an image in the Report, select **Text>Image Title** from the Object menu.
2. Left click at the point where you want the Image Title to appear.

   The number following ImgTitle is associated with the image or images in your report. If the report has more than one image, the program prompts you to define the image that the title should be associated with.
3. Enter the Report Image Number.
4. Click on OK. When you run the report, the file and path for the image displays.

   You might have to resize the ImgTitle box to display the entire file path.
**Image Memo**

Insert the memo that you entered for a TIFF, JPEG, or SPOT database image. Follow these steps:

1. After you have inserted an image in the Report, select **Text>Image Memo** from the Object menu.
2. Left click at the point where you want the Image Memo to appear. The number following ImgMemo is associated with the image or images in your report. If the report has more than one image, the program prompts you to define the image that the memo should be associated with.
3. Enter the Report Image Number.
4. Click on OK. When you run the report, the memo displays.

**Image Sequence Index**

Insert the number of a specific image when reporting on an image sequence file.

**Image Sequence Size**

Add the total number of images in the sequence to the image.

**Image Sequence Elapsed Time**

Insert the elapsed time between two images. When you run a report that contains the Image Sequence Elapsed Time, the program prompts you to specify both the **Reference Image Index Number** and the sequence number of the image you are reporting on. The Reference Image Index number is any number within the image sequence, typically one that precedes the image being reported on. If you specify a number that comes after the image that you are reporting on, the elapsed time will be a negative value.

**Database Record ID (Windows only)**

Include the record number of a database image in your report. The Database Record ID can only be used with run-time or selected images.

To insert the database record ID for a database image, follow these steps:

1. After you have inserted a database image in the Report (either as a run-time image or a selected image), select **Text>Database Record ID** from the Object menu.
2. Left click at the point where you want the record ID to appear. The DBRecID box appears on the display grid. The number following DBRecID is associated with the image or images in your report. If the report has more than one image, the program prompts you to define the image that the database record should be associated with.
3. Enter the Report Image Number.
4. Click on OK. When you run the report, the record ID of the database image displays.

**Database Field Name (Windows only)**

The Database Field Name and Database Field Entry objects allow you to run reports that parallel some or all of the information from a SPOT database. Use the Database Field Name object to insert a text/numeric or lookup field from an open database.

1. After you have inserted a database image in the Report (either as a run-time image or a selected image), select **Text>Database Field Name** from the Object menu.
2. Left click at the point where you want the field name to appear. The program prompts you to select the field that you want in the report.
3. Select an entry from the Field drop-down list. The drop-down list options are generic i.e., Text/Numeric – 1, Text/Numeric – 2, etc.…

4. Click on OK.

5. If the report has more than one image, the Image Number dialog box prompts you to define the image that the database field name should be associated with.

6. Enter the Report Image Number.

7. Repeat steps one through six to add additional database fields to the report.

**Database Field Entry (Windows Only)**

The Database Field Name and Database Field Entry objects allow you to run reports that parallel some or all of the information from a SPOT database. Use the Database Field Entry object to insert the data from a text/numeric or lookup field.

To insert a Database Field Entry in your report, follow these steps:

1. After you have inserted a database image in the Report (either as a run-time image or a selected image), select Database Field Entry from the Object menu.

2. Left click at the point where you want the field name to appear. The program prompts you to select the field that contains the entry (data) that you want to appear in the report:

3. Select an entry from the Field drop-down list.

4. Click on OK. The box at right appears.

5. If the report has more than one image, the program prompts you to define the image that the database field entry should be associated with.

6. Enter the Report Image Number.

7. Click on OK. When you run the report, the database field entry displays.

8. Repeat steps one through seven to add additional database field entries to the report.

**User Name**

Add the user name to the report. This name defaults to the user that is logged on to the computer if SPOT Users has not been set up. (See Ch. 2 of this section for more information on SPOT Users).

**Save as Defaults**

Saves the current attributes for future report objects.

**Editing Report Objects**

Once you have created a report, you can edit the report objects as needed. There are three basic ways to edit a report object:

- **Use the Attributes menu** - The Attributes menu, as noted in the Defining Report Attributes section of this chapter, allows you to either set the attributes for adding specific types of objects, or to select existing objects and modify them as needed. Refer to the Defining Report Attributes section for more details.

- **Use the Edit menu** - The Edit menu contains general editing features such as Undo, Copy, Cut, Send to Back, etc…
Right-click (Windows)/[Ctrl] click (Mac) on the report object - Right clicking/[Ctrl] clicking on a report object brings up a customized editing menu that contains both general editing commands and the attributes that can be edited for that object. Refer to the Working in the Report Mode section for more information on the right click function.

The Edit Menu

The Edit menu provides general editing features for arranging, copying, and sizing report objects. Edit menu options are active only when a report object is selected. The following sections describe each of the Edit menu options. As is explained in the sections below, not all of the options are available at all times.

**Undo**
Undo the last action. The Undo feature allows you to undo up to ten actions.

**Bring to Front**
Bring a selected object in front of all other objects.

**Move Forward**
Bring a selected object one layer forward.

**Move Backward**
Send the selected object one layer back.

**Send to Back**
Send a selected object behind all other objects.

**Select All**
Select all of the object in the report.

**Delete**
Delete the selected object(s).

**Delete All**
Delete all of the objects in the report.

**Copy to Clipboard**
Copy the selected object(s) to the Windows clipboard. You can then paste the object(s) into:

- A new SPOT report
- A different location in the same report

This feature is particularly useful when you are creating a new report and want to use objects from an existing report.

**Cut**
Cut the selected object(s) for pasting into a new report or to a new location in the existing report.
Paste

Paste the object that you cut or copied to its new location.

Duplicate

Create additional copies of a report object. To duplicate a report object, follow these steps:

5. Select the object(s) that you want to duplicate.
6. Select Duplicate from the Edit menu. The program prompts you to enter the number of duplicate copies.
7. Enter the number of copies, and click on OK.
8. The duplicate object(s) appear at the top of report window.

Set Position, Alignment, and Size

The Set Position, Alignment, and Size option allows you to specify precise sizing and position values for single or multiple selected report and annotation objects.

The Position options enable you to:

- Align top/bottom edges of multiple objects.
- Align left/right edges of multiple objects.
- Align the centers of multiple objects.
- Center an object(s) on the page.
- Enter exact values in inches or millimeters to position the object.

The Size options enable you to enter:

- Exact width/height in inches or millimeters for one or more objects.
- Set the width/height dimension for multiple objects the to smallest or largest object’s value in inches or millimeters.

Add Page

Add a page to your report. When you add a page, the program prompts you with the Add Page dialog box:

1. Specify whether the page that you want to add will be inserted Before or After a specified page.
2. Specify the Page Number that the additional page will precede or follow.
3. Click on OK.

SPOT reports can have a maximum of ten pages.

Delete Page

Delete a page from your report. When you select the Delete Page option, the program prompts you to specify the page number.
Add Static Images

Add a static image object to the report. Refer to the Static Image object description in the Defining Report Objects section above for details on this process.

Order Run-Time Text Prompts

When you run a report with multiple run-time text prompts (see the Defining Report Objects section), the prompts, by default, appear in the order that you defined them. Use the Order Run-Time Text Prompts option to rearrange the order as needed.

To re-order the run-time text prompts for a report, follow these steps:

1. From the Edit menu, select Order Run-time Text Prompts. The current order of the run-time text prompts displays.
2. Click and drag the prompts to rearrange them in the desired order.
3. Click on OK. When you run the report, you will be prompted to enter the run-time text in the newly defined order.

Set Image Number

Change the report image number of the image.

Set Image Source

Change the source of the image.

Set Image Options

Determine the line thickness for image borders; define the justification of the image within the display box, and show/hide annotations, calibration marks, and measurements.

Set Colors

Define the foreground and background colors for all objects.

Running a Report

To run a SPOT report, follow these steps:

1. From the File menu, select Run Report. You can either run an open report or a report from file:
   - Currently Open Template
     If more than one report template is open, select from the drop-down list.
   - File
     Either enter the file name and path for the report that you want to run, or click on the Browse button to the right of the Name box to search for the report file.

Select the output format for the report.
The output options are discussed in more detail in the sections below.

2. Specify the Allow Multiple Records Horizontally and Allow Multiple Records Vertically options. When a report contains multiple Selected Image objects, SPOT separates each image with a page break: the report displays only one image per page. The Allow Multiple Records Horizontally and Allow Multiple Records Vertically options allow you to display multiple images on a page for cases such as a report on a database or a sequence image file.

To display multiple images in a row, check Allow Multiple Records Horizontally.

To display the multiple images in a column, check Allow Multiple Records Vertically.

To display the images in rows and columns, check both options.

In addition to selecting these options from the Run Report dialog, you can select them from the Preview window (see Previewing a Report below).

3. Click on Run. The prompts that you see depend on the type of report objects that you defined. Refer to the Defining Report Objects section in this chapter for more information.

Previewing a Report

When you run a report in the Preview Window, the report appears with a navigation toolbar at the bottom of the preview window, as shown here:

From left to right, the toolbar buttons are as follows:
• **Navigation arrows** - Move forward or backward in a multi-page report, or to the first page or last page in the report.

• **Page display** – See which page of the report you are viewing.

• **Allow Multiple Records Horizontally** – Display multiple selected images in a row.

• **Allow Multiple records Vertically** – Display multiple selected images in a column.

• **Zoom** – Zoom in or out on the report. There are six options.

• **Print** – Print the report without saving it.

• **Save** – Save the report as a Run Report (.rpd) file.

• **Close** – Close the report preview without printing or saving it.

• You may also navigate up or down a report page being previewed using a mouse scroller (if available with your computer).

**Printing a Report**

When you run a report with an output to Printer, the program prompts you to enter print information:

Follow these steps:

1. Select the printer.
2. Click on Properties to define the printer’s properties, if needed.
3. Specify the page range if you are not printing an entire report.
4. Specify the number of copies.
5. Click on OK.

Please note:

On Mac computers (only), it is also necessary to follow these steps before printing a report in order to ensure your specified margins print properly:

1. Choose Printer Setup from the File menu.
2. Choose Custom Paper Size from the Settings drop-down menu.
3. Select New, name the custom paper size, and set up a custom paper size with all four printer margins set to 0.
4. Select Save, and then choose OK to close out of the Page Setup dialogue.
5. Choose Printer Setup again from the File menu, and select the named custom paper size from the Paper Size drop-down menu and choose OK.

**Saving a Report to File**

When you run a report with an output to File, the program prompts you to save the file. Follow these steps:
• When saving a new report (.rpd file type), SPOT prompts you with the default file location – i.e., C:\SpotCam\Reports folder (Windows) or Users\Shared\SPOT Files\Reports (Mac). Either save to the default location or specify a new location. If you plan to save many reports without compressing the image files, you should save them to a Jaz drive or to a network drive.

| Note: Mac users will see the .rpd file type extension only if the Add Extensions to File Names on Save option is selected on the Preferences window. |

• Enter a file name for the report.

• Define the JPEG Compression for the image(s) in the report. The Use JPEG2000 Compression for Images box is checked as a default. To select any other compression format, check its corresponding box.

For JPEG2000 format,

• Lossless will give you the truest reproduction of data, but will also create the largest file size for any JPEG2000 compression scheme. Typical compression ratios range from 2:1 to 3:1.

• Lossy will compress the file to a level specified by the user through a compression ratio. The larger this ratio, the smaller the file, but also the greater chance that some digital information will be compromised. Lossy compression can achieve file compressions of up to 100 times smaller file size than lossless, yet still provide good resolution. (see examples at end of chapter)

For JPEG format,

• A value of 1 is the most compressed. File size and image resolution are decreased to the maximum extent.

• A value of 100 is non-compressed. File size remains large and the image resolution remains high.

• Click on Save. You can now use the SPOT program to open and view the report at a later time.

Instant Reports

To quickly preview and print a simple report, without first running a preview report or saving the report to file, use the new Store Image in Report Template feature. The Store Image in Report Template feature allows you to view a Static Image report object in the report template: you do not need to run a preview report to see what the final printed product will look like.

Follow these steps:


2. Add a report image that to the template. From the Object menu, select Images>Static Image. Left-click and drag the cross-hairs cursor to size and position the Static Image box. When you release the button, the Static Image window appears.

3. Select File for the Image Source. Click on the button to the right of the Name box to select an image.

4. If you have selected a sequence file, specify the Sequence Index – i.e., the number of the image in the sequence.

5. Ensure that the Store Image in Report Template box is checked.

6. Click on OK. The Static Image appears in your report, where it can be sized, positioned, or annotated as needed.

7. Add additional static images as needed. Follow steps one through seven.
8. From the File menu, select **Run Report**.
9. For the Output Destination, select **Printer**.
10. Click on **Run**.

**Distributing Reports**

If you intend to distribute SPOT image reports to people who do not have the SPOT program, we recommend that you purchase Adobe Acrobat. Using Acrobat, you can convert the SPOT report (.rpd) files to PDF files, which can be distributed to users who do not have the SPOT software. They can view the reports with the free Acrobat Reader software, which is included on the SPOT software CD. The latest version of the Acrobat Reader can also be downloaded from the Adobe’s web site www.Adobe.com.
Introduction

The SPOT Advanced application offers the same, simple interface as SPOT Basic for printing one or multiple images. Please note: some of the Printer options are dependent on your own printer, so those areas will be more general. The SPOT Basic application’s options will be explained in detail.

Example Printing Workflow:

1. To begin Printing from SPOT Basic, select Print from the File Menu or click on the Print icon on the toolbar.

   The Print Layout Editor will appear with access to your printer’s preferences and the page layout.

2. Click on Setup to access general page layout options such as margins, units of measure, and paper orientation and size.
3. Arrange single or multiple images in the Print Layout Editor. This section will be explained in detail in the following sections.

4. Click the Print button to access your printer’s print settings. Click on the Printer’s Print dialog Print button to finish printing your images.

Print Layout Editor – Printing Single or Multiple Image Files

The SPOT Basic application offers the Print Layout Editor shown here for customizing the way your images will print.

To print images from the SPOT software, follow these steps, either select Print from the File menu, or click on the Print toolbar button.

The Print Layout Editor appears with a preview of the active image and the print canvas. The following sections are available for scripting the print canvas.

Layout

Under the layout section, the Printable Area is displayed and the following buttons are available:
Setup
The Setup button allows access to general page layout options such as margins, units of measure, and paper orientation and size as shown above.

Add
In the Print Layout Editor, you can print multiple images on one print canvas. Use the Add button to add more images to the canvas. There are two ways you can select images to add:

Currently Open Image
Add one or all of the currently open images. Select either the desired image or <All Images> from the Title drop-down list. Ensure that you enter the Sequence Index (i.e., the number of the image in the sequence) if you are adding an image from a sequence file.

File
Add a file from disk. Check the Image File option, and click on the square next to the box. Browse for the desired image, and click on Select. Ensure that you enter the Sequence Index (i.e., the number of the image in the sequence) if you are adding an image from a sequence file.

Auto-Arrange Images
If you check the Auto-Arrange Images box, the SPOT program automatically sizes and positions the images to fit on the print page, so you can add multiple images without having to resize them. For example, if you add five images, the preview will show six images (the original and five added) of equal size, distributed proportionally across the page.

If you did not use the Auto-Arrange Images option, the images will be stacked on top of each other for you to arrange. See below for arrangement options.

Click on the OK button to add the images to the print page and return to the Print window. The images appear in the preview box.

Remove
The Remove button allows you to remove an image from the printing canvas. When you click on it, the topmost image (highlighted in green) will be removed from the printing canvas.

Arrange
The arrange button allows you to set the arrangement of multiple images on a print canvas. When you click on the Arrange button, the Arrange Images dialog appears.

The Arrangement section allows you to select the number of row(s) and column(s) you would like for your print document.

The Spacing section allows you to enter a value for the spacing between the images on the printout in inches or millimeters.

Select Apply to all Pages to make the arrangement applicable to every page. This feature is only available when printing an image sequence which falls on more than one page of the print document. See below for more information on printing image sequences.
Top Image
The Top Image section has controls which dictate the placement and appearance of the topmost image. The topmost image is outlined in green. This can be very useful when printing multiple images on the same print canvas.

Image Position and Size Controls

Left
The value in the Left entry sets the distance between the left side of the printable area and the left side of the image. Use the up and down arrows or you can type in a value.

Top
The value in the Top entry sets the distance between the top of the printable area and the top of the image. Use the up and down arrows or you can type in a value.

Alternatively instead of typing in the values for image position, you can position the cursor on the image. The cursor will appear as a four pointed arrow and you can then left-click and drag the image to the desired location.

Width
The width of the image can be adjusted by changing the value in the Width entry. Use the up and down arrows or you can type in a value.

Height
The height of the image can be adjusted by changing the value in the Height entry. Use the up and down arrows or you can type in a value.

Alternatively to typing in values for the image size, you can position your cursor on a side or a corner of the image. The cursor turns into a two-ended arrow. Use the two-ended arrow cursor to drag a side or corner to enlarge or reduce the image. The resized image maintains the height to width ratio of the original image.

\[\text{Note: The aspect ratio of the image will be maintained whether you adjust the Width or the Height of the image.}\]

\[\text{Note: If you select values that are outside the printable range of the paper, the values will be displayed in red font.}\]

Image Appearance Controls

Show Annotations, Calibration Marks, Measurements and Reticles
In SPOT, any annotations, calibration marks, measurements and/or reticles are saved in separate layers which can be turned on and off for viewing and here, for printing. This option will be available unless the annotations, calibration marks, measurements and/or reticles have been
merged into the image. Each layer can be turned on or off for printing individually. Check the appropriate box to have the layer print, or uncheck the appropriate box to not print the layer. If you do not have an annotation, calibration mark, measurement or reticle on the image, these check boxes will all be inactive.

### Print Layout Editor – Printing Sequential Image Files

Printing images from a sequential image file is very similar to printing individual or multiple image files. See the above section for shared features.

When you select the **Print** option for a sequential image file, the program prompts you to specify the image(s) in the sequence that you want to print. There are two options:

- **All Images in Sequence**
  Use this option to add all images from the sequential image file to the printing document.

- **Specified Images**
  Use the option for Specified Images to select either a single image or multiple images from the sequential image file. Separate multiple images with commas and/or dashes – e.g., 1, 2, 3; 1-3; or 1, 2, 3-6.

  - After your selection is complete, click the Ok button and program will prompt you to specify how many images to print on each page. Make your selection and click OK to return to the Print Layout Editor to arrange the images if necessary.

  - When back in the Print Layout Editor, if multiple pages have been created, use the pull down menu to move between pages of the print document.

  - Click on Print when you are ready to print your document.

### Print Controls

**Close Window After Printing**

If you would like the Print Dialog Editor to remain open for other printing jobs within SPOT, uncheck the box to **Close Window After Printing**.
Print
Click on the Print button and your printer’s normal Print Dialog should appear with additional settings for printing, such as print quality and Color options.
Click on the appropriate buttons (Ok and/or Print) to send the information to the printer.

Close
Click the Close button to close the Print Layout Editor. This will be necessary when you are done printing images and you have not selected the Close Window After Printing option (above).

Help
Click on the Help button to open the Help files relating to Printing.
SECTION IV – Integrating a SPOT Camera into Another Application

Ch. 1 – Introduction

While many people use the SPOT Software to control their SPOT Cameras, it is possible to use a SPOT Camera from within a different application. We collectively refer to these other applications as 3rd party host applications. By integrating the camera it is possible to acquire images directly into the 3rd party host application.

Applications such as Photoshop or other image-based applications will often support this kind of functionality. This sort of usage comes in handy when you have an image program which you like to use to adjust images, or perform other modifications to them.

On a PC, these 3rd party host applications must be TWAIN compliant and on a Mac the program has to be able to open images.

Please refer to the appropriate chapter(s) below for details on how to set up the communication between a typical 3rd party host application and your SPOT Camera.

In addition to the simple integration described above and in the subsequent chapters in this section. Some imaging applications have specialized communication bridges to integrate SPOT Cameras. We refer to these specialized communication bridges as 3rd party drivers. Some of these 3rd party drivers are available as legacy versions at no cost and others require the purchase of the 3rd party driver. Please see our website for a complete list of 3rd party drivers and applications which support SPOT Cameras.

www.spotimaging.com/software/thirdpartysoftware.html
INTRODUCTION

The SPOT software provides a TWAIN compliant interface for controlling SPOT cameras. This allows TWAIN compliant applications (e.g. IrfanView, ImagePro…) to directly control SPOT cameras within their application environment. The SPOT TWAIN Interface supplies the camera settings, operation controls, live image window, captured preview window and the transfer function that provides the image to the host application. The SPOT TWAIN Interface opens up the power of SPOT Cameras to the world of TWAIN compliant host applications.

ESTABLISHING THE SPOT TWAIN INTERFACE

There are two basic steps necessary to set up the SPOT Standard TWAIN interface.

1. Selection of the TWAIN Source.
2. Initiating the TWAIN interface connection to acquire the image.

Here is the standard setup process:

1. Go to the File Menu and select Import and choose SPOT Standard.

Other programs, such as IrfanView utilize a two step process. IrfanView’s two step process looks similar to the steps outlined below:

Note: Adobe Photoshop is no longer supporting the TWAIN Interface. As of the Photoshop CS5 version, TWAIN support is not included as part of the standard installation. However, TWAIN support in Photoshop CS5 is available as a free plug-in as a separate download from the Adobe website.
1. From the File menu, choose Select TWAIN source and then choose SPOT Standard from the list in the Select Source dialog box and click on Select.

![Select Source dialog](image)

2. From the File menu, choose Acquire/Batch Scanning. Follow the host application’s instructions for making any selections necessary and click on OK.

![Acquire/Batch Scanning dialog](image)

**Note:** Advanced imaging software applications often support TWAIN control of cameras in their macro/journal language. In these cases use of the non-user interface TWAIN mode can be utilized to provide completely automated control of the camera. In this case SPOT Standard TWAIN Profile settings are made prior to running the macro/journal by manually selecting the “Acquire...” selection from the file menu and interacting with the SPOT Standard TWAIN Interface dialog.
THE SPOT STANDARD TWAIN INTERFACE

Once the connection has been established with the SPOT Camera, the SPOT Standard TWAIN Interface will appear and look similar to that pictured here:

Create a Profile
Profiles allow you to create, modify, and reuse specific exposure settings that are tailored to your image capture needs.

View Controls
Controls allow you to specify the window zoom level, enable the Pan Window, and toggle the Magnifier.

Focus Gauge
The Focus Gauge provides additional visual indication of focus.

Define Image Settings
Define exposure settings for images.

Capture an Image
All of the image capture options are located on the bottom portion of the window, as illustrated here.

Status Bar
The Status Bar indicates current imaging area, live mode status and frame rate, and image profile saving mode.

Preview Your Specimen
Use the live image as a point of reference to focus and position the image and to scan for areas of interest.

Help, Pref's and Device
Access the Help menus, set seldom changed preferences and select a camera if multiple cameras are installed.
TYPICAL IMAGE ACQUISITION PROCESS

Image capture using the SPOT Standard TWAIN interface will generally include the following steps:

1. Establish the TWAIN connection with the SPOT Camera.
2. Select or create an Imaging Profile.
3. Preview the Live image.
4. Adjust the focus and frame the specimen.
5. Adjust the image appearance using the Image Settings’ tabbed controls.
6. Acquire and transfer an image, or multiple images, back to the host application.
7. Close the SPOT Standard TWAIN interface.

The following sections will explain in detail the functionality of each of the controls and displays encountered in the SPOT Standard interface.

IMAGE SETTINGS

Profile

The Profile feature allows you to name a particular configuration of image settings and recall it when you encounter that imaging situation again. When you open the TWAIN interface, the Default Profile is selected. When you make changes to any of the image settings, these changes can be saved to a Profile – either the Default or one that you create and name.

To add, edit, or delete Profiles, select the appropriate button or right-click on the Profile box. Either affords you the following options:

- **Add** – Add a new Profile. When you add a new Profile, the program prompts you to name it.
- **Save** – Save a Profile that you have modified.
- **Rename** – Rename an existing Profile.
- **Delete** – Delete a Profile. This option appears only if there is more than one Profile.

The Image Settings dialog box is divided into 4 tabs:

- **Appearance** – Adjustments for gamma, colors, and some post-processing features
- **Exposure** – Settings for image brightness
- **Area** – Options to set an imaging region of interest and image rotation
- **Focus** – Settings for the focus gauge
Appearance Tab

Use Defaults

The Use Defaults button will reset the values for Gamma, Contrast, Saturation and Color Temperature to their original default positions of 1 for Gamma, 0 for Contrast and Saturation and 5000K for the Color Temperature. This button may be useful if multiple adjustments have been made to these settings and you would like to start over with a fresh, un-adjusted image. Each of the features is discussed in further detail below.

Correct Color Technology™ (Color Cameras Only)

The Correct Color Technology option utilizes camera dependent color correction profiles that optimize the matching of colors between your microscope specimen, the live image you view on the screen of your monitor, and the image you capture with your SPOT camera. This is done by transforming the raw camera color data allowing it to be adjusted to display the closest approximation of the same color on your monitor.

In order to get the best results using this feature, you should make sure you set up your imaging system including your computer monitor appropriately. See Appendix C: Correct Color Technology for more information on system set-up.

Note: Color correction transformations that occur when you use Correct Color Technology will be applied to the raw image data, leaving a modified image file. If you will require the raw data for further analysis of your image, you should uncheck the Correct Color Technology checkbox.

Note: If your camera is a three-shot or slider version, Correct Color Technology will only be available in the Image Settings window if RGB is set as the filter color.

Gamma

Gamma adjustments are nonlinear operations which smoothly lighten darker areas of an image without burning out bright areas or lightening black areas. This is especially useful for capturing/editing images with a wide range of brightness values (dynamic range) such as fluorescence specimens or macroscopic objects with glints, (e.g., printed circuitry).
When the bright areas of these types of images are correctly exposed, the darker areas can be so dark that they are in effect invisible. Gamma Adjust can remedy this problem. The figures below illustrate the effect of a gamma adjust on a fluorescent image. The image on the left is the original image prior to the gamma adjustment. The image on the right has been gamma adjusted to a value of 1.75. In this instance, the gamma adjustment results in a better display of detail by lightening the darker areas without burning out bright areas or lightening black areas:

Fluorescence image, no gamma adjustment

Fluorescence image, gamma adjusted to 1.75

In the SPOT Software:

- Values between 1 and 4 lighten the darker areas of the image.
- Values between .1 and 1 darken the brighter areas of the image.

**Contrast (only available when Correct Colors is enabled)**

Contrast is the degree of difference between the brightest and darkest parts of an image. If you would like to exaggerate the differences between bright and dark areas in an image, adjust the Contrast slider to the right to a level which looks suitable to you.

**Saturation (only available when Correct Colors is enabled)**

Saturation refers to the dominance of hue in a color. Colors which are not fully saturated will be more grey, or pastel, and colors which are fully saturated will be richer in color (hue). Move the Saturation slider to the right if you want to increase the richness, or to the left to decrease the richness of the colors in the image.

**Color Temperature (only available when Correct Colors is enabled)**

The Color Temperature slider (in Kelvin) is available for users to match the display of their images with their source illumination's color temperature. Below is a list of some general color temperatures for typical light sources. Keep in mind these are averages or ranges and your individual bulb may differ. For the best accuracy, check the specification on your light bulb for the color temperature in degrees Kelvin.

For example, if you are using a Halogen bulb without a daylight blue filter in the light path, adjust the slider for **Color Temperature** to 3200K to best match how the software will display your
image with what you see at the eyepieces. See the table below for a list of commonly available light sources and their range of typical color temperatures.

<table>
<thead>
<tr>
<th>Type of Bulb</th>
<th>Typical Color Temperature (K)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Incandescent</td>
<td>2800 – 3400, varies with voltage setting on microscope</td>
</tr>
<tr>
<td>Halogen</td>
<td>3200</td>
</tr>
<tr>
<td>Direct Sunlight</td>
<td>5000</td>
</tr>
<tr>
<td>Mercury</td>
<td>5000 - 6000</td>
</tr>
<tr>
<td>Zenon</td>
<td>6000 - 6200</td>
</tr>
</tbody>
</table>

**White Balance (Color cameras only)**

White balance is the ratio of red, green, and blue exposure times (3-shot cameras) or gains (color mosaic cameras) necessary to achieve the proper color rendition for an image. Many factors impact the coloration of an image capture, including lamp voltage, the coloration of the glass used in the slide, and the coloration of the glass used in the lenses of the microscope’s objectives. To minimize the impact of these factors, use the White Balance feature. When you perform a white balance calculation, SPOT samples the color of the white light provided by your light source after it has passed through the slide and the objective, and then calculates the red, green, and blue exposure times (3-shot cameras) or gains (color mosaic cameras) needed to produce images where the white areas are white and the color areas are true.

You should perform a new white balance calculation when:

- Starting a new image capture session.
- Changing the lamp voltage.

To perform a white balance, follow these steps:

1. Set the illumination and the objective that you will use for the image capture.

2. Select the appropriate **Image Profile**. Each Image Profile has its own set of white balance values. Any white balance values that you compute for an image type remain linked to that image type until you compute new values. When selecting a new image profile, remember that you will be using the white balance values linked to that image profile.

3. Show the camera a sample of white light. This step varies according to microscopy technique and Image Type (sample), as shown in the table below.

4. Click on the **White Balance** button. By default, a **Compute White Balance** dialog will appear with instructions on how to properly perform a white balance. If the preference to show helpful Messages has been turned off, this step will be skipped.
Note: If you are comfortable with performing White Balances, you can check the box for Do not show this message again. If you desire, you can always turn this message back on in the Preferences (see below).

<table>
<thead>
<tr>
<th>Image Type</th>
<th>White Balance Technique</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brightfield-transmitted light</td>
<td>Position the slide so that the specimen is not in the field of view, but light is going through the slide near the specimen.</td>
</tr>
<tr>
<td>Darkfield-transmitted light</td>
<td>Perform the white balance using the brightfield mode on your microscope. See Brightfield – transmitted light above.</td>
</tr>
<tr>
<td>Fluorescence</td>
<td>Use the Match Color feature (see below)</td>
</tr>
</tbody>
</table>
| Nomarski DIC/Hoffman          | **For Nomarski DIC:** Adjust the Nomarski prism until the image is in either the “brightfield” or the “gray scale” view.  
                                | **For Hoffman:** Perform the white balance directly on the Hoffman image.                                                                                   |
| Phase contrast                | Position the slide so that the specimen is not in the field of view, but light is going through the slide near the specimen.                          |
| Polarized light               | Place all polarizers and compensators into the light path and then position the slide so that the specimen is not in the field of view, but light is going through the slide near the specimen. |
| Brightfield-reflected light   | Replace your sample with a mirror.                                                                                                                                 |
| Darkfield-reflected light     | Perform the white balance using the brightfield mode on your microscope. See Brightfield – reflected light above.                                         |
| Stereo/Macro (all three options) | Using an EPI-illuminator (shining a light on the top of your specimen from off to one side), replace your sample with a white sheet of paper.             |

5. Click on **Begin** to start the calculation. The camera computes the white balance values, and they are automatically saved to the image settings for the image profile that you selected.

**Match Color**

The Match Color feature is typically used in two situations:

- You want to set the white balance for pictures taken with a microscopic technique that never has white in its images. A prime example of this situation is fluorescence microscopy. (To White Balance an Image)
- You want to change the colors of an image on the screen to match the way that you think the specimen looks. (To Match a Color)

If you use the Match Color option on a captured, previewed, or Live image, you can follow these steps to adjust the white balance.

1. Click on the Match Color button.
2. The mouse cursor will change to an eye dropper. Use the cursor to select (click) the color which needs to be adjusted to white.
Note: The R, G, and B values of the pixel that you select must all be less than full scale, i.e. 255 for 8 bit images, 1023 for 10 bit images, 4095 for 12 bit images and 16383 for 14 bit images.

3. The Match Color dialog appears with information about the pixel that you selected:

- **Hue** – The actual color, as distinguished from others in the color spectrum. Hue is derived from a color wheel and is expressed in the color’s angular location (i.e., 0 to 360 degrees).

- **Saturation** – The richness of perceived pure hue in the color. Saturation (in the SPOT Software) is measured on a numerical scale of 0 to 100, where zero equals pure grey and 100 equals pure hue (i.e., ‘day glow’).

4. Click the Make White/Grey button to rebalance the red, green, and blue ratio to make the selected pixel ‘white’.

5. To use these new values for the white balance values, click the Set White Balance button and click OK.

If you use Match Color on a captured or previewed image, you can also adjust a color which is not being displayed as you see it with your eyes.

Note: If you use the following options on a Live Image, the change you make will only be reflected in the current image frame. While you use the Match Color feature, the Live Image is paused and the below changes will only be reflected in the displayed paused image frame. As soon as you click the OK button on the Match Color dialog box, the Live Image will resume and any modifications you made will revert back to the original colors. To retain the settings, click the Set White Balance button.

To use the Match Color feature for this purpose, follow these steps:

1. Click on the Match Color button.

2. The mouse cursor will change to an eye dropper. Use the cursor to select (click) the color which needs to be adjusted to a different color.

Note: The R, G, and B values of the pixel that you select must all be less than full scale, i.e. 255 for 8 bit images, 1023 for 10 bit images, 4095 for 12 bit images and 16383 for 14 bit images.

3. The Match Color dialog box appears with information about the color you selected as outlined above (Hue and Saturation).
4. The color you selected can be adjusted by a few different methods, aside from the Set White Balance option described above:

- The Hue and Saturation inputs which are best used for minor adjustments or to set fluorescent colors to saturation.
- The Select Color option is available for assigning a color correction to the image. This is accomplished by moving the crosshairs on the color wheel to the desired location by clicking on the new location or clicking and dragging.

For any of these adjustments, you can click the “Modify Main Image” check box to see your changes on the source image as you make them.

5. Click on OK to accept the adjusted image.

**Noise Filter**

The Noise Filter corrects for the effects of electrical or thermal noise. When capturing dim images with lengthy exposure times, the noise filter acts as a “virtual cooler” for non-cooled camera models, eliminating “hot pixels.”

The Noise Filter checks each pixel on the CCD chip as described below:

1. The program compares the value of each pixel with the values of eight neighboring pixels of the same color.
2. If none of the eight neighboring pixels has a value within the threshold value set (±15 %) for the pixel being checked, the value for the pixel being checked is replaced with the average of the eight neighboring pixels.

> **Note:** On color mosaic cameras, this procedure is performed on each, the red, green and blue sets of pixels.

To activate the Noise Filter, check the Noise Filter box. The program runs the noise filter each time an image is captured.

**Flatfield**

The Flatfield option is used to correct for display problems associated with uneven intensity or coloration in illumination, or to correct for artifacts (e.g., dust) in the optical system.

> **Note:** Flatfield correction with the SPOT camera refers only to the correction of uneven lighting. It should not be confused with the correction of optical field flatness.

To use Flatfield Correct, follow these steps:

1. Ensure that the specimen is under the desired objective and in focus.
2. From the Image Settings menu, select Add under the Flatfield dropdown menu. The Acquire Flatfield dialog box appears.
3. Choose a number of frames to average. Larger numbers of frames will increase the accuracy of the flatfield correction, but will also increase the length of time it takes to create the flatfield image. The default number of frames to average is 3.
4. Select a name for the flatfield image file. Because flatfield image files are different for each objective, you might want to name the file according to the objective’s magnification (e.g., 10x).

5. Remove the slide from the field of view.

6. Click on Begin. The program will acquire the number of frames that you specified.

7. When the program finishes acquiring the frames, it will prompt you to block all of the light to the camera. This can be accomplished by installing the dust cap that was supplied with the camera or by adjusting the microscope’s optical path. After the light is blocked, click on OK. The program computes another frame.

8. The name of the flatfield file that you defined in step four should appear in the drop-down list of flatfield files.

9. Additional flatfield files can be created and used in different Image Profiles. This may be useful when using different objectives where different flatfield files would be necessary. Each Image Profile could be for a different objective with a different flatfield file. Use the pull down list to make the appropriate flatfield file selection and save it to an Image Profile.

Perform the image capture. SPOT automatically uses the flatfield image to correct the capture.

**Exposure Tab**

**Exposure: Auto or Manual**

The Exposure option gives you the choice of having the camera calculate exposure time (Auto), or setting the exposure on your own (Manual). When you enter one of the above exposure settings, note that it applies both to the live image that you are viewing and the captured image. The exposure options will vary according to whether you select Auto or Manual, as illustrated later in this section. First the common features will be described.
Features Common to Auto and Manual Exposures

**Binning**

Binning combines adjacent pixels on the CCD chip, thereby reducing the number of pixels used in the image capture. Binning is useful when you have dim images and want to increase sensitivity and reduce download time. This gives you higher frame rates and less noisy images. But, as binning level increases, image resolution decreases. All of these factors should be considered when you select a binning option.

There are different binning options, depending on the camera model. Here are some of the possible choices:

- **None** 1 pixel = 1 pixel
- **2 x 2** 4 pixels = 1 pixel
- **3 x 3** 9 pixels = 1 pixel
- **4 x 4** 16 pixels = 1 pixel
- **8 x 8** 64 pixels = 1 pixel

*Note: If your camera is a color mosaic version, binning will collapse the color data, resulting in a monochrome image.*

**Filter Color (3-Shot Color and Slider models only)**

The Filter Color option specifies the color or colors that will be exposed in the live image preview/image capture.

- **RGB** – Preview/capture a full color version of your specimen using each state (red, green and blue) of the LCD filter.
- **Red** – Preview/capture a monochrome version of your specimen using the red state of the LCD filter.
- **Green** – Preview/capture a monochrome version of your specimen using the green state of the LCD filter.
- **Blue** - Preview/capture a monochrome version of your specimen using the blue state of the LCD filter.
- **Clear (not available on all LCD Filters)** – Preview/capture a monochrome version of your specimen using the clear state of the LCD filter.
- **None (Slider models only)** – Preview capture a completely unfiltered image. When using the Live Image window to focus or position dim images, users can slide the filter out to provide higher frame rates and less noisy images.

**Display Images in Grayscale (3-Shot Color and Slider models only)**

Grayscale imaging provides a “Black and White” version of your colored monochrome image. This feature provides a higher contrast, more easily visualized version of colored fluorescence images. The reason the human eye can visualize grayscale images better than monochrome color images is related to the fact that white light stimulates all three color receptors in the eye, providing higher perceived brightness and resolution. Use the **Display Images in Grayscale** to use this feature.
Features Specific to Auto Exposures

Image Type
An Image Type tells the SPOT program how to expose image captures. Each of the 11 available Image Types corresponds to a microscopy technique: select the Image Type that matches the technique you are using. The camera will compute exposures and capture the image accordingly. The table below describes typical situations for each image type.

<table>
<thead>
<tr>
<th>Image Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brightfield-reflected light</td>
<td>Polished metallurgical specimens and semi-conductors using a microscope with a vertical illuminator.</td>
</tr>
<tr>
<td>Brightfield-transmitted light</td>
<td>Stained specimens on glass slides using transmitted light microscopes.</td>
</tr>
<tr>
<td>Darkfield-reflected light</td>
<td>Bright areas of specimens being viewed with darkfield, reflected light techniques.</td>
</tr>
<tr>
<td>Darkfield-transmitted light</td>
<td>Bright specimens on dark backgrounds using transmitted light darkfield technique.</td>
</tr>
<tr>
<td>Fluorescence</td>
<td>Fluorescence specimens fluorescing in a single red, green, or blue primary color</td>
</tr>
<tr>
<td>Nomarski DIC/Hoffman</td>
<td>Specimens being viewed with either Nomarski DIC or Hoffman techniques.</td>
</tr>
<tr>
<td>Phase contrast</td>
<td>Specimens being viewed using the phase contrast technique.</td>
</tr>
<tr>
<td>Polarized light</td>
<td>Specimens being viewed with polarized light techniques.</td>
</tr>
<tr>
<td>Stereo/macro-metallic glints</td>
<td>Metallic specimens with intense glints.</td>
</tr>
<tr>
<td>Stereo/macro–no glints</td>
<td>Matte specimens without bright glints.</td>
</tr>
<tr>
<td>Stereo/macro–shiny glints</td>
<td>Shiny or wet specimens with bright glints.</td>
</tr>
</tbody>
</table>

Brightness
The Brightness control allows you to overexpose or underexpose (darken or lighten) the image area. A brightness value of 1, the default value, gives you the correct image brightness for most images. In many cases, an image has varying levels of brightness; to see a specific area better you might want to lighten or darken the image. When using the Brightness control, the SPOT camera uses an algorithm that combines gain and exposure time to provide the fastest possible frame rate in live mode:

- When overexposing images to make them brighter (i.e., entering values between 1.01 and 34), the camera first selects the highest possible gain before lengthening the exposure time. Because gain also brightens an image, less exposure time is needed.
- When underexposing images to make them darker (i.e., entering values between 0.24 and 0.99) the camera uses the lowest possible exposure time before lowering the gain.

Gain Limit
Normally an auto exposure routine in a digital camera sets the exposure time so that the brightest pixel on the CCD chip is completely “filled” with electrons, or is “full well”. This simple technique works well for bright images, but as an image gets dimmer, exposure times can get uncomfortably long. With the SPOT camera, you can shorten exposure times by filling the brightest pixel on the CCD to less than full well, and then using this lower level as full scale. The inverse fraction of full well that the brightest pixel on the CCD is filled to is known as the gain. For example, filling a pixel to half of full well cuts the exposure time in half. Since the exposure time is cut in half, we call this a gain of 2.
The Gain Limit feature allows you to set an upper limit on the gain options that will be available during the Auto-Exposure process.

For example, with a Gain Limit of 32 the camera can “choose” from a range of gain options. However, if you find that gains of 16 or 32 are too noisy for your images, you can prevent the camera from selecting these options by setting the Gain Limit to 8. When the Gain Limit option is set to 8, the camera is limited to the lower four gain options: 1, 2, 4, or 8. The following table illustrates levels of gain, the fraction of full well that the brightest pixel is filled to for each level, and a sample exposure time for each level:

<table>
<thead>
<tr>
<th>Gain</th>
<th>Fraction of Full Well</th>
<th>Exposure Time (sample)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>80 seconds</td>
</tr>
<tr>
<td>2</td>
<td>1/2</td>
<td>40 seconds</td>
</tr>
<tr>
<td>4</td>
<td>1/4</td>
<td>20 seconds</td>
</tr>
<tr>
<td>8</td>
<td>1/8</td>
<td>10 seconds</td>
</tr>
<tr>
<td>16</td>
<td>1/16</td>
<td>5 seconds</td>
</tr>
<tr>
<td>32</td>
<td>1/32</td>
<td>3 seconds</td>
</tr>
<tr>
<td>64</td>
<td>1/64</td>
<td>1 second</td>
</tr>
</tbody>
</table>

The table below summarizes the relationship between exposure time, background noise, and gain.

<table>
<thead>
<tr>
<th>Gain Limit</th>
<th>Possible Auto – Gain Settings</th>
<th>Exposure Time (dim images)</th>
<th>Background Noise (dim images)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>Longest</td>
<td>Lowest</td>
</tr>
<tr>
<td>2</td>
<td>1, 2</td>
<td>↑</td>
<td>↓</td>
</tr>
<tr>
<td>4</td>
<td>1, 2, 4</td>
<td>↑</td>
<td>↓</td>
</tr>
<tr>
<td>8</td>
<td>1, 2, 4, 8</td>
<td>↑</td>
<td>↓</td>
</tr>
<tr>
<td>16</td>
<td>1, 2, 4, 8, 16</td>
<td>↑</td>
<td>↓</td>
</tr>
<tr>
<td>32</td>
<td>1, 2, 4, 8, 16, 32</td>
<td>↑</td>
<td>↓</td>
</tr>
<tr>
<td>64</td>
<td>1, 2, 4, 8, 16, 32, 64</td>
<td>Shortest</td>
<td>Highest</td>
</tr>
</tbody>
</table>

To set the Gain Limit, follow these steps:

1. Ensure that the camera is set to use the Auto-Exposure option.
2. Click on the Gain Limit select list, and select the number that you want to limit the gain to.

For more information on the concept of gain, refer to Appendix A: Electronic Imaging Theory and the SPOT Camera.
Live Image Auto-Brightness

Live Image Auto-Brightness is a feature that will recalculate brightness levels automatically. This feature is useful when you are changing objectives or changing between brighter and darker samples because the software will automatically recalculate the proper exposure based upon the brightness level as opposed to you clicking on the Live or Recompute Exposure (see below) buttons. Live Image Auto-Brightness is only available when you are using Auto exposure and viewing a live image.

Spot Metering Area

Similar to the way photographers spot meter their cameras on a particular location within their subject image plane, the SPOT user can do the same within the microscope’s imaging plane. The spot metering feature allows the user to best select an area of the image to be used as the region of interest for the automatic exposure level determined by the software.

This can be useful when the default auto-exposure settings (full image sampling) do not provide a captured image that provides the detail you need for a particular region of your subject being viewed.

On the Exposure Tab, there are two options:

- **Same as Imaging Area**
  
  This selection will meter the exposure based on the entire imaging area.

  OR

- **Set Area**
  
  This selection will meter the exposure off of the area in the selected subregion

  To set the Spot Metering Area:

  o  Click on the *Set Area* button under Spot Metering Area.

  o  Select the area of the Live, Paused, or Preview image by clicking and dragging the mouse across the desired area on the image.

Exposure Limits – Live Image Maximum

The Maximum Exposure setting allows you to set the maximum exposure time that is allowed while using the Auto Exposure feature. Computed auto exposures that would require an exposure time that exceeds this limit will result in an *Image Too Dim* error message. This allows you to configure what exposure time is considered out of range for the type of imaging you are performing.

Without this setting the software could try to calculate a multi-hour exposure due to the common user error of not having the microscopes light path selector to send light to the camera. Typically the value is set to between 1-2 seconds for brightfield and bright fluorescence images. Longer exposures may benefit from manual exposure setting or test bracketing of sample specimens.

The range of valid values is dependent upon the type of camera you are using.

Recompute Exposure

Recompute Exposure is a way of forcing the camera and software to recalculate the appropriate exposure time. This feature is useful when not using the Live Image Auto-Brightness feature and you would prefer to control when the camera recalculates its exposure. If you would like the
software to automatically adjust the exposure, you can use the Live Image Auto-Brightness feature, see above for details.

Features Specific to Manual Exposures

Exposure Time(s)
Photographically speaking, an exposure is the total amount of time that light is allowed to hit the imaging sensor before it is read out by the camera. The exposure of the image can be manipulated by adjusting the Exposure Time to suit your needs. Use the slider-bar to specify an exposure time and adjust as needed.

Gain
When you define your own Exposure, you can enter the precise gain that the camera will use for an image capture. You can manually enter the gain value by using the slider bar to make your selection. The gain value displays to the right of the slider-bar.

To read more about Gain and what it is used for, please refer to the previous section about Gain Limit.

Auto-Adjust Exposure
This feature is designed to auto-adjust the exposure with changes to the binning level.

Select this checkbox and the SPOT program will adjust the exposure each time the binning level is changed in order to match the original brightness level of the displayed image.

The Exposure Time will decrease with greater binning levels and increase with lower binning levels.

Area Tab

Chip Imaging Area
SPOT allows you to use any rectangular portion of the CCD chip for image capture.

Using a portion of the chip is helpful in cases where you want to:
- Increase the live preview or captured frame rates
- Keep file sizes small.
- Shorten download times.
- Avoid areas of the image with optical problems (e.g., vignette areas).

There are three image area options:
- **Full Chip** – Capture the entire area of the CCD chip.
- **Center** – Capture a rectangular part of the CCD chip’s area that has the same height - to-width ratio as the full chip, and is centered on the center of the full chip. The percentage that you enter is the percentage of full chip width that the new area’s width will be.

- **Selection** – Capture a specific part of the CCD chip. To set, click on the Set Area button. Click and drag a rectangular region on the Live, Paused, or Preview Image.

**Display Full Chip Area in Live Image** - Ensures that you will always see the Full Chip view when viewing a live image. Keep in mind that the selection that you make here determines how the live image displays when viewing a region of the chip. Refer to the Chip Imaging Area section for details.

**Rotate**

To match what you see through the eyepieces to what you see on your computer monitor, rotating the displayed image may be necessary. This may be required in situations where the optics provide a mirrored image or the camera is required to be rotated relative to the eyepiece image. Specify whether images will be rotated during the image capture/live image viewing process.

- Select **None** if you do not want the image to be rotated.
- Select **Left 90°** to rotate the image counterclockwise 90 degrees.
- Select **Right 90°** to rotate the image clockwise 90 degrees.

**Flip**

To match what you see through the eyepieces to what you see on your computer monitor, flipping the displayed image may be necessary. This may be required in situations where the optics provide a mirrored image or the camera is required to be rotated relative to the eyepiece image. Specify whether images will be flipped during the image capture/live image viewing process.

- Select **Horizontal** to flip the image from left to right.
- Select **Vertical** to flip the image from top to bottom.
- Select both options to flip the image from left to right and from top to bottom.

**Resolution**

The Resolution option specifies various resolution mode settings for the SPOT cameras. These settings increase or decrease the resolution for any region of interest. The trade off in each instance is between frame rate download time and resolution.

**Flex**

The Flex camera has the ability to shift its CCD sensor and increase the captured image resolution. Moving the CCD sensor provides the user with several different resolution options.

<table>
<thead>
<tr>
<th>Resolution</th>
<th>Application</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal 4Mp</td>
<td>The Normal setting takes a picture without shifting the CCD sensor. Each pixel on the CCD measures one color; red, green or blue, and the other two colors are interpolated based on neighboring pixels. The Normal setting is suggested for situations where a fast image capture is needed, such as when the specimen is moving or when a fluorescent dye is quenching rapidly. This mode of image capture provides images of a quality similar to other color mosaic SPOT cameras and a large area of image capture.</td>
</tr>
<tr>
<td>Interpolated Color</td>
<td></td>
</tr>
<tr>
<td>FX1520/1521 Color Mosaic 4-Shot 4Mp Co-Site</td>
<td>The 4-shot setting takes four consecutive images as the piezoelectric carriage moves the whole sensor in one-pixel increments in a 2x2 matrix so that each pixel location in the image will have each of the sensor’s colors shifted through it. This mode provides full color sampling.</td>
</tr>
</tbody>
</table>
Sampled Color

similar to that achieved with SPOT 3-shot cameras. Shifting the CCD increases the time needed to capture the image. The 4-shot setting is suggested for non-moving, non-quenching specimens and when very accurate color and full sensor resolution is to be maintained.

16-Shot

16Mp Co-Site Sampled Color

The 16-shot setting moves the sensor 16 half pixel moves in a 4x4 matrix providing full color sampling at twice the CCD resolution. This increases the time needed to capture the image. The 16-shot setting is suggested for non-moving, non-quenching specimens and when very accurate color and high resolution is required. This mode of image capture extends the sensor resolution via subpixel sampling and provides images of unparalleled quality (resolution and color) compared to other color cameras available.

Normal

4Mp Monochrome

The Normal setting takes a picture without shifting the CCD sensor. The Normal setting is suggested for situations where a fast image capture is needed, such as when the specimen is moving or when a fluorescent dye is quenching rapidly. This mode of image capture provides images of a quality similar to other 4Mp monochrome SPOT cameras and a large area of image capture.

4-Shot

16Mp Monochrome

The 4-shot setting for the Flex Monochrome cameras takes four consecutive images as the piezoelectric carriage moves the whole sensor in half pixel increments in a 2x2 matrix. Shifting the CCD increases the time needed to capture the image. The 4-shot setting is suggested for non-moving, non-quenching specimens and when high resolutions images are desired.

9-Shot

36Mp Monochrome

The 9-shot setting for the Flex Monochrome cameras takes four consecutive images as the piezoelectric carriage moves the whole sensor in one-third pixel increments in a 3x3 matrix. Shifting the CCD increases the time needed to capture the image. The 9-shot setting is suggested for non-moving, non-quenching specimens and when very high resolutions images are desired.

16-Shot

64Mp Monochrome

The 16-shot setting for the Flex Monochrome cameras takes four consecutive images as the piezoelectric carriage moves the whole sensor in one-quarter pixel increments in a 4x4 matrix. Shifting the CCD increases the time needed to capture the image. The 16-shot setting is suggested for non-moving, non-quenching specimens and when very high resolutions images are desired. This mode of image capture extends the sensor resolution via subpixel sampling and provides images of unparalleled quality.

Note: Sub-pixel shifting will increase the image file size.

Idea

The SPOT Idea camera allows the selection of lower resolution settings to provide faster frame rates and smaller file sizes. Using the camera in these modes can improve imaging of moving specimens or enhance sequential image captures.

<table>
<thead>
<tr>
<th>Resolution</th>
<th>Application</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal Full Sensor Resolution</td>
<td>The Normal setting takes a picture without reducing the resolution of the sensor. The Normal setting is suggested for situations where a full resolution image capture is needed.</td>
</tr>
<tr>
<td>0.5 One-Half Resolution</td>
<td>The Half Resolution setting takes a picture with one half of the pixels in the width, and one half the pixels in the length dimensions. This setting allows for a faster live image display and may be of benefit when you may want to capture a better image of a moving specimen.</td>
</tr>
<tr>
<td>0.33 One-Third Resolution</td>
<td>The One-Third Resolution setting takes a picture with one half of the pixels in the width, and one half the pixels in the length dimensions. This setting allows for a faster live image display and may be of benefit when you may want to capture a better image of a moving specimen.</td>
</tr>
</tbody>
</table>
0.25
One-Quarter Resolution

The One-Quarter Resolution setting takes a picture with one half of the pixels in the width, and one half the pixels in the length dimensions. This setting allows for a faster live image display and may be of benefit when you may want to capture a better image of a moving specimen.

**Live Mode Acceleration**

Live Mode Acceleration enables you to “speed up” the live image display (higher frame rates) in cases where you are willing to sacrifice some live preview resolution for a higher frame rate. Depending on the model of your SPOT camera, this option may appear as a slider with multiple positions or a simple check box to toggle the feature on or off. If you have a slider available, moving the slider towards the right increases the acceleration. This setting does not decrease the resolution of the captured image.

**Focus Tab**

**Show Focus Gauge**

The Focus Gauge feature is designed to be an aid in focusing the selected region of the Live Image window. As the focus is adjusted at the microscope the blue bar lengthens and shortens showing the current focus level. The red line acts as a high water mark showing the highest level of focus over the last few seconds. Check the box for **Show Focus Gauge** to activate this feature.

**Focusing Area**

The Focus gauge can be set to provide focus feedback from all or only a specific area of the image. The two options are:

- **Same as Imaging Area**: This selection will set the focus gauge based on the entire area currently being viewed.
- **Set Area**: This selection will set the focus gauge based on a sub-region you draw. The sub-region is created by clicking the Set Area button and then clicking and dragging the desired area on your image. Once the selection has been made it will be highlighted in pink.

*Note: The Focus Area must be within the Imaging Area. If you are using the option to “Display Full Chip Area in Live Mode” and you draw a region outside of the yellow box, no selection will be made and the ‘Set Area’ button will remain depressed, waiting for a valid input. If the region is drawn overlapping the imaging area, the software will use the portion of the drawn focus region which is within the imaging area.*
IMAGE DISPLAY SETTINGS

Display Zoom Level

The Display Zoom feature provides the display window with a magnified sub-region view of the image. It allows for a detailed examination of small image features. It is a useful and important feature since modern digital cameras provide image resolutions exceeding the resolution of the monitor.

The trade-off for this resolution advantage is reduced field of view which is compensated for with the Pan Window control discussed in the next section.

Setting the Display Zoom Level

The Zoom Level controls provide several methods to set magnification:

- **By Slider Bar**: Moving the slider bar changes the magnification displays the magnification in the drop down button box.

- **By Image to Window Aspect**: At the top of the drop down button box are selections to match certain aspects of your image to certain aspects of the display window. They are:
  
  - **Actual Size**: When selected, each pixel from the camera image is represented by a single pixel in the display image. In many cases, this will result in the displayed image appearing with scroll bars since the camera resolution is usually greater than the screen resolution.
  
  - **Fit to Window**: When selected, the image is sized to fit into the Live Image Window. Choose this setting to provide a full field of view at the maximum size that will still fit into the Live Image Window. In most cases, this will result in the displayed image appearing at lower resolution that what is available in the image. The magnifier can be used to look at image details in this case.
  
  - **Fill Window**: This feature will resize the image to entirely fill the preview window or full screen. Note that horizontal or vertical areas of the image will not be seen since they will be out of the image window field of view.
  
  - **Fit Width**: When selected, the display zoom level of the image will automatically adjust to the maximum setting which allows the entire image width to be viewable within the display canvas. This may result in unused areas of the Live Image Window or portions of the display screen while in Full Screen mode.
  
  - **Fit Height**: When selected, the display zoom level of the image will automatically adjust to the maximum setting which allows the entire image height to be viewable within the display canvas. This may result in unused areas of the Live Image Window or portions of the display screen while in Full Screen mode.

- **By Choice List**: Clicking on the drop down button box you will see a list of predefined magnification percentages. Percentages greater than 100% magnify while percentages less than 100% demagnify.

- **By User Entry**: At the bottom of the drop down button box is a menu selection for custom entry. This will allow the user to type in a specific magnification percentage between 10% and 1600%
Magnifier

The Magnifier is a moveable rectangular window that moves over the Image window with the mouse cursor and provides a magnified view of the image below it. Its dimensions and magnification are configurable by the user. See below in Preferences for additional information on the Magnifier settings.

Pan Window

The Pan Window is a window that contains a smaller version of the full field of view image. It provides the user with a reference location for the current sub-region view with respect to the full field of view. Dragging the field of view box around the Pan Window provides scrolling control of the sub-region being viewed.

To enable the Pan Window check the adjacent box. When the Pan Window is enabled, it will automatically appear anytime the main view window is showing a region that is less than the full field of view and will hide when the full field of view is showing.

ADDITIONAL CONTROLS AND FUNCTIONS

Preferences

The TWAIN window includes a Prefs button, which allows you to define live image viewing, exposure and other preferences. The window includes the following options:

- Profile Saving Options
- Image Acquisition Settings
- Bus Speed Setting (Firewire cameras only)
- Temperature Readout Section (Pursuit and Xplorer cameras only)
- Image Print Resolution Options
- Image Transfer Settings
- Magnifier Setup
- Helpful Hint Messages Setting

Profile Saving

There are three options for saving your changes to your Image Profiles:

- **Automatically Save Changes** - With this option selected, the SPOT Software will automatically save any changes you make to an Image Profile upon closing the SPOT TWAIN window or changing profiles.
• **Prompt Before Saving Changes** - With this option selected, you will be asked if you would like to save changes to your Image Profile upon closing the SPOT TWAIN window or changing profiles.

• **Do Not Save Changes** - With this option selected, changes to your Image Profile will not be saved nor will you be prompted and informed of the changes upon closing the SPOT TWAIN window or changing profiles.

**Image Acquisition**

*Captured Image Bits per Channel*

*Bit Depth* is the number of bits per channel (or *bits per pixel* (bpp)) that the camera uses to create an image. The number of colors, or intensity levels, available in an image is defined by its bit depth setting. Higher bit depths provide more intensity levels. The number of intensity levels is defined by $2^n$ where $n$ is the bit depth setting. For example, an image with a bit depth of 8 would have $2^8 = 256$ intensity levels, or 256 levels.

The SPOT program provides different options, depending on which camera model you are using. For color camera users, the 24 bpp RGB color setting is the most common selection because it is an industry standard color format that is used by Windows and most printers. Most monitors cannot display more than 24 bpp. The advantage of using higher bit depths is for the user who will perform image adjustments/enhancements after the image is captured. Higher bit depths ensure that there are no truncation errors created during data manipulation. Once the image adjustment is finished, the image can be down sampled to 24 bit RGB.

This option enables you to specify a different image bit depth when saving an image captured in the SPOT TWAIN interface.

**8 Bits per Channel** – The 8 bits per channel option provides 256 intensity levels per color:

- With B/W cameras, captured images are 8 Bit Depth monochrome.
- With Color cameras, captured images are 24 Bit Depth RGB color.

This option results in smaller, more manageable image sizes, and is best for images that do not require extensive modification.

**10 Bits per Channel** – The 10 bits per channel option provides 1024 intensity levels per color:

- With monochrome cameras, captured images are 10 bits per pixel monochrome.
- With color cameras, captured images are 30 bits per pixel RGB color.

This option results in smaller, more manageable image sizes, and is best for images that do not require extensive modification.

**12 Bits per Channel** – The 12 Bits per channel option provides 4,096 intensity levels per color.

- With B/W cameras, captured images are 12 Bit Depth monochrome.
- With Color cameras, captured images are 36 Bit Depth RGB color.

This option reduces banding problems that can result with modified images, but also results in larger file sizes.

When saving 12 bit per channel images, SPOT prompts you to select either 12 bits per channel or 16 bits per channel. If you use Adobe’s Photoshop for image editing, you should select the 16 bit per channel option because Photoshop cannot read 12 bit per channel images.

**14 Bits per Channel** – The 14 bits per channel option provides 16,384 intensity levels per color. This option is available only with some camera models.
With B/W cameras, captured images are 14 Bit Depth monochrome. With Color cameras, captured images are 42 Bit Depth RGB color.

This option further reduces banding problems that can result with modified images, but also results in larger file sizes.

When saving 14 bit per channel images, SPOT prompts you to select either 12 bits per channel or 16 bits per channel. If you use Adobe’s Photoshop for image editing, you should select the 16 bit per channel option because Photoshop cannot read 12 bit per channel images.

Make Shutter Sound

The user may select whether to utilize the audible shutter sound when capturing an image.

Monitor Color Filter Position for Image Capture (Slider Cameras Only)

If this option is selected the SPOT software will produce an error message if the color filter isn’t in the proper position while capturing an image. The Monitor Camera Color Filter Position box is checked by default.

Monitor Color Filter Position for Live Images (Slider Cameras Only)

If this option is selected the SPOT software will produce an error message if the color filter isn’t in the proper position while viewing the live image. The Monitor Camera Color Filter Position box is checked by default.

Use Single-Channel Readout for Live Images (Insight, Flex, Pursuit, Xplorer cameras)

In the Live Image Window, many SPOT cameras read out the CCD chip using two channels. This allows a faster frame rate than single channel output, making focusing and framing more fluid. This, however, can sometimes lead to a slight mismatch in intensity between the two sides of the live image.

To avoid this, you can select single channel readout, which will eliminate any intensity mismatch, but will slow down the live image frame rate of the camera.

Note: SPOT cameras always capture images in single channel mode, thereby eliminating any chance of intensity mismatch in the acquired images. The Insight Gigabit camera is the exception to this rule, as the captured image is read out via multiple circuits.

Set Exposure Conversion Factor (RT Cameras Only)

The Set Exposure Conversion Factor function compensates for a difference between the RT series Live Image readout circuits and the Image Capture readout circuits. It ensures the gain and offset between the two circuits is matched.

To use Set Exposure Conversion Factor, follow these steps:

1. From the Camera menu, select Set Exposure Conversion Factor. The Set Exposure Conversion Factor dialogue box appears with a default conversion factor displayed.
2. Select Compute. A dialogue box will prompt you to “Move to sample for exposure computation”.
3. Ensure that your sample is in field of view and click OK.
4. The SPOT software will compute the appropriate conversion factor. Click OK to finish.
Bus (Firewire cameras only)

*Bandwidth*

For the Firewire cameras, you can select the relative amount of bandwidth that your system will utilize to capture and transfer images between the camera and your computer. Choices are High, Medium, and Low. Typically selecting the High setting provides the best image preview frame rates.

Temperature Readout (Xplorer/Pursuit cameras)

*Sensor Temperature Readout Timing*

This section allows you to specify the time interval between temperature readouts. The default time interval is 30 seconds. The CCD temperature is displayed in the upper left corner of the TWAIN window.

Image Print Resolution

Use the Image Print Resolution if you would like to set the print resolution to a specific number of pixels per unit area (inch or cm).

This option is available for users who wish to set the print resolution of images in pixels per unit area. For example, a full size image from a SPOT 4Mp camera such as the IN1420 would be 2048 pixels wide by 2048 pixels tall. If you wanted to set the printing size to be 2.048 inches by 2.048 inches, you would set the image print resolution to 1000 pixels per inch. In this way, the larger the number of pixels per inch you select, the smaller the image will print and vice versa.

The Image Print Resolution value is passed with the image information to other image applications such as Photoshop.

Image Transfer

SPOT Cameras have the ability to capture images at 8, 10, 12, and/or 14 bits per channel depending on the camera model. Many other imaging applications are unable to handle bit depths which are not a multiple of 8. Therefore, if the bit depth setting in the Image Acquisition pane is set to 10, 12, or 14, you can use the **Promote 10/12/14-bit Data to 16-bit when Transferring** option to ensure that the 3rd party software application can open the image. Check the documentation for your host imaging application to ensure it supports the image bit depth you will be transferring.

Image Display

If you need to see the individual image pixels in order to see individual pixel data, check the box to **Show Image Pixels when Zooming or Stretching**.

Magnifier

The dimensions and magnification factor to be used for the magnifier option are set here. Set the dimensions of the magnifier in pixels and use a numerical value for the magnification factor you wish to use. See the previous section under **Image Display Settings** for additional information on how to use the Magnifier.
Messages
Select **Show All Informational Messages** to display helpful prompts from the SPOT program to walk you through such features as Compute White Balance, etc. It is only recommended to turn this feature off for expert users of the SPOT TWAIN interface.

Keep TWAIN window on top
When this option is selected, the SPOT TWAIN window will be the topmost window and will not fall behind any other application window. This setting will help avoid confusion when the SPOT TWAIN window is accidently covered up by another application window resulting in the user unable to find it.

Device…
The **Device** button is used when multiple SPOT cameras are connected to your system and allows you to select the camera that you would like to use (or switch to) for the next image capture. Once you have selected a different device, the TWAIN window will update automatically to include options consistent with the selected device.

Help
Use the Help button to open the SPOT Online Help system which can also be searched by key word.

Close
When you are done capturing images and you wish to begin working in the host application (i.e. Photoshop), click on the Close button to close the SPOT TWAIN interface and return to the host application.

Taking a Picture
From the SPOT TWAIN Interface, you can capture images in a couple of different ways:

Preview
- You can capture a **Preview** image. Preview images remain available in the TWAIN window for basic editing and serve as the basis for the final image capture. When you click on the **Preview** button, the **Get Image** dialog displays the capture status as it is captured, and the captured image then replaces in the Live Image in the window. Note that the status bar indicated that you are viewing a Preview image.
Transfer

- If you like the Preview image, you can Transfer it image directly to the host application that you are using. The Transfer button is active only for Preview image captures.

Acquire

- The Acquire button will capture an image and have it automatically transfer to (open in) the host imaging application.

F-Keys

The following function keys are available as shortcuts in the SPOT TWAIN interface:

<table>
<thead>
<tr>
<th>Function Key</th>
<th>Action</th>
<th>TWAIN Interface Option</th>
</tr>
</thead>
<tbody>
<tr>
<td>[F 4]</td>
<td>Restart the live image view.</td>
<td>Live</td>
</tr>
<tr>
<td>[Alt] + [F 4]</td>
<td>Close the SPOT Camera window.</td>
<td>Close</td>
</tr>
<tr>
<td>[F 9]</td>
<td>Capture an image and automatically transfer it to the imaging application.</td>
<td>Acquire</td>
</tr>
<tr>
<td>[Ctrl] + [F 10]</td>
<td>Compute white balance values.</td>
<td>White Balance</td>
</tr>
</tbody>
</table>
Ch. 3 – SPOT Image Capture Application - Mac

INTRODUCTION
The SPOT Image Capture is a simple AppleScript based controller for the full SPOT application. It allows users to quickly acquire images and optionally open them for editing in either SPOT or another, host application.

The SPOT Image Capture application is installed in the same folder as SPOT, typically /Applications/SPOT 5.0. When the SPOT Image Capture application is opened, the SPOT Application also opens.

The application’s single window allows easy access to the necessary functions to acquire images using an existing SPOT Image Setup.

Note: In order to transfer images to a host application, the Auto-save feature must be turned on in the SPOT application. Read more about setting up the Image Auto-save in Section II – Ch. 2 SPOT Basic Image Settings and Preferences or Section III – Ch. 2 SPOT Advanced Image Setups, Live Image Controls, and the Setup Menu.

THE SPOT IMAGE CAPTURE DIALOG
In normal operation, the application dialog presents four options as pictured here. Each button’s options are outlined in further detail below.

Capture
Use the Capture button to acquire a single image, using a specific Image Setup.

Live Image
The Live Image button toggles the live image window, showing or hiding it as appropriate.
Setup
The setup button displays configuration options including:

Open Images Using
Clicking on Open Images Using will open a popup window which will specify whether acquired images are opened at all and into which program to open them.

Add
Select Add from the menu to browse installed applications and add them to the list so they are available in which to open captured images.

Clear List
Select Clear List from the menu in order to reset the list of available applications to the defaults.

Image Setup
The Image Setup dialog chooses the image setup to be used for all acquisitions. The default selection is the current setup in the SPOT application, but any available setup can be selected from the pull down list.

Quit
Click on the Quit button in order to close the SPOT Image Capture application and your imaging session.
SECTION V – THE SPOT ADVANCED MODULES

Ch. 1 - Introduction

If you have the SPOT Advanced Application, there are optional modules available for furthering your options within the SPOT Software. Four different modules are available, all with a different set of features available within them. You can choose to have any combination of the following: Extended Depth of Focus, Quantitative Imaging, Peripheral Device Control, and Extended TWAIN. Each module will be described in detail in the subsequence chapters of this section.

This Section of the Software User Guide assumes that you already familiar with certain aspects of the software such as Preferences, Image Setups, etc. With each module, you may find additional Macro command available which correspond to the module-specific features. The functioning of these macro commands can be understood by reviewing the content on each feature (below) and macro scripting (Section III – Ch. 6). If you encounter references to other aspects of the SPOT Software and are unsure of their usage, please see the appropriate chapter in Section III.
Ch. 2 – Extended Depth of Focus Module

Introduction

This module allows you to create one single best image from a series of images where the focus, contrast, or intensity may not be even across a single plane of focus. When the Extended Depth of Focus module has been purchased and your SPOT License Key has been updated, you will find the Create Extended Focus Image feature under the File menu. The feature will be active only if an image document is open.

Using the Extended Depth of Focus Module

To begin, follow these steps:

1. Open the images you want to use as source images.
2. From the File menu, select Create Extended Focus Image. The Create Extended Focus Image dialog will open.
3. The options available under Image Source will depend on the type of image documents open within the SPOT Application. If you have individual images open, you will have the option to Use All Open Images. If you have one or more image sequences open, you will have the option to select the desired image sequence file. If both types of image documents are open, both will be available in the Image Source pull down menu.
4. You can use either the Entire Image Area or a Selected Area from which to create the Extended Focus Image.
   - If Entire Image Area is selected, the entire image data will be used with the selected Method for creating the Extended Focus Image.
   - To use a Selected Area, make this selection in the Create Extended Focus Image dialog box and then use your cursor to click drag a rectangular selection on one of the open images. Only the pixel data within this area will be used for creating the new Extended Focus Image. The entire original image area will still be displayed while the Selected Area will reflect the method chosen for creating the Extended Focus Image.
5. There are three Methods available for creating an Extended Focus Image:
   - Best Local Contrast-The best contrast at each point, or neighborhood, is analyzed throughout all indicated images and the best contrast image data is used to create one final image. The user has the ability to set the size of the neighborhood for this process. A grid of pixels either 3X3, 5X5, or 7X7 in dimension can be used.
   - Best Local Image-The single image, from all indicated images, with the best overall contrast will be used to create a new image file.
   - Maximum Projection-The brightest pixel data at each pixel position throughout all indicated images will be used to create one final image.
Ch. 3 – Quantitative Imaging Module

Introduction

The Quantitative Imagining Module is intended for users of the SPOT Software who are performing lower light level fluorescence. The features included in this module provide a variety of tools which help minimize exposure times and enhance the image display and viewing options. When the Quantitative Imaging Module has been purchased and your SPOT Software Key has been updated or activated, you will notice various additional features throughout the SPOT Advanced Application. These new features are outlined below.

Quantitative Imaging Features under the Edit Menu

Preserve Pixel Intensity Data

When this feature is activated, the actual image data will be preserved throughout image manipulations. Preserve Pixel Intensity Data can be set in the Image Setup to ensure data integrity for all captured images. Also, under the Edit menu, you can make the selection to activate or de-activate the Preserve Pixel Intensity Data feature.

When turned on, certain functionality will be disabled in the software so that the raw pixel data cannot be altered. If “Preserve Pixel Intensity Data” has been selected for an image and you de-activate this feature from the Edit menu, you will be asked to verify this choice. Once Preserve Pixel Intensity Data is turned off, any changes made to the way the image is displayed will permanently change the pixel data which is saved.

Set Intensity Display Scaling

This feature is accessible from the menu command or by clicking on the icon on the Image Display Settings Panel (see View menu section).

Any changes made to these settings will only change the way an image is displayed as long as Preserve Pixel Intensity Data is activated for the image.

- Scaling

  Off - Default selection to apply no change to the stretching of the black and white points of the image display.

  Manual - Enter a set value to which you would like the Black and/or White points to be reset for image display.

  Auto - Enter a value in the form of a percentage to adjust the black and white points for image display. The value indicated will be the percentage of pixels that will become Black/White.
- **Gamma**
  Gamma Adjust smoothly lightens darker areas of an image without burning out bright areas or lightening black areas. This is especially useful for editing images with a wide range of brightness values (dynamic range). Values above 1 will brighten and values below 1 will darken the image display.

- **Histogram Area**
  Adjustments to this selection will change the information that is displayed in the histogram as well as define the area that will be used for calculating black/white values as indicated in the Scaling section. You can either choose to use the Full Image Area or select a Region. If you choose a Region, you can set the pixel values to define a rectangular area, or if a previous selection (click and drag) was made from the Select/Show Histogram Area, these pixel values will be displayed here.

  The values that are set for the Intensity Display Scaling can be saved to an image setup via the Set Image Display Values (See Section III, Ch. 3 – SPOT Advanced Image Captures and the Camera Menu).

  The settings described above are also available as part of the Live Image Controls for live viewing manipulation of your image. In this way, you can use the Live Image Controls to adjust your image and then you can also use the same features from under the Edit menu to adjust image which is already captured.

**Quantitative Imaging Features under the View Menu**

The View Menu offers a couple of new features designed to enhance your image viewing options when the Quantitative Imaging Module has been activated.

**Show Image Display Settings Panel**

The panel below is the Image Display Settings Panel which can be toggled on and off from the View menu. If this feature is activated, the panel will be displayed within the image window. The Image Display Panel feature can be turned on or off as a Preference under the Setup Menu.

![Image Display Settings Panel](image.png)

This feature allows easy access for many tools for adjusting the way your image is displayed. Certain tools will not be available for color images (i.e. Set Palette and Indicate Saturated Pixels).
Histogram View of Pixel Data: A graphical representation of image pixel data which allows for quick adjustments by grabbing on to the end pointers (to scale the white and black points, or the center pointer (to adjust the Gamma).

Set Intensity Display Scaling: This button will bring up a dialog box to enter values for Scaling the image, adjusting the Gamma, or to set the area of the image which is represented in the Histogram. This dialog box is also available from the Edit menu.

Set/Show Histogram Area: If this toggle button is depressed, the area of the image which is graphically represented in the histogram will be outlined in turquoise. If the entire image is being used for the histogram display, the turquoise outline will not be viewable. The menu listing can also be used to show/hide the histogram selection area.

Set Palette: Use this button for quick access to existing color Palettes or create a New Palette.

Indicate Saturated Pixels: This button allows for easy toggling of viewing saturated pixels.

Show Image Display Histogram Area
Use this feature to toggle the display (with a cyan rectangle) of a selected region that is used for the Histogram (see Show Image Display Settings Panel).

Quantitative Imaging Features under the Camera Menu
The Camera Menu has one new feature when the Quantitative Imaging Module has been activated.

Save Image Display Values
With an image open in the SPOT application, the option to Save Image Display Values will be available. If you like the values that you have used on an image for Scaling, Gamma, Palette selection, etc, you can use those values from the image and save them to the Image Setup of your choice.
Quantitative Imaging Features under the File Menu

Lastly, there are a few new features under the File Menu for users of the Quantitative Imaging Module.

Duplicate Image

Creates a duplicate image so that a copy is available to further manipulate, or you can create a duplicate of the original image after manipulation. If changes have been made to the display of the image, you will have the option to either duplicate the raw, actual image data or duplicate the displayed image data. You can also set the bit depth of the newly created image and, if any annotations, calibrations, or measurements have been added to the image, you can choose to Merge all of these objects to the image. The option to Merge Objects in layers is only available when selecting As Displayed.

Export Pixel Values

Exports and saves the image data to either a binary or text format file. If only a selected region of the image is desired, this area can be selected prior to accessing this feature and using the ‘Selection’ option. If a selection is not indicated on the image prior to accessing the Export Pixel Values feature, the option for ‘Entire Image’ or ‘Selected Area’ will be unavailable and grayed out.
Ch. 4 – Peripheral Device Control

Introduction

What is the Peripheral Device Controller?

The peripheral device controller allows the SPOT program to communicate with external devices. This provides a means for directing the external device to obey simple commands. As most external devices (filter wheels, shutters, etc.) will have their own unique set of commands that they obey, you will need to access the reference documentation of the external device in order to make use of this function in SPOT software.

Why and when would I use this feature?

One of the powerful uses of the peripheral device controller is to automatically change the condition of the external device while you carry out an experimental process. This is most powerful when the peripheral device control commands are placed in a Macro (see chapter 13 – Macro Scripting to learn or review the use of the Macro feature).

WARNING

Note: External Devices are typically electromechanical devices that may have their own hazards of use. Before you attempt to use any external device alone or in conjunction with SPOT software, refer and abide by all instructions and warnings that accompany that external device. Particularly note the potential hazards associated with the use of that device and do not attempt to control that device without being able to view its operation from the control location, including the computer running the SPOT software.

Additionally, note the limitations of the device you are controlling. Do not set the SPOT software to exceed those limitations as doing so could result in damage to the external device or a hazardous situation to the user.

Developing Peripheral Device Commands

Once you have the external device’s documentation and then locate its command list, you are ready to begin.

Access the peripheral device set-up editor by selecting it from the Setup dropdown menu on the menu bar.

The Peripheral Devices window will appear and will initially be empty. Select the Add button to begin.
Naming the External Device - Start by giving the device you are controlling a name that you will recognize. For example, if you are developing commands for a Sutter filter wheel, you might want to name the device as such. Be as general or specific as you need to be depending upon the number and type of external devices you could connect to your computer.

Specifying the Device’s Communication Settings - Before you push the add button, you may specify the communication information of your external device. To begin, specify the output port that the communication cable is connected from at your computer (The other end will be attached to the external device controller). Select this from the dropdown menu in the PORT box.

You will often find the other communication information in the external device reference manual, in the same section as the external command list or in the specification section. As an example, the following excerpt is from the Uniblitz VMM-D1 Shutter’s User Manual.
RS-232C (DB-9 female)  Baud rate 9600, 8 Data bits, 1 Stop bit, No parity, No flow control, command acquisition time 0.94 msec; 6 commands available; 1 global, 8 local address locations for commands (see "ADDRESS Select" specification for switch settings of local address locations).

Note that the specification tells you the type of communication mode (RS232C) and gives you communication specifications including Baud rate, the number of data bits, the number of stop bits, whether there is a parity bit or not and what type it is.

Select the matching information from one of the drop down menus for each Baud Rate, Parity, Data Bits, and Stop Bits.

Alternatively, you can select the Use System Port Settings checkbox. The boxes for the technical information noted above will become inactive. The communication will default to the settings specified for that port on your computer.

Note: The communication information must match between that specified and that of the external device. Otherwise, information exchange may be flawed and the external device controller may not understand the external device commands.

Push the add button to add a command name to your library.

**Naming the External Device Command** - You will want to name the peripheral device command. You can name it whatever you choose without regard for the function that the command will send to the external device. Logically, however, you probably want it to be closely related to the function (i.e. “Open the shutter” might be better than “Bob’s eye-opening experience”) especially if other users may be accessing these commands.

**Entering the Desired Command** - Once you have named the command, you must enter the corresponding command string in that box that will be understood by the external control device.
The following special notation can be used in the command string:

- `$` “Escape” character
- `^A`-`^Z` Control A through control Z
- `\$` Dollar sign
- `\` Backslash
- `\^` “^” character
- `\b10101010` Binary value “10101010” expressed in true binary
- `\dyy` value “yy” expressed in decimal
- `\xyy` value “yy” expressed in hexadecimal

For example, the following command options would be available for the Uniblitz VMM-D1 shutter. Note that the Peripheral Device Command feature will not support the Octal command codes listed in the following table.

<table>
<thead>
<tr>
<th>RS232 Global Address Codes</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Commands</td>
</tr>
<tr>
<td>Open</td>
</tr>
<tr>
<td>Close</td>
</tr>
<tr>
<td>Trigger</td>
</tr>
<tr>
<td>Reset</td>
</tr>
<tr>
<td>Open B</td>
</tr>
<tr>
<td>Close B</td>
</tr>
</tbody>
</table>

If you wanted to send the “Open” command in hexadecimal, you would type the following:
Note: You no longer need to use three alphanumeric characters to describe a decimal command. For example, the previous command \d05 can now be specified as \d5.

Setting a Response Command - You may elect to receive a response when the SPOT program has sent the command, and the external device has completed that command. Click on the Response String checkbox and type in the appropriate response command. This response command string will also be found, if available, in the external device documentation.

Using Variables - In the command string, you may insert variables. The variables will be expanded at the time that the command is sent to the device. If you insert a "RunTimeText" variable, the user will be prompted, with your supplied prompt text, at the time the command is sent, and the user's response will be inserted into the command string at the point where the variable appears. The "TextVar" and "NumVar" variables may be useful when the command is used from within a macro (see Chapter 13 – Macro Scripting).

Using Timeouts - You may also select a time limit between the time that the command is sent by SPOT and the time it takes for the command to be received and the action of the function is completed. This can be handy in letting you know that there is a communication problem between the computer and the external device, when you expect an action to take place within a prescribed length of time.

Testing the Peripheral Device Command - You may test the command immediately by selecting the Test button. If you have selected timeout duration, a response window will let you know if the command has not been received and carried out within the prescribed length of time.

Note: Make sure your external device is connected properly to the computer and that it is turned on before considering other potential communication problems.
Modifying and Deleting the Peripheral Device Command – Once you have created a command, you can modify its parameters or delete it. Select the command from the Peripheral Device Window and push the modify or delete button.

![Peripheral Device Window](image)

Using the Peripheral Devices Commands

From the Dropdown menu - Once you have created at least one peripheral device, a “Peripheral Devices” menu will appear in the application. You can send any of the commands you defined by selecting it from the appropriate submenu.

![Peripheral Devices Menu](image)

In a Taskbar - You can also add any of your peripheral device commands to your floating taskbar in the same way that you can add any other menu command (see screenshot below). Once placed on a taskbar, simply click on the Peripheral Device command and it will be carried out (For a review of taskbar development, see Chapter 12- Taskbars).
In a Macro - Finally, you can use any of these peripheral device commands as part of a Macro program that you develop. On playback of the Macro, the peripheral device commands will be carried out in the sequence and order specified in the Macro program (see Chapter 13 for a review of developing Macros).

Moving Peripheral Device Commands

You can move your peripheral device commands to and from another computer.

**To import peripheral device commands**, follow these steps:

1. Choose Peripheral Devices from the Setup menu.
2. Click on Import.
3. Select the peripheral device export that you would like to import. This will be a file of type SPOT Export (spx).
4. Choose Open. The peripheral device export will appear in the Import menu.
5. Select the peripheral device export and choose Import. The peripheral device commands will now be ready for you to use.

**To export peripheral device commands**, follow these steps:

1. Choose Peripheral Devices from the Setup menu.
2. Select the peripheral devices you would like to export. To select multiple peripheral devices, hold down the Control button while selecting them.
3. Click on Export.
4. Select a File name and location and choose Save.
Introduction

The Extended Third Party Interface Module offers you the ability to access all of the SPOT Advanced features as well as the Extended Depth of Focus, Quantitative Imaging and Peripheral Device Control Module features while accessing your SPOT Camera from a different application. When the Extended Third Party Interface Module is activated and you select your camera source, you will have two options, SPOT Standard and SPOT Extended.

Using SPOT Extended Third Party Interface Module

Connecting to the SPOT Camera

For more about accessing the SPOT Camera from another application, see Section IV above.

New Toolbar in SPOT Extended Third Party Interface

In addition to the full SPOT Advanced interface, there are a couple of TWAIN related buttons present on the toolbar.

Transfer

This button will Transfer the captured image to the 3rd Party Host application and will keep the SPOT window open and available for more image captures.

Transfer and Return

The Transfer and Return button will Transfer the image to the 3rd Party Host application and return you to the 3rd Party Host application so that you can continue your work in your main application (the 3rd Party Host application).
Appendix A: Electronic Imaging Theory and SPOT Cameras

Introduction

This appendix is a brief overview of the operational theory behind SPOT digital cameras. The next two sections, Digital Photography and Color Images, provide a short introduction to electronic imaging theory; the following section describes how this theory applies to the SPOT cameras.

Digital Photography

Modern electronic imaging is based on the charged coupled device (CCD). All of today’s digital cameras have a CCD chip or chips. In digital cameras, the CCD chip/sensor replaces the film of traditional cameras as the means by which the camera records the image. The surface of the CCD chip is composed of light-sensitive cells arranged in a checkerboard pattern. Each cell of the checkerboard is known as a picture element, or more commonly, a pixel. The following is a simplified description of what happens when you take a picture with a digital camera:

1. The camera’s optical system forms images on the “checkerboard” of pixels.
2. The CCD is exposed to the image for a period of time.
   During this period, each photosensitive cell receives photons of light, converts the photons to electrons, and then stores the electrons in the cell. The process by which each cell accumulates electrons can be compared to a well filling with water. As more light hits a cell, the electron level in the well rises. The more electrons that are in the cell, the more voltage it will have when read by the digital camera.
3. Following the exposure, a digital camera does three things:
   a. It measures the voltage of each cell.
   b. It converts the voltage to a binary number.
   c. It transmits this number down a cable to your computer.
4. The computer reconstructs the image by assigning a brightness value to each pixel in the final image. Each brightness value is proportional to the voltage of the corresponding cell on the CCD chip.

Dark Current, System Offset, and Scientific Imaging

Dark Current is a component of any image captured with a CCD.

What it is: Dark current is the rate of accumulation of electrons in a pixel due to thermal action. Dark current is related to the temperature of the camera CCD. Dark current is higher at higher CCD temperatures. The level and type of impurities in the silicon of each pixel will affect the dark current for that pixel. Pixels with pure silicon will have lower dark current. Pixels with impurities will have higher dark current.

What it is not: Dark current is not the result of photons (light) from the target specimen striking the CCD and therefore, does not represent true data related to the target image.

The accumulation of electrons in each pixel due to dark current is repeatable and predictable for any combination of time and CCD temperature.

In scientific imaging, the goal is to capture image data strictly related to the light gathered from the target specimen. Dark current is additional unwanted data (electrons) that can degrade the
image data desired. Get Bias Frame and Get Background Image are features that can eliminate the effect of this unwanted dark current, leaving the user with a better representation of the true data associated with the target specimen.

In scientific imaging, pixel values of zero are not desired. Therefore, the camera electronics add an “offset” to all pixel values so that a pixel value that would normally be zero (no light) is offset to a higher positive number. The amount of this offset is referred to as the “system offset”.

Dark Frames, Bias Frames and Background Images: Definitions

A **dark frame** is any image taken with no light hitting the CCD.

A **bias frame** is a short exposure dark frame. Each pixel in the bias frame has a value equal to the system offset plus any dark current electrons accumulated by the pixel in the time between the end of exposure and when that pixel’s charge is measured by the camera’s electronics. Since the pixels are read one at a time, the first pixel read would have the least amount of dark current electrons and the last pixel read would have the most.

Subtracting a bias frame from any image will subtract the system offset and the dark current electrons that accumulated in each pixel while it was waiting to be read out.

A **background image** is a longer exposure dark frame with the bias frame subtracted. All that is left after subtraction of the bias frame is the accumulation of dark current electrons in each pixel that happened during the exposure time of the dark frame.

Subtracting a background image from any image of the same exposure time will remove the dark current electrons that accumulated during the exposure time. Since the accumulation of dark current electrons is directly proportional to exposure time (twice the exposure time results in twice as many dark current electrons) the background subtraction frame is “scalable”. This means that one background image (at a known exposure time) can be scaled up or down to predict the amount of dark current electrons that will accumulate in each pixel of an image of ANY exposure time.

Subtracting both a bias frame and a (scaled) background image should erase the system offset and eliminate all electrons due to dark current and leave an image that has pixel values due only to light striking the CCD. This is a highly useful way to “clean up” an image.

**Color Images**

Because a CCD chip is inherently monochromatic (black and white), color filters must be used to extract the color information from the image. There are several basic design methodologies.

**Single CCD design using color masked pixels (color mosaic cameras like the Insight Color Mosaic and RT3 Color Mosaic)**

Digital cameras designed in this manner have one CCD chip with color filters physically bonded to each pixel on the chip. Some pixels get red filters, some pixels get green filters and some pixels get blue filters. Since each pixel is only able to measure the intensity of one color, the intensity of the missing two colors for this pixel must be estimated, based on nearby pixels that have precise measurements of the missing colors. For example, a pixel that has a green filter will have an exact measurement of the green color value, but the red and blue values must be estimated, based on the nearest red and blue pixels. This estimation is known as *interpolation*.

- **Pros and Cons**: A digital camera designed in this way is inexpensive and can freeze moving images with a single exposure. However, because they interpolate brightness values, such cameras cannot provide as high of a resolution as that provided from a non-filtered CCD chip.
Three CCD design using color beam splitter
This design uses three CCD chips. The incoming image first goes through a color beam splitter which directs the red light to one chip, the green light to a second chip and the blue light to a third chip. The chips are very accurately aligned so as to achieve near perfect registration between the three chips. The red, green, and blue values for each point on an image are measured by the corresponding pixel on each of the three chips.

- **Pros and Cons:** This design produces an image that retains the high resolution of the individual chips. This type of camera can also freeze moving images with a single exposure. However, because most of the cost in a high resolution CCD camera is in the CCD chip itself, three chip cameras are far more costly than their single chip counterparts.

Single CCD design that takes three pictures (three pass method) (3-shot Color and Slider model cameras like the Insight 3-shot Color and Xplorer Slider)
Cameras designed in this way expose a single CCD chip three times, once to red light, once to green light, and once to blue light. One variant in this type of camera is how the chip is exposed to the different colors of light. Some cameras switch individual red, green and blue glass filters in front of the chip for each exposure. Others use a liquid crystal filter that changes from red to green to blue as different voltages are applied to it. By exposing the chip three times, each cell on the CCD is able to measure all three color values.

- **Pros and Cons:** This technique attains the high resolution of the three CCD design without the high cost associated with using three chips. However, because these cameras require three exposures, they cannot freeze moving images.

Single CCD design using color masked pixels with pixel-shifting (Flex cameras)
Cameras designed in this way use a motor to move the CCD in pixel or sub-pixel increments. This allows the camera to sample red, green and blue for each image while still using a color mosaic sensor.

- **Pros and Cons:** This technique attains the high resolution of the three CCD design without the high cost associated with using three chips. Since the motor can shift the CCD in sub-pixel increments, the spatial resolution can be increased. However, because these cameras require multiple exposures, they cannot freeze moving images. They also generate very large image files which require a computer with large storage capacity.

SPOT Digital Cameras
In order to provide you with an understanding of what happens when you take a picture, the following sections highlight some of the basic operating principles of SPOT cameras.

Pixel Digitization
Following each exposure, SPOT camera systems read the CCD chip and digitize each pixel data as it is transferred off of the CCD chip, and before it is sent through the cable into the computer. This technique minimizes noise and maintains the lack of distortion that is inherent with CCD chip geometry. The SPOT cameras use two methods of pixel digitization, one for live imaging, and one for image capture:

- **Live imaging**
  To provide the fastest possible frame rate; SPOT cameras use two separate circuits to digitize the left and right halves of the CCD simultaneously.
• **Pros and Cons:** This method provides an extremely fast display when using SPOT’s Live Image feature. The challenge comes in achieving a good brightness match between the two image halves. Our current algorithm achieves a good match with bright images. However, with dim images, mismatches can occur, resulting in a “split” appearance, where one half of the image is brighter than the other half. A “split” Live Image view is not indicative of what your image capture will look like.

• **Image capture**
To provide the most accurate image captures, most SPOT cameras use a single circuit to digitize the entire CCD chip.

• **Pros and Cons:** Because a single circuit is used to digitize the entire CCD chip, all pixels are inherently matched. However, this method provides a slower download than the two circuit method used for live imaging.

**Gain**

Normally an auto exposure routine in a digital camera sets the exposure time so that the brightest pixel on the CCD chip is completely "filled" with electrons, or is “full well” (see the Digital Photography section). This simple technique works well for bright images, but, as an image gets dimmer, exposure times can get uncomfortably long.

With the SPOT camera you can shorten exposure times by filling the brightest pixel on the CCD chip to less than full well, and then using this lower level as **full scale**. The inverse fraction of full well that the brightest pixel on the CCD is filled to is known as the **gain**. For example, filling a pixel to half of full well cuts the exposure time in half. Since the exposure time is cut in half, we call this a gain of 2.

The following table illustrates the relationship between gain, the fraction of full well that the brightest pixel is filled to, and the effect of gain on exposure time. Note that the camera model and selected pixel bit depth will determine the gain options available.

<table>
<thead>
<tr>
<th>Gain</th>
<th>Fraction of Full Well</th>
<th>Exposure Time (sample)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>80 seconds</td>
</tr>
<tr>
<td>2</td>
<td>1/2</td>
<td>40 seconds</td>
</tr>
<tr>
<td>4</td>
<td>1/4</td>
<td>20 seconds</td>
</tr>
<tr>
<td>8</td>
<td>1/8</td>
<td>10 seconds</td>
</tr>
<tr>
<td>16</td>
<td>1/16</td>
<td>5 seconds</td>
</tr>
<tr>
<td>32</td>
<td>1/32</td>
<td>3 seconds</td>
</tr>
<tr>
<td>64</td>
<td>1/64</td>
<td>1 second</td>
</tr>
</tbody>
</table>

An 80 second exposure at a gain of one turns into a 5 second exposure at gain 16. This is good in terms of the exposure time. Unfortunately, background noise is directly proportional to gain. It is 16 times higher at a gain of 16 is than at a gain of one.

**An Automated Exposure Process**

Normally, for any given image, trial and error would have to be used to determine the optimal combinations of gain and exposure time. In order to eliminate the need for trial and error experimentation, the SPOT camera automatically determines this information by sampling light levels before each exposure. Based on the light levels and the user-determined Auto-Gain Limit, SPOT determines the optimal gain setting and exposure time for the image. For details on using the Auto-Gain Limit feature, refer to Section 1 – Ch. 2 for SPOT Basic users or Section 2 – Ch. 2 for SPOT Advanced users.
## Appendix B: Keyboard and Toolbar Button Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Keystroke or F-key</th>
<th>Toolbar Button</th>
<th>Basic and/or Adv. Mode</th>
<th>Windows and/or Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File Menu</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Open Image File</td>
<td>F3</td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td></td>
<td>⌘ + O, ⌘ + F3</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show Image File Thumbnails</td>
<td>F5</td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td></td>
<td>⌘ + T</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Run Report</td>
<td>F6</td>
<td></td>
<td>Advanced</td>
<td>Both</td>
</tr>
<tr>
<td></td>
<td>⌘ + F6</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Reload</td>
<td></td>
<td></td>
<td>Advanced</td>
<td>Windows</td>
</tr>
<tr>
<td>Save</td>
<td>F2</td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td></td>
<td>⌘ + F2, ⌘ + S</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save As</td>
<td>Ctrl + A</td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td></td>
<td>Shift + S</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save to Database</td>
<td>Ctrl + D</td>
<td></td>
<td>Advanced</td>
<td>Windows</td>
</tr>
<tr>
<td>Save All</td>
<td>Ctrl + F3</td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td>Close Image Document Window</td>
<td>Ctrl + F4</td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td></td>
<td>⌘ + W</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Print</td>
<td>Ctrl + P</td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td></td>
<td>⌘ + P</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Exit</td>
<td>Alt + F4</td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td>Quit</td>
<td>⌘ + Q</td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td><strong>Database menu</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Search</td>
<td></td>
<td></td>
<td>Advanced</td>
<td>Windows</td>
</tr>
<tr>
<td><strong>Edit menu</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Undo</td>
<td>Alt + Backspace; Ctrl + Z</td>
<td>Both</td>
<td>Both</td>
<td></td>
</tr>
<tr>
<td></td>
<td>⌘ + Z</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Redo</td>
<td></td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td>Copy to Clipboard</td>
<td>Ctrl + C; Ctrl + Insert</td>
<td>Both</td>
<td>Both</td>
<td></td>
</tr>
<tr>
<td></td>
<td>⌘ + C</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cut Objects</td>
<td>Ctrl + X; Shift + Delete</td>
<td>Both</td>
<td>Both</td>
<td></td>
</tr>
<tr>
<td></td>
<td>⌘ + X</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Appendix B: Keyboard and Toolbar Button Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Keystroke or F-key</th>
<th>Toolbar Button</th>
<th>Basic and/or Adv. Mode</th>
<th>Windows and/or Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>Paste Objects</td>
<td>Ctrl + V</td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td></td>
<td>⌘ + V</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Match Color</td>
<td></td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
</tbody>
</table>

### Sequence menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Keystroke or F-key</th>
<th>Toolbar Button</th>
<th>Basic and/or Adv. Mode</th>
<th>Windows and/or Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>Play Forward</td>
<td>Ctrl + Space</td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td></td>
<td>⌘ + Space</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Play Reverse</td>
<td>Ctrl + Backspace</td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td></td>
<td>⌘ + Backspace</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Stop Play/Resume Play</td>
<td>Enter</td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td>Step Forward</td>
<td>Space</td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td>Step Back</td>
<td>Backspace</td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
</tbody>
</table>

### View menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Keystroke or F-key</th>
<th>Toolbar Button</th>
<th>Basic and/or Adv. Mode</th>
<th>Windows and/or Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fit to Window</td>
<td>Ctrl + F</td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td></td>
<td>⌘ + F</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Zoom</td>
<td>Ctrl + Z; Alt + Z</td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td></td>
<td>Option + Z</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show Magnifier</td>
<td></td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td>Show Gridlines</td>
<td>Ctrl + G</td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td></td>
<td>⌘ + G</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show Pan Window</td>
<td>Ctrl + W</td>
<td></td>
<td>Both</td>
<td>Both (Macs – button only)</td>
</tr>
<tr>
<td>Image Date/Time</td>
<td>Ctrl + T</td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td></td>
<td>⌘ + T</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Full Screen</td>
<td>F7</td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td></td>
<td>⌘ + F7</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show Image Settings</td>
<td></td>
<td></td>
<td>Basic</td>
<td>Both</td>
</tr>
</tbody>
</table>

### Camera menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Keystroke or F-key</th>
<th>Toolbar Button</th>
<th>Basic and/or Adv. Mode</th>
<th>Windows and/or Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>Live Image</td>
<td>F11</td>
<td></td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td></td>
<td>⌘ + F11</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Acquire Single Image (exposure from setup)</td>
<td>F9</td>
<td>⌘ + F9</td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td>Acquire Single Image (last used exposure)</td>
<td>F8</td>
<td>⌘ + F8</td>
<td>Advanced</td>
<td>Both</td>
</tr>
</tbody>
</table>
### Appendix B: Keyboard and Toolbar Button Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Keystroke or F-key</th>
<th>Toolbar Button</th>
<th>Basic and/or Adv. Mode</th>
<th>Windows and/or Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acquire Time Lapse Images</td>
<td>Both</td>
<td>Advanced</td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td>Compute Exposure</td>
<td>F10</td>
<td>Advanced</td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td></td>
<td>⌘ + F10</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Non-menu driven commands

<table>
<thead>
<tr>
<th>Non-menu driven commands</th>
<th>Keystroke or F-key</th>
<th>Toolbar Button</th>
<th>Basic and/or Adv. Mode</th>
<th>Windows and/or Mac</th>
</tr>
</thead>
<tbody>
<tr>
<td>Access the Image Setup window</td>
<td>F12</td>
<td>Advanced</td>
<td>Both</td>
<td>Both</td>
</tr>
<tr>
<td></td>
<td>⌘ + F12</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Increase vertical scroll speed by factor of ten</td>
<td>Ctrl + scroll</td>
<td>Both</td>
<td>Windows</td>
<td></td>
</tr>
<tr>
<td>Increase vertical scroll speed by factor of one hundred</td>
<td>Shift + scroll</td>
<td>Both</td>
<td>Windows</td>
<td></td>
</tr>
<tr>
<td>Scroll horizontally</td>
<td>Right click + scroll</td>
<td>Both</td>
<td>Windows</td>
<td></td>
</tr>
<tr>
<td>Compute White Balance Values</td>
<td>Ctrl + F10</td>
<td>Both</td>
<td>Both</td>
<td></td>
</tr>
<tr>
<td></td>
<td>⌘ + F10</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Note: PC commands are noted on the first line, Mac on the second. Any multiple keystroke combinations for the same function are separated by a semicolon ';'. The + sign indicates that the two keys need to be pushed.
Appendix C: Correct Color Technology

Introduction
In order to maximize the benefit of Correct Color Technology with your SPOT camera, you should set your microscope imaging system using the following approach.

Microscope Setup
Set your microscope to deliver light at 5000º K color temperature. This can be accomplished using a bulb of a known type and voltage combined with the appropriate daylight blue color filter in the light path. Consult your microscope manufacturer or dealer for advice on selecting and obtaining the correct light and filter products.

Camera Setup
You will want to set the white balance of your camera using the white balance feature in the SPOT program. This feature will allow you to save the white balance settings to your current image setup.

The SPOT program contains the ICC color correction profile as part of the Correct Color Technology system. The software will access this profile as appropriate for the type of SPOT camera that the software identifies upon startup. There is no need on your part to do anything here, except that you will need to enable Correct Color in the Image Setup window (Advanced mode – see the Post Processing menu, Basic mode is on the Image Settings window), and the live image control window (Advanced mode only). For advanced mode, you must enable Correct Color in the image setup first, to enable the setting in the live image window.

Display Monitor Setup
There are many different types of monitors that are provided as part of a computer system. Each has its own characteristics related to color. Additionally, the environment in which you view your monitor has a bearing on the colors that you will see on the screen (for example, white will look a bit bluer in a darkroom environment than it will look if you open the door and allow natural sunlight to enter the same room). There are a couple of different approaches to setting your display monitor to an optimum color matching display.

Simple Method - The SPOT Correct Color Technology system is designed to utilize the ICC profile that is assigned to your monitor. For most systems this profile is sRGB. This profile assumes a color temperature of 6500º K. If you do nothing to change this profile, you will need to simply change your monitor setting to 6500º K. You can do this by changing the color temperature setting using control buttons on your monitor (refer to the monitor User Guide or menu to make this change). This setting will provide color matching between the specimen and the screen that is a very good approximation to the image you see in microscope.

On some display screens, this adjustment may not be available. However, they typically are set to 6500ºK as a default value.

If your monitor supplied a disk that included an ICC color profile for your particular monitor model, you should use this profile in place of the default profile assigned to your monitor. Check with the monitor supplier for downloadable releases of any new color correction files and follow their directions for their use.
Enhanced Method – For the best color matching, you will need to calibrate your monitor color and create your own ICC color profile for the display device. This profile will replace the default profile noted in the Simple Method above.

You will need to create the calibration profile using a 3rd party software or software/hardware package such as PANTONE® COLORVISION® Spyder™ or a similar product and follow the instruction provided in the package. You will need to acquire these packages separate from the SPOT imaging system.
## Index

### A

<table>
<thead>
<tr>
<th>Annotation</th>
<th>Page Numbers</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Calibration Mark</td>
<td>110, 263</td>
</tr>
<tr>
<td>Add Measurement</td>
<td>111, 264</td>
</tr>
<tr>
<td>Adding</td>
<td>250</td>
</tr>
<tr>
<td>a currently open file</td>
<td>250</td>
</tr>
<tr>
<td>a SPOT database image</td>
<td>250</td>
</tr>
<tr>
<td>an image from file</td>
<td>250</td>
</tr>
<tr>
<td>Adjust Brightness (additive)</td>
<td>237</td>
</tr>
<tr>
<td>Adjust Brightness (multiplicative)</td>
<td>238, 239</td>
</tr>
<tr>
<td>Adjust Contrast</td>
<td>240</td>
</tr>
<tr>
<td>HSL</td>
<td></td>
</tr>
<tr>
<td>HSV</td>
<td>240</td>
</tr>
<tr>
<td>RGB</td>
<td>239</td>
</tr>
<tr>
<td>Adjust Gamma</td>
<td>241</td>
</tr>
<tr>
<td>HSL</td>
<td>241</td>
</tr>
<tr>
<td>HSV</td>
<td>241</td>
</tr>
<tr>
<td>RGB</td>
<td>241</td>
</tr>
<tr>
<td>Adjust Histogram</td>
<td>244</td>
</tr>
<tr>
<td>HSL</td>
<td>244</td>
</tr>
<tr>
<td>HSV</td>
<td>244</td>
</tr>
<tr>
<td>RGB</td>
<td>242</td>
</tr>
<tr>
<td>Adjust Hue, Saturation, and Luminance</td>
<td>238</td>
</tr>
<tr>
<td>Adjust Hue, Saturation, and Value</td>
<td>238</td>
</tr>
<tr>
<td>adjusting brightness/darkness of an image (Basic mode)</td>
<td>96</td>
</tr>
<tr>
<td>Adjust Image (Basic mode)</td>
<td>96</td>
</tr>
<tr>
<td>Brightness</td>
<td>96</td>
</tr>
<tr>
<td>Contrast</td>
<td>96</td>
</tr>
<tr>
<td>Dark Level</td>
<td>96</td>
</tr>
<tr>
<td>Gamma</td>
<td>96</td>
</tr>
<tr>
<td>Advanced interface</td>
<td>17</td>
</tr>
<tr>
<td>quick start</td>
<td>22</td>
</tr>
<tr>
<td>Advanced program mode</td>
<td>137</td>
</tr>
<tr>
<td>annotation</td>
<td>110, 263</td>
</tr>
<tr>
<td>adding to zoomed images</td>
<td>85, 225</td>
</tr>
<tr>
<td>attributes</td>
<td>105, 257</td>
</tr>
<tr>
<td>images</td>
<td>101, 253</td>
</tr>
<tr>
<td>Basic mode</td>
<td>101, 253</td>
</tr>
<tr>
<td>annotation objects</td>
<td>101, 254</td>
</tr>
<tr>
<td>Connected Lines</td>
<td>103, 255</td>
</tr>
<tr>
<td>editing</td>
<td>109, 261</td>
</tr>
<tr>
<td>Images</td>
<td>103, 256</td>
</tr>
<tr>
<td>Lines</td>
<td>102, 255</td>
</tr>
<tr>
<td>Shapes</td>
<td>103, 255</td>
</tr>
<tr>
<td>Text</td>
<td>104, 256</td>
</tr>
<tr>
<td>area</td>
<td>48, 159, 180, 395</td>
</tr>
<tr>
<td>artifacts in optical system</td>
<td>42, 165, 212, 389</td>
</tr>
<tr>
<td>attributes</td>
<td>105, 257</td>
</tr>
<tr>
<td>annotation</td>
<td>105, 257</td>
</tr>
<tr>
<td>report</td>
<td>122, 353</td>
</tr>
<tr>
<td>Auto-Gain Limit</td>
<td>45, 151, 178, 392</td>
</tr>
<tr>
<td>Auto-Save Images</td>
<td>66, 167</td>
</tr>
</tbody>
</table>

### B

| Background Image | 424 |
| Basic interface | 17 |
| quick start | 18 |
| Basic program mode | 31 |
| menu bar | 33 |
| reports | 119 |
| status bar | 34 |
| toolbar | 33, 140 |
| viewing and editing window | 33 |
| Bias Frame | 424 |
| Binning (Insight 3-Shot) | |
| Basic mode | 44, 391 |
| Binning (Insight B/W) | 149, 177 |
| Black Level Subtract (12 BPP) | 163 |
| blurry images | |
| sharpening | 94, 246 |
| borders | 85, 225 |
| brightness | |
| adjusting additive | 237 |
| adjusting for captured images (Basic mode) | 96 |
| adjusting multiplicative | 238 |
| Brightness | |
| Image Setting for Basic mode | 45, 152, 178, 392 |
| brightness (multiplicative) | 239 |
| adjusting | 239 |
| Bulb Trigger | 157 |
| buttons, toolbar | 140 |
| image capture | |

### C

| Calibration and measurement | |
| Basic mode | 110, 262 |
| Calibration mark | 110, 263 |
| calibration of microscope objectives | 59, 164 |
| Calibration | 25 |
| camera | |
| initializing | 70, 77, 206 |
| capturing a region in an image | 70, 207 |
| capturing images | |
| Get Sequential Images | 75, 203, 204 |
| Set Chip Imaging Region | 207 |
| capturing images (Basic mode) | |
| Get Image | 74, 202 |
| CCD chip | 423 |
| design methodologies | 424 |
| Change Pixel Bit Depth | 100, 249 |
| charged coupled device (CCD) | 423 |
| Chip Defect Correction | 164 |
| Chip Imaging Area | 48, 159, 180, 395 |
| color matching | |
| Basic mode | 98, 247 |
D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D

D
Binning ........................................... 149, 177
Gain ........................................... 48, 157, 180, 395
Use
   Red Green Blue .................. 47, 153, 394
White Balance (Basic TWAIN) 39, 72, 157, 209,
   386
exposure time
   reducing .......................... 45, 151, 178, 392
Exposure Time
   live image exposure option ...... 48, 180, 395

F
fields
   Lookup ........................................ 333
fields, database ......................... 332
default values for ...................... 335
Lookup ........................................ 333
Textual/Numeric .......................... 333
file format
   images ....................................... 331
File menu options
   Basic mode .............................. 78, 215
files
   .rpb (Basic mode report) .......... 129, 370
   .rpd (Run Report) .......................... 368
database query (.qry) ............... 344
flatfield ..................................... 43, 390
rpt (report template)
   saving (Basic mode) .................. 348
Filter (Edit menu options)
   Filter Noise .............................. 95, 247
Sharpen ................................... 94, 246
Smooth ...................................... 93, 245
Unsharp Mask ............................ 94, 246
Filter Color (Insight 3-Shot)
   Basic mode ................................ 44, 391
First Page (report mode) .......... 351
flatfield correction
   Advanced Program Mode .......... 165, 212
   Basic Program Mode ................. 37, 161, 182, 384
fluorescence images
   adjusting in Basic mode ...... 95, 165, 389
   lightening dark areas of .......... 38, 162, 182, 385
   focusing images in real-time
   Basic mode .............................. 172
   Advanced mode ....................... 70, 201
   framing images in real-time
   Advanced mode ....................... 172
   Basic mode .............................. 70, 201
   full scale ................................ 45, 151, 178, 392
   Full Screen view option .......... 90, 231
   full well
   concept of .............................. 426

G
gain ........................................... 45, 151, 178, 392
defined ...................................... 426
   relationship to exposure time 45, 151, 178, 392
Gain ...................................... 48, 157, 180, 395
gamma
adjusting in Advanced mode ........ 241
adjusting in Basic mode ............. 96
types of adjustment
   RGB ........................................ 241
types of adjustment
   HSL ........................................ 241
   HSV ......................................... 241
Gamma
   Basic mode .............................. 37, 161, 182, 384
Get Image (Basic mode) ............. 74, 202
Get Sequential Images ............... 75, 203, 204
glints ....................................... 38, 162, 182, 385
grainy images
   smoothing ................................ 93, 245
girds (report)
   display ................................... 351
   object ..................................... 352

H
halo effect
   correcting on low contrast image captures 165, 212
   correcting on low contrast image captures 42
   correcting on low contrast image captures 389
histogram
   HSL .......................................... 244
   HSV ......................................... 244
   RGB ......................................... 243
Histogram
   equalize .................................. 245
   in image display settings panel .... 413
   Set/Show Area .............................. 413
   Show Image Display Histogram Area 413
   HSL color space .......................... 97, 235
   Hue ........................................ 97, 235
   adjusting .................................... 238

I
ID
   database image ........................... 335
illumination
   correcting for uneven ............ 42, 165, 389
   illumination correcting for uneven 212
image
   zooming .................................... 84, 85, 224, 225
Image
   duplicate image ......................... 414
   Save Display Values .................... 413
   image capture
   Basic mode .............................. 74, 202
   Recall Previous Exposure ........... 209
   image capture status messages .... 74, 202
   Image Date/Time ....................... 88, 89, 228, 229, 230
   image editing
   basic functions ......................... 91, 232
   brightness ............................. 97, 235
color ........................................ 97, 235
contrast .................................. 97, 235
copy ...................................... 91, 232
sizing and position .................. 92, 232
Index

image IDs .................................................. 335
Image Index (image sequences) ............... 117, 270
image memo ........................................... 115, 267
associating with a database image ............. 336
image quality enhancing .................................. 92, 234
image sequences controls for playing .................. 117, 270
   Image Index ........................................ 117, 270
   Play Options ...................................... 117, 270
displaying play controls ......................... 87, 227
editing .................................................. 117, 271
printing .................................................. 135, 376
Sequence menu options ......................... 115, 268
Image Settings (Basic mode) ...................... 36
   Binning (Insight 3-Shot) ......................... 44, 391
   Brightness .......................................... 45, 152, 178, 392
   Color Enhancement .............................. 37, 161, 181, 384
   Filter Color (Insight 3-Shot) ................. 44, 391
   Flatfield ........................................... 42, 389
   Gamma ............................................. 37, 161, 182, 384
   Image Flip .......................................... 37, 161, 182, 384
   Image Rotate ...................................... 49, 160, 396
   Noise Filter ...................................... 42, 94, 246, 389
Image Settings (Basic TWAIN)
   Image Type .......................................... 45, 151, 177, 392
Image Setup (Advanced mode)
   Flatfield .......................................... 212
image setup options .................................. 146
Image Setup window
   accessing .......................................... 144
image setups .......................................... 144
   adding ............................................ 144
deleting ............................................. 145
importing ............................................. 29
locking ................................................ 147
modifying .......................................... 145
naming ................................................. 147
pre-configured settings for .................... 144
Image Type
   selecting (in Basic TWAIN) .................. 45, 151, 177, 392
images annotating
   Basic mode ...................................... 101, 253
   changing pixel bit depth ..................... 100, 249
   compressing ..................................... 130, 332, 370
   lightening and darkening .................... 237, 238, 239
   merging multiple monochrome ............... 220, 251
previewing in real time
   Advanced mode ................................... 172
   Basic mode ...................................... 70, 201
   resizing .......................................... 233
   saving automatically ......................... 66, 167
   saving to a SPOT database ................... 335
sharpening appearance of .................... 94, 246
smoothing grainy ................................... 93, 245
stretching ............................................ 243
subtracting from open ......................... 250
Importing
   calibrations ....................................... 25
   Easy Essentials Taskbar ....................... 28
   image setups ..................................... 29

palettes .............................................. 27
Indicate Saturated Pixels ......................... 166, 413
Initialize Camera .................................. 70, 77, 206
Intensity set intensity display scaling ............ 411, 413
Interactive Mode
   in macros ......................................... 285

J

JPEG Quality ....................................... 130, 332, 370

L

labels volume .......................................... 331
Last Page (report mode) ............................ 351
light sensitivity of CCD chip
   increasing ......................................... 149, 177
lightening dark areas (Basic mode) ............. 96
Link
   Image Window Scrolling ........................ 87, 227
   Image Window Zoom Level .................... 86, 226
Live Image Controls
   Exposure options
      Exposure Time .................................. 48, 180, 395
   live imaging
      Advanced mode ................................ 172
      Basic mode .................................... 70, 201
      view options .................................... 172
locking
   image setups ..................................... 147
Lookup fields ......................................... 333
low contrast image captures
   halo effect on ..................................... 42, 165, 389
low contrast images
   increasing contrast in ......................... 242
Luminance ........................................... 97, 236
   adjusting .......................................... 238

M

Macro
   Protect ............................................. 293
Macro Window ........................................ 280
   Accessing and Navigating ..................... 280
   other options on ................................ 288
Macros
   benefits of using ................................ 279
   Commands Available ............................ 281
   Creating .......................................... 279
   Developing ....................................... 286
   Edit ............................................... 291
   Interactive Mode ................................ 285
   New ............................................... 280
   Play .............................................. 292
   Record .......................................... 291
Macro-specific Commands ....................... 293
   Communication .................................. 314
   Conditional ..................................... 294
   Timing ............................................ 310
   Variable ......................................... 303
magnified images
   navigating ........................................ 86, 226
Magnifier ........................................ 85, 225
Make Negative .................................. 95, 247
manual
   organization of .................................. 15
Match Color
   Basic mode .................................. 98, 247
   Basic TWAIN ..................................... 40, 387
measurements
   adding ........................................ 111, 264
   types of .......................................... 112, 265
Measurements
   export .......................................... 222
   measuring specimens ................................ 111, 264
memos
   associating with a database image ............ 336
   associating with an image ........................ 115, 267
   for image report objects ....................... 363
menu bar
   in the Basic program mode ...................... 33
menus
   Advanced program mode .......................... 139
   Basic program mode ................................ 33
   database ........................................... 325
Edit
   Basic mode .................................. 91, 231
   Sequence ........................................ 115, 268
View
   Basic mode .................................. 83, 223
Merge
   annotations, calibration marks, measurements ........................................ 114, 267
   Images ........................................ 220, 251
microscopy techniques .......................... 45, 151, 177, 392
   and image types .................................. 195
   table of .......................................... 195
modes
   Advanced program ................................ 137
   Basic program .................................. 31
monochrome image capture
   applying a color palette to ..................... 253
monochrome images
   converting to ..................................... 100, 250
   defining color palettes for .................. 76, 190, 191, 206
   moving database images from your hard drive .................................... 337

N
negative
   creating .......................................... 95, 247
New Macro ....................................... 280
Next Page (report mode) .......................... 351
noise, electrical and thermal
   reducing in images .............................. 42, 94, 164, 246, 389

O
Object Grid
   setting ........................................... 352
objects

P
palette
   applying color to a monochrome image capture .................................... 253
   importing ......................................... 27
   palette, color
      defining for monochrome images 76, 190, 191, 206
password protecting a database .................. 329
Peripheral Devices
   Developing Peripheral Device Commands ........................................ 415
   Modifying and Deleting Peripheral Device Commands .......................... 420
   Using the Peripheral Devices Commands
      In a Macro ..................................... 421
      In a Taskbar .................................... 420
      Menu Item ..................................... 420
   What is the Peripheral Device Controller? ................................. 415
   photography
      digital ............................................ 423
   Pixel
      export pixel values ................................ 414
      preserve pixel intensity data .................. 411
      pixel bit depth .................................. 147, 401
      changing (as an edit option) ................. 100, 249
   pixel borders
      displaying ........................................ 85, 225
      pixellation ....................................... 164
   Pixels
      Indicate Saturated ................................ 166, 413
      pixels (picture elements) ...................... 423
      combining on CCD chip ......................... 149, 177
   Play
      macros ........................................... 292
   play controls
      displaying for image sequences ............... 87, 227
   Play Options (image sequences) ................... 117, 270
   Post-Processing options
      Background Image ................................ 424
      Bias Frame ...................................... 424
      Black Level Subtract (12 BPP) .................. 163
      Chip Defect Correction ........................ 164
      Flatfield Correct ................................ 165
      Image Size Double ................................ 164
      Noise Filter .................................... 164
   Preferences
      Basic mode .................................. 53, 194
      Captured Image Bit Depth ...................... 57, 58, 198
      Thumbnail Button Size ......................... 56, 197
   Preserve Pixel Intensity Data .................... 411
   previewing
      reports .......................................... 368
   Previous Page (report mode) ..................... 351
   printing
      image sequences ................................ 135, 376
Index

reports..............................................................369
reports (Basic mode)..................................130
single images ..................................................132, 373
Profiles
  defining in Basic mode .......................36, 383
  defining in Basic TWAIN mode .........36, 383
program modes
  Advanced ..................................................137
  Basic ..........................................................31
Promote Data
to 16 bits per channel ..................80, 218
Protect
  macro ..............................................................293
Q
  quality of images
    enhancing ...................................................92, 234
  quick start
    preparing the microscope and camera...18, 22
R
  real-time image preview
    Advanced mode ..........................................172
    Basic mode ...............................................70, 201
Recall Previous Exposure .................209
records
data base ......................................................336
reducing image size .................................233
region
  defining for an image capture ...........207
report objects
  Advanced mode
    Text .............................................................360
  Basic mode
    Connected Lines ...............................126, 357
    Images .........................................................126
    Lines .........................................................125, 356
    Shapes ......................................................126, 357
    Text ...............................................................127
  defining in Advanced mode ...............356
  defining in Basic mode ......................125
double-clicking on ..............................120, 350
editing ..............................................................364
  editing (Basic mode) ..............................127
right-clicking on .................................120, 350
sizing and positioning ..........................350
report records
  displaying multiple on a single page ...368
reports
  attributes (Basic Mode) ...................122, 353
  Basic mode ..................................................119
    creating new ..............................................119
    defining attributes ..................................122, 353
    defining view options ..............................120
    editing objects ...........................................127
    right-click and double-click functionality .120
    sizing and positioning report objects ....120
    creating new ..............................................349
distributing ....................................................130, 371
  output format .................................................367
  previewing ......................................................368
  printing .........................................................369
  printing (Basic mode) .......................130
  running .........................................................367
  saving .........................................................369
  saving (Basic mode) .........................129
SPOT sample ..................................................347
  resizing images .............................................233
  RGB color space ............................................97, 235
  running reports ..........................................367

S
  samples
    SPOT database ..............................................326
    SPOT report .................................................347
  Saturation .................................................97, 236
  adjusting ....................................................238
  Save
    Image Display Values ..................................413
    save image thumbnails ....................................332
  saving
    reports .........................................................369
    reports (Basic mode) ..................................129
    saving images automatically ..................66, 167
    search conditions ........................................340
  search results
    displaying ....................................................342
    ordering ......................................................342
  searching
databases ....................................................340
  selecting an image type (Basic TWAIN)...45, 151, 177, 392
Sequence menu ....................................115, 268
sequential images
  capturing .....................................................75, 203, 204
  number/timing options .........................75, 204
  types of ......................................................75, 203
Set
  Histogram Area ............................................413
  Intensity Display Scaling ....................411, 413
  Palette ..........................................................413
  Set Display Grid Size .........................351
  Set Object Grid Size ...............................352
  setting
    image region ...............................................207
setup
  calibration ...................................................59, 184
  sharpen .........................................................94, 246
  Show
    histogram view ...........................................413
    Image Display Histogram Area ...............413
    Image Display Settings Panel ...............412
  Show Grid Lines .....................................85, 225
  Show Magnifier .............................................85, 225
  Show Results as Table .........................342
  Show Results as Thumbnails .................343, 344
  Show Sequence Thumbnails .................343, 344
  Show Tools dialog box .........................101, 254
  Advanced mode ............................................353
    Basic mode ..................................................122
    Smooth .......................................................93, 245
snap to grid ............................................. 121, 352
SPOT cameras operating principles .......... 425
SPOT program modes
comparison of Basic and Advanced features 17
SPOT RT camera operating principles
automated exposure process .................... 426
gain ....................................................... 426
pixel digitization .................................... 425
SPOT sample report ................................ 347
opening ................................................. 347
running ............................................... 348
viewing objects in .................................. 348
stage micrometer ................................... 59, 184
status bar
Advanced program mode ......................... 141
Basic program mode ............................... 34
status messages (image capture) .......... 74, 202
storage
options for database images .................... 330
Stretch Bright and Dark Level
HSL ...................................................... 163, 242
HSV ...................................................... 163, 242
RGB ..................................................... 242
stretching images .................................... 243
Subtract Image ....................................... 250
T

taking a picture
Basic mode ......................................... 70, 201
first time instructions ............................ 18, 22
taskbars
importing Easy Essentials ....................... 28
techniques
microscopy ........................................... 45, 151, 177, 392
white balance (Basic TWAIN) ....... 40, 72, 210, 386
Textual/Numeric fields .......................... 333
time lapse photography ......................... 75, 203, 204
T
appearance when SPOT program is first
delayed ................................................... 140
Basic program mode .............................. 33, 140
Trigger
External
Bulb .................................................... 157
Edge .................................................... 157
U
Unsharp Mask ........................................ 94, 246
Use
Red  Green  Blue -------------------------- 47, 153, 394
V
Value
adjusting .............................................. 238
view full screen ...................................... 90, 231
View menu options
Basic mode .......................................... 83, 223
viewing and editing window
in the Advanced program mode ............ 139
in the Basic program mode ................. 33
volume labels
defining for removable media ............ 331
W
wells on CCD chip ................................... 423
white balance
techniques (Basic TWAIN) ....... 40, 72, 210, 386
White Balance
Basic TWAIN ........................................ 39, 72, 157, 209, 386
Window
Link Image Scrolling ............................. 87, 227
Z
zoom options
Link Image Window Zoom Level ....... 86, 226
magnifier .............................................. 85, 225
Zoom In/Out ........................................ 84, 224
Zoom Level .......................................... 85, 225
zoomed images
navigating around ................................. 86, 226, 400
zoomed images annotating ................. 85, 225